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1Starting up

About Dreamweaver Digital Classroom
Adobe® Dreamweaver® lets you design, develop, and maintain web pages and websites. 
Designers and developers both use Dreamweaver, which lets you create and edit content 
using either a visual layout or a coding environment. Dreamweaver CS6 also provides tight 
integration with other Adobe products such as Photoshop® CS6 and Flash® CS6 Professional.

The Adobe Dreamweaver CS6 Digital Classroom helps you to understand these capabilities, 
and how to get the most out of your software, so that you can get up-and-running right 
away with the CS6 version of the software. You can work through all the lessons in 
this book, or complete only specifi c lessons. Each lesson includes detailed, step-by-step 
instructions, along with lesson fi les, useful background information, and video tutorials.

Adobe Dreamweaver CS6 Digital Classroom is like having your own expert instructor guiding 
you through each lesson while you work at your own pace. This book includes 17 self-
paced lessons that let you discover essential skills, explore new features, and understand 
capabilities that will save you time. You’ll be productive right away with real-world 
exercises and simple explanations. Each lesson includes step-by-step instructions and lesson 
fi les available on the included DVD. The Adobe Dreamweaver CS6 Digital Classroom lessons 
are developed by the same team of Adobe Certifi ed Instructors and Dreamweaver experts 
who have created many offi  cial training titles for Adobe Systems.

Prerequisites
Before you start the Adobe Dreamweaver CS6 Digital Classroom lessons, you should have a 
working knowledge of your computer and its operating system. You should know how to 
use the directory system of your computer so that you can navigate through folders. You 
also need to understand how to locate, save, and open fi les, and you should also know how 
to use your mouse to access menus and commands.

Before starting the lesson fi les in the Adobe Dreamweaver CS6 Digital Classroom, make sure 
that you have installed Adobe Dreamweaver CS6. The software is sold separately, and not 
included with this book. You may use the free 30-day trial version of Adobe Dreamweaver 
CS6 available at the Adobe.com website, subject to the terms of its license agreement.

System requirements
Before starting the lessons in the Adobe Dreamweaver CS6 Digital Classroom, make 
sure that your computer is equipped for running Adobe Dreamweaver CS6. The 
minimum system requirements for your computer to eff ectively use the software are 
listed on the following page and you can fi nd the most current system requirements at 
http://www.adobe.com/products/dreamweaver/tech-specs.html. 

Starting up
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Prerequisites

Dreamweaver CS6 Digital Classroom2

Windows 

• Intel® Pentium® 4 or AMD Athlon® 64 processor

• Microsoft® Windows® XP with Service Pack 2 (Service Pack 3 recommended); 
Windows Vista® Home Premium, Business, Ultimate, or Enterprise with Service Pack 1; 
or Windows 7

• 512 MB of RAM (1 GB recommended)

• 1 GB of available hard-disk space for installation; additional free space required during 
installation (cannot install on removable fl ash-based storage devices)

• 1280×800 display with 16-bit video card

• Java™ Runtime Environment 1.6 (included)

• DVD-ROM drive

• QuickTime 7.6.6 software required for HTML5 media playback

• Broadband Internet connection required for software activation and access to online services.

Mac OS

• Multicore Intel processor

• Mac OS X v10.6 or v10.7

• 512 MB of RAM (1 GB recommended)

• 1.8 GB of available hard-disk space for installation; additional free space required 
during installation (cannot install on a volume that uses a case-sensitive fi le system or on 
removable fl ash-based storage devices)

• 1280×800 display with 16-bit video card

• Java™ Runtime Environment 1.6 

• DVD-ROM drive

• QuickTime 7.6.6 software required for HTML5 media playback

• Broadband Internet connection required for software activation and access to online services.
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3Starting up

Resetting the Dreamweaver workspace

Starting Adobe Dreamweaver
As with most software, Adobe Dreamweaver is launched by locating the application in your 
Programs folder (Windows) or Applications folder (Mac OS). If you are not familiar with 
starting the program, follow these steps to start the Adobe Dreamweaver CS6 application:

Windows
1 Choose Start > All Programs > Adobe Dreamweaver.

2 Close the Welcome Screen when it appears. You are now ready to use Adobe 
Dreamweaver CS6.

Mac OS
1 Open the Applications folder, and then open the Adobe Dreamweaver CS6 folder.

2 Double-click on the Adobe Dreamweaver application icon.

3 Close the Welcome Screen when it appears. You are now ready to use Adobe 
Dreamweaver CS6.

Menus and commands are identifi ed throughout the book by using the greater-than symbol (>). 
For example, the command to print a document appears as File > Print.

Access lesson files & videos any time
Register your book at www.digitalclassroombooks.com/CS6/Dreamweaver to download the 
lesson fi les onto any computer you own, or watch the videos on your Internet connected 
tablet, smartphone, or computer. You’ll be able to watch the Digital Classroom videos 
anywhere you have an Internet connection. Registering your book also provides you 
access to lesson fi les and videos even if you misplace your DVD.

Checking for updated lesson files
Make sure you have the most up-to-date lesson fi les and learn about any updates 
to your Dreamweaver CS6 Digital Classroom book by registering your book at 
www.digitalclassroombooks.com/CS6/Dreamweaver.

Resetting the Dreamweaver workspace
To make certain that your panels and working environment are consistent, you should 
reset your workspace at the start of each lesson. To reset your workspace, choose Window 
> Workspace Layout > Designer.
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Loading lesson fi les

Dreamweaver CS6 Digital Classroom4

Loading lesson files
The Dreamweaver CS6 Digital Classroom DVD includes fi les that accompany the exercises for 
each of the lessons. You may copy the entire lessons folder from the supplied DVD to your 
hard drive, or copy only the lesson folders for the individual lessons you wish to complete.

For each lesson in the book, the fi les are referenced by the name of each fi le. The exact 
location of each fi le on your computer is not used, as you may have placed the fi les in 
a unique location on your hard drive. We suggest placing the lesson fi les in the My 
Documents folder (Windows) or at the top level of your hard drive (Mac OS).

Copying the lesson files to your hard drive:
1 Insert the Dreamweaver CS6 Digital Classroom DVD supplied with this book.

2 On your computer desktop, navigate to the DVD and locate the folder named 
dwlessons.

3 You can install all the fi les, or just specifi c lesson fi les. Do one of the following:

• Install all lesson fi les by dragging the dwlessons folder to your hard drive.

• Install only some of the fi les by creating a new folder on your hard drive named 
dwlessons. Open the dwlessons folder on the supplied DVD, select the lesson(s) you 
wish to complete, and drag the folder(s) to the dwlessons folder you created on your 
hard drive.

Unlocking Mac OS files

Mac users may need to unlock the files after they are copied from the accompanying disc. 
This applies only to Mac OS computers, and is because the Mac OS may view files that are 
copied from a DVD or CD as being locked for writing.

If you are a Mac OS user and have difficulty saving over the existing files in this book, you 
can use these instructions so that you can update the lesson files as you work on them, and 
also add new files to the lessons folder 

Note that you only need to follow these instructions if you are unable to save over the 
existing lesson files, or if you are unable to save files into the lesson folder.

1 After copying the fi les to your computer, click once to select the pslessons folder, then 
choose File > Get Info from within the Finder (not Dreamweaver). 

2 In the dwlessons info window, click the triangle to the left of Sharing and Permissions to 
reveal the details of this section.

3 In the Sharing and Permissions section, click the lock icon, if necessary, in the lower-
right corner so that you can make changes to the permissions.

4 Click to select a specifi c user or select everyone, then change the Privileges section to 
Read & Write.

5 Click the lock icon to prevent further changes, and then close the window.
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5Starting up

Working with the video tutorials

Working with the video tutorials
Your Dreamweaver CS6 Digital Classroom DVD comes with video tutorials developed by 
the authors to help you understand the concepts explored in each lesson. Each tutorial is 
approximately fi ve minutes long and demonstrates and explains the concepts and features 
covered in the lesson.

The videos are designed to supplement your understanding of the material in the chapter. 
We have selected exercises and examples that we feel will be most useful to you. You may 
want to view the entire video for each lesson before you begin that lesson. Additionally, at 
certain points in a lesson, you will encounter the DVD icon. The icon, with appropriate 
lesson number, indicates that an overview of the exercise being described can be found in 
the accompanying video.

0
DVD video icon.

Setting up for viewing the video tutorials
The DVD included with this book includes video tutorials for each lesson. Although you 
can view the lessons on your computer directly from the DVD, we recommend copying 
the folder labeled videos from the Dreamweaver CS6 Digital Classroom DVD to your hard 
drive for best performance.

Copying the video tutorials to your hard drive:

1 Insert the Dreamweaver CS6 Digital Classroom DVD supplied with this book.

2 On your computer desktop, navigate to the DVD and locate the folder named videos.

3 Drag the videos folder to a location onto your hard drive.
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Working with the video tutorials

Dreamweaver CS6 Digital Classroom6

Viewing the video tutorials with the Adobe Flash Player
The videos on the Dreamweaver CS6 Digital Classroom DVD are saved in the Flash 
projector format. A Flash projector fi le wraps the Digital Classroom video player and the 
Adobe Flash Player in an executable fi le (.exe for Windows or .app for Mac OS). The fi le 
extension may not always be visible. Projector fi les allow the Flash content to be deployed 
on your system without the need for a browser or prior stand-alone player installation.

Playing the video tutorials:

1 On your computer, navigate to the videos folder you copied to your hard drive from 
the DVD. Playing the videos directly from the DVD may result in poor quality 
playback. 

2 Open the videos folder and double-click the Flash fi le named PLAY_DWCS6videos to 
view the video tutorials.

3 After the Flash player launches, press the Play button to view the videos. 

The Flash Player has a simple user interface that allows you to control the viewing 
experience, including stopping, pausing, playing, and restarting the video. You can 
also rewind or fast-forward, and adjust the playback volume.

A B D E FC

A. Go to beginning. B. Play/Pause. C. Fast-forward/rewind. D. Stop. E. Volume Off /On. F. Volume control.

Playback volume is also aff ected by the settings in your operating system. Be certain to adjust the 
sound volume for your computer, in addition to the sound controls in the Player window.
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7Starting up

Additional resources

Hosting your websites
While you can work on everything in this book using only your computer, you will 
eventually want to create websites that you share with the world. To do this, you will need 
to put your website on a computer connected to the Internet that is always accessible. This 
is known as a web server. If you don’t want to get involved in hosting a website, you can 
pay a company to provide space on their web servers for you. A good place to look for a 
hosting provider is here: http://www.microsoft.com/web/jumpstart/hosting.aspx. If you want 
to set up your own computer for hosting a web server and you are using any Windows 
computer, you can turn it into a web server at no cost by using the Web Platform Installer 
available at: http://www.microsoft.com/web. If you are a Mac OS user, you can get Mac OS X 
server from Apple to use a Mac OS computer as a web server.

If you are just getting started, you don’t need to worry about web hosting just yet. But 
you’ll fi nd this information useful once you start creating sites, and you learn how to 
manage sites using Dreamweaver. 

Additional resources
The Digital Classroom series goes beyond the training books. You can continue your learning 
online, with training videos, at seminars and conferences, and in-person training events.

Training from the Authors
The authors are available for professional development training workshops for schools 
and companies. They also teach classes at American Graphics Institute including training 
classes and online workshops. Visit agitraining.com for more information about Digital 
Classroom author-led training classes or workshops.

Book series
Expand your knowledge of creative software applications with the Digital Classroom 
training series. Books are available for most creative software applications as well as web 
design and development tools and technologies. Learn more at DigitalClassroom.com.

Seminars and conferences
The authors of the Digital Classroom seminar series frequently conduct in-person 
seminars and speak at conferences, including the annual CRE8 Conference. Learn more at 
agitraining.com and CRE8summit.com.

Resources for educators
Visit DigitalClassroom.com to request access to resources for educators, including an 
instructors’ guide for incorporating this Digital Classroom book into your curriculum.
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9Lesson 1, Dreamweaver CS6 Jumpstart

What you’ll learn in 
this lesson:
• An overview of 

Dreamweaver CS6 
features

• How the Web works

• An introduction to HTML

Lesson 1

Whether you are a novice web designer or an experienced developer, 
Dreamweaver is a comprehensive tool you can use for site design, 
layout, and management. In this lesson, you’ll take a tour of 
Dreamweaver’s key features and get a better understanding of how 
web pages work.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

Before you start, be sure to register your book at www.digitalclassroombooks.com/CS6/Dreamweaver 
to learn about updates to any of the lesson fi les and gain access to the accompanying video 
tutorials on any Internet connected computer, tablet, or smartphone.

You will work with several fi les from the dw01lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

Dreamweaver CS6 Jumpstart
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1 What is Dreamweaver?

Dreamweaver CS6 Digital Classroom10

If you want to get started and create a page, jump ahead to “Tag structure and attributes” later 
on in this lesson. Otherwise, the next few pages provide you with an overview of key capabilities 
and features of Dreamweaver CS6.

See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the supplied DVD.

What is Dreamweaver?
Dreamweaver is an excellent web design and development tool for new and experienced 
users alike. Over the years it has become the preferred website creation and management 
program, providing a creative environment for both designers and developers. Whether 
you design websites, develop mobile phone content, or script complex server-side 
applications, Dreamweaver has something to off er. 

Design and layout tools
Dreamweaver’s many icon-driven menus and detailed panels make it easy to insert and 
format text, images, and media (such as video fi les and Flash movies). This means that you 
can create attractive and functional web pages without knowing a single line of code—
Dreamweaver takes care of building the code behind-the-scenes for you. Dreamweaver 
does not create graphics from scratch; instead, it is integrated with Adobe Photoshop CS6, 
so you can import and adjust graphics from within the application.

The Insert panel features objects in several 
categories that let you easily add images, 
web forms, and media to your page.

1
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What is Dreamweaver?

Site management and File Transfer Protocol 
Dreamweaver has everything you need for complete site management, including built-in 
File Transfer Protocol (FTP) capabilities between a server and your local machine; reusable 
objects (such as page templates and library items); and site optimization tools (such as link 
checkers and site reports), so that you can ensure that your site functions properly and 
looks good. If you’re designing your pages with Cascading Style Sheets (CSS), then the 
W3C Validation, the Browser Compatibility Check, and the CSS Advisor features will 
help you locate and troubleshoot any potential display issues that may occur across diff erent 
web browsers.

Coding environment and text editor
Dreamweaver lets you work in a code-only view of your document that acts as a powerful 
text editor. Features such as color-coding, indentation, and visual aids make Dreamweaver 
an excellent text editing or coding environment for web designers of any level.

Code view is a full-featured text editor that color-codes, tags, and scripts for editing that’s easier to decipher.

For more experienced developers, Dreamweaver supports popular coding and scripting 
languages, such as JavaScript, in addition to several server-side languages, including 
ColdFusion, PHP, and ASP.NET. Specialized insert menus and code panels help you build 
pages and applications in the language of your choice.

Scripting languages, such as those used to build interactive web pages or e-commerce sites, fall 
into two categories: client-side and server-side. Client-side languages (such as JavaScript) run in 
your browser, while server-side languages (such as ColdFusion) require that special software be 
installed on the server in order to run.
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Mobile design and development features
The tools in Dreamweaver have evolved as the Web has evolved. The most recent versions 
of the application have numerous features designed to help make your website look and 
function well in the rapidly growing arena of mobile phones and devices. The Multiscreen 
Preview feature allows you to preview your pages in common screen sizes for smartphones 
and tablets and can be accessed by choosing Window > Multiscreen Preview.

Additionally, there is support for creating Media Queries, which are a CSS3 feature aimed 
at creating unique page layouts for diff erent-sized screens. For more advanced users there is  
support for jQuery Mobile, which creates unique user interfaces for touchscreen devices. 
There is also support for creating native applications for iOS and Android operating 
systems with the new addition of the PhoneGap integration added in Dreamweaver CS6.

Multiscreen Preview allows you to test your pages in common screen sizes for mobile and other devices.

Who uses Dreamweaver?
Dreamweaver’s popularity is a result of its fl exibility. Its ability to build a site from 
conception to launch—and provide continued maintenance afterward—makes it a preferred 
tool among industry professionals, businesses, and educational institutions. However, it 
remains easy and accessible enough for novice designers to get up-and-running quickly. It’s 
not unusual to see Dreamweaver utilized for personal projects or by small businesses and 
media professionals, such as photographers and painters, to maintain a web presence.
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Dreamweaver’s workspace features
This book is dedicated to exploring, learning, and putting to use all that Dreamweaver has 
to off er. This section looks at some of the application’s key features.

Four diff erent points of view: When you work with a document, Dreamweaver lets 
you see your work in one of four views: Code, Split, Design, or Live view. Dreamweaver’s 
default Design view lets you add elements to your page in a visual fashion, either by 
dragging objects onto the page from the Insert panel, or by directly adding text, image or 
multimedia content. More experienced web designers and coders can use the Code view 
to edit a document’s HTML code and scripts directly, enhanced with easy-to-read color-
coding and visual aids. 

For those who like something in between, the Split view provides a split-pane Design 
and Code view all at once. You can easily change views at any time with a single click in 
the Document toolbar. The Live view is a type of “reality check” that allows you to view 
your page in a native web browser, eliminating the need to leave the program in order to 
preview your designs.

The Split view lets you edit your page visually while also seeing the code being created behind the scenes.
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Built-in FTP: You can easily upload and download fi les to and from your web server 
using the Files panel’s drag-and-drop interface. You can also use the Get/Put button at 
any time to post pages you’re currently working on. In either case, there’s no need for 
separate software. Dreamweaver also provides Check In/Check Out functionality and 
synchronization features; these allow multiple people to work more safely and effi  ciently 
on the same site.

Page and code object Insert panels: You can fi nd intuitive icons for most common 
web page elements in a categorized Insert panel, from which you can add elements to 
your page with a single click. You can use additional panels to fi ne-tune any page element 
to ensure that you see exactly what you want. Included in the default Insert panel are 
tools for formatting text, building forms, and creating layouts. You can also customize a 
Favorites tab with your most-used icons.

Customizable workspace layouts: You can save combinations and positions of panels 
and toolbars for easy recall at any time. Save multiple workspace layouts for diff erent users, 
or create diff erent workspaces for specifi c tasks, such as coding or designing page layouts.

You can choose a specifi c workspace layout in order to create an 
arrangement of panels that suits you best.
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Powerful visual aids: Take advantage of the precision you’re accustomed to in other 
design programs through Dreamweaver’s guides, rulers, measuring tools, and customizable 
positioning grid; many of these features are found and can be activated within the View 
menu. Dreamweaver’s Design-Time style sheets let you customize the look of your page 
exclusively for the editing process, making layout quicker and easier without permanently 
altering the page’s appearance.

Rulers, a document grid, and guides help you size and position page items with precision.

CSS Styles panel: Take advantage of the vast design and formatting options that CSS 
provides through Dreamweaver’s full-featured CSS Styles panel, which lets you create, 
edit, and manage styles on-the-fl y from a single panel.
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Live View and Live Code
Experience tells you that visual web editors often display diff erently than the browsers 
they’re emulating. As script-driven interactivity gains popularity, the need to accurately 
design the diff erent states of your page (including menus, panels, and interface elements), 
has become increasingly important. The static nature of the Design view in Dreamweaver 
often times does not meet users’ advanced needs.

Dreamweaver’s Live View mode uses the WebKit rendering engine (which is also the basis 
for the Safari and Google Chrome web browsers), to give you a more accurate preview of 
your page in the same way that a browser would render it.

Live View enables you to preview your page as if it were in a web browser.

When you are in the Live View mode, the Live Code feature is enabled. Live Code allows 
you to see, in real time, how visually changing your page aff ects the code behind the scenes. 
If you have added interactive elements such as drop-down menus or accordion panels, then 
you can visually select an item on the page and see how the HTML code might be aff ected. 

Also useful is the Freeze JavaScript button (or the F6 key). This feature freezes your page in a 
particular state (for example, with a menu locked open and a hover eff ect in place). You can 
then edit those interactive elements directly in Dreamweaver.
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CSS Inspection and the Enable/Disable Feature
Another feature that is enabled when in Live View is the Inspect Mode. This mode allows 
users to peek at the visual model and structure of a page by hovering over elements on 
the page. When hovering in Inspect Mode you can see the relationships between the 
HTML elements on your page and the styles assigned to them. This is useful because it 
dramatically shortens the time it takes to locate any given style for any given object on the 
page. However, when paired with the Enable/Disable feature, the Inspect Mode becomes 
even more powerful.

The Enable/Disable feature allows you to temporarily “turn off ” an applied style on your 
page. This can be very useful when dealing with unfamiliar or complex designs where half 
the battle is simply understanding what styles are being used. Disabling a style will remove 
its properties so that you can visually observe the results. Keep in mind that disabling is 
always temporary, and that it is just as easy to restore the style by clicking Enable.

In the Inspect Mode, mousing over the elements in the Design view reveals the HTML and CSS code.
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Related files
Web-based projects are becoming more complex than ever before, and you often fi nd that 
even a single page is composed of a variety of assets. These assets can include Cascading 
Style Sheets (CSS), external JavaScript fi les, and more. Dreamweaver CS6 has a feature 
that will help you become much more eff ective at designing and managing sites and 
applications with multiple assets.

The Related Files bar runs across the top of your document window, just below the 
document tabs. The bar shows you all the various fi les that, when combined, create your 
fi nished page. You can switch between these fi les using the Related Files bar without 
losing the visual preview of their parent page. Design view (or Live View) always shows 
the parent fi le, but you can now edit any of the related fi les without losing their important 
visual context.

The Related Files bar shows you the various fi les that are part of your fi nished page.
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Code Navigator

Code Navigator
The Code Navigator ( ) is a feature enabled in the Design view that appears when you hover 
over an element on the page. Clicking on the Navigator will let you see a quick summary 
of any CSS styles that have been applied, and if you choose to, you can click on the style in 
order to view the code directly. The benefi t is that it is no longer necessary to manually hunt 
through your style sheets to fi nd a specifi c rule; it’s just a click away in Dreamweaver.

The Code Navigator allows you to easily view the location and properties of your CSS styles in the Design View.
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Photoshop smart objects
Dreamweaver off ers support for Photoshop smart objects, meaning you can drag a PSD fi le 
into a web page within Dreamweaver, optimize the image for the Web, and even resize it.

Inserting a native Photoshop fi le into Dreamweaver will trigger an automatic conversion into a 
suitable web graphic such as JPG, PNG, or GIF.

Also, if you decide to update the original PSD fi le at a later time, then a red arrow appears 
on the image in Dreamweaver to indicate that the source fi le has changed. You can then 
click the Update from Original button in the Property Inspector and a new version of the 
image will be created.

Support for Content Management Systems 
Enjoy authoring and testing support for content management systems like WordPress, 
Joomla! and Drupal. A CMS/blog software like WordPress provides users with an easy 
way to publish content online and has features such as automatic archiving and database 
integration. In the past, designers have been frustrated with creating the page designs for 
a CMS using Dreamweaver because these systems generally rely on a relatively complex 
combination of dynamic pages (often PHP) that could not be previewed in Dreamweaver. 
For designers or users who are not code-savvy, the complexity of these fi les can be 
daunting. Dreamweaver can now help you discover the related fi les needed to put together 
the pages in your CMS framework.

Dreamweaver does this by previewing the fi les of a CMS framework in the Design view 
(as long as you have a testing server defi ned), using the built-in Live View option. With 
this feature, Dreamweaver CS6 also lets you interact directly with a database, which means 
you can now test online forms, insert and modify database records, and more.
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HTML5, CSS3, and PHP code hinting
For advanced users, there is now built in code-hinting support for HTML5 and CSS3 
syntax. This means the “library” of HTML and CSS syntax that is now available within 
Dreamweaver is larger than ever, which is a good sign for those designers and developers 
who need to build modern web pages. 

Additionally, advanced users who use the scripting language PHP will be happy to learn 
that Dreamweaver CS6 now has improved support for PHP syntax. This includes code 
completion and syntax checking, as well as full support for all core functions, constants, 
and classes. PHP code hints have also been improved substantially.

 
Dreamweaver provides support for HTML5, CSS3, and PHP code-hinting.

HTML and CSS Starter Pages
HTML and CSS Starter Pages have been around in Dreamweaver for a few versions now.
These pages allow you to get a jumpstart on building page layouts by choosing from a 
variety of pre-built page layouts that you can subsequently modify. In Dreamweaver CS6, 
the code for these starter pages is new and improved for modern web browsers and comes 
with plenty of code commenting behind the scenes to help you start modifying your pages 
quickly. You can view starter pages by choosing File > New. The Layout column features a 
number of page layouts. CSS starter pages can also be found by clicking on the Page From 
Sample button.
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Subversion
Dreamweaver has improved support for Subversion, a version control system similar to 
CVS and Visual SourceSafe (VSS). Subversion is typically used by companies to maintain 
a team environment on larger projects that require changes to be logged and versions to be 
controlled. Without Subversion, if you wanted to maintain versions, you would have to do the 
work yourself by maintaining folders and copies of previous versions. With Subversion, all fi les 
are kept on the Subversion server. Changes are tracked so that you can restore your project 
to any previous state. Subversion is enabled by choosing Site > New Site ( or Site > Manage 
Sites), choosing Version Control and then clicking the Access menu and choosing Subversion.

Business Catalyst integration
Adobe’s Business Catalyst is an online service that provides a variety of features such as 
online store/shopping cart capabilities, email marketing, web form functionality, analytics 
extension, and more. With the Business Catalyst extension in Dreamweaver you can log-
in to Business Catalyst and synchronize multiple sites at once. Dreamweaver can be used to 
access and edit the style module used on your Business Catalyst connected sites. 

How websites work
Before embarking on the task of building web pages (and in turn, a website), it’s a good 
idea to know the basics of how websites work, how your users view them, and what you 
need to know to make sure your website functions and looks its best. 

A simple flow chart
What happens when you type in a website address? Most people don’t even think about 
it—they just type in a URL (Uniform Resource Locator) and the website appears. They 
most likely don’t realize how many things are going on behind the scenes to make sure 
that pages gets delivered to their computer so that they can do their shopping, check their 
e-mail, or research a project.

http://www.yoursite.com/User Machine (client) Web Host (server)

When you type a URL or IP address in the address bar of a web browser, you are 
connecting to a remote computer (called a server), and downloading the documents, images, 
and resources necessary to render the pages you will view while on the site. Web pages 
aren’t delivered as a fi nished product; your web browser is responsible for reconstructing 
and formatting the pages based on the HTML code included within the pages. HTML 
(Hypertext Markup Language) is a simple, tag-based language that instructs your browser 
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how and where to insert and format pictures, text, and media fi les. Web pages are written in 
HTML, and Dreamweaver builds the HTML as you construct your page in the Design view.

An Internet Service Provider (ISP) enables you to connect to the Internet. Some well-
known ISPs include Verizon, Comcast, and EarthLink. You view web pages over an 
Internet connection using a browser, such as Internet Explorer, Firefox, or Safari. A browser 
can decipher and display web pages and their content, including images, text, and video.

Domain names and IP addresses
When you type in a website address, you usually enter the website’s domain name (such as 
DigitalClassroom.com). The website owner purchased this domain name and uses it to mask 
an IP address, which is a numerical address used to locate and dial up the pages and fi les 
associated with a specifi c website. 

So how does the Web know what domains match up with what IP address, and in 
turn, with what websites? It uses a Domain Name Service (DNS) server, which makes 
connections between domain names and IP addresses. 

Servers and web hosts
A DNS server is responsible for matching a domain name with its companion IP address. 
Think of the DNS server as the operator at a phone company who connects calls through 
a massive switchboard. DNS servers are typically maintained by either the web host or 
the registrar from which the domain was purchased. Once the match is made, the request 
from your user is routed to the appropriate server and folder where your website resides. 
When the request reaches the correct account, the server then directs it to the fi rst page of 
the website, which is typically named index.html, default.html, or whatever the server is 
set up to recognize as a default starting page.

A server is a machine very much like your desktop computer, but it’s capable of handling 
traffi  c from thousands of users (often at the same time!), and it maintains a constant 
connection to the Internet so that your website is available 24 hours a day. Servers are 
typically maintained by a web host. Web hosts are companies that charge a fee to host and 
serve your website to the public. A single server can sometimes host hundreds of websites. 
Web hosting services are available from a variety of providers, including well-known 
Internet service companies such as Yahoo!, and other large, dedicated hosting companies. It 
is also common for a large company to maintain its own servers and websites on its premises. 

The role of web browsers
A web browser is an application that downloads and displays HTML pages. Every time 
you request a page by clicking a link or typing in a website address you are requesting an 
HTML page and any fi les that it includes. The browser’s job is to reconstruct and display 
that page based on the instructions in the HTML code, which guides the layout and 
formatting of the text, images, and other assets used within the page. The HTML code 
works like a set of assembly instructions for the browser to use.

DWCS6_06Pass.indb   23DWCS6_06Pass.indb   23 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

V413HAV
Typewritten Text
V413HAV

http://www.it-ebooks.info/


1 An introduction to HTML

Dreamweaver CS6 Digital Classroom24

An introduction to HTML
HTML is what makes the Web work; web pages are built using HTML code, which in 
turn is read and used by your web browser to lay out and format text, images, and video 
on the page. As you design and lay out web pages in Design view, Dreamweaver writes the 
code behind the scenes that is necessary to display and format your page in a web browser.

Contrary to what you may think, HTML is not a programming language, but rather a 
simple text-based markup language. HTML is not proprietary to Dreamweaver—you can 
create and edit HTML in any text editor, even in simple applications such as Windows 
Notepad and Mac OS X’s TextEdit. Dreamweaver’s job is to give you a visual way to 
create web pages without having to code by hand. If you like to work with code, however, 
Dreamweaver’s Code view is a fully featured text editor with color-coding and formatting 
tools that make it easier to write and read HTML and other languages.

Tag structure and attributes
This exercise is for users who are completely new to HTML and Dreamweaver, and it 
will cover basic concepts such as the role of tags in HTML documents. HTML uses tags, 
or bracketed keywords, that you can use to place or format content. Many tags require a 
closing tag, which is the keyword preceded by a forward slash (/). 

1 Launch Dreamweaver. Choose File > Open. When the Open dialog box appears, 
navigate to the dw01lessons folder. Select BasicHTML.html and press Open. 

2 Select the Split button in the Document toolbar to see the layout as well as the code 
that makes up the page.

Take a look at line 10 (indicated at the left edge of the Code panel). The text My Bold 
Title is inside a Strong tag, which is simply the word strong contained within angled 
brackets. Any words or characters inside these tags are formatted in bold, and appear as 
shown in the Design view.

A look at the code reveals the tags used to format text in your page.
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Tags can also accept CSS rules that specify additional information for how the tag 
should display the content. CSS rules may have one or more properties, such as size, 
color, or alignment. Take a look at the line that reads: This text will appear inside of its own 
paragraph. This line is enclosed in a p (paragraph) tag, which separates it from the other 
text by a line above and below. You can add a CSS class rule to this to align the text. 

3 Highlight the entire line that reads: This text will appear inside of its own paragraph at the 
bottom of the Design view.

4 With the CSS button selected in the Property Inspector panel at the bottom of the 
page, locate the paragraph align buttons. Press the Align Center button ( ).

5 In the New CSS Rule dialog box, type .center into the Selector Name text fi eld, and 
press OK.

Name a newly created style in the New CSS Rule dialog box.
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6 The text is now centered. Take a look at the Code view, and notice that the .center 
rule has been added to the opening <p> tag. This is not the only method of centering 
a paragraph using CSS, but it begins to introduce you to the practice of integrating 
HTML and CSS.

Align or format text in the Property Inspector, and then see the appropriate rules and attributes created in your code.

For more information on formatting text with CSS rules, please see Lesson 3, “Adding Text and 
Images.”

7 Choose File > Save to save your work, then choose File > Close.
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The structure of an HTML document
In HTML a pair of tags is referred to as an “element.” For example, in the last exercise 
you created a style for one of the paragraph elements on the page. HTML elements defi ne 
the structure of a page and examples include lists, images, tables, and even the HTML 
documents themselves. The HTML element is the most fundamental element you will use. 
It is used to specify the beginning and end of HTML in a document:

<html></html>

The HTML element consists of two tags that contain two key sections of your web page: 
the head and the body. The head element of your page contains items that are not visible 
to your user, but are important nonetheless. Search engine keywords, page descriptions, 
and links to outside scripts or style sheets are all found in the head element. You create the 
head of the document inside the HTML tags using the <head> tags:

<html>
<head></head>
</html>

The body of your page is where all the visible elements of your page are contained. This is 
where you insert text, images, and other media. You defi ne the body of the page using the 
<body> element:

<html>
<head></head>

<body>

My text and pictures go here...

</body>
</html>

Whenever you create a new HTML document in Dreamweaver, this structure is created 
automatically before you add anything to the page. Any visual elements you add to the 
page are added, using the appropriate HTML code inside the <body> element.
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Placing images in HTML
You use some elements in HTML to place items, such as pictures or media fi les, inside a 
web page. The <img> element is the most common example; its job is to place and format 
an image on the page. To place an image and see the resulting code, follow these steps:

1 Choose File > Open. When the Open dialog box appears, navigate to the dw01lessons 
folder. Select the Images.html fi le and press Open to edit the fi le.

2 If necessary, click the Split button in the Document toolbar so that you’re viewing 
both the layout and the code for your page. In the Design view portion of the Split 
view, click below the line of text to place your cursor underneath it. This is where 
you’ll place a new image.

Enter the Split view before you insert the image onto your page.

DWCS6_06Pass.indb   28DWCS6_06Pass.indb   28 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

http://www.it-ebooks.info/


1

29Lesson 1, Dreamweaver CS6 Jumpstart

An introduction to HTML

3 From the Common category in the Insert panel on the right side of the screen, click 
on the Images element and choose Image. When the Select Image Source dialog 
box appears, select the fi le named gears.jpg, located in the images folder within the 
dw01lessons folder and press OK (Windows) or Choose (Mac OS).

Choose Image from the Common tab in the Insert bar.

4 When the Image Tag Accessibility Attributes dialog box appears, type the words 
Gears Image in the Alternate text fi eld, and press OK to place the image.

Attach alternate text to your image.

The Image Tag Accessibility Attributes dialog box appears when you add images to provide 
additional information for users with special needs (such as the visually impaired). You should 
always provide each image with alternate text, but you can disable this panel by choosing 
Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS). In the Accessibility 
category, uncheck the Images option. 

DWCS6_06Pass.indb   29DWCS6_06Pass.indb   29 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

http://www.it-ebooks.info/


1 An introduction to HTML

Dreamweaver CS6 Digital Classroom30

5 The code shows that the HTML <img> element has been used to place the image. 
Click once on the image in the document window to select it. The Property Inspector 
at the bottom of the page displays and sets the properties for the image. 

6 Choose File > Save to save your work, then choose File > Close.

Note that in HTML, images and media are not embedded, but placed. This means 
that the elements contain additional information known as attributes and values that 
point to the location of an image fi le and may even contain other information such as 
the width and height values.

Colors in HTML
In Dreamweaver’s various panels and in your code, each color is referred to by a six-
character code preceded by a pound sign. This code is called the hexadecimal code, and it 
is the system that HTML pages use to identify and use colors. You can reproduce almost 
any color using a unique hexadecimal code. For example, you represent dark red in 
HTML as #CC0000.

The fi rst, middle, and last two digits of the hexadecimal code correspond to values in the 
RGB spectrum. For instance, white, which is represented in RGB as R:255 G:255 B:255, 
is represented in HTML as #FFFFFF (255|255|255). Choosing colors is easy, thanks to a 
handy Swatches panel, which you can fi nd in many places throughout the work area. 

The Swatches panel makes it easy to work with colors.

The color pickers in Adobe Photoshop and Illustrator also display and accept hexadecimal codes, 
making it easy to copy and paste colors between these applications and Dreamweaver.
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Case sensitivity and whitespace rules
HTML is a fl exible language that has very few rules regarding its own appearance. Based 
on how strictly you want to write it, HTML can be either very specifi c about whether tags 
are written in upper- or lowercase (called case sensitivity), or not specifi c at all. To see how 
HTML treats whitespace, follow these steps.

1 Choose File > Open. When the Open dialog box appears, navigate to the dw01lessons 
folder. Select the Whitespace.html fi le, and then press Open. 

2 If your fi le is not in Split view, press the Split button in the Document toolbar at the 
top of the page, so that you can view both the layout and the code. The fi rst three 
paragraphs have diff erent amounts of space between them in the HTML but will be 
rendered on the page one after the other.

The browser ignores any white space between the paragraphs.

This tells you that whitespace and line returns are ignored by the browser. You have 
to begin making a distinction between code that is readable by humans versus the way 
a web browser interprets and renders code.
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3 You will see there are a few diff erent ways to format your text. In the Design view, 
click once after the sentence that reads, This is one sentence, and then press Shift+Enter 
(Windows) or Shift+Return (Mac OS) twice. This creates two line returns—you can 
see that each line return is created in your code by a <br> (break) tag. When rendered 
in the browser, the <br> tag adds blank lines between the sentences; however the 
sentences are technically within the same paragraph. This is sometimes referred to as a 
hard return. This method is actually not the ideal way to add new lines on your page, 
although it does occasionally come in handy.

To create a line return, hold down the Shift key while pressing the Enter or Return key.

4 To create a new paragraph, position your cursor before the phrase This is another, and 
press Enter (Windows) or Return (Mac OS). The text is separated by a line above 
and below, and is wrapped inside a set of <p> (paragraph) tags. This is the preferred 
method of adding paragraphs.

Other than a standard single space (such as the space used between words), several consecutive 
spaces created by the spacebar are ignored and are displayed as only one space in Design view and 
in a browser.

5 Choose File > Save to save your work then choose File > Close.
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Element hierarchy
HTML elements should have a well-formed hierarchy or nesting structure in order to make 
sure that everything displays as it should. The element at the top of the hierarchy is the 
<html> element, and every other element you create is contained within it. Elements such 
as the <body> end up nesting all the other elements on a page, such as the <p> (paragraph), 
<img> (image), and <strong> (bold) elements. In addition, structural elements (such as 
those that create divs, paragraphs, lists, and tables) hold more weight than formatting tags 
such as <strong> (bold) and <em> (italic). Take this line of code, for example:

<strong><p>Big bold paragraph</p></strong>

Although code such as this may work in certain browsers, it isn’t structured well because 
the <strong> tag technically holds less weight than the <p> tag. The following code 
represents a better way to include the bold type:

<p><strong>Big bold paragraph</strong></p>

Dreamweaver generally does a great job of keeping tags properly nested or contained 
within each other. When you choose to manipulate the code by hand, you should always 
keep good coding techniques in mind.

XHTML 1.0 Transitional
The language of HTML has continued to evolve over the years and there are a few 
diff erent page types currently in use. Unless you specifi cally change it, the default page 
type that Dreamweaver creates is named XHTML 1.0 Transitional. To keep things simple 
for now, think of XHTML (which was introduced around the year 2000), as a stricter 
version of the HTML language that was used to build the fi rst web pages in the 1990s, 
when the Web was fi rst created (for now, we’ll refer to this as HTML 4.0, although the 
technical details are a bit more complicated). XHTML was designed to make web pages 
more compatible with newer platforms, such as mobile phones and handheld devices. 
XHTML combines elements of HTML and XML, a language used to describe data. 
XML, or Extensible Markup Language, has become a popular method of exchanging 
information among seemingly unrelated applications, platforms, and systems. 

What’s the difference?
The diff erence between the HTML 4.0 specifi cation and XHTML is not terribly dramatic. 
The structure of the language changes somewhat with XHTML in that it becomes stricter. 
Whereas HTML 4.0 was very forgiving of coding practices such as overlapping or unclosed 
tags, XHTML requires that all tags be closed and properly nested. HTML 4.0 doesn’t care 
which case you use when constructing tags, but in XHTML, all tags must be lowercase. 
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Here’s an example of how HTML and XHTML might diff er. The break element is used to 
push or “break” content to the next line on a page. In HTML, you can do this by simply 
adding the opening tag <br>. In XHTML, all opening tags must also have a closing 
tag. The long way to do this would be <br></br>. However, there is special syntax in 
XHTML that lets you get away with less code, and this syntax is called self-closing. You 
can write tags to self-close by using a forward slash—making sure there is a space between 
the br and the forward slash—and then closing the bracket like so:

<br />

The result is a well-formed language that takes advantage of newer browsers and device 
platforms, while remaining compatible with older browsers. As noted previously, working 
with XHTML in Dreamweaver requires nothing more than creating a new page.

Explorations in code
Although this book occasionally refers to the code for examples, hand-coding is not a 
primary goal of these lessons. The best way to learn how code represents the layouts you 
are building visually is to switch to the Code view and explore what’s happening behind 
the scenes.

It’s important to remember that every button, panel, and menu in Dreamweaver represents 
some type of HTML tag, attribute, or value; very rarely will you learn something that is 
unrelated or proprietary to Dreamweaver alone. Think of the Dreamweaver workspace as 
a pretty face on the HTML language.
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A look at the Welcome Screen
A common fi xture in most CS6 applications is the Welcome Screen, which is a launching 
pad for new and recent documents. In Dreamweaver, the Welcome Screen appears when 
the application launches or when no documents are open. From the Welcome Screen, 
you can create new pages, create a new site, open a recent document, or use one of 
Dreamweaver’s many starter pages or layouts.

The Welcome Screen appears when you launch the application, or when no documents are open.

Here’s what you’ll fi nd on the Welcome Screen:

Open a Recent Item: A list of the last few documents you worked on appears in the 
far left column, or you can browse to open a diff erent fi le using the Open button at the 
bottom.

Create New: In addition to HTML pages, you can choose from a variety of new 
document formats, such as CSS, JavaScript, and XML. Dreamweaver is not just a web 
page-building tool, but also a superior text editor, making it ideal for creating many non-
HTML fi les. You can also defi ne a new Dreamweaver site using the link at the bottom, or 
choose the More folder for even more new fi le options.
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Top Features (videos): On the far right side of the Welcome Screen, there is a column 
that contains link to videos of Top Features. These videos explore some of the new top 
features of Dreamweaver CS6, including Fluid Grid Layouts, Business Catalyst, and the 
CSS Transitions panel among others. The videos are located on Adobe’s website, adobe.com, 
and when you click on one, Dreamweaver launches the site in your web browser to give 
you access to the video.

Creating, opening, and saving documents
The lessons throughout this book require that you create, save, and open existing fi les. 
You can accomplish most fi le-related tasks from the File menu at the top, or from the 
Welcome Screen that appears when you launch Dreamweaver.

Creating new documents
Dreamweaver creates text fi les most commonly in the form of HTML fi les (or web 
pages). It can also create fi les in a variety of text-based languages, including CSS, XML, 
JavaScript, and even Flash ActionScript. 

You can create blank fi les that you build from the ground up, or you can get started with a 
variety of layout templates and themes. You can create new documents from the File menu 
or from the Welcome Screen. Here, you’ll create a new page using the File menu.

The New Document dialog box gives you a choice of new fi les in a variety of formats and templates.
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1 To create a new document, choose File > New. The New Document dialog box appears. 

2 Select Blank Page and under the Page Type column, choose HTML. Under Layout, 
choose <none> to start a new blank document. Leave the DocType drop-down menu 
at its default. Press Create.

3 Choose File > Save or File > Save As to start the process of saving your document.

4 When prompted, choose a location for your fi le and assign it a name. Note that you 
must save HTML fi les with an .html extension, or they will not be interpreted properly 
in a browser. This rule applies for fi les of any type (such as .xml, .css, and .cfm).

Opening a recently opened document

To open a document you’ve worked on recently, Choose File > Open Recent or, from 
the Welcome Screen, select a document under the Open a Recent Item column.

Now that you’ve seen what Dreamweaver can do, it’s time to put what you’ve learned into 
practice. Move to the next lesson so that you can begin building your fi rst Dreamweaver site!
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Self study
Explore the ready-to-use CSS layouts available in Dreamweaver by choosing File > New, 
then selecting HTML from the Page Type column. Browse the options listed in the Layout 
column and open a few layouts. Identify some that you’d like to use as a starting point for 
any future project.

Review 
Questions
1 From what two locations in Dreamweaver can a new document be created?

2 In what three views does Dreamweaver allow you to view and edit documents?

3 True or False: When a web page is requested, it is delivered to a user’s browser as a 
completed, fl at fi le ready for viewing.

Answers
1 From the Welcome Screen or by choosing File > New. 

2 Design, Split, and Code views. 

3 False. Files are delivered individually; the browser uses HTML code to assemble the 
resources together to display a fi nished page.

DWCS6_06Pass.indb   38DWCS6_06Pass.indb   38 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

http://www.it-ebooks.info/


39Lesson 2, Setting Up a New Site

What you’ll learn in 
this lesson:
• Defi ning site settings

• Establishing local and 
remote folders

• Selecting, viewing, and 
organizing fi les with the 
Files panel

• Defi ning Page Properties

Lesson 2

Dreamweaver’s strength lies in its powerful site creation and 
management tools. You can use the software to create everything 
from individual pages to complete websites. The pages you create 
within your site can share similar topics, a cohesive design, or a 
common purpose. And, once your Dreamweaver site is complete, you 
can effi  ciently manage and distribute it from within the program.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw02lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Setting Up a New Site
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See Lesson 2 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Creating a new site
In Dreamweaver, the term site refers to the local and remote storage locations where the 
fi les that make up a website are stored. A site can also include a testing server location for 
processing dynamic pages. To take full advantage of Dreamweaver’s features, you should 
always start by creating a site. In Dreamweaver CS6, there is a new category called a 
Business Catalyst Site. Business Catalyst is a service that Adobe provides (for a fee) that 
allows you to connect your website with analytic software and other features. However, 
we do not cover setup of Business Catalyst sites in this book.

The easiest way to create a standard new site in Dreamweaver is to use the Site Setup dialog 
box. One way to access this dialog box is by choosing Site > New Site from the menu bar.

You can also use the Manage Sites dialog box to create a new site. This and other functions of 
the Manage Sites dialog box are discussed later in this book.

In this lesson, you begin by using the Site Setup dialog box to accomplish the following tasks:

• Defi ne the site

• Name the site

• Defi ne the local root folder

• Set up a remote folder

• Explore advanced settings

• Save the site

By default, the Site Setup dialog box opens with the Site Settings available. The options 
available here will help guide you through the essentials of defi ning your site. The Servers, 
Version Control, and Advanced Settings options allow you to set up local, remote, and 
testing servers directly.

2
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1 Launch Dreamweaver CS6, if it is not already open, then choose Site > New Site. 
First, you have to name the site. In the Site Name text fi eld, type Organic Utopia.

Type the Site Name into the text fi eld.

Next, you need to set up a local root folder, which is where Dreamweaver stores the fi les 
with which you’re currently working. The Local Site Folder fi eld allows you to enter 
information regarding where you’ll be working with your fi les during development.

To ensure that the links you set up on your computer will work when you upload the site to a web 
server, it is essential that you store all the site’s resources in one main folder on your hard drive, 
then identify it within Dreamweaver. This is because the links will only work properly if all the 
site’s elements remain in the same relative location on the web server as with your hard drive.

2 Click on the Folder icon ( ) to the right of the Local Site Folder text fi eld to navigate 
to any pre-existing fi les. In the next step you will locate the lesson fi les we have 
provided for this chapter.

If you did not click on this folder and clicked Save, Dreamweaver would simply create 
a new folder on your system where you could begin to create new pages in your site. 
In this case, you will be pointing to a preexisting folder that already has fi les within it.

It is important to distinguish between adding a new site (which is what you are doing 
now) and creating a new site from scratch. In both cases, the important part is that 
Dreamweaver knows where this folder is on your system. This folder is known as the 
root folder and will always contain the content that will eventually be your website.
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3 Navigate to your desktop and locate the dw02lessons folder you copied to your 
desktop earlier.

4 Select the dw02lessons folder. On the Windows platform, click Open to open this 
folder, then press Select (Windows). On the Mac OS platform, press Choose to choose 
this as your local root folder. The fi eld now shows the path to your newly defi ned local 
root folder. 

At this point, you have done the minimum amount of steps required to begin working 
on a site, however you will take a look now at some of the optional features within the 
Site Setup process.

5  Click on the Servers tab. This section allows you to defi ne the remote server where 
your website will end up being hosted. Take a moment to read the heading in the 
dialog box. Note that it says you do not need to fi ll in this information to begin 
creating a website. It is only necessary if you are connecting to the Web.

You are not connecting to the Web in this lesson, but you should take a look at the 
screen anyway to understand the information needed.

6 Click on the + button and the Basic site settings window appears. Here there are fi elds 
for Server Name, Connect Using, FTP Address, Username and Password, along with 
other options. These settings allow you to choose both a destination and a method 
(FTP being the most common) for Dreamweaver to use to transfer fi les.

Set up access to your remote folder.

As noted earlier, this is an optional step, and you do not have to defi ne your remote 
folder at this stage. Dreamweaver allows you to defi ne your remote folder at a later 
time, such as when you’re ready to upload.
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7 Click on the Advanced tab. Click on the Server Model menu in the Testing Server 
section. Here there are choices for diff erent scripting languages such as PHP and ASP 
pages. If you are an advanced user, this is where you would set up the connections to 
your testing server.

Again, you won’t be making any changes here, so press Cancel.

8 Click on the Version Control option on the left to access Subversion settings. 
Subversion, a VCS (or version control system), keeps track of changes made to fi les, 
enabling users to track changes and return to previous versions of any fi le. For this 
exercise, make sure the Access pull-down in this window is set to None, as you won’t 
be using Subversion.

You’ve now completed the site setup process, using basic settings. Don’t close the 
Site Setup dialog box yet, though, as you’ll now explore the options found under the 
Advanced Settings option.

Advanced site-creation options
Chances are if you are new to Dreamweaver or web design you won’t need these advanced 
settings. If you are in this category, press Save and skip to the Adding Pages section. Other 
users may be curious what these settings are and should proceed.

1 Click on the arrow next to Advanced Settings in the Site Setup dialog box.

2 From the categories listed below Advanced Settings, choose Local Info.

Choose Local Info from Advanced Settings.
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The information you set in the Local Info window identifi es your Default Images 
folder, what your links are relative to, and a web URL to be used if you don’t have a 
remote server defi ned. One of the more important Local Info settings, though, is case-
sensitive link checking.

The case-sensitive link checking feature ensures that your links will work on a Unix 
server, where links are case-sensitive. If you’re using a Windows or Mac OS server, this 
doesn’t matter as much, but it is a good idea to follow the strict naming and linking 
conventions of a Unix system in case you ever move your site to a diff erent server.

If you happen to have already defi ned a CSS3 site-wide Media Query fi le, this is 
where you could redefi ne or modify it.

(We cover the creation of site-wide Media Query fi les in Lesson 15, “Mobile Design 
and Layout”.)

The remaining categories to the left of the Advanced tab of the Site Setup dialog box 
help to defi ne your site’s production, collaboration, and deployment capabilities. They 
include the following:

Cloaking allows you to specify fi le types or specifi c fi les that you do not want 
uploaded to the server.

Design Notes is a collaboration tool that keeps notes regarding the development of 
the page or site. 

File View Columns is an organizational tool. If you want to share the custom 
columns with others, you must enable Design Notes as well. 

Contribute is a separate application that enables users with basic word processing and 
web browser skills and little or no HTML knowledge to create and maintain web pages.

Templates can be automatically updated with rewritten document paths using this 
option.

Spry is a JavaScript library for web designers. It allows designers to build pages that 
provide a richer experience for their users.

Web Fonts allows you to defi ne where you are storing the web fonts you would like 
to use for this site.

3 At this point, you are fi nished defi ning your settings, so press Save. Dreamweaver 
creates a site with the settings you have defi ned. 

You are now ready to work with pages for your defi ned website and take advantage of 
Dreamweaver’s site features.
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Adding pages
Dreamweaver contains many features to assist you in building pages for your site. For 
example, you can defi ne properties for pages, including titles, background colors or 
images, as well as default text and link colors.

The fi rst step for creating a new page correctly was taken when you defi ned the site in the 
last exercise. By defi ning the root folder, Dreamweaver will always create new pages in 
your site automatically. These pages are now visible in the Files Panel in the lower right of 
your screen.

The Files panel.

If your Files panel does not look the same as it does here, choose Window > Workspace Layout 
> Reset ‘Designer.’
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1 Choose File > New. The New Document dialog box opens.

Use the New Document dialog box to add a page to your site.

2 You can create a new page using a predesigned layout, or start with a blank page and 
build a layout of your own. In this exercise, you’ll start with a blank page and in later 
lessons will get a chance to explore some of the other options. Click on the Blank 
Page category on the left side of the New Document dialog box.

3 In the Page Type column, you can select the type of page you want to create (for 
example, HTML, ColdFusion, and so on). Select HTML if it is not currently selected.

In the Layout column, you can choose to base your page on a prebuilt design. These 
predesigned layouts fall into one of three categories:

Fixed creates a layout with columns that do not resize based on the user’s browser 
settings. They are measured in pixels.

Liquid creates a layout with columns that resize if the user resizes the browser 
window, but not if the user changes the text settings.

HTML5 creates a fi xed layout that uses the new HTML5 elements such as <header>, 
<section> and <article> among others.

DWCS6_06Pass.indb   46DWCS6_06Pass.indb   46 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

http://www.it-ebooks.info/


2

47Lesson 2, Setting Up a New Site

Adding pages

4 Click on <none> in the Layout column to build the page without using a prebuilt 
layout.

5 Click on the DocType menu in the lower-right corner. This DocType drop-down 
menu defi nes the document type for diff erent versions of HTML including HTML5. 
XHTML 1.0 Transitional is the default setting and is suitable in most cases, so be sure 
to bring it back to this option.

Choose XHTML 1.0 Transitional as your DocType.

The Layout CSS and Attach CSS settings are irrelevant here, as you didn’t choose a 
 CSS-based layout for this page.
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6 Press Create to create a new, blank HTML page. You will learn more about 
Workspaces a bit later, but to make sure you are working as we are, choose Window > 
Workspace Layout and choose Reset Designer. Your screen should now look like ours. 
(Although if you are in Code View, you should switch to the Design view now.)

Your new, blank HTML page.

Saving a page to your site
You should get accustomed to saving pages to your local root folder early and often. It is 
very important that you store all your site’s resources in one main folder on your hard drive 
so that the links you set on your computer will work when your site is uploaded to a server. 

1 Choose File > Save.

2 In the Save As dialog box, Dreamweaver should have automatically opened your 
dw02lessons folder which was defi ned earlier in the Site Settings.

If this is not the case, navigate to your desktop and locate the dw02lessons folder.

3 In the Save As text fi eld, name your fi le about_us.html. 

4 Click Save to save the page in your local root folder. In the Files panel note that 
the fi le about_us.html has now been added. Again, this is why site settings are so 
important in Dreamweaver, fi les are automatically saved and organized based on 
having a site defi nition.
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Defining page properties
Now that you’ve created a page in Dreamweaver, you’ll use the Page Properties dialog 
box to specify its layout and formatting properties. For example, you can set page titles, 
background colors and images, text and link colors, as well as other basic properties of 
every web page. You use this dialog box to defi ne page properties for each new page you 
create, and to modify the settings for pages you’ve already created.

1 To access the Page Properties dialog box, choose Modify > Page Properties, or use the 
keyboard shortcut Ctrl+J (Windows) or Command+J (Mac OS). The Page Properties 
dialog box appears, with the Appearance (CSS) category selected by default.

The Page Properties dialog box.

Settings found in the Appearance (CSS) category will automatically create a Cascading 
Style Sheet that defi nes the appearance of your page. Using a CSS fi le to defi ne these 
page properties adds fl exibility to your design, as styling can be changed more easily, 
and more universally, than if your defaults are defi ned using HTML code.

2 The Page font and Size fi elds defi ne the default appearance of text on your page. For 
now, leave these settings at their defaults. You’ll be styling type with CSS in later 
lessons in this book.
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3 The Text color option allows you to set a default color in which to render type. To 
set a text color, click on the color swatch next to Text; the Swatches panel appears. 
You can choose your default text color by clicking on the appropriate swatch from 
the Swatches panel. Try this by clicking on any color swatch, and press Apply to apply 
your desired default text color.

You can also type the hexadecimal notation for your desired color into the text fi eld. 
Type the hex code 666666 in the text fi eld to specify a dark gray as the default text color.

You’ll see the eff ects of this change later in this lesson, when you add text to your page using the 
Files panel.

4 Use the Background color option to choose a background color for your page. Click on 
the color swatch next to the Background text fi eld; the Swatches panel appears. You can 
choose your background color by clicking on the appropriate swatch from the Swatches 
panel. Try this by clicking on any color swatch, then press Apply to see the results.

You can also choose the background color by typing the hexadecimal notation for 
your desired color into the Background text fi eld. Type the hex code 739112 in the 
Background text fi eld, then press Apply to specify a green as the background color.

Set a background color for your page.

5 The Background image fi eld allows you to set a background image for your page. 
Dreamweaver mimics a browser’s behavior by repeating, or tiling, the background 
image to fi ll the window. To choose a background image, click the Browse button 
next to the Background image text fi eld. The Select Image Source dialog box appears.

6 Navigate to the folder titled “Images” within the dw02lessons folder and select bg_
gradient.gif for your page background; then press Apply. You will see the background 
image, which is a gradient, appear on the page. Background images are tiled both 
horizontally and vertically by default, which is not appropriate for this image, so you 
will fi x this with the Repeat property.
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7 From the Repeat drop-down menu, choose repeat-x. Click Apply to see the change.

Choose a background image for your page (background.gif).

You can also type the path to your background image into the Background image text fi eld.

8 By default, Dreamweaver places your text and images in close proximity to the top 
and left edges of the page. To build in some extra room between your page edges and 
the content on them, use the Margin settings in the Page Properties dialog box. In the 
Left margin text fi eld, type 25 to place your content 25 pixels from the left edge of the 
page. In the Top margin text fi eld, type 25 to place your content 25 pixels from the 
top edge of the page.

The Appearance (HTML) category in the Page Properties dialog box contains many 
of the same settings you just defi ned. Setting default page attributes with HTML code, 
however, is not recommended. Setting appearance with CSS is a better option.

The Links (CSS) category allows you to defi ne the appearance of linked text within 
your document. For more information on creating hyperlinks, see Lesson 3, “Adding 
Text and Images.” 

9 Click on the Links category on the left-hand side and leave the Link font and Size 
settings at their defaults (same as Page font). This ensures that your hyperlinks will 
display in the same typeface and size as the rest of the text on your page. 
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10 Set the colors for your diff erent link types in the following fi elds:

Link Color: Type #fc3 for the default link color applied to linked text on your web page.

Visited links: Type #ccc for the color applied to linked text after a user has clicked on it.

Rollover links: Type #f03 for the color applied to linked text when a user rolls over it.

Active links: Type #ff 6 for the color applied when the user clicks on linked text.

11 Because you’re using CSS formatting, you can choose whether or not (and/or when) you 
want your links to be underlined. This is not possible with HTML formatting. Choose 
the default setting of Always Underline in the Underline style drop-down menu.

Choose default colors for links, visited links, and active links.

The Headings (CSS) category allows you to defi ne the font, style, size, and color of 
heading text within your document.

12 Click the Headings (CSS) category and leave the settings at their defaults for now. 
You’ll be using CSS to style your heading text later in this book.

13 Click the Title/Encoding category to the left of the Page Properties dialog box to 
expose more settings. Most of these settings are better left alone unless you know what 
they do and why you need to change them, with the major exception of the fi rst one: Title.
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14 Type Organic Utopia: About Us in the Title text fi eld. This sets the title that 
appears in the title bar of most browser windows. It’s also the default title used when a 
user bookmarks your page.

Leave the Document Type (DTD) set to XHTML 1.0 Transitional. This makes the 
HTML document XHTML-compliant.

Unicode (UTF-8) will likely be set as the default option. This specifi es the encoding 
used for characters in your page, letting the browser know what to expect.

The Unicode Normalization Form is likely set to C (Canonical Decomposition). This 
setting is rarely changed unless you have a specifi c reason for changing it. Unicode 
Normalization Forms has to do with the way special characters such as glyphs are 
rendered on the screen.

The Title/Encoding category allows you to title your page and/or specify the encoding used.

15 Click the Tracing Image category in the left part of the Page Properties dialog box. 
A tracing image is a JPEG, GIF, or PNG image that you create in a separate graphics 
application, such as Adobe Photoshop or Fireworks. It is placed in the background of 
your page for you to use as a guide to recreate a desired page design. 

16 Press the Browse button next to the Tracing image text fi eld. You can also type the 
path to your image directly into this text fi eld.
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17 In the Select Image Source dialog box, navigate to your dw02lessons folder, and 
select the fi le named tracing.gif from the Images folder; then press OK (Windows) or 
Choose (Mac OS).

18 Set the transparency of the tracing image to 50 percent by sliding the Transparency 
slider to the left.

Place a tracing image in the background of your page.

19 Press Apply to see the results. Tracing Images can be useful tools for building layout. 
Oftentimes, you can import a page mockup created originally in Photoshop or 
another application and use it as a visual guideline.

20 When activated, the tracing image replaces any background image you’ve added to 
your page, but only in Dreamweaver. Tracing images are never visible when you view 
your page in a browser. Now that you have a sense of how the tracing feature works, 
you’ll remove it. Select the path within the Tracing Image fi eld and press Delete to 
remove it.

21 Press OK to close the Page Properties dialog box.

22 Choose File > Save. Now that you’ve fi nished setting up your page properties, you’ll 
examine your page in Dreamweaver’s three diff erent work view modes.
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Work views
In this book’s lessons, you’ll do most of your work in the Design View, as you’re taking 
advantage of Dreamweaver’s visual page layout features. You can, however, easily access the 
HTML code being written as you work in the Design View, and use it to edit your pages 
through Dreamweaver’s other work views. You’ll switch views, using the Document toolbar.

The Document toolbar.
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1 In the Document toolbar, press the Design view button, if it is not currently selected. 
Design view is a fully editable, visual representation of your page, similar to what the 
viewer would see in a browser.

With Design view, you see your page as the viewer will see it.
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2 Click on the Code view button to switch to the Code view. Your page is now 
displayed in a hand-coding environment used for writing and editing HTML and 
other types of code, including JavaScript, PHP, and ColdFusion.

Code view shows the HTML code generated to display your page.
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3 Click on the Split view button to split the document window between the Code and 
Design views. This view is a great learning tool, as it displays and highlights the HTML 
code generated when you make a change visually in Design mode, and vice versa.

Use Split view to display your page in both modes at once.

4 Switch back to the Design view to continue this lesson.

A deeper look into the Files panel
You have already seen how Dreamweaver populates the Files panel when you defi ne a 
new site. However, the Files panel is more than just a window into your root folder; it also 
allows you to manage fi les locally and transfer them to and from a remote server. The Files 
panel maintains a parallel structure between local and remote sites, copying and removing 
fi les when needed to ensure synchronicity between the two.

The default workspace in Dreamweaver displays the Files panel in the panel grouping to 
the right of the document window.

When you chose to use the dw02lessons folder as your local root folder earlier in this 
lesson, Dreamweaver set up a connection to those local fi les through the Files panel. 
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Viewing local files
You can view local fi les and folders on the right side of your screen within the Files panel, 
whether they’re associated with a Dreamweaver site or not.

1 Click on the drop-down menu in the upper-left part of the Files panel, and choose 
Desktop (Windows) or Computer > Desktop folder (Mac OS) to view the current 
contents of your Desktop folder.

2 Choose Local Disk (C:) (Windows) or Mac HD (Mac OS) from this menu to access 
the contents of your hard drive.

3 Choose CD Drive (D:) (Windows) from this menu to view the contents of an inserted 
CD. On a Mac, the CD icon and the name of the CD appear in the menu.

4 Choose Organic_Utopia to return to your local root folder view.

Selecting and editing files
You can select, open, and drag HTML pages, graphics, text, and other fi les listed in the 
Files panel to the document window for placement.

1 Double-click on the index.html fi le, located in the Files panel. The page opens for 
editing. Click beneath the heading The lowly beet.

2 Click on the plus sign (Windows) or arrow (Mac OS) to the left of the images folder 
to expand it and then click and drag the beets.jpg image fi le from the Files panel to 
the index.html document window. If an Image Tag Accessibility Attributes dialog box 
appears type beets inside the Alternate Text fi eld and then press OK. The image is 
added to the open page.

If you have an image editor such as Photoshop or Fireworks installed on your computer, you can 
double-click on the beets.jpg image fi le to open for editing and optimizing.

3 Double-click on the_lowly_beet.txt in the Files panel to open it directly in 
Dreamweaver.

4 Choose Edit > Select All to select all the text in this fi le. You could also use the 
keyboard shortcuts, Ctrl+A (Windows) or Command+A (Mac OS).

5 Choose Edit > Copy to copy the text to the clipboard. You could also use the 
keyboard shortcuts, Ctrl+C (Windows) or Command+C (Mac OS).

6 Click on the index.html tab of the document window to return to the index page. 
Click on your page to the right of the image to place an insertion cursor, and press 
Return once to start a new paragraph. 
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7 Choose Edit > Paste. You could also use the keyboard shortcuts, Ctrl+V (Windows) 
or Command+V (Mac OS). The text has now been added to the open page, beneath 
the image, in the default text color you chose earlier.

Paste the new text in the page.

8 Choose File > Save and then close this fi le. 

Congratulations! You have fi nished this lesson. You will get a chance to work with 
text and images a lot more in the next lesson.
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Review 

Self study
Using your new knowledge of site creation techniques in Dreamweaver, try some of the 
following tasks to build on your experience:

1 Choose Site > New Site to invoke the Site Setup dialog box, and use it to create a 
new local site called Practice_Site on your desktop. Make sure you understand the 
diff erence between creating an empty site from scratch (as you are doing here) and 
adding a pre-existing site (as you did in the opening exercise of this lesson).

2 Use the File > New command to create a new, blank HTML page, and save it to your 
Practice_Site. Then choose Modify > Page Properties to access the Page Properties 
dialog box, and experiment with the background, links, margin, and title options 
available. Finally, switch to the Code and Design view in the document window to 
view the code generated by your experiment.

Review 
Questions
1 What characters should you avoid using when naming your site, and why?

2 How is the local root folder essential to the creation of your site?

3 Where can you view, select, open, and copy fi les to and from your local root folder, 
and to and from remote and/or testing servers?

Answers
1 Avoid using spaces (use underscores instead), periods, slashes, or any other unnecessary 

punctuation in your site name, as doing so will likely cause the server to misdirect 
your fi les.

2 It’s essential that you store all your site’s resources in your local root folder to ensure 
that the links you set on your computer will work when your site is uploaded to a 
server. In order for your links to work properly, all the elements of your site must 
remain in the same relative location on the web server as they are on your hard drive.

3 Dreamweaver provides the Files panel to help you manage fi les locally and also so that 
you can transfer them to and from a remote server. You can view, select, open, and 
copy fi les to and from your local root folder, and to and from remote and/or testing 
servers, in this panel.
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What you’ll learn in 
this lesson:
• Previewing pages

• Adding text

• Understanding styles

• Creating hyperlinks

• Creating Lists

• Inserting and editing 
images

Lesson 3

Text and images are the building blocks of most websites. In this 
lesson, you’ll learn how to add text and images to web pages to 
create an immersive and interactive experience for your visitors.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your 
workspace. See “Resetting the Dreamweaver workspace” in the Starting Up section of 
this book.

You will work with several fi les from the dw03lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw03lessons folder from 
the included DVD that contains resources you need for this lesson. Go to Site > New Site, 
and name the site dw03lessons, or, for details on creating a site, refer to Lesson 2, 
“Setting Up a New Site.”

Adding Text and Images
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See Lesson 3 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Typography and images on the Web
Dreamweaver CS6 off ers some convenient features for placing images and formatting text. 
In this lesson, you’ll be working with a few pages within a site and adding some photos 
and text to a simple page for a fi ctional store.

Adding text
You should already have created a new site, using the dw03lessons folder as your root. In 
this section, you’ll be adding a headline and formatting the text on the events.html page.

1 If it’s not already open, launch Dreamweaver CS6. 

2 Make sure your dw03lessons site is open in the Files panel. If not, open it now.

3 Double-click on the events.html fi le in your Files panel to open it in the Design view. 
Without any formatting, the text seems random and lacks purpose. First, you’ll add a 
headline to give the fi rst paragraph some context. 

4 Click to place your cursor in front of the word There’s in the fi rst paragraph. Type 
OrganicUtopia Events and press Enter (Windows) or Return (Mac OS) to create a 
line break.

Typing the words OrganicUtopia Events and then putting them on their own line.

5 Click and drag to highlight the phrase you just typed. You will now format your 
text using the Property Inspector. Located at the bottom of the screen, the Property 
Inspector allows you to format your text using a combination of HTML and CSS. 
HTML stands for Hypertext Markup Language, and CSS stands for Cascading Styles 
Sheets. You will learn much more about the use of HTML and CSS in the next lesson; 
however, you will need to have a basic understanding of these two languages in order 
to use the Property Inspector to format your text.

3
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6 Locate the Property Inspector at the bottom of your screen; there are two buttons 
immediately below the word “Properties.” If necessary, click on the HTML button to see 
your HTML formatting options. Choose Heading 1 from the Format drop-down menu. 
The text gets larger and becomes bold. By default, the style of any HTML text formatted 
as Heading 1 is generic: the color is black and the font-family is Times New Roman. 

Use the Format drop-down menu in the Property Inspector to make the selected text a level-1 heading.

Although you are working in Dreamweaver’s Design view, you have actually changed 
the HTML code for this page. Page content such as text is wrapped in opening and 
closing tags, and everything between these two tags is formatted according to the 
rules of these tags. The text OrganicUtopia Events originally had an opening and 
closing tag defi ning it as a paragraph. The code looked like this:

<p>OrganicUtopia Events</p>

The fi rst <p> is the opening tag for a paragraph, and the second </p> is the closing tag 
for a paragraph. A pair of opening and closing tags in HTML is called an element. So 
in the previous step, you changed the formatting of the text from a paragraph element 
to a Heading 1 element, and the HTML code changed to this:

<h1>OrganicUtopia Events</h1>
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Headings are important structural elements in HTML. The largest heading is H1, and 
the subsequent headings become smaller with H2, H3, and so on. For the next step, 
you will format this text in order to change the font style of this heading to Arial; 
however, you will not be using HTML to accomplish this, but rather CSS.

7 Click anywhere inside the heading OrganicUtopia Events; you do not need to have it 
selected. In the Property Inspector, click on the CSS button to access the formatting 
options. Choose Verdana, Geneva, sans-serif from the Font drop-down menu. 

The CSS section of the Property Inspector allows you to change the font.

The New CSS Rule dialog box appears. 
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8 From the Selector Type drop-down menu, choose Tag. In the Selector Name text 
fi eld, the selector h1 has been chosen for you. Dreamweaver does this because you 
placed your cursor inside the text formatted as H1.

The New CSS Rule dialog box appears the fi rst time you style text.

Press OK. Your heading is now styled in Verdana.

Dreamweaver allows you to format text in a way that is similar to desktop publishing 
and word processing applications, but there are important diff erences to keep in 
mind. When you chose the styling, Verdana, Geneva, and sans-serif, they were listed 
together as one option in the Font drop-down menu. When a web page is rendered in 
a browser, it uses the fonts installed on the user’s computer. Assigning multiple fonts 
allows you to control which font is used if the person viewing your page doesn’t have 
a specifi c font installed. In this case, if the user doesn’t have Verdana, Geneva displays 
instead. Sans-serif is included as the last option in case the user doesn’t have either 
Verdana or Geneva. A generic font family (either sans-serif or serif ) is listed at the end 
of all the options in the Font drop-down menu.

You will now change the text color using the Property Inspector.
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9 Highlight OrganicUtopia Events and click on the Text Color button to the right of 
the Size drop-down menu. When the Swatches panel appears, hover over the color 
swatches. At the top of the Swatches panel, a diff erent hexadecimal color value appears 
for each color. When you locate the value labeled #9C3 (an olive green), click once to 
apply the color.

Click on the Text Color swatch and choose the #9C3 color from the swatches.

10 Choose File > Save. Keep this fi le open for the next part of this lesson.
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An introduction to styles
You have styled the fi rst element on your page by fi rst formatting the text as a Heading 1 
in HTML, and then you changed the font and color using CSS. It’s important to realize 
that every change you make in the Design view creates or modifi es the code. In the next 
exercise, you’ll begin to explore the HTML and CSS code behind the Design view. To 
help put this exercise in context, a little background on HTML and CSS is in order.

The HTML language has been around since the dawn of the Web. It’s easiest to think 
of HTML as the structure behind the pages that are rendered in your web browser. An 
HTML page at its most basic is a collection of text, images, and sometimes multimedia 
such as Flash or video fi les. The diff erent sections of a web page, such as a paragraph, a 
heading, or a list, are all elements. 

CSS is also a language, but it has not been around as long as HTML. In many ways, CSS 
was created in order to allow HTML to do what it does best: create the structure of a 
page, but not style. CSS is a simple language that works in combination with HTML to 
apply style to the content in web pages, such as text, images, tables, and form elements. 
CSS uses rules, or style instructions, that the HTML elements on your page follow. The 
most important thing to remember is that HTML and CSS are two separate languages, but 
they are very closely aligned and work together very well.

In the last exercise, you were introduced to this interplay between HTML and CSS. There 
was an HTML element for the Heading 1 formatting. In the code it looks like this:

<h1>OrganicUtopia Events</h1>

That was the HTML element. The CSS rule that defi nes the appearance of the <h1> 
element looks like this:

h1 {
font-family: Verdana, Geneva, sans-serif;
color: #9C3; 

}

CSS has a diff erent syntax than HTML. In HTML, tags are defi ned by angled brackets, 
and you have opening tags, <h1>, and closing tags, </h1>. In CSS code, you are not 
working with tags at all, instead you use selectors. In the CSS code above, the h1 is 
referred to as the selector because it is selecting the HTML element and then declaring 
some rules for its appearance. Because you’ve established that HTML and CSS are two 
separate languages and have diff erent syntax, it’s important that you see where this code 
lives in your web page. You will do this by changing Dreamweaver’s workspace.

This exercise is intended to help you understand the relationship between HTML and CSS 
code that is created in Dreamweaver, and is not necessarily the way you will always work 
in the program. Many people will work in the Design view most of the time, but the Split 
view you are about to use is very helpful for learning the languages of HTML and CSS.
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1 Click on the Split button in the Document toolbar at the top of your page to open up 
the Split view. The Split view allows you to see your code and the design of your page 
simultaneously. 

2 Click quickly three times in the paragraph beneath OrganicUtopia Events in the 
Design view. In the Code view the text is highlighted between the opening and 
closing paragraph tags. As noted above, this is referred to as the paragraph element. 

A paragraph highlighted in the Split view.

You will now change the font size of your paragraphs.

3 Make sure you have CSS selected in the Property Inspector at the bottom of your 
page and choose 18 from the Size drop-down menu. The New CSS Rule dialog box 
appears again. This dialog box appears because it is the fi rst time you have attempted 
to style a paragraph. After you defi ne the properties, all text formatted as a paragraph 
will appear as indicated.

4 From the Selector Type drop-down menu, choose Tag. Since there are diff erent 
categories of CSS rules, Dreamweaver wants to know which one you would like to 
use. You will stick with Tag for now (as you did in the last exercise). In the Selector 
Name text fi eld, the selector p has been chosen for you because your cursor was inside 
a paragraph. Press OK to apply the changes; in this case, the font size is set to 18 
pixels. Now let’s look at the CSS code that is defi ning this font size.
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5 Within the Code view of the split screen is all the HTML and CSS code that defi nes 
the appearance of this page. On the right side of the Code view, scroll up by clicking 
on the up arrow or by clicking the scroll bar and dragging upward. Toward the top of 
the page, you are looking for a few lines of code that look like this:
<style type="text/css">
h1 {

font-family: Arial, Helvetica, sans-serif;
color: #9C3; 

}
p {

font-size:18px;
}
</style>

Between the two <style> tags are all the CSS rules you have created up to this 
point. Previously, you learned that CSS has a diff erent syntax than HTML: because 
all the CSS rules are actually contained within an opening <style> tag and a closing 
</style> tag, they are allowed to have a diff erent syntax. Additionally, the style tag 
itself is nested inside an opening and closing <head> tag. In the world of HTML, 
nothing contained within head tags is rendered on a web browser’s screen. You will 
explore this further in the next lesson, but this is referred to as an internal style sheet.

You will now see that changes made in Dreamweaver’s Code view apply to the Design 
view as well. 

6 In the Code view, locate the line font-size:18px in the rule for p, and select the 
value 18 by clicking and dragging over it. Type 14 to change the value. Although you 
made a change in the Code view, it has not yet been automatically updated in your 
Design view. You need to refresh your page in order to see the changes occur in the 
Design view.
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7 In the Property Inspector, press the Refresh button to apply the changes; your 
paragraph text becomes smaller. 

Changes made in the Code view are refl ected in the Design view after pressing the Refresh button.

You can also click once inside the Design view for the page to refresh automatically.

On the Web, font sizes are specifi ed diff erently than they are in print. The numerical 
choices in the Size drop-down menu refer to pixels instead of points. Also, the xx-
small through larger options may seem oddly generic if you are accustomed to the 
precision of print layout. Because web pages are displayed on a variety of monitors and 
browsers, relative measurements can be a useful way for designers to plan ahead for 
inevitable discrepancies in the rendering of pages.

8 Click inside the fi rst paragraph in the Design view. You will now change the color of 
the paragraph slightly to a dark gray rather than the default pure black. In the Property 
Inspector, click on the color swatch, and in the top-left corner, locate the dark gray 
swatch, which is hexadecimal color #666. Click on the swatch to apply the color. 
Notice that not only does the appearance in the Design view change, but in your 
Code view a new line of CSS has also been created (color: #666).

Working in the Split view can be a great way to learn about hand-coding without 
diving in completely. Even if you’re not quite comfortable editing code, keeping an 
eye on the code that Dreamweaver writes for you can give you a better understanding 
of how things like CSS aff ect your web pages.

9 Click the Design view button to return to Design view.
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10 Choose File > Save. Keep this fi le open for the next part of this lesson.

For a more in-depth look at Cascading Style Sheets see the Web Design with HTML and 
CSS Digital Classroom book available in electronic and print formats.

Previewing pages in a web browser
Viewing your pages in the Design view is helpful, but visitors to your site will be using a 
web browser to access your site. In Lesson 1, “Dreamweaver CS6 Jumpstart,” you learned 
how browsers use HTML code to render a page. Unfortunately, not every browser renders 
HTML code in exactly the same way, so it’s important to test-drive your pages in a 
number of diff erent browsers to check for inconsistencies and basic functionality.

Next, you’ll use Dreamweaver’s Preview in Browser feature to see how the OrganicUtopia 
site looks in a web browser.

1 With events.html open in Dreamweaver, choose File > Preview in Browser and select 
a browser from the available options. This list varies, depending on the browsers you 
have installed on your hard drive.

Preview in Browser allows you to see how a selected browser would render your page.

The options found under File > Preview in Browser can be customized by choosing File > 
Preview in Browser > Edit Browser List. 
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2 When events.html opens in the browser of your choice, look for diff erences between 
the Design view preview and the version rendered by your browser. At this stage, 
there shouldn’t be anything too surprising, but there may be subtle diff erences in 
spacing and font style. Close your web browser.

There is another method to preview your pages: the Live View feature. Live 
View allows you to preview your page without having to leave the Dreamweaver 
workspace. You can think of Live View as a browser within Dreamweaver (in fact, 
it is the same WebKit rendering engine found in browsers such as Apple’s Safari and 
Google’s Chrome, among others).

3 Press the Live button located in the Document toolbar at the top of your page. You 
will not see a dramatic diff erence, but your text may shift slightly. Select the fi rst 
heading in the window and try to delete it; you will be unable to, because Live View 
is a non-editable workspace. However, Live View does allow you to edit your page 
when you are in Split view. Here, you are allowed to edit in the Code view and 
changes will be refl ected in real time. An additional advantage is that your document 
does not have to be saved in order to see the changes.

When Live View is enabled, Dreamweaver simulates a web browser.

4 Click the Live button again to deactivate this view. While Live View is a useful addition 
to Dreamweaver, it does not replace the need to preview your page in a browser. Web 
pages might be rendered diff erently depending on your visitor’s browser, and so it is a 
good habit to check your page occasionally as you make changes to your design. 

Understanding hyperlinks
When people visit a website, they usually expect to see more than one page. Imagine 
trying to shop for a new book by your favorite author on a site that consisted of nothing 
more than a single order form with every book off ered by a retailer like Amazon.com. This 
might seem absurd, but without hyperlinks you wouldn’t have much choice.

Hyperlinks make the Web a truly interactive environment. They allow the user to freely 
navigate throughout a website, or jump from one site to another. There are a number of 
ways to create links in Dreamweaver, but before you get started, you should be aware of 
some fundamental facts. 
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Links rely on directory paths to locate fi les. A directory path is simply a description of a 
fi le’s location that can be understood by a computer. A classic, real-world example is an 
address. If you wanted to send a letter to your friend Sally in Florida, you would have to 
specify the state, city, street, and house number where Sally can be found. If Sally lived at 
123 Palm Street in Orlando, the path would be:

Florida/Orlando/123 Palm Street/Sally

This simply means that inside Florida, inside Orlando, in the house numbered 123 on a 
street named Palm Street, you can fi nd a person named Sally. Hyperlinks follow the same 
logic:

www.somewebsitesomewhere.com/photos/mydog.jpg

This URL address is a link to a JPEG image named mydog.jpg, which is inside a folder 
named photos on a website named somewebsitesomewhere.com. 

Creating hyperlinks
Later in this lesson, you’ll be creating a gallery page to showcase some of the sample 
products mentioned in the main paragraph. Before you work on that page, you’ll link it 
to the home page by creating a hyperlink. If you are not already in Design view, select 
Design view now.

1 In the Property Inspector, click on the HTML button to access the HTML properties.

2 In the fi rst paragraph, highlight the word products in the second sentence.

3 In the Property Inspector, type products.html in the Link text fi eld. Press Enter 
(Windows) or Return (Mac OS). The highlighted word automatically becomes 
underlined. It is important to note that we have created this page for you and it is 
currently inside your site folder, you are simply linking to it.

Type products.html into the Link text fi eld in the Property Inspector.

4 Choose File > Save and then File > Preview in Browser.
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5 Click on the new products link. The products page appears in your browser window. 
This is because a previously existing page named products.html was located in this 
folder.

Now visitors can easily navigate to the products page, but what happens when they 
want to go back to the events page? It looks like you’ll need another link.

6 Return to Dreamweaver and double-click on products.html in the Files panel. Click 
to the right of the word Produce and press Enter (Windows) or Return (Mac OS) to 
create a new line. Choose Insert > Hyperlink to open the Hyperlink dialog box. 

The Hyperlink dialog box is one of the many ways to create a link in Dreamweaver. It 
off ers all the options found in the Property Inspector, with a few additions. 

7 Type Events in the Text fi eld.

The Hyperlink dialog box is one of the many ways to 
create links in Dreamweaver.

8 Click on the Browse button to the right of the Link text fi eld to open the Select File 
dialog box. The dw03lessons folder you defi ned as the root for this site should be 
selected for you by default. If not, click the Site Root button. Select events.html and 
press OK (Windows) or Open (Mac OS).

9 Click inside the Title fi eld and type Organic Utopia events page. Titles are 
strictly optional for hyperlinks, but they improve accessibility for users with assistive 
technologies, such as Screen Readers. Additionally, adding titles to your hyperlinks 
can also improve your site’s search engine rankings. Click OK to commit the changes; 
notice that a link to events.html has been created for you using the text entered into 
the Text fi eld in the Hyperlink dialog box.

10 Choose File > Save and keep this fi le open for the next part of this lesson.
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Relative versus absolute hyperlinks 
After reading about the fundamentals of hyperlinks and directory paths a few pages ago, 
you may be surprised by the simplicity of linking events.html and products.html. Instead 
of entering a long directory path in the Link text fi elds, you merely typed the name of the 
fi le. This kind of link is called a relative link. Let’s go back to the address example to see 
how this works.

Remember Sally from Orlando? Imagine you were already standing on Palm Street, where 
she lives. If you called her for directions to her house, she probably wouldn’t begin by 
telling you how to get to Florida. At this point, all you need is a house number. Relative 
links work the same way. Because events.html and products.html both reside in the 
dw03lessons folder, you don’t need to tell the browser where to fi nd this folder.

Now you’ll create an absolute link that will allow visitors to access the Adobe website to 
learn more about Dreamweaver CS6.

1 Click on the events.html tab above the Document toolbar to bring the page forward. 
Scroll down to the bottom of the page if necessary. Using the Design view window, 
create a new line at the bottom of the page after the text that reads “Occasionally we 
gather...”, and type This page was created with Adobe Dreamweaver. 

2 Highlight the words Adobe Dreamweaver and in the Common section of the 
Insert panel on the right side of the screen, click on the Hyperlink icon to open the 
Hyperlink dialog box.

The Hyperlink icon in the Insert panel 
is another convenient way to create links.
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3 The Hyperlink dialog box opens. Notice that Adobe Dreamweaver has been entered 
into the Text fi eld for you. In the Link text fi eld, type http://www.adobe.com/
products/dreamweaver.html. Make sure to include the colon and the appropriate 
number of forward slashes. 

The absolute link http://www.adobe.com/products/dreamweaver.html instructs the browser 
to fi nd a website named adobe.com on the World Wide Web. Then the browser looks 
for a fi le named dreamweaver.html located inside a folder named products.

You do not have to type the absolute hyperlinks if you have the website open in your browser. 
In your web browser, select the address in the address bar, copy it, and then paste it into the Link 
fi eld in Dreamweaver.

4 Choose _ blank from the Target drop-down menu. Choosing the _ blank option 
will cause the hyperlink to the Adobe website to open in a new, blank browser 
window or tab (depending on the browser).

Set the target window for the hyperlink to open in a blank 
browser window or tab.

5 Press OK to close the Hyperlink dialog box. Choose File > Save, then File > Preview in 
Browser, or press the Preview/Debug in Browser button ( ) in the Document toolbar. 

6 Click on the Adobe Dreamweaver text. Unlike the Events and Products links you 
created earlier, this link causes your browser to open a new tab or window, and it is 
pointing to an external web page on the Internet. 

7 Close your browser and keep this fi le open; you will be adding to it in the next exercise.
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Linking to an e-mail address
Absolute and relative links can be used to access web pages, but it’s also possible to link to 
an e-mail address. Instead of opening a new web page, an e-mail link opens up the default 
mail program on a visitor’s computer and populates the address fi eld with the address you 
specify when creating the link. As you may imagine, this kind of link can work diff erently 
depending on how your visitors have confi gured their computers.

In the previous part of this lesson, you gave the visitor a link to some information on 
Dreamweaver. Now you’ll link them to an e-mail address where they can get some 
information on learning Dreamweaver from the folks who wrote this book.

1 Place your cursor at the end of the last line, then hold down your Shift key and 
press Enter (Windows) or Return (Mac OS). Instead of creating a new paragraph, 
this creates a line break, or a soft return, and the text begins immediately below 
the previous line. Type Contact info@agitraining.com for information on 
Dreamweaver classes.

2 Highlight the text info@agitraining.com and click the Email Link button in the 
Insert panel.

3 The Email Link dialog box opens with both fi elds automatically populated. Press OK. 
You may preview this page in your browser if you choose. Remember that if you click 
on the link, your email client will begin to launch.

The Email Link dialog box allows you to link to 
an e-mail address.
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Creating lists
Bulleted lists may be familiar to you if you have worked with word processing or desktop 
publishing applications. Lists are a helpful way to present information to a reader without 
the formal constraints of a paragraph. They are especially important on the Web. Studies 
indicate that people typically skim web pages instead of reading them from beginning to 
end. Creating lists will make it easier for your visitors to get the most from your website 
without sifting through several paragraphs of text.

1 On the events.html page, click and drag to highlight the four lines below Spring 
Events.

2 Make sure you have the HTML button selected in the Property Inspector at the 
bottom of your page, and click the Unordered List button. The highlighted text 
becomes indented, and a bullet point is placed at the beginning of each line.

Use the Unordered List button in the Property Inspector to create a bulleted list.

3 Click the Ordered List button to the right of the Unordered List button. The bullets 
change to sequential numbers. 

4 Choose Format > List > Properties to open the List Properties dialog box. Choose 
Bulleted List from the List type drop-down menu to return to your fi rst style of list. 
The Numbered List and Bulleted List options in the List type drop-down menu also 
allow you to switch between ordered and unordered lists. 
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5 From the Style drop-down menu, choose Square. This changes the default circular 
bullets to square bullets. Press OK to exit the List Properties dialog box.

Change the bullet style to square in the List Properties 
dialog box.

You may have noticed that the four lines of text in your list have lost their style. They 
are slightly larger than your paragraphs and they are black, not dark gray. This is 
because a style has been defi ned for paragraphs, but not an unordered list. You will 
now create a new CSS rule for the appearance of all unordered lists in the document.

6 With all four lines still highlighted, click on the CSS button in the Property Inspector 
at the bottom of your page. Click on the arrow to the right of the Size fi eld. Choose 
14 from the Size drop-down menu in the Property Inspector. The New CSS Rule 
dialog box appears. This dialog box appears because it is the fi rst time you have 
attempted to style an unordered list. After you defi ne the properties, all text formatted 
as an unordered list will appear the same.

7 From the Selector Type drop-down menu, choose Tag. In the Selector Name text 
fi eld, the selector ul has been chosen for you; ul is the HTML tag for an unordered 
list. If ul is not chosen for you, type ul inside this text fi eld. Press OK to apply the 
changes; in this case the font size is set to 14 pixels. Now you need to change the color 
of the unordered list to match the color of your paragraph.

8 In the Property Inspector, if the Targeted Rule drop-down menu does not read ul, 
choose ul from the menu. Click on the color swatch and in the top-left corner of the 
colors panel, locate the dark gray swatch, which is hexadecimal color #666. Click on 
the swatch to apply the color.

9 Choose File > Save. Leave this fi le open for the next part of this lesson.
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Using the Text Insert panel
There are a number of ways to format text in Dreamweaver. One method you haven’t 
explored yet is the Text Insert panel. Because most of the options available in the Text 
Insert panel are also available in the Property Inspector, you may fi nd it more convenient 
to use the Property Inspector for common tasks. However, you should be aware of the 
Characters menu located in the Text Insert panel. One of the most common items in the 
Characters menu used on the Web is the copyright symbol, ©. You will now insert a 
copyright notifi cation at the bottom of your Events page.

1 Click to the left of the sentence This page was created with Adobe Dreamweaver and type 
2012 and then add a space.

2 Click before the text 2012 to insert your cursor.

3 Click on the menu at the top of the Insert panel on the right side of your page 
and choose Text. Scroll all the way to the bottom of the resulting list and click on 
Characters to open a menu. Choose the Copyright symbol from the list to add it to 
the beginning of the line.

The copyright symbol can be inserted from 
the Character menu.

DWCS6_06Pass.indb   82DWCS6_06Pass.indb   82 5/2/12   5:15 PM5/2/12   5:15 PM

www.it-ebooks.info

http://www.it-ebooks.info/


3

83Lesson 3, Adding Text and Images

Inserting images

4 Highlight the last two lines on your page, beginning with the newly inserted 
copyright symbol and ending with Dreamweaver classes. You are going to set these 
two lines apart from the rest of the page by italicizing them. Layout considerations such 
as headers and footers will be discussed throughout the following lessons in this book, 
but for now you can use the Text options in the Insert panel to italicize these two lines.

5 Scroll to the top of the Text options in the Insert panel and click the Italic option.

You could have also used the Italic button in the Property Inspector. Additionally, you could have 
selected the text and chosen Insert > HTML > Text Objects to accomplish the same thing.

6 Choose File > Save.

Inserting images
Images are an essential part of most web pages. Just as lists make content friendlier and 
more accessible, images help to give your visitors the rich, visual experience that they’ve 
come to expect on the Web. However, before you learn to insert images, you will briefl y 
learn about web graphics.

Image resolution
While it is possible to resize images with Dreamweaver, it’s generally not a good idea. 
Specifying the width and height of an image in the Property Inspector changes the 
display size of the image, but it does not resample the image the way a graphic processing 
application like Photoshop does. For example, a JPEG image that is 150 pixels by 150 
pixels might have a fi le size of 30k. You could resize this image in Dreamweaver by 50% 
and the result would be a thumbnail image displayed at 75 pixels by 75 pixels. However, 
even though the image is visually smaller, the fi le size remains the same. A visitor to your 
website still must download the 30k fi le and this translates to slower loading time for the 
image (and possibly the page) and a potentially poor user experience, especially if they 
have low bandwith.

Image formats
The three most common image formats on the Web are JPEG, GIF, and PNG. While an 
exhaustive description of how each of these formats compresses data is beyond the scope of 
this book, a general overview can help you avoid some common pitfalls.

The JPEG format was created by a committee named the Joint Photographic Experts Group. 
Its sole purpose is to compress photographic images. Specifi cally, it uses lossy compression, 
which means that it selectively discards information, to reduce the size of a fi le. When you 
save a JPEG, you decide how much information you are willing to sacrifi ce by selecting a 
quality level. A high-quality image preserves more information and results in a larger fi le 
size. A low-quality image discards more information, but produces a smaller fi le size. The 
goal is to reduce fi le size as much as possible without creating distortion and artifacts. 
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Because JPEGs were designed to handle photographic images, they can signifi cantly 
reduce the size of images containing gradients and soft edges, without producing 
noticeable degradation. However, reproducing sharp edges and solid areas of color often 
requires a higher quality setting.

The GIF format was created by CompuServe. GIF is an acronym for Graphics Interchange 
Format. Unlike the JPEG format, GIFs do not use lossy compression. Instead, GIFs rely 
on a maximum of 256 colors to reduce the size of images. This means that images with 
a limited number of colors can be reproduced without degradation. Logos, illustrations, 
and line drawings are well-suited to this format. Unlike JPEGs, GIFs excel at reproducing 
sharp edges and solid areas of color. However, because photographic elements such as 
gradients and soft edges require a large number of colors to appear convincing, GIF images 
containing these elements look choppy and posterized. 

The PNG format has become increasingly popular on the Web in recent years because 
it incorporates many of the best features of JPEGs and GIFs. The PNG format is closer 
to GIFs in that it off ers lossless compression and comes in two categories: 8 bit and 24 
bit. This means it can be used quite eff ectively for simple graphics as well as continuous 
tone photographic images. A PNG also off ers better transparency features than a GIF, 
most signifi cantly the support of alpha channels. For many years the adoption of PNGs 
(especially the use of the transparency) was held back because Internet Explorer 6 ignored 
the transparency. As the number of people using this browser continues to decline, the 
PNG format is being used more frequently. For more information on web graphics see the 
Web Design with HTML and CSS Digital Classroom book, which is available in both print 
and electronic formats.

Creating a simple gallery page
Now that you have a better understanding of the types of images that are appropriate for 
use on your website, it’s time to build the products.html page that you linked to earlier in 
this lesson.

1 Double-click on products.html in the Files panel or click on the tab, as it’s still open. 
Place your cursor after the word Produce and press Enter (Windows) or Return 
(Mac OS) to create a new line.

2 Choose Insert > Image. The Select Image Source dialog box appears. If your site 
folder does not open automatically, click the Site Root button, and then double-click 
the images folder. Select beets.jpg and press OK (Windows) or Open (Mac OS).
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3 When the Image Tag Accessibility Attributes dialog box appears, type Beets in the 
Alternate text fi eld. Press OK.

The Alternate text fi eld in the Image Tag Accessibility Attributes dialog box corresponds to the 
Alt attribute of an <img> tag. Including a description of the inserted image in this fi eld is not 
technically necessary, but it is good practice. It provides information about the images to visually 
impaired visitors using screen readers. Also, Alt text is displayed in place of images on some 
handheld devices, and browsers where images are disabled.

4 Click on the Split button in the Document toolbar to view the code that was written 
by Dreamweaver when you inserted beets.jpg. An <img> tag was created, with four 
attributes. The src attribute is a relative link to the .jpg fi le in your images folder. The 
alt attribute is the alternate text you specifi ed in the last step. The width and height 
attributes are simply the width and height of the image, and these have automatically 
been added by Dreamweaver. Press the Design button to return to this view.

Dreamweaver creates an <img> tag with a number of attributes when you insert an image.
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5 Double-click on the images folder in the Files panel to reveal its contents. In the document 
window, click to the right of the beets image and press Enter (Windows) or Return 
(Mac OS) to create a new line. Click and drag cucumbers.jpg from your Files panel 
directly below the beets image in the Design view. When the Image Tag Accessibility 
Attributes dialog box appears, type Cucumbers into the Alternate text fi eld. Press OK. 

6 Click to the right of the cucumber image to place your cursor, and press Enter 
(Windows) or Return (Mac OS) to create a new line. To add the last image, you’ll use 
the Insert panel on the right side of your page. Click the menu at the top of the Insert 
panel and choose Common from the list. Click on the Images:Image option, and the 
Select Image Source dialog box appears.

Choose Image from the Images drop-down menu 
in the Common section of the Insert panel.

7 Navigate to the images folder if necessary, select the eggplants.jpg image, and press 
OK (Windows) or Open (Mac OS).

8 Type Eggplants in the Alternate text fi eld of the Image Tag Accessibility Attributes 
dialog box, then press OK.

9 Choose File > Save and leave products.html open for the next part of this lesson.
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Linking images
Often, gallery pages on the Web contain small thumbnail images that are linked to 
larger, high-resolution images. Like many web conventions, there are practical reasons for 
this format. Because all the images on a gallery page must be downloaded by visitors in 
order to view the page, small images are necessary to keep the page from taking too long 
to load. Additionally, a user’s screen isn’t large enough to accommodate multiple large 
pictures at one time. Giving your visitor a way to preview which pictures they would like 
to see on a larger scale makes the page more user friendly and interactive.

1 In products.html, click on the image of the beets to select it. In the Property 
Inspector, type images/beets_large.jpg into the Link text fi eld. Press Enter 
(Windows) or Return (Mac OS). The 5-pixel border around the image turns blue. 
This border indicates that the image is a link.

Manually typing in the link is one way to link to the image, but can introduce errors. 
Here is a second method using Dreamweaver’s Point to File feature.

2 Click on the image of the cucumbers to select it. In the Property Inspector, locate the 
Point to File icon ( ) next to the Link text fi eld. Click and drag this icon into the 
Files panel. An arrow with a target at the end follows your cursor. As you hover over 
items in the Files panel, they become highlighted. Release the mouse while hovering 
over the cucumbers_large.jpg fi le.

With the Point to File feature, you can simply click and drag to create a link.

3 Select the image of the eggplants and use the Point to File icon to link it to 
eggplants_large.jpg.

4 Choose File > Save, and then File > Preview in Browser. Click on the thumbnails to 
see the large versions of each image. You’ll have to use your browser’s back button to 
get back to the products page.
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Using image placeholders
Often, you will want to start building web pages before you have all the fi nal content 
available. This happens regularly in professional situations where diff erent people may be 
responsible for preparing images, writing copy, and creating the site. Next, you’ll build 
a second section in the products.html page that will eventually include a collection of 
chocolate pictures.

1 In Dreamweaver, on the products.html page, place your cursor to the right of the 
eggplants.jpg image, and press Enter (Windows) or Return (Mac OS) to create a new line.

2 Type Chocolate, then press the HTML button in the Property Inspector and choose 
Heading 2 from the Format drop-down menu. Place your cursor at the end of the 
word Chocolate and press Enter/Return to create a line below this new heading.

3 Choose Insert > Image Objects > Image Placeholder. When the Image Placeholder 
dialog box appears, type belgianchocolate in the Name text fi eld, 300 in the Width 
text fi eld, and 200 in the Height text fi eld. Leave the Color set to the default and the 
Alternative text fi eld blank. Press OK to exit the dialog box.

A gray box with the name belgianchocolate appears. This box is simply an <img> tag 
with an empty Src attribute. If you are new to web design, it’s important to note that 
placeholders are not required, but they are useful in allowing you to visualize a page 
when you don’t have images available. Now you’ll insert an image into the placeholder 
by setting the Src attribute in the Property Inspector.

The belgianchocolate image placeholder.

4 With the belgianchocolate image placeholder selected, click and drag the Point to File 
icon to the right of the Src text fi eld and locate the belgianchocolate.jpg image. The 
image of the Belgian chocolate replaces the gray box.
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5 In the Property Inspector, use the Point to File icon of the Link text fi eld to link 
belgianchocolate.jpg to belgianchocolate_large.jpg. Choose File > Save and leave this 
fi le open for the next part of this lesson.

Editing images
Although it’s best to make adjustments to your images using a professional graphics-
editing program like Adobe Photoshop, sometimes that’s not an option. Dreamweaver 
off ers a number of editing options, including an Edit link that allows you to quickly open 
a selected image in the graphics editor of your choice.

The Edit button can be customized in the File Types/Editors section of the Preferences dialog 
box, found under the Dreamweaver drop-down menu. You can use this section to add or subtract 
programs from the list of available editors, and set programs as the primary choice for handling 
specifi c fi le extensions. 

Adjusting brightness and contrast
Now you’ll use Dreamweaver’s Brightness and Contrast button to lighten up the eggplants 
image on your products page.

1 Click on the eggplants.jpg image in products.html to select it, then click on the 
Brightness and Contrast button in the Property Inspector.

Select the Brightness and Contrast button in the Property Inspector.

A warning dialog box appears, indicating that you are about to make permanent 
changes to the selected image. Press OK.

2 When the Brightness/Contrast dialog box appears, drag the Brightness slider to 20 or 
type 20 in the text fi eld to the right of the slider.

3 Drag the Contrast slider to 10 or type 10 in the text fi eld to the right of the slider.

4 Click the Preview checkbox in the lower-right corner to see the original photo. Click 
the Preview checkbox again to see the changes. Press OK.

While changing the brightness and contrast is very convenient in Dreamweaver, you should be 
sure you are not performing the corrections on the original, as these changes are destructive.
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Optimizing images
In most cases, if you need to have fi ne control over the appearance of your graphics, you 
should open an image editor designed for that purpose. Both Dreamweaver and Photoshop 
are made by Adobe, and you’ll see some of the integration between the two in this exercise. 
However, sometimes you will just want to make a quick-and-easy change to a graphic. In 
this scenario, you can use the Edit Image Settings option in the property inspector.

You’ll use this feature to change the optimization of the belgianchocolate.jpg image, but 
before you make any permanent changes, you’ll duplicate this image in the Files panel. It’s 
good practice to save copies of your image fi les before making permanent changes. Later, 
you’ll use this backup copy to undo your changes.

1 In the Files panel, click on the belgianchocolate.jpg fi le to select it. From the Files 
panel menu ( ), select Edit > Duplicate. A new fi le named belgianchocolate - Copy.jpg 
appears in the list of fi les inside the images folder.

2 Click on the belgianchocolate.jpg image in the document window to make sure it is 
selected, then click the Edit Image Settings button ( ) in the Property Inspector at 
the bottom of your page. The Image Optimization window appears. This window 
allows you to either choose from a number of compression presets, or to create your 
own. Currently, the format is set to JPEG because Dreamweaver recognizes the type 
of fi le you have selected. Notice in the bottom-left corner that the fi le size is listed; in 
this case, 31k. Pay attention to this number as it plays a role in the rest of this exercise.

The Image Optimization window appears when you click on the Edit Image Settings button.

3 Click the preset menu and choose GIF for Background Images. The optimization 
settings appear. Click the Color menu and choose 4. The image of the chocolate 
changes to a preview of these settings, and the image has become fl at with most of the 
detail removed. Notice that the fi le size has changed to 3K.

This tells you that you would achieve a tremendous reduction in fi le size, but it would 
occur at the expense of image quality. In fact, the GIF fi le format is not generally 
suited for photographic images. You will now try a custom setting.
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4 Click the Format menu and choose JPEG from the list. You now have a slider for 
quality, the default value is 80 and you can see the fi le size has changed to 9K. Drag 
the slider to the left to a quality of 10 and notice that the image quality changes 
instantly. Again, this is too drastic a trade-off . Drag the quality slider to 90. The 
image looks slightly better than it did at a quality of 80, and you have a fi le size of 
around 14K (which is approximately 50% of the original image).

Click OK to commit the change. Note that this method of optimization is risky if you 
do not have a backup. (Recall the backup created in step 1.) 

5 You can also choose to do your optimization in Photoshop. Click the cucumbers 
image, and then in the Property Inspector, click the Photoshop icon if available. Note 
that you must have Photoshop installed for this icon to be visible. As noted earlier, 
you can always change the photo editor that Dreamweaver uses by opening Edit > 
Preferences > File Types/Editors (PC) or Dreamweaver > Preferences > File Types/
Editors (Mac), and then changing the application associated with images.

Click on the Photoshop icon to launch Photoshop.

6 The image will open in Photoshop, and then you can make any changes you want, as 
well as use the more in-depth controls of the Save for Web feature. We will not walk 
through that process now, so you can close this image and return to Dreamweaver.

Updating images
Assuming you have a backup copy of an image, it is possible to swap one image for 
another. To swap out the image, you’ll simply change the Src attribute, using the Property 
Inspector. But fi rst, it’s a good idea to rename the duplicate image.

1 Right-click (Windows) or Ctrl+click (Mac OS) on the fi le named 
belgianchocolate - Copy.jpg in the Files panel and choose File > Rename. Type 
belgianchocolate_original.jpg and press Enter (Windows) or Return (Mac OS).

2 Click on the chocolate image in the Design view to select it. In the Property Inspector 
at the bottom of your page, highlight the text that reads images/belgianchocolate.jpg in 
the Src text fi eld. 

3 Click and drag the Point to File icon to the belgianchocolate_original.jpg image you 
just renamed. The compressed image is replaced with the copy you made earlier. 

4 Choose File > Save. 

Congratulations, you have fi nished this lesson. 
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Self study
To practice styling text with the Property Inspector, create styles for the text in 
events.html. If you’re feeling bold, try copying the CSS styles from the Code view. 

To make the thumbnail links in products.html open in a new window, set their target 
attributes to _blank in the Property Inspector.

Try adding your own photos to the products page. Remember to be careful when resizing 
them!

Review
Questions
1 Of the two most common image formats used on the Web, which is better suited for 

saving a logo?

2 If an inserted image is too small, can you make it larger by increasing its size in the 
Property Inspector?

3 How do you insert a copyright symbol (©) in Dreamweaver?

Answers
1 Because logos usually contain a lot of hard edges and solid areas of color, the GIF 

format is the most appropriate choice.

2 Yes, it is possible to increase the display size of an image; however, doing so reduces 
image quality. 

3 Use the Characters drop-down menu in the Text tab of the Insert bar.
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What you’ll learn in 
this lesson:
• An introduction to 

Cascading Style Sheets (CSS)

• Using the CSS Styles panel

• Creating tag and class 
styles

• Styling text and hyperlinks

• Creating external style 
sheets

Lesson 4

Many years ago, creating a beautiful web page required a lot of work, 
using the limited capabilities of HTML tags. The introduction of 
Cascading Style Sheets changed the way pages are created, giving 
designers an extraordinary amount of control over text and page 
formatting, as well as the ability to freely position content anywhere 
on a page. In this lesson, you’ll focus on the fundamentals of 
working with CSS in Dreamweaver. 

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw04lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Styling Your Pages with CSS
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Before you begin, you need to create site settings that point to the dw04lessons folder from 
the included DVD that contains resources you need for these lessons. Go to Site > New 
Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

See Lesson 4 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

What are Cascading Style Sheets?
In the last lesson you had a brief introduction to Cascading Style Sheets (CSS); now you 
will dive in a bit deeper. CSS is a simple language that works alongside HTML to apply 
formatting to content in web pages, such as text, images, tables, and form elements. 
Developed by the World Wide Web Consortium (W3C), CSS creates rules, or style 
instructions, that elements on your page follow. There are three locations for CSS: (1) An 
internal style sheet where the styles are located directly within the <head> section of an 
HTML document, (2) inline styles (the CSS is located side by side with your HTML tags), 
or (3) An external style sheet where styles are located in an external fi le that can be linked 
to any number of HTML pages. If you completed Lesson 3, you have had experience with 
the fi rst option. 

A style sheet is a collection of CSS rules; typically, rules that belong to a specifi c project, 
theme, or section are grouped together, but you can group rules in any way you want. You 
can place style sheets directly within your page using the <style> tag or in an external 
.css fi le that is linked to your document with the <link> tag. A single page or set of pages 
can use several style sheets at once.

You can apply CSS rules selectively to any number of elements on a page, or use them 
to modify the appearance of an existing HTML tag. Each CSS rule is composed of one 
or more declarations. A declaration contains both a property and a value. Examples of 
properties include color, width, and font size. Examples of values for these properties are 
green, 450px, and 12px, respectively. Dreamweaver’s CSS Styles panel lets you easily view 
and modify any of these properties and values and change the appearance of your page in 
real time.

This sample rule is composed of three declarations that control the color, typeface, and 
size of any text to which it’s applied. In the simplest example, the CSS rules defi ne the 
appearance of an H1 or heading element:

h1 {
color: red;
font-family: Arial,Helvetica,Sans-serif;
font-size: 28px;

}

4
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Here is the result of the preceding code snippet applied to text:

CSS-styled text shown in the Design view.

CSS rules can aff ect properties as simple as typeface, size, and color, or as complex as 
positioning and visibility. Dreamweaver uses CSS as the primary method of styling page 
text and elements, and its detailed CSS Styles panel makes it possible to create and manage 
styles at any point during a project.

CSS replaces inefficient HTML styling
Before CSS came along, you styled text on a page using the <font> tag in HTML; you 
could wrap this tag around any paragraph, phrase, or tidbit of text to apply color, or to set 
the font size and typeface. Although it was reliable, it was also very ineffi  cient. Imagine a 
page with 10 paragraphs. Using the <font> tag, you would have to add the <font> tag 
10 times, even if the color, size, and typeface values were exactly the same. Although the 
<font> tag is not in use as much anymore, you should still understand how it works. You 
will now open an HTML document in which the list is styled using the <font> tag.

1 In your Files panel located in the lower-right corner of your screen, locate and double-
click the HTML fi le named FontTagList.html to open it in the document window. 

2 Press the Code View button in the Document toolbar at the top of the document 
window. Notice that the <font> tag is used to style the items in the bulleted list.

Here, a <font> tag is used to format each bullet point. If you add more bullet points, you’ll need to 
use more <font> tags to keep the style of those bullets consistent with the others.

As you can see, there’s a lot of repetition in this code. 
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3 Press the Design View button on the Document toolbar. Position your cursor at the end 
of the last bulleted item, press Enter (Windows) or Return (Mac OS) to add a new bullet 
point, and type Peppers. You see that the text reverts to the default typeface, size, and 
color. You would have to add a new <font> tag with the same attributes as the others to 
get it to match. If you wanted to change an attribute such as the color for all the bullet 
points, you would have to adjust each tag separately. In early versions of Dreamweaver, 
there were actually ways to perform global changes using HTML; however, these were 
sometimes tricky to control, and CSS off ers a better solution in any case.

You may lose the formatting between bullet points when using <font> tags.

4 Choose File > Save to save your work, then choose File > Close.

The benefits of CSS styling
CSS introduces a new level of control and fl exibility far beyond the <font> tags in 
HTML. A signifi cant benefi t of CSS is the ability to apply consistent formatting of 
elements across one or all pages in a website. In the following exercises you will learn a 
few diff erent ways to create CSS rules that aff ect the style of your text. The fi rst method 
you will explore involves creating tag- or element-based style rules. If you completed 
Lesson 3, you saw this method used to format text. This type of rule alters the appearance 
of an existing HTML tag, so the tag and any content that appears within it always appears 
formatted in a specifi c way. Instead of having to add a <font> tag around the contents of 
each new bullet point in a list, it would be easier for you to set a rule that states that items 
in a list should always be blue, for example. 

1 Locate and double-click the fi le named CSSList.html from the Files panel to open it.

2 Press the Design View button in the Document toolbar if necessary. The list that 
appears onscreen, unlike the one you saw in the previous example, is formatted 
without the use of <font> tags, and uses only CSS.

3 Position your cursor after the last bulleted item and press the Enter (Windows) or 
Return (Mac OS) key to create a new bullet point. Type in Peppers. The new text 
matches the bullet points above it. 

4 Press Enter/Return again to add a fi fth bullet point, and type Okra. 

No matter how many bullet points you add, the formatting is applied automatically 
every time.
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5 Select Split view at the top of the document window so that you can see both code 
and design:

CSS allows you to defi ne a style rule for a list item. All list items on this page will be blue.

What you’ll notice is the absence of any formatting tags like the <font> tags you saw 
in the last exercise. In this example, you have several list items; however, all the styling 
information, such as the font-family, size, font style, and color, is being defi ned in one 
place: the CSS rule for the <li> tag. 

6 If necessary, scroll to the top of the page and you’ll see the code that makes this 
possible:

<style type="text/css">
<!--
li {

font-family: Arial, Helvetica, sans-serif;
font-size: 13px;
font-weight: bold;
color: #0000FF;

}
-->
</style>

In the code above, a CSS selector (seen here as li) is being used to defi ne the style of 
all list items. It’s almost like a dress code for all <li> tags; they know that when they 
are used on the page, they must look a certain way. Best of all, if you need to modify 
their appearance, you make your changes to that single style rule at the top of the 
page. You will get a chance to do this shortly; however, let’s take a step back and look 
at how CSS is controlled in Dreamweaver.

7 Choose File > Save to save your work, then choose File > Close.
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How do you create CSS rules in Dreamweaver?
In this exercise, you will take a tour of Dreamweaver’s CSS controls. If you haven’t 
worked with CSS before, this is a chance to learn a bit more about how it works. If you 
have worked with CSS previously, this section will help you understand the Dreamweaver 
interface and how it applies to familiar concepts. Regardless of your comfort level with 
CSS, you won’t be making any changes, merely getting familiar with features that you 
will be using in later exercises.

You work with CSS rules in a few ways in Dreamweaver:

Using the CSS Styles panel

You can use Dreamweaver’s CSS Styles panel to create new rules and/or style sheets that 
you can place directly within one or more pages in your site. You can easily modify rules 
directly from the CSS Styles panel. Furthermore, you can selectively apply rules from 
several places, including the Style or Class menu on the Property Inspector, or the tag 
selector at the bottom of the document window.

The CSS Styles panel has two buttons labeled All and Current. You’ll get a chance to 
explore these shortly. In the following fi gure, you are seeing the panel in the All view.

A
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B

F

H

G

I

N

L

M

K
J

To ensure that you are seeing the same panels we are, you’ll reset your workspace. Choose 
Window > Workspace Layout > Designer. Then choose Workspace Layout > Reset 
‘Designer’ to make sure the panels are reset.

To free up more screen space, double-click the Business Catalyst tab to close it. This expands 
the CSS Styles panel. Click the File panel tab at the bottom of the screen to expand it.

1 Double-click the StylePlaces.html document in your Files panel to open it, and click 
the Design View button, if necessary.

2 Click in the fi rst line, Hi there! I’m styled with an INLINE style!

Launch the CSS panel by choosing Window > CSS Styles. 
A. Show Category View. B. Show List View. 
C. Show Only Set Properties. D. Internal Style Sheet. 
E. External Style Sheet. F. CSS panel menu. 
G. Switch to Current Selection Mode. H. Rules pane. 
I. Properties pane. J. Attach Style Sheet. 
K. New CSS Rule. L. Edit Style Sheet. 
M. Disable/Enable CSS Property. N. Delete/Unlink.
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3 Press the Current button in the CSS Styles panel. A summary pane lists the CSS 
properties for the current selection. Depending on your monitor resolution you may 
not have enough room to see all the information in this panel. You can adjust the 
diff erent panel groups by hand.

4 Place your cursor at the bottom of the CSS Styles tab group. A black double-arrow 
cursor will appear. You can now click and drag downward to lengthen this panel.

You can expand a panel by clicking and 
dragging the edges.

Take a few moments to read through this panel and absorb the summary. Don’t worry 
too much about each detail; you’ll have plenty of time to familiarize yourself with this 
panel. It hopefully makes sense that the properties of the fi rst paragraph are the color 
blue, the font-family Arial, and the font size of 14 pixels.

5 Click on the second paragraph and notice that the color property changes to red. 
Click on the third paragraph and notice that the color property changes to green. The 
current selection always lists the properties of the selected text.

6 Press the All button in the CSS Styles panel to return to this view. You will toggle 
between these two views often. The Current view allows you to see the specifi c CSS 
properties and values of a selected object. The All view gives you an overview of all 
the styles associated with the document.
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Creating styles using the Property Inspector

Whenever you format text directly on your page using the Property Inspector, 
Dreamweaver saves your settings as a new rule, which you have to name in your 
document. Rules that Dreamweaver creates appear in your CSS panel, where you can 
easily modify or rename them.

1 Click in the second paragraph, Hi there! I’m styled with an embedded, or INTERNAL 
style sheet!

2 In the Property Inspector at the bottom of the screen, press the HTML button if 
necessary. This paragraph is styled using a CSS class named red. You’ll learn more 
about classes and how to create and modify them shortly.

3 Press the CSS button in the Property Inspector. You can see some of the properties of 
this rule here in the Inspector, and you can also create and modify them here as you 
did in the previous lesson.

CSS styles are automatically created when you format text with the Property Inspector.

4 In the CSS styles panel, you should be in the All view. If not, click this button now. If 
the style labeled .red is visible, click it now. (If it is not visible, click the + sign to the 
left of the <style> label.) Compare the Property Inspector with the CSS Styles panel: 
they are displaying the exact same information at the moment. However, as your styles 
become more complex, you will see that the Property Inspector only shows you the 
most common styles, whereas the CSS Styles panel always shows you all of them. 

DWCS6_06Pass.indb   100DWCS6_06Pass.indb   100 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


4

101Lesson 4, Styling Your Pages with CSS

What are Cascading Style Sheets?

In the Code view

CSS rules can also be created and modifi ed directly in the Code view. Editing CSS in 
Dreamweaver’s Code view off ers a great degree of control and is often called hand-coding. 
Many coders and designers prefer hand-coding because of this control, but it’s not for 
everyone. For example, when you work in the Code view misspellings or an incomplete 
knowledge of CSS syntax can easily break a page. 

1 Click in the second paragraph if you are not currently inside it. Press the Code View 
button to view your page in Code view. If you haven’t worked with code previously, 
see if you can locate the second paragraph of HTML. (It has the class named “red.”) 

2 On the left side of the screen, notice that the line numbers are running from top to 
bottom; when working with code, each line has its own number, making it easy to 
refer to and locate objects.

On line 10, select the value red in the color property and then delete it. Now type 
#CE1A30. As soon as you start typing, Dreamweaver’s code-hinting appears, giving 
you a color picker. Code-hinting is a form of assistance from Dreamweaver that can 
make the task of typing code by hand a little easier. However, you can also ignore it, 
and you should for this exercise.

Modifying the CSS color property in Code View.

3 Press the Design view button. The text is still red, however it is using a hexadecimal 
color instead of a keyword. The danger of adding CSS properties by hand of course, is 
that if you mistype the value you may get a diff erent color or no color at all.
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Working with the Code Navigator

The Code Navigator allows you to view the CSS properties directly in the Design view 
through a small pop-up window. Additionally, it allows you to click on a property and 
edit it directly in the Split view.

1 Press Alt (Windows) or Command+Option (Mac OS) and click on the third 
paragraph. A small window appears, listing the properties of the CSS rule applying 
to this paragraph. The window lists the name of the style sheet, as well as the rule 
.greenText.

2 Place your cursor over the .greenText class, and the properties appear in a yellow 
pop-up window. This feature allows you to quickly view the properties without 
needing to move to the CSS Styles panel or go into Code view.

The Code Navigator displays the CSS rules applied to a paragraph.

Understanding Style Sheets
The term Cascading in Cascading Style Sheets alludes to the fact that styles can live in 
three diff erent places, each of which has its strengths and weaknesses. You’ve actually 
been working with all three types of styles in the last exercise. The fi rst paragraph is being 
defi ned with an inline style, the second with an internal style sheet, and the third with an 
external style sheet. 

Inline styles 

An inline style is a set of CSS properties defi ned directly in an HTML tag using the 
style attribute. These are slightly less common because you can’t reuse them easily, and 
reusability is one of the major benefi ts of CSS. Nevertheless, inline styles are a part of the 
CSS language, and you should know what they are.

1 In the fi le StylePlaces.html click three times rapidly to select the fi rst paragraph. 

2 Press the Split view button, and notice that your selected text is nested inside a 
paragraph or <p> element; however, the CSS style rules for color, font-family, and 
font-size are contained directly inside the opening paragraph tag. This is called an 
inline style because the CSS rules are not separated from the HTML.

Although inline styles are part of CSS, they are used infrequently. They present many 
of the same problems as the older <font> tags in HTML. They only apply to one tag 
at a time and are not easily reusable. So when are they used? Inline styles are useful 
when an internal or external style sheet may not be available; a good example of this is 
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HTML-based e-mail. They are also used in certain situations to override other styles, 
but you will learn more about this later.

An inline style places rules within a HTML opening tag.

Internal versus external style sheets

Internal style sheets are CSS rules that are contained directly within a document, using the 
<style> tag. The entire style sheet is contained within the opening and closing <style> 
tags. External style sheets are style rules saved in a separate document with the extension 
“.css.” One of the fundamental diff erences between internal and external style sheets is that 
with internal style sheets, the CSS rules apply only to the HTML in a single document. 

For example, if you had a ten-page website and could only use internal style sheets, you 
would essentially have ten style sheets: one per page. If you made a change on one page 
and then needed to make the other pages look the same, you would have to either copy or 
redefi ne internal styles from page to page—not an enjoyable prospect.

External style sheets, by contrast, have CSS rules located in one single document. You 
can attach .css fi les, or external style sheets, to an unlimited number of HTML pages. 
This method is extremely fl exible: if a style rule such as the font-color for a paragraph 
is changed in the external style sheet, all paragraphs in the site are instantly modifi ed, 
whether it be two pages, ten pages or 100 pages.

In Dreamweaver, when you create a new style, the default behavior is to use an internal 
style sheet. In many ways, a web browser doesn’t care which type of style sheet you use; it 
renders the page exactly the same. There are certain situations when an internal style sheet 
makes more sense than an external style sheet and vice-versa. You will explore this in 
more detail in later exercises, but fi rst you need to know how to determine whether a style 
is internal or external. 

1 Open StylePlaces.html if you do not already have it open and click the Design View 
button to enter the Design view. In the CSS Styles panel, click on the All button if 
necessary. In the top half of the screen you will see a listing for <style> and one for 
StylePlacesCSS.css. The fi rst line is the internal style sheet, and the second is for the 
external style sheet.

2 If necessary, click the arrow to the left of the plus sign (Windows) or the arrow 
(Mac OS) to the left of the <style> option, and it expands to show you the rule for 
the class red. Again, if necessary, click the arrow to the left of StylePlacesCSS.css to 
expand this and see the rule for the class .greenText. You may have noticed that the 
listing for the inline style is not here; only rules for internal and external style sheets 
are visible in All mode.
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In the last exercise, you used the Code Navigator to view the CSS rules applied to a 
paragraph. You can also use the Code Navigator to quickly determine where the CSS 
rules are located.

3 Back in Design view, Alt+click (Windows) or Command+Option+click (Mac OS) 
inside the second paragraph to open the Code Navigator. The window reads 
StylePlaces.html and the class .red is indented below it. If a style is located inside an 
HTML document, as it is in this case, it must be an internal style.

The Code Navigator has located the origin of this 
CSS rule to be in StylePlaces.html.

4 Place your cursor over the .red class, and all the properties appear; this is a quick way 
to determine the properties.

5 Click on the .red rule, and Dreamweaver’s Split view opens, sending you directly to 
the internal style. An experienced hand-coder might use this to directly edit the rule 
as you did earlier, although you will not be making any changes at this point. Now 
you will look at the external style sheet again using the Code Navigator.

6 Alt+click (Windows) or Command+Option+click (Mac OS) in the third paragraph to 
open the Code Navigator.

7 This time, the Code Navigator window lists StylePlacesCSS.css fi rst. If a style is 
located inside a .css document, as it is in this case, it is an external style. Place your 
cursor over the .greenText class, and all the properties appear.

8 Click on the .greenText class, and in the Split view, the external style sheet 
StylePlacesCSS.css appears. Doing this actually opens the external style sheet, which is 
a separate document. 

An External Style Sheet is a separate document with the extension .css.

To return to the original HTML document, press the Source Code button 
immediately to the left of the button labeled StylePlacesCSS.css.
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9 Choose File > Save All. Close this document for now. Choosing Save All saves not just 
the HTML document but the external stylesheet at the same time.

Understanding why they’re called Cascading
You have learned how CSS integrates with HTML, and that there are three categories 
of styles: inline, internal, and external. Additionally, you have seen that an HTML 
document, such as the one from the last exercise, can contain all three types. Now you’ll 
begin to explore when you might use one type over the other. A good way to look at this 
is to ask the question: Which one of the three style types is most dominant?

To help you picture this, consider the following situation: you have a paragraph, or 
more accurately, a <p> tag in your document, and you have the three style types (inline, 
internal, and external). Each one targets the <p> tag with the same property (color, for 
example) but they all have diff erent values. So which one wins? The answer is the inline 
style, which is the most dominant because it is closest to the HTML source. The strength 
of competing styles is largely related to where the style is in relation to the HTML source. 
For internal and external styles, if they have competing rules, whichever style comes last 
within the HTML is the strongest. So in the following scenario, imagine that there is 
a paragraph style in the external style sheet (styles.css) declaring paragraphs to be blue. 
Because it comes after the internal style sheet’s rule for red paragraphs, the external style 
sheet “wins” and the paragraph is blue.

<style type="text/css">
p {

color: red;
}
</style>
<link href=" styles.css" rel="stylesheet" type="text/css" />

However it is equally possible that the author of the HTML has arranged the styles in a 
diff erent order:

<link href=" styles.css" rel="stylesheet" type="text/css" />
<style type="text/css">
p {

color: red;
}
</style>

Here, the paragraphs will be red because the internal style sheet comes last in the HTML 
code. There is no default order of styles in the documents that Dreamweaver creates, so 
you do need to be aware of this rule.

We have simplifi ed the relationship for now. The strength of internal styles versus external styles 
can actually change depending on where the references to these styles are in the HTML. If the 
reference to the internal style sheet appears last in the HTML, these rules would be strongest. If 
the reference to the external style appears last in the HTML, then these would be the strongest.
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Creating and modifying styles 
You will now get a chance to begin working more deeply with CSS. In this exercise, 
you’ll be picking up where you left off  in the last lesson with the events page for the 
OrganicUtopia website. In that lesson, you covered the creation of new CSS rules; 
however, you essentially worked with just one category of CSS rules, the element or tag-
based rules. In all instances from the last lesson, you defi ned the properties for a tag, such 
as <h1>, <p>, and <ul> (unordered lists). You will now explore how to create classes and 
IDs. First, a brief review of the styles you used in the last lesson for tag styles.

A tag style assigns rules directly to a specifi c HTML tag to alter its appearance. You can 
attach tag styles to any tag from the <body> tag down; as a matter of fact, when you 
modify page properties (Modify > Page Properties) to change default text formatting and 
background color, you are using a tag style assigned to the <body> tag. 

The most basic tag styles are very straightforward. For instance, when you create a rule 
defi nition for the <p> (paragraph) tag, all paragraphs appear the same. The limitations 
begin when you want to customize one specifi c paragraph to appear diff erent from the 
others. You will explore some solutions to this dilemma; for now, keep in mind that tag 
styles are a great way to ensure consistency across multiple elements and pages where 
specifi c tags are used, such as lists, tables, and paragraphs.

1 Double-click the events.html fi le in the Files panel to open it. This page has already 
had its Heading 1, paragraph, and list styled. You will now style the Heading 2.

2 In the Design view, click inside the heading Spring Events. This is already formatted as 
a Heading 2 for you.

3 Click the CSS button in the left side of the Property Inspector; this allows you to 
defi ne the properties of the Heading.
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4 Choose 18 from the Size drop-down menu on the Property Inspector, and the New 
CSS Rule dialog box appears. From the Choose a contextual selector type for your 
CSS rule drop-down menu, choose Tag. In the Selector Name text fi eld, the selector 
h2 has been chosen for you. Dreamweaver does this because you placed your cursor 
inside the text formatted as h2. Press OK. Now you can add additional properties, and 
Dreamweaver adds them to the defi nition of the h2 tag.

Defi ning a Heading 2 for the fi rst time causes the New CSS Rule 
dialog box to appear.

5 In the Property Inspector, click on the color swatch to choose a color for your text from 
the Swatches panel that appears. Select a dark green. The color #390, located in the top 
row, is used in this example. Your heading now changes to green. You have just styled 
the font-size and color of the <h2> tag. At this point, all text formatted as h2 appears 
this way. You will now format the last heading in the page in order to see this.

6 Click inside the text, Rent our facility. In the Property Inspector, click the HTML 
button. You need to toggle into this view because you now want to change the 
HTML formatting, not the CSS.
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7 In the Property Inspector, note that the Format for this text is currently set to None. 
From the Format drop-down menu, choose Heading 2 to see your text change.

Formatting text as a Heading 2 assumes the properties of the CSS rule.

What you have seen in this exercise is an example of HTML and CSS working 
together with a tag style. In this case, all text tagged in the HTML as a Heading 2 
or <h2> is defi ned by the CSS rule as green and 18 pixels. At this point you may be 
itching to create more complex layouts; if you understand the fundamentals of styling 
tags, it will pay off  as you move to the next level of CSS. 

8 Choose File > Save but keep this fi le open. You will be working on it in the next 
exercise.

Creating a class style with the Property Inspector
In the last exercise, you created a new CSS rule by defi ning the properties of the <h2> tag. 
Now you will create another CSS rule, this time using a class. In CSS, class styles have 
unique names and are not associated with any specifi c HTML tag. A CSS class can have a 
specifi c style that can be applied to one or more elements in your website. So you might 
create a class called holidayText, for example, and the properties of this class might 
be a single rule defi ning the font-color. Once the class is created, this text could then be 
applied to a table, paragraph, heading, or form element simultaneously. So on Halloween, 
if you change the property of the font-color to orange, all text that is defi ned by the 
holidayText class is orange, and on Valentine’s Day, if you change the property of the 
font-color to red, it all changes to red. 
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In this exercise, you will create a class for the copyright text at the bottom of the page in 
order to distinguish it from the rest of the page.

1 Locate the paragraph at the very bottom of your page, click immediately before the 
copyright symbol, and then drag across until the two lines are selected.

2 Press the CSS button in the Property Inspector if necessary; note that this text has a 
size of 14 pixels and a dark grey color. This is because these are paragraphs and the 
CSS rules for paragraphs in this document currently have these properties. You will 
now format all this text with a diff erent size and font, and then add a background 
color. First notice the section of the Property Inspector labeled Targeted Rule and 
note that it is set to <New CSS Rule>.

The Targeted Rule is set to <New CSS Rule>.

Because CSS is so f lexible, you often have many options for styling. Here, 
Dreamweaver is telling you that a new rule will be created. The other option is that 
you could update the paragraph rule that already exists. You can see this option by 
clicking the menu and noting the “p” rule in the Cascade section. For now, make sure 
that New CSS Rule is still selected.

3 In the Property Inspector, click on the drop-down menu for Size and change the 
size from 14 pixels to 10 pixels. The New CSS Rule dialog box appears. The default 
choice for Selector Type is Class, which is what you would like to use. Classes, unlike 
the Tag styles you have been using, must be named; additionally, you must name the 
class, as Dreamweaver does not do it for you. 

Older versions of Dreamweaver automatically assigned generic names to new classes, such as 
.style1, .style2, and so on. In recent versions of Dreamweaver when it comes to styles, 
users are now required to name CSS classes. Although this may seem to be an extra step, it is 
a good one. By being forced to assign names to styles, users are more aware of the code they are 
generating, which makes their web pages easier to maintain.
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4 In the Selector Name fi eld, type copyright. As you type, notice that Dreamweaver 
adds the text, This selector name will apply your rule to all HTML elements with class 
“copyright.” This is Dreamweaver’s way of helping you understand how your new class 
can be applied.

Set the rules for the new copyright class.

5 Press OK. You now see the text formatted at 10 pixels. Once the class is created, you 
can add other properties.

6 Click once in the fi rst line of the copyright text. Notice in the Property Inspector, 
in the Targeted Rule section, the menu is now set for .copyright. This is important, 
as it confi rms that you are modifying the class, not creating a new rule or modifying 
the paragraph tag style. In the Property Inspector, choose Verdana, Geneva, sans-serif 
from the Font menu to add this property to the copyright class. Now you’ll add a new 
line of text and apply the copyright class to it.

7 Place your cursor at the end of the last line of the paragraph and press Enter 
(Windows) or Return (Mac OS) to add a new line. Type the following text: 
All images on this website are the copyright of Glenn “The Hodge” 
Hodgkinson. Notice that the text is still using the copyright style. If you wanted to 
remove this class for any reason, you could click on the Targeted Rule drop-down 
menu and choose Remove Class.
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Creating and modifying styles in the CSS Styles panel
Using the Property Inspector is a quick-and-easy way to create and apply styles and make 
some basic formatting choices; however, the number of style choices in the Property 
Inspector is very limited. To take advantage of the full power of CSS, you will begin 
to dive into the CSS Styles panel. In this exercise, you’ll explore some of the powerful 
options that CSS has at its disposal. The fi rst thing you’ll do is change the background 
color of your page by adding a new style to the body tag.

1 At the top of the CSS Styles panel in the upper-right corner of your screen, make sure 
the All tab is active, and locate <style> underneath; if it is not currently expanded, 
click the arrow to see the list of current rules in your document. You will now add a 
new rule for the body tag in order to change the background color.

2 Click the New CSS Rule icon ( ) at the bottom of the CSS Styles panel. This 
displays the same dialog box you are accustomed to working with, just accessed from 
a diff erent location. From the Choose a contextual selector type for your CSS rule 
drop-down menu, choose Tag. Previously, you have accepted the automatic choices 
in the Selector Name section, but in this case, you need to instruct Dreamweaver that 
you would like to create a new rule for the body tag.

3 From the Choose or enter a name for your selector drop-down menu, select body. 
Press OK. The CSS Rule defi nition dialog box appears. This dialog box gives you 
access to the numerous styling options available in CSS.

Creating a new rule for the body tag launches the CSS Rule defi nition dialog box.

4 In the left Category column, select Background to access the Background properties. 
In the fi eld for Background-color, type in the following hexadecimal number: 
#E0F0E4. The background color does not apply automatically. Press the Apply 
button in the bottom-right corner to preview the new background color.

5 Press OK to confi rm the background color. You will now change the background 
color for the copyright class at the bottom of the page.
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6 In the list of rules in the CSS Styles panel, double-click the .copyright class to edit 
these properties.

Double-clicking a style in the style window 
opens the CSS Rule defi nition dialog box.

7 In the CSS Rule defi nition dialog box that appears, click the Background Category, 
click on the Background-color swatch, and choose white (#FFF) from the list. Press 
OK. The two copyright paragraphs at the bottom of the page are styled with white 
backgrounds. The gap between the two paragraphs reveals the background color 
because these are separate paragraphs, and are both block elements. The gap is somewhat 
visually unappealing and is something you will be fi xing a bit later in the lesson. 

Advanced text formatting with CSS
Text on the Web is necessarily limited due to the fact that designers cannot assume that 
fonts they choose in Dreamweaver will be available to the user. There is a small set of fonts 
that designers can use that are essentially guaranteed to be on all users’ systems. Given this 
limitation, you can use some of the properties in CSS to give your text a distinctive look. 
In this exercise, you will work with the line spacing of your paragraphs and lists, and the 
letter spacing of your headings. 

The limitations on web fonts are slowly changing, and in Dreamweaver CS6, there is now a new 
feature that allows you access to a wider range of font choices. For now, it is still important to learn the 
basics. We cover the new web fonts feature in Lesson 7, “CSS3 Animation and CSS3 Web Fonts.”
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1 In the CSS panel, double-click the rule for p (paragraph) to open the CSS Rule 
defi nition dialog box. You will now override the default line-height for your 
paragraphs. If you have a print background, you may be familiar with leading, which 
is the amount of space between the lines in a paragraph. Line-height is the same thing 
as leading.

2 In the Line-height fi eld, type 20; the value is automatically set for pixels. Press Apply, 
and you will see the space between your paragraph lines increase. Extra line-height 
can often make your text more readable, so it is great that you have this option in 
CSS. However, a problem may arise if you change the font-size. For example, setting 
the fi xed value of 20 pixels looks good with 14-pixel type, but what if you were to 
later change the font-size of your paragraph? The 20-pixel line-height would look 
strange. A more fl exible way to assign line-height is to use a percentage.

3 From Line-height drop-down menu to the right of the text fi eld, choose percent (%). 
Change the value from 20 to 120, and press Apply. You won’t actually see a dramatic 
diff erence because the end result is similar, but by assigning the line-height to 120 
percent, your initial font-size isn’t as important. There will always be the height of the 
line plus 20 percent extra, no matter what the font-size is. Press OK.

Changing the line-height value of a paragraph to a percentage is more fl exible 
than using pixels.

Notice that the list under Spring Events did not change. This is because the line-height 
property applies solely to paragraphs, not lists. If you want to make this list appear the 
same, you could always apply the same value of line-height. However, you will be 
adding extra space between the lines to make the list stand out from the rest of the page.

4 In the CSS Styles panel, double-click on the ul rule. The CSS Rule defi nition dialog 
box appears. In the fi eld for line-height, type 150; then from the drop-down menu 
to the right, select percentage (%). Press OK, and you now have extra space between 
your list items. Now you’ll style your Heading 2 element.
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5 In the CSS Styles panel, double-click the h2 rule. In the Text-transform section, click 
the menu, and from the list, choose uppercase. Press Apply, and you will see your two 
headings, Spring Events and Rent Our Facility!, transform to uppercase. This helps your 
headings stand out and is a lot faster than retyping these headings by hand. Now you’ll 
add some space between all the letters.

Transforming your text to uppercase is just a style; in the HTML, your original text still has 
the standard formatting. One of the few times this might be an issue is if your web page is being 
viewed without a style sheet; older cell phones and PDAs with web browsers do not fully support 
style sheets (or use them at all), and so your text would appear lowercase as it is in the HTML.

6 Select the Block category in the CSS Rule defi nition dialog box. Block styles 
generally control the way text is displayed in the browser. In the fi eld for Letter-
spacing, type 5; then choose px from the drop-down menu to the right. Press Apply, 
and the two headings are extended. Each letter pair has 5 pixels of space between 
them. Press OK. When used well, letter-spacing can make your headings more 
readable and unique.

Adding letter-spacing and uppercasing to your 
headings can make them stand out.
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Fine-tuning page appearance with contextual and pseudo-class selectors
CSS allows you to create styles that are targeted at specifi c HTML elements on your page. 
Understanding these techniques are crucial if you want to gain control over the appearance 
of your page. Look at the Spring Events list on your page: lines 1 and 4 both begin with 
the word Free. Let’s say you wanted to emphasize this word to attract your user’s attention. 
You could simply bold the word, but what if you not only wanted to bold it, but change 
the color as well. It would be possible to create a class to do this, but there is another 
option that has some useful benefi ts called contextual selectors. 

Dreamweaver actually refers to contextual selectors, which is the offi  cial CSS term for 
them, as compound selectors. Despite the terminology, they are very powerful and important 
to understand.

Contextual selectors apply formatting to tags and classes when they appear in a specifi c 
combination. For instance, you often have separate rules for the <p> (paragraph) and 
<strong> (bold) tag, but what if you want a rule for <strong> tags that are used inside 
<p> tags? Contextual selectors can handle this; for instance, you can designate that any 
text inside a <strong> tag must be red, unless it is used within a <p> tag, in which case 
it should be blue. This breathes new life into your tag styles by multiplying the number of 
times you can use them in conjunction with each other. 

1 In the fi rst line of the Spring Events list, select the word Free. Click the HTML 
button in the Property Inspector, then press the Bold button. (This actually creates 
a <strong> tag in the HTML.) Using the example from above, let’s say that simply 
bolding this wasn’t enough and you wanted to add some color.

2 Press the CSS button in the Property Inspector; then click the menu for Targeted 
Rule and choose <New CSS Rule>. You must do this; otherwise, when you choose a 
color, you will target the whole list, which is not what you want.

3 Click the color swatch in the Property Inspector and choose the dark green swatch in 
the top row, #030. The New CSS Rule dialog box appears.
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4 From the Choose a contextual selector type for your CSS rule drop-down menu, 
choose Compound (based on your selection). In the Selector Name fi eld, the text body 
ul li strong appears. This may look strange at fi rst, but it’s logical if you read it from left 
to right. The body tag is the ancestor, or parent, of the ul tag, which is the parent of 
the li tag, which is the parent of the strong tag. In other words, your style will only 
apply to strong tags, which are nested in a list item (which is nested in the unordered 
list, and so on). 

Set the Selector Type to Compound to create a contextual selector.

In the offi  cial specifi cation of CSS, the concept of ancestor and parent elements is an important 
one. In fact, the concept is taken even further in the example above, where the ul tag is referred 
to as the child of the body element because it is the direct descendant of the body element. There 
are even sibling elements!

Dreamweaver includes the body element in this rule, but it’s not necessary. Technically 
speaking, body is the ancestor of all tags in a document, so Dreamweaver wants to 
include it. There’s no harm in leaving it as is, but it is a little redundant. In any case, 
you have the option to shorten this code manually. 

5 Below the Selector Name section, click the Less Specifi c button, and the list of rules is 
shortened to ul li strong. This has no eff ect on the behavior of the rule. Press OK. The 
word Free is now bold and dark green. Deselect the text to see the fi nal result. The 
rule is in place, and anything that is bold inside a list will have this appearance. You 
can see this now by bolding the word Free in the fourth line of the list.

6 Press the HTML button in the Property Inspector. Select the word Free in the fourth 
line and then press the Bold button in the Property Inspector. The word takes on 
the same appearance. Bolding anything else in the list causes it to have the same 
appearance, while bolding anything not in a list has only the default eff ect.
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Styling hyperlinks

You’re slowly beginning to pull together a page with a color theme to it, even if there is no 
layout per se. A frequently asked question when people are learning to create web pages is 
how to style the hyperlinks on a page. This can be accomplished with CSS, although there 
are some precautions. Since the early days of CSS, the default style for unvisited hyperlinks 
has been a bright blue with an underline and a purple color with an underline for visited 
hyperlinks. An argument can be made that users might be confused by hyperlinks that 
do not fi t this mold. On the other hand, many designers like being able to color their 
hyperlinks to match the rest of their page. Regardless of the debate, it’s important to 
understand how to do this. 

Technically speaking, hyperlinks live in a category called a pseudo-class. A pseudo-class 
selector aff ects a part or state of a selected tag or class. A state often refers to an item’s 
appearance in response to something happening, such as the mouse pointer rolling over it. 
One of the most common pseudo-class selectors is applied to the <a> tag, which is used 
to create hyperlinks. You’ll now create a pseudo-class selector to aff ect the appearance of 
hyperlinks on the events.html page in diff erent states:

1 Click the products link in the fi rst paragraph, and then choose New from the CSS 
Styles panel menu to create a new rule. The New CSS Rule dialog box appears.

2 From the Choose a contextual selector type for your CSS rule drop-down menu, 
choose Compound. In the Selector Name section, click to open the drop-down menu 
to the right of the selector fi eld. You will have diff erent selectors appearing at the 
top of your menu; this is because Dreamweaver is attempting to create a compound 
rule, but in fact you are only interested in the last four options, which are a:link, 
a:visited, a:hover, and a:active. Choose a:link, which aff ects the appearance of 
a hyperlink when it hasn’t yet been visited. Press OK.

Set the Selector type to Compound and choose a:link from the Selector menu.
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3 The CSS Rule defi nition dialog box appears. Under the Type category, click the color 
swatch next to Color and choose the green shade you used in the previous exercise 
(#030). Press OK, and the products link in the fi rst paragraph as well as the two links 
at the bottom of the page are now green instead of blue. Now you’ll set the style for 
hover links, or a:hover.

4 Make sure that the products link in the fi rst paragraph is selected and once again, 
choose New from the CSS Styles panel menu and the New CSS Rule dialog box 
opens. You will leave the state for the visited link alone for now. In this case, the 
default purple is fi ne. You will now change the state for a:hover, which defi nes the 
color of a hyperlink when a user places their cursor over it.

5 From the Choose a contextual selector type for your CSS rule drop-down menu, 
choose Compound. In the Selector Name section, choose a:hover from the drop-
down menu, then press OK.

6 From the Type category, click the color swatch next to Color and select the bright 
orange approximately in the center of the Swatches panel (#C60). In the Text-
decoration section, mark the last checkbox labeled none. This removes the underline 
from the hyperlink for the hover state only. Press OK.

Set properties for a:hover, or the appearance of hyperlinks when the mouse 
pointer rolls over them.

You can preview the appearance of the hyperlinks by clicking on the Live View 
button in the Application bar or opening your page in a browser.

7 Choose File > Save; then choose File > Preview in Browser and choose a browser from 
the list to launch it. Place your cursor over the products link, but don’t click it. This 
is the hover link. Click the products link to bring you to the products page, and then 
click back to the events page by clicking the Events link at the bottom of the page. The 
products link is now purple because the browser understands you have visited it.

You will leave off  styling the a:active link for now. Setting the a:active property 
defi nes the way a link appears when it is being clicked on by a user. Close the web 
browser.
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Div tags and CSS IDs

Div tags and CSS IDs
Your page is coming along nicely on the style front, as you have used quite a bit of CSS, 
but looking at your page, it’s fair to say that it is still lacking a cohesive style. All your 
various headings and paragraphs, as well as your list, are fl oating about on the page, and 
with the exception of the copyright text at the bottom of the page, it’s diffi  cult at a single 
glance to get a sense of where one section ends and another begins. It’s time to add more 
structure to your page through the use of the <div> tag and more control of your CSS 
with ID selectors.

Let’s look at the structure fi rst. It would be nice to gather the text on the bottom of your 
page, starting with the line, Occasionally we gather…, and then the two paragraphs below, 
and put it all into a single section. You could then take this new section and style it 
separately from the rest of the page. This is possible with the <div> tag. In this exercise, 
you will begin by creating a footer ID.

1 Click and drag to select all the text from the line, Occasionally we gather…, down to the 
bottom of the page. You will be grouping these three paragraphs together.

2 Immediately above the CSS Styles panel is the Insert tab. Click on this once to open 
the Insert panel. If the drop-down menu is not set to Common, select Common from 
the menu now. In the Common section, press the Insert Div Tag ( ) button, and 
the Insert Div Tag dialog box opens. In the Insert section, the default choice is Wrap 
around selection; this is exactly what you want to do, so leave this option as is.

Press the Insert Div Tag button in the Common section of the 
Insert panel.

A <div> tag by itself doesn’t do anything until some CSS properties are attached to 
it. In other words, unlike other HTML tags, which often have a default visual eff ect 
in the browser (think of headings), the <div> tag has no eff ect on your rendered page 
unless you specifi cally instruct it to. You will now get to do this.

3 In the fi eld labeled ID, type footer. Just like classes, IDs should have good, descriptive 
names to help identify them. You’ll now apply a background color of white to the 
entire block of text you selected. Notice that there is a fi eld for class as well. Classes 
and IDs are very similar. The diff erence between them is that classes can be used 
multiple times on diff erent elements on a page, whereas an ID can only be used once. 
In this case, an ID is appropriate because there is only one footer on this page.
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4 Click the New CSS Rule button. You don’t need to change anything here; just 
confi rm that you are creating an ID with the name footer. The footer name is 
preceded by the pound sign (#). This is the main diff erence between ID names and 
class names. If this were a class named footer, it would be named .footer. Press OK, 
and the CSS Rule defi nition dialog box appears.

5 Select the Background category, then click the Background-color swatch. Choose the 
pure white swatch (#FFF) and press OK. Press OK again to close the Insert Div Tag 
dialog box. In Dreamweaver’s Design view, a box has appeared around the text and 
there is now a white background unifying the footer text.

Set the Background-color to #FFF in the CSS Rule defi nition dialog box.

If you haven’t guessed by now, these are the fi rst steps toward page layout with CSS. A 
footer is a common element on most pages, and there are a few other obvious ones as 
well: headers, sidebars, and navigation bars to name a few. You’ll begin working with 
these page structures more deeply in upcoming lessons, but fi rst you’ll need to have 
some more control of the CSS rules that you’ve been working with this lesson.

Internal versus external style sheets
Now that you’ve seen how to modify a few items in a single page at once, you can imagine 
how powerful a style sheet shared by every page in your website can be. As noted earlier, 
when you create new CSS rules, you have the opportunity to defi ne them in the current 
document or in a new CSS fi le. A collection of rules stored in a separate .css fi le is referred 
to as an external style sheet. You can attach external style sheets to any number of pages in a 
site so that they all share the same style rules. 

So far, you’ve created internal, or embedded, styles. This means you wrote the style rules 
directly into the page using the <style> tag. Although you can format a page with an 
internal style sheet, this method is not very portable. To apply the same rules in another 
page, you have to copy and paste the internal style sheet from one page to another. This can 
create inconsistency among pages if the same rule is updated in one page and not the other.

To utilize the true power of style sheets, you need to create an external style sheet that any 
or all pages on your site can share. When you change an external style, pages linked to 
that style sheet are updated. This is especially handy when working with sites containing 
many pages and sections.
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You can create external style sheets in the following ways:

• Move rules from an internal style sheet into a new CSS fi le.

• Defi ne styles in a page in a new document using the New CSS Rule panel.

• Create a new CSS document from the Start page or File menu.

Now you will export internal styles from your events.html page into a separate CSS fi le so 
that other pages may share them.

1 With the events.html document open, expand the style sheet shown in the CSS 
Styles panel so that you can see all the rules you have created. If you have limited 
screenspace, double-click the Insert panel to collapse it. Also remember you can 
expand a pane by clicking the bottom edge and dragging down.

2 Click the fi rst rule below the <style> tag at the top of the panel and then scroll down if 
necessary to locate the last rule. Shift+click the last rule in the panel so that all the rules 
are selected. In the upper-right corner, press the CSS Styles panel menu button ( ) and 
choose Move CSS Rules.

Select all rules in your style sheet and then choose 
Move CSS Rules.

3 The Move CSS Rules dialog box appears, asking if you want to move the styles to an 
existing or a new style sheet. Select A new style sheet and press OK.

4 A Save Style Sheet dialog box appears, asking you to choose a name and location for 
the new fi le that is about to be created. Name it mystyles, navigate to the root folder 
of your site (dw04lessons folder), and choose Save.
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5 Look inside your CSS Styles panel and note that the new style sheet, mystyles.css, is 
listed and all the rules are nested within. The internal style sheet (shown as <style>) 
is still in your document, but it contains no rules. You can always click the plus sign 
(Windows) or arrow (Mac OS) to the left of mystyles.css to collapse or expand it. 

Attaching an external style sheet to your page
Dreamweaver automatically made the new external style sheet available to the current 
page by attaching it. However, you will have to link this style sheet to other pages in your 
site to use it. You can accomplish this with the Attach Style Sheet command in the CSS 
Styles panel.

1 Double-click the products.html fi le from the Files panel. This page is a version of the 
products page you created in Lesson 3, “Adding Text and Images.” You will now link 
your new style sheet to this page. 

2 If necessary, click the All button in the CSS Styles panel, then at the bottom of the CSS 
Styles panel, click the Attach Style Sheet icon ( ). The Attach Style Sheet panel appears.

3 Next to File/URL, click the Browse button to locate a style sheet fi le to attach. In the 
dw04lessons folder, select the mystyles.css fi le from the Select Style Sheet dialog box 
and press OK (Windows) or Open (Mac OS). Press OK to close the Attach External 
Style Sheet dialog box.

Adding an external style sheet.

The page refreshes with the styles defi ned in the external style sheet. You can also see 
that the CSS Styles panel shows that mystyles.css and all its rules are now available for 
use and editing.

Modifying attached style sheets
Because an attached style sheet appears in your CSS Styles panel, you can modify any of 
its rules and the changes will apply across other pages that share that style sheet. You’ll be 
another step closer to layout now by modifying the body property in order to add some 
margins to your page.

1 If necessary, in the CSS Styles panel, click the plus sign (Windows) or arrow (Mac OS) 
to the left of mystyles.css and double-click the body rule. The CSS Rule defi nition 
dialog box opens.
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2 Click the Box category and deselect the checkbox labeled Same for all in the Margin 
column.

Deselect the checkbox in the Margin section of the Box category.

Because CSS is based on a box model, it treats every element as a container. Because 
the <body> tag is the largest container, if you modify its margins, it aff ects all the 
content on the page. You’ll specifi cally be changing the left and right margins to 
create a more centered layout.

3 In the Margin fi eld labeled Right, type 15, and choose % from the drop-down menu.

4 In the Margin fi eld labeled Left, type 15, and choose % from the menu. Press OK, and 
your content shifts toward the center.

Change the left and right margin for body to 15 percent.
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5 Choose File > Save All, and then preview your page in the browser. You are able to 
navigate between the products page and the events page using the hyperlinks in each 
document. Shorten the width of your browser, and notice that the content adjusts 
accordingly. There will always be 15 percent space to the left of content in the browser 
window and 15 percent to the right, thereby centering your content. Open the 
events.html fi le in your web browser to see how this page’s appearance is now being 
controlled by the external style sheet. When done, close the browser.

Creating a new .css file (external style sheet)
Although it’s easy to move styles to a new .css fi le, you can also create styles in a new .css 
fi le from the beginning. The New CSS Rule dialog box gives you this option whenever 
you create a new rule. By creating styles in an external .css fi le, you can avoid the extra 
step of exporting them later and make the style sheet available to other pages immediately. 

1 In the Files panel, double-click on the event1.html fi le. 

2 From the CSS Styles panel menu, choose New; the New CSS Rule dialog box 
appears.

3 Set the Selector Type as Tag, and choose body from the Tag drop-down menu if it 
is not automatically selected. At the bottom of the screen, click the Rule Defi nition 
menu and choose (New Style Sheet File); then press OK.

Creating a new external style sheet from scratch.
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4 You are prompted to name and save the new .css fi le. Name it morestyles.css and 
save it in the root folder of your site.

5 When the CSS Rule defi nition dialog box appears, choose the Background category. 
Set the background color to light yellow, #FFC. Press OK to create the rule.

Your page’s background color should be yellow, and the CSS Styles panel refl ects that 
the style was created in a new external style sheet. Now you can attach this style sheet 
to any other page in your site.

6 Choose File > Save All. 

More details on CSS

Inheritance
When you nest one rule inside another, the nested rule inherits properties from the rule in 
which it’s contained. For instance, if you define a font-size and font-family for all <p> tags, 
then it carries over to a class style used within the paragraph. This paragraph may not specify 
values for either property. It automatically inherits the font-size and font-family from the 
<p> tag selector.

CSS rule weight
What happens if two classes of the same name exist in the same page? It is possible to have 
two identically named styles, either in the same style sheet or between internal and external 
style sheets used by the same page. Along the same lines, it is possible to have two rules that 
both apply to the same tag. If either of these cases exists, how do you know which rule is 
followed?

You know which rule is followed based on two factors: weight and placement. If two 
selectors are the same weight (for instance, two tag selectors for the body tag), then the last 
defined rule takes precedence. 

If a rule of the same name is defined in both an internal and external style sheet in your 
document, the rule from the last defined style sheet takes precedence. For instance, if an 
external style sheet is attached to the page anywhere after the internal style sheet, the rule in 
the attached style sheet wins.
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Self study
Create a new document and add some unique content to it, such as text or images. 
Afterwards, use the CSS Styles panel to defi ne at least one tag style, two class styles, and 
one contextual selector (advanced) in a new, external .css fi le. Create a second document 
and attach your new external style sheet to it, using the Attach Style Sheet command from 
the CSS Styles panel. Add content to this page, and style it using the style rules already 
available from your external style sheet. If desired, make changes to the rules from either 
document, and watch how both documents are aff ected by any modifi cations made to the 
external style sheet.

Review 
Questions
1 What are the four types of selectors that can be chosen when creating a new CSS rule? 

2 In what three places can styles be defi ned? 

3 True or false: A style sheet is composed of several CSS rules and their properties. 

Answers
1 Tag, Class, ID and Compound (which includes contextual and pseudo-class selectors).

2 Inline (written directly into a tag), internal (embedded inside a specifi c page using the 
<style> tag), or external (inside a separate .css fi le).

3 True. A style sheet can contain many CSS rules and their properties. 
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What you’ll learn in 
this lesson:
• Understanding the CSS 

Box model

• Creating Divs and AP Divs

• Stacking and 
overlapping elements

• Styling box contents

• Using visual aids to fi ne-
tune positioning

Lesson 5

Now that you’ve used Cascading Style Sheets, you’ve seen how 
powerful they can be for styling a page. CSS is equally powerful as 
a layout tool, allowing you to freely position page content in ways 
not possible with HTML alone.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw05lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw05lessons folder. Go to 
Site > New Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

Creating Page 
Layouts with CSS
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See Lesson 5 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

The CSS Box model
CSS positions elements within a page using the Box model, which refers to the fact that all 
HTML elements have default boxes that you can choose to style. You can think of a box 
as a container for text, images, media, tables, and other content. In most cases, the width 
and height of a box is determined by the amount of content; however, you can also assign 
an explicit width and height to any box. Additionally, each box can have its own optional 
padding, margin, and border settings (described in detail shortly). 

Toward the end of Lesson 4, “Styling Your Pages with CSS,” you began to explore page 
structure through the use of the HTML <div> element. The Box model in CSS applies 
to all elements in HTML but is often paired with <div> tags. The <div> element, in 
conjunction with CSS rules, can be freely positioned, formatted, and even told how to 
interact with other boxes adjacent to it. You can also stack and overlap <div> containers, 
opening the door to fl exible and creative layouts that are not possible with HTML alone.

This lesson dives deeper into the many uses of the <div> element. If you have jumped 
directly to this lesson, it is highly recommended that you understand the basic concepts in 
Lesson 4, “Styling Your Pages with CSS,” before starting this one.

If you’ve worked with layout applications such as InDesign, the idea of creating and positioning 
containers for page content should be very familiar to you. Boxes created with the <div> tag can 
be thought of as analogous to the text and image frames you create in InDesign.

The basics of CSS margins, padding, and borders
The Box model allows each element on a page to have unique margin, padding, and 
border settings. 

Lorem ipsum dolor sit amet
consectetuer adipiscing elit
sed diam nonummy nibh
euismod tincidund ut laoreet
dolore magna aliguam erat

A B C D

E

A. Margin. B. Border. C. Padding. 
D. Content width. E. Visible width.

5
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Margins refer to the transparent area surrounding the box, which you set using the 
margin group of CSS properties. Margins can play an essential role in creating distance 
between a box and the content surrounding it (such as other boxes), or the boundaries of 
the page itself. You can set margins for all sides at once or uniquely for each side. 

Padding is the distance between the inside edge of the box and its contents. By setting 
padding, you create space between the box and any text, images, or other content that it 
contains. You set padding using the padding group of CSS properties, and, like margins, 
you can set padding for all four sides of a box at once or for each side individually.

The border of a box is transparent by default, but you can add width, color, and a border 
style for decoration or defi nition around boxes. Borders sit directly between margins and 
padding, and defi ne the actual boundaries of the box. You set borders using the border 
group of CSS properties and, like margins and padding, you can defi ne borders for all four 
sides at once or for each side individually.

You can incorporate each property into any style rule and attach it to a box, similar to the 
way you’ve attached classes to paragraphs and tables in previous lessons.

Reviewing the <div> element
As mentioned earlier, when exploring and creating page layouts with CSS, you will 
frequently encounter and use the <div> element. The <div> element creates areas or 
divisions within an HTML document; you can place page content such as text and images 
directly within sets of <div> tags. Dreamweaver enables you to create CSS-driven page 
layouts using the Insert Div Tag and Draw AP Div buttons in the Insert panel; both of 
these features use <div> tags to create areas of layout, but do this in diff erent ways.

Reviewing the ID selector 
In Lesson 4, “Styling Your Pages with CSS,” you learned about the diff erent selector 
types in CSS: classes, tags, pseudo-class selectors, and IDs. In this lesson, IDs take center 
stage and become an essential part of working with CSS boxes and positioning. An ID is a 
special selector type created for a unique element using the same name within a page, and 
it’s meant for one-time use only. ID rules appear within a style sheet and are preceded by a 
pound sign (#), in contrast to classes, which are preceded by a period character ( . ).

Because IDs can be used only once per page, they are ideal for setting properties that need 
to be specifi c to a single element, such as positioning information. In other words, page 
elements such as headers or columns occupy a specifi c position on the page, such as top, 
right, left, and so on. When creating layouts using the Insert Div Tag button, Dreamweaver 
requires you to create or assign an ID rule for each box created. When drawing boxes 
with the Draw AP Div button, Dreamweaver automatically creates a unique ID rule that 
contains positioning, width, and height information for that specifi c box. 
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Because the <div> element has no display attributes, it is given its properties by either an 
ID or a class, or both. Dreamweaver has a bias; therefore, the program is more likely to 
use CSS IDs for layout. Think of an ID as a set of instructions that give a <div> its unique 
appearance and behavior (as DNA does to a human being). An ID rule is matched to a 
<div> using the tag’s ID attribute. 

The Code view shows the style sheet and <div> tag that create the container.
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Tables or CSS for layout?

When CSS first appeared as a tool for layout (in the early 2000s), a debate started within the 
web design community about the best approach to creating page layouts, because designers 
could use either CSS or HTML tables. The argument went something like this: Many 
designers felt like tables were the wrong tool for the job and CSS, with its box model, should 
be adopted as the primary method for positioning page content. Designers in favor of tables 
asserted that tables are more reliable in older browsers and easier and quicker to build. For 
the most part, the argument has been resolved: CSS layout is now regarded as the industry 
standard for creating page layouts.

Here is a brief overview of what you need to know:

Tables: Although fewer sites are being built from scratch in tables these days, there remain 
countless websites that were built with them and are still on the Web being updated and 
maintained. Designers who find themselves having to maintain a tables-based site would do 
well to understand their behavior. Also, HTML email often relies on the use of tables due to 
the limited capabilities of email readers.

Tables’ limitations include the following: You are restricted to its cell-based structure, and to 
achieve more complex layouts, you need to nest several levels of tables. Tables also add extraneous 
code to pages and can present difficulties in accessibility for devices such as screen readers.

CSS: CSS positioning has been around for many years. However different browsers have 
chosen to support it at varying and inconsistent levels. At this point, CSS positioning has a 
set of Best Practices that are widely known and used across the web design and development 
industry. If you need your sites to work reliably in older browsers, testing is still necessary to 
expose potential inconsistencies.

The CSS Advisor and Browser Compatibility Check features in Dreamweaver CS6 benefit 
designers who want to use CSS more extensively. These tools f lag and help troubleshoot any 
CSS-related items that may be incompatible or inconsistent in commonly used browsers. 
The CSS Advisor and Browser Compatibility Check are discussed in detail in Lesson 16, 
“Managing Your Website: Reports, Optimization, and Maintenance.”
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Creating a centered container for your page
The goal of this lesson is to create the home page for the Organic Utopia site. This page 
will look like the thumbnail below.

The completed layout you will be creating in this lesson.

The home page will be a diff erent design and layout than the rest of the site (this layout 
is covered in more detail in Lesson 6, “Advanced Page Layout.”), and you will start by 
creating a container that will end up nesting the other sections of your page such as the 
header, sidebar and other elements. This container will have a fi xed width of 960 pixels 
and also be centered within the browser window. 

This container will use a combination of relative positioning and automatic margins to 
achieve the centering eff ect. Relative positioning allows you to position this box relative 
to the body of the page, and the automatic margins will force the fi xed-width container to 
stay centered regardless of the browser window’s width.

1 In the Files panel, navigate to the dw05lessons folder and double-click the layout.html 
fi le to open it. This document has been partially prepared for you, with a background 
color and a page title added. Additionally, the default font, font color, and font size 
have been defi ned as Lucida Sans, grey, and small, respectively. Your fi rst step will be 
to add a box, which will become your main column of text.

2 If it’s not already visible, open the Insert panel by choosing Window > Insert. The 
Insert panel features a list of objects that can be added to your pages easily. 
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3 In the bottom-left corner of your document window, click the <body> tag. 
Remember, the body tag encloses all the other tags within a page. You will now 
create a new <div> element that will function as a container for the other layout 
elements. In the Insert panel, click the Insert Div Tag button.

Click the Insert Div Tag to add a container div element.

4 The Insert Div Tag dialog box appears. Click in the ID text fi eld and type container, 
then click the New CSS Rule button. In the New CSS Rule defi nition dialog box 
that appears, make sure that #container is listed as the Selector Name and then click 
OK. The CSS Rule defi nition dialog box appears and you can begin to style your 
container div.

5 Select the Box listing in the Category column on the left side of the dialog box. In 
the Width text fi eld, type 840 and make sure px (pixels) is selected from the drop-
down menu to the right. For Height, type 800 in the text fi eld. In the Margin section, 
uncheck Same for All, then, from the Right margin drop-down menu, choose auto. 
Choose auto from the Left margin drop-down menu as well. 

Choose the settings for the #container element.
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You’ll explore using margins in more depth, but by setting a margin value of auto 
to the left and right side of the container, you are instructing the browser to put 
equal amounts of space on the right and left sides. The end result will be a box that is 
centered within the browser window. 

6 Select the Background category on the left side of the dialog box, then click 
the Background-color swatch and choose the white (#FFF) swatch. This adds a 
background color of white to your entire container, separating it from the background.

7 Select the Positioning category on the left side of the dialog box and choose relative 
from the Position drop-down menu. This is key to the success of your next steps. By 
setting the position of the container to relative you will be able to position the page 
elements using the container as a frame of reference. Press OK in this dialog box, as 
well as OK for the Insert Div Tag dialog box that is still open.

8 Choose File > Save, then choose File > Preview in Browser. Your container will 
be centered in the middle of your browser window and Dreamweaver’s default 
placeholder text is aligned in the top left of your container. (Occasionally, we have 
noticed Dreamweaver does not add this placeholder text; if this is the case for you, 
return to Dreamweaver, click within the container, and then type content for id 
“container” Goes Here.)

With position set to relative and auto margins the container element will always be centered.

Resize the browser width; the container stays centered until the window is narrower 
than 840 pixels, at which point the box is cropped. Close your browser. If your 
container div did not appear centered, it is possible you are using an older browser. 
Even if your container div is centered, there are a few additional steps you will now 
add to ensure the page centers in older browsers.
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Making layouts cross-browser compatible
If you are new to web design, welcome to the world known as CSS hacks. In an ideal 
world, all web browsers would render HTML and CSS using the same set of rules, and 
all web pages would look the same, regardless of the browser. Unfortunately, this is not 
the case. For a variety of reasons, diff erent web browsers render pages diff erently. For 
example, older web browsers such as Netscape 4 and Internet Explorer 4 do not render 
CSS positioning particularly well. More modern browsers have their own set of quirks as 
well. In certain cases, additional rules can be added to the CSS that make the page work. 
These fi xes are never ideal because they require additional code and sometimes create 
more problems than they solve; however, they are necessary if you want your pages to look 
similar across browsers.

1 With layout.html open, double-click the body rule in the CSS Styles panel to edit 
its properties. In the CSS Rule defi nition dialog box, select the Block category and 
choose center from the Text-align drop-down menu. Press OK.

This fi xes a problem that exists with version 6 (and earlier) of Internet Explorer 
regarding automatic margins. Although this fi xes the bug, it creates another problem in 
that it will center all text on your page (you can see this currently in your container). 
So, in order to fi x that problem you must create another rule to counteract this one.

2 Double-click the #container rule in the CSS Styles panel. In the CSS Rule 
defi nition dialog box, select the Block category on the left, and then choose left from 
the Text-align drop-down menu. This will align your text to the left, and all is back 
to normal. Press OK to accept these changes.

3 Choose File > Save.

In this exercise you created a centered box named container. In the next exercise, you 
will place all your other layout sections as well as your content, into this container. 
Before doing this, a brief overview of the diff erence between absolute and relative 
positioning may help.

For a more in-depth look at cross-browser compatibility see the Web Design with HTML and 
CSS Digital Classroom book available in electronic and print formats.
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Absolute versus relative positioning
Absolute positioning: An element that is set to absolute strictly follows the positioning 
values given to it, relative only to its containing element. The containing element can be 
another div or the page itself. Absolutely positioned elements are pulled out of the normal 
fl ow of HTML content, and regardless of what surrounds them (for example, text content 
or neighboring divs), they always appear at the exact coordinates assigned to them. 

Here is an example of a div absolutely positioned within another div. The larger div 
(Box #1) is the containing element, and so any positioning values assigned to Box #2 are 
relative to the element boundaries of Box #1.

Box #2 is contained, or nested, within Box #1.

Adding additional content to the containing box (#1) has no eff ect on the nested div. It 
remains positioned outside the fl ow of HTML.

Box #2 remains in position even with added 
content in Box #1.
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Relative positioning: A relatively positioned element accepts values for position 
properties such as top and left, but it also takes the normal fl ow of neighboring HTML 
content into account. Here are boxes and values shown in the preceding two fi gures; the 
only diff erence here is that the position property for Box #2 has been set to relative instead 
of absolute.

Box #2 is still off set, just as before, but 
it’s being displaced by the content before it.

Although it appears that the top and left values have changed, they haven’t. Unlike 
absolutely positioned elements, relatively positioned elements stay within the normal fl ow of 
HTML content, which means that they can be displaced by the elements (in this case, the 
text) surrounding them. In this example, Box #2 is still 50 pixels from the top and 50 pixels 
from the left, but its point of reference is the end of the preceding text content, not Box #1.

Positioning items relatively is useful when you want an item to fl ow with the items surrounding 
it. The following image shows fi ve divs nested inside a larger div to create a menu.

All menu items are positioned relative 
to one another, and so they fall into 
place based on each other’s position.
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The same example is shown in the fi gure below, with the position set to absolute for all 
menu items. The result is a collapse of the menu—all the menu items are trying to occupy 
the same place at the same time, without regard for their neighbors.

When set to absolute, the menu items stack 
on top of one another, because they all 
must be at the same place, regardless of the 
elements that surround them.

The fi les used for these examples are located in the dw05lessons folder, and are named 
absolute_relative.html and relative_menu.html. Open them in Dreamweaver and explore the 
code to further your knowledge.

Any element, or, in this case, any box, can have the position property applied, and one 
of fi ve possible values can be set: absolute, fi xed, relative, static, or inherit. The two 
most commonly used are absolute and relative, and although both can accept positioning 
properties such as top and left; they are rendered diff erently, even with identical 
positioning values.

Positioning content with AP Divs
Now that your container is centered on the page, you’ll need to add boxes to hold content 
within the container. The easiest and most visual way to place boxes in Dreamweaver is 
with the Draw AP Div button. An AP or Absolute Positioned Div is placed exactly where 
you draw it, using the page as its point of reference by default; after drawing, you can 
reposition it precisely.

For this exercise, you’ll want your AP Divs to be positioned using the container as their 
point of reference. To change the default behavior of AP Divs as you draw them, an 
additional step is required. This step will ensure that your AP Divs are nested inside the 
container div.
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1 In the layout.html document, choose Edit > Preferences (Windows) or Dreamweaver 
> Preferences (Mac OS) and then choose the AP Elements category. Click the 
checkbox labeled Nesting. This ensures that the new boxes you create will be nested 
inside the container. Click OK.

Set your Preferences so that new AP Elements automatically nest when inside your container.

Creating a header section with the Draw AP Div
You have already created a container that is centered within your page; now you’ll add the 
other layout elements, starting with the header. The Draw AP Div tool allows you to add 
boxes within your pages manually. Once a box is added, you can style it with CSS (change 
the width and height, add background color and more) and you can also add content such 
as text or images. 

1 In the Insert panel, click the drop-down menu and choose Layout.

The Layout section of the Insert panel displays the available layout icons.
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2 In the Insert panel, click the Draw AP Div button. Move back over the page; your 
cursor is now a crosshair signifying that you can begin to draw.

3 Place your cursor below the placeholder text in the top-left corner of the container 
and then click and drag down and to the right to draw a box. Stop approximately 25% 
of the way down the screen. The box appears with a handle in the top left corner.

The newly created AP Div has a handle in its top-left corner.

4 Click the selection handle in the top-left corner of the AP Div and click and drag the 
box around the screen to see how you can position the box manually. Notice in the 
Property Inspector that the properties for your box are displayed and dynamically 
change as you move it; currently just the Left and Top position (L and T) will change. 
Your settings will likely be diff erent than those in the fi gure.

Click inside the Bg color text fi eld, type #9fcc41, and then press Enter (Windows) or 
Return (Mac OS) to apply the color, which is a yellow-green shade.

The Property Inspector displays the properties of the AP Div and allows you to set its background color.

You will now position this box to become your header.

5 In the bottom-left corner of the Property Inspector, locate the CSS-P Element text fi eld. 
It is currently named apDiv1. Select the text within this text fi eld and type header.

When Dreamweaver creates new AP Divs, it gives them the default names of apDiv1, 
apDiv2, and so on. You can, and most often should, rename these, simply because the 
default name is nondescriptive and unhelpful. Keep in mind that functionally, this is 
exactly the same step as the previous exercise when you named the div “container.” In 
both cases you are creating a CSS ID behind the scenes.

6 Select the placeholder text Content for id “container” Goes Here and delete it. You 
are about to create your header at the top of the page and you don’t need this content.

7 If you currently do not have rulers visible, choose View > Rulers > Show. Click the edge 
of the header div again, and pay careful attention to the L (Left) and the T (Top) values. 
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You will now position the header to the top-left corner of the container using the 
Property Inspector.

8 In the Property Inspector, type 0px into the L (Left) text fi eld and press Enter 
(Windows) or Return (Mac OS). The box moves and the left side of the box is 
positioned horizontally at 0 pixels. Type 0px into the T (Top) text fi eld and press Enter 
(Windows) or Return (Mac OS). The top of the box is positioned vertically at 0 pixels. 

Be sure to type the number and the px value (i.e., 100px) together in order for 
position to be valid.

With Top and Left values both set to 0px the header is aligned to the top-left corner of the container.

9 You also need to set the width of this header. Again, you could do this manually by 
dragging the edges of the header box, but this is not precise. It is better to use number 
values and match the width of the header to the width of the container.

In the Property Inspector, type 840px for the W value and 80px for the H value.

10 You can add content to the box by simply typing in it. Click inside the box on the 
workspace and type Organic Utopia. You’ll be replacing this with the logo a bit 
later, for now this will serve as a placeholder.

11 Choose File > Save to save your work, and then preview your page by choosing 
File > Preview in Browser or by pressing the Preview/Debug in browser button ( ) at 
the top of the document window. Close the browser when fi nished.
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Adding an introduction section to your page
Now you can add additional sections to your page. The fi rst section you’ll add is a box 
below the header where you’ll format an introductory paragraph to state the mission of the 
site, and grab the user’s attention.

1 In the Insert panel, click the Draw AP Div object and draw a box below your header. 
Don’t worry about the exact size of the box, but make the width about half the header 
and roughly twice the height. 

A good habit to get into is renaming your AP Divs immediately after they are created. 

2 Click the edge of the new div and in the CSS-P Element text fi eld, type intro and 
press Enter (Windows) or Return (Mac OS).

3 Click inside the intro box and type the following text: Organic Utopia is a 
community owned and operated supermarket and marketplace. Anyone may 
shop in our stores but members enjoy special discounts and other benefi ts. 

The #intro AP Div with added text.

Now you’ll format the text in this box using techniques from the last lesson.

4 In the Property Inspector, click the HTML button if necessary. Select and highlight 
the text you entered and choose Paragraph from the Format drop-down menu.

DWCS6_06Pass.indb   142DWCS6_06Pass.indb   142 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


5

143Lesson 5, Creating Page Layouts with CSS 

Positioning content with AP Divs

5 With the text still selected, click the CSS button in the Property Inspector. Then click 
the Font drop-down menu and choose the Georgia, Times New Roman, Times, serif 
family. The New CSS Rule defi nition dialog box will open. The Selector Type will 
be compound. The Selector Name is #container #intro p. Press the Less Specifi c 
button to set the selector to #intro p. 

Press OK and the change is applied.

6 In the Property Inspector, click the Size drop-down menu to change the font size and 
choose the keyword large. 

Set the paragraph text inside the intro box to Georgia and large.

Depending on how large you made your intro box, you will likely need to adjust the 
width and height of the box.

7 Click the edge of the intro box to activate it and then click any of the anchor points on 
the box to adjust the width and height. We used a width of 720px and a height of 130px.
Click anywhere on the background of the page to deselect the intro div.
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Adding images to your layout
Before you add the remaining sections of your page, you’ll add images to both the header 
and container sections of the page. First, you’ll add a background image of vegetables to 
the right side of your header.

1 In the CSS Styles panel double-click the #header rule to open the CSS Rule 
defi nition dialog box. Click the Background category. In addition to the background 
color, you can also add CSS background images.

2 In the Background image section, press the Browse button. In the select Image Source 
dialog box, navigate to the images folder within the dw05lessons folder and select 
veggies.jpg. Press OK (Windows) or Choose (Mac OS). Press Apply and you will see 
the image tiled across the header. (If you see a Missing Profi le message click OK.)

By default, background images in CSS have this tiled eff ect, so you will need to add 
additional properties in order to remove the tiling and position the image to the right. 

3 From the Background-repeat drop-down menu, choose no-repeat. From the 
Background-position (X) drop-down menu, choose right. Press OK and you see the 
image now aligned to the right side of the header.

Background images can be added and positioned to a <div> element.

A background image is controlled by CSS, and you can only have one background 
image per element. So in order to have two images inside the header, you’ll add the 
Organic Utopia logo as an inline element. This means the logo is being added to the 
HTML code, not the CSS. 
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4 Select the Organic Utopia placeholder text in the #header div and delete it. Then 
choose Insert > Image. In the Select Image Source dialog box, navigate to the images 
folder within the dw05lessons folder and select ou_logo.gif. Press OK (Windows) or 
Open (Mac OS). Type OrganicUtopia Logo into the text fi eld when asked to add an 
Alternative text tag, and then press OK. The image appears in the top-left corner of 
the header. You will position this image away from the sides of the header box later in 
the lesson. (If you receive a Missing Profi le message, click OK.)

When working with images, follow this rule of thumb: HTML inline images should be used for 
content; CSS background images should be used for decoration. One way to test this rule is to 
imagine the impact on the page if the image were not displayed. In the example above, the image 
of the vegetables is not essential, so the website would not be adversely aff ected if the image is not 
displayed; however, the logo is important, so it should be considered content, not decoration.

Photoshop integration
Often the images used in your web page need to be modifi ed in Photoshop before they 
integrate well with your design. Photoshop and Dreamweaver are integrated in a few 
ways. In this exercise, you will see how Dreamweaver can optimize .psd fi les when you 
insert them into your page.

1 In the CSS Styles panel, double-click the #container rule. Click the Background 
category and choose the Browse button in the Background-image section. In your 
dw05lessons folder, open the artwork folder. Choose the veggiebackground.psd fi le 
and press OK (Windows) or Open (Mac OS) The Image Optimization dialog box 
appears.

This dialog box appears because you have chosen a .psd fi le to import and this is not 
a valid fi le format for the Web. Dreamweaver triggers the Image Optimization dialog 
box, which allows you to optimize the graphic and save it in a more appropriate format.

Importing a .psd fi le into Dreamweaver will trigger the 
Image Preview, allowing you to save as a web graphic.
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2 Click the Preset menu and choose “JPEG high for Maximum Compatibility” if it is 
not already selected. Slide the Quality slider to 1 and notice that the preview of the 
image on your page becomes pixelated. Reducing the quality results in a smaller fi le 
size, but going too low results in unacceptable loss of detail.

3 Drag the Quality slider to 70, and notice that the quality improves dramatically. As 
with most compression, the goal is to fi nd a good balance between small fi le size and 
image quality.

4 Click OK, and then navigate to the images folder in the dw05lessons folder and 
double-click it. In the URL section, notice the path images/veggie_background.jpg. 
It’s important to understand that you are saving a copy of the original PSD fi le as a 
JPEG in this step. Click Save and you now have a link to the new background image.

5 Click the Background-repeat drop-down menu and choose no-repeat, and then click OK.

Adding Main and Sidebar content areas
Now you’ll add two more sections to your page: a main column, which will feature the 
latest news from our fi ctional company Organic Utopia and a sidebar column, which 
features incentives for visitors to become members.

1 In the Insert panel, click the Draw AP Div button, then place your cursor below the 
intro box and click and drag down and to the right. As you are drawing the AP Div 
notice there are width and height values that are updated in the Status Bar on the 
bottom right of your document window

The width and height of an AP Div are updated in the Status bar as you draw the div.

Make the AP Div roughly 450px wide by 200px high. Don’t try to get the exact 
dimensions, as it is very diffi  cult to be precise when drawing. You can always fi ne-
tune the width and height in the Property Inspector.
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2 Click the border of the div and in the CSS-P Element text fi eld rename the div to 
main. Next, click the Bg color swatch in the Property Inspector and from the color 
swatches that appear, choose white.

3 Click the Draw AP Div button again and draw another box to the right of the Main 
div. Make this one approximately the same height, and the width should be about 240. 
Again don’t worry about the exact dimensions for now.

4 Click the border of the new div and in the CSS-P Element text fi eld, type sidebar to 
rename the AP Div. Click the Bg color menu and make this background white as well.

You’ll now make sure the top edges of the two boxes are lined up.

5 Click the handle on the top-left of the main div and reposition it to the following left 
and top values: L (Left) should be 35 and T (Top) should be 260. 

Setting the Left and Top values of an AP Div.

6 Click the top-left edge of the sidebar div and type 260 for the Top value. You can use 
the left and right arrows on your keyboard to nudge the div horizontally. We ended 
up with a Left value of 515.

With the top values the same for both boxes, the top edges line up. Once the boxes are 
lined up, you can always move them as a unit by selecting and dragging or nudging them.

7 Click the edge of the main div to select it and then Shift+click the sidebar. With both 
boxes selected, press your up arrow keys to move both boxes upward. There is no right 
value here, use your judgment and push the two boxes closer to the intro text.
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Adding additional content and styles
Up to this point, you’ve been working with the base structure of your layout. Now it’s 
time to add additional content in the form of text so that you can see how your layout 
works with real content, and make any necessary changes. 

1 Double-click the main_content.html fi le in the Files panel to open it. This is text that 
has already been formatted; all that is necessary is to copy and paste it into your layout.

2 Choose Edit > Select All and then choose Edit > Copy. Close the main_content.html 
document. In the layout.html document, click inside the main div and choose Edit > 
Paste. The content appears styled as Lucida Grande because there is a rule in the body 
defi ning the font-family; however, there are no CSS rules yet for headings or paragraphs.

The results of copying and pasting the main_content.html page into your main div element.

You pasted more content than can fi t inside this box, which is why the text is fl owing 
outside the boundaries of the container. In fact, what you are seeing is one of the 
disadvantages of using AP Divs. Defi ning the width and height of a box in pixels creates 
an infl exible container. One solution to this is simply to expand the size of the box.

3 Click the bottom of the blue border for the div and drag it down slightly, the box will 
automatically expand to fi t the existing content.

Now you’ll add the content to the member benefi t section.

4 Double-click the memberbenefi ts_content.html fi le in the Files panel. Choose Edit > 
Select All and then choose Edit > Copy. Close the memberbenefi ts_content.html 
document. In the layout.html document, click inside the sidebar and choose Edit > Paste.

5 Click the bottom of the sidebar div and drag it down slightly to expand the box to fi t 
the content.
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Setting margins and borders
As you learned earlier, CSS uses the Box model for elements, and as such, each element can 
be given unique margins, padding, and borders, either for decorative or practical purposes.

Now that you have content inside your columns, it is clear that you need to do some fi ne-
tuning. Your text and logo are crowded against their respective div elements and you 
should make them more pleasing and readable. Technically, you can start anywhere, but in 
this exercise, you’ll start at the top of your page and work down. 

1 Select the Organic Utopia logo in the header. In the CSS Styles panel, press the New 
CSS Rule button ( ). The New CSS Rule dialog box appears and the Selector Name, 
#container #header img is selected. Since the rule gets more specifi c from left to 
right, ultimately you are targeting the <img> tag located inside the header div, which 
is inside the container div. Click OK. 

2 In the CSS Rule defi nition dialog box that appears, select the Box category on the 
left. If necessary, move the dialog box to see the logo. Uncheck the Same for All 
checkbox in the Margin section. In the Top text fi eld, type 20 and press Apply. The 
logo is pushed down 20 pixels from the top of the header div, because there is now a 
20-pixel margin applied to the top of the image.

3 In the Left margin text fi eld, type 15 and press OK. Adding a 15-pixel left margin 
pushes the logo to the right. Now you’ll add similar margins in the main column.

4 Click anywhere inside the heading Celebrating Vegetables in the main column. In the 
CSS Styles panel, press the New CSS Rule button. In the New CSS Rule dialog box, 
make sure the selector name reads #container #main h2. Press OK.

5 In the CSS Rule defi nition dialog box, select the Box category, and uncheck the Same 
for All checkbox in the Margin section. In the Left text fi eld, type 15 and press OK.

Applying a left margin of 15 to the main heading.
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6 Click inside the paragraph below the Celebrating Vegetables heading. In the CSS Style 
panel, press the New CSS Rule button and in the New CSS Rule dialog box, make sure 
that #container #main p is highlighted in the Selector Name text fi eld. Press OK.

7 In the CSS Rule defi nition dialog box, select the Box category from the left column, 
and uncheck the Same for All checkbox in the Margin section. In the Left and Right 
text fi elds, type 15. You need to add both left and right padding because the text fi lls 
the main container. Press OK.

Overriding default margins in CSS
If you are new to Dreamweaver and/or CSS, an important concept is that of default 
margins. Web browsers will apply default margins to most block elements unless there is a 
value overriding them. So paragraphs and headings, for example, will have space between 
them even if you haven’t set a value. You can see this space by using Dreamweaver’s 
Inspect feature.

1 In your document window, click the Live View button to cause the Live Code and 
Inspect buttons to appear. Click the Inspect Mode; Dreamweaver will prompt you to 
change your workspace settings. Press “Switch Now” to change your settings to the 
Split Code view. Now you can hover over elements on your page and see the normally 
invisible margins.

2 Place your cursor over the Celebrating Vegetables heading. The yellow highlight 
shows the margins being applied to this element.

The Inspect feature in Dreamweaver CS6 highlights the margins of an element in yellow.

DWCS6_06Pass.indb   150DWCS6_06Pass.indb   150 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


5

151Lesson 5, Creating Page Layouts with CSS 

Setting margins and borders

Hover over the paragraph below the heading and note there are margins being applied 
here as well. In order to reduce the space, you will need to reduce the bottom margin 
of the heading and the top margin of the paragraph.

3 In the CSS Styles panel, click the “All” tab, and then locate and double-click the 
#container #main h2 style and then select the Box category. Set the bottom 
margin value to 0 px and press OK.

4 Place your cursor over the heading. Note that the bottom margin is gone (in other 
words, there is no yellow border). You now need to set the top margin of the 
paragraph to 0 as well.

5 In the CSS Styles panel, double-click the #container #main p style and select the 
Box category. Set the top margin value to 0 px and press OK. Now all the paragraphs 
in the main column shift upward.

6 Click the Live View button to de-activate this mode, and then click the Design button 
to return to your default mode.

Because margins and padding are invisible, many designers resort to applying either background 
colors or borders to elements at the beginning of the layout process. This helps to understand the 
relationship between various sections on the page. The Inspect button in Dreamweaver partially 
removes the need to do this, but you may still fi nd the original technique useful.

Adding borders to elements
The ability to add borders to elements is a great feature in CSS. Because of the CSS Box 
model, almost anything can be styled with borders: div elements, headings, lists and more. 
Additionally, the style, width and color of these borders can be set globally or for any 
given side.

1 In the CSS Style panel, double-click the #main style and then click the Border 
category to begin setting these properties.

2 In the Style category uncheck the Same for all checkbox. Click the Top menu and 
choose solid. Then click the Bottom menu and choose solid.

In the Style menu, note the other options available. Styles such as dotted and dashed 
are the most reliable styles. For various reasons the other options such as groove, ridge, 
etc. are not particularly well-supported in older browsers and you should use them 
sparingly.

3 In the Width category, uncheck the Same for all checkbox and click the Top menu. 
Note that you can also choose keywords here for thin, medium or thick. Select (value) 
and then type 2. The default value is px. Click the Bottom menu and type 2.
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4 In the Color category, uncheck the Same for all checkbox and in both the Top and 
Bottom fi elds type #063. This is a dark green color. 

Setting border styles for the top and bottom of the Main div element.

Click OK in the CSS Rule defi nition dialog box.

The borders will be hard to see since the div is still selected.

5 Choose File > Save All and preview the results by choosing File > Preview in Browser. 

Take a moment to admire your layout. You’re almost done; however the last step is to 
future proof your page layout.

6  Close the browser and return to Dreamweaver.

Future proofing your layout
Absolutely positioning the elements of your page layout is very stable and reliable, but it 
also has some fundamental limitations. You have already seen what happens when there is 
more content than can fi t inside a box: the box overfl ows resulting in unattractive content. 
You have also seen one solution, which is simply to expand the size of the box. Even this 
is not an ideal solution though. Content on the Web changes constantly; text is added 
and removed, images are inserted and so on. The designer of the page may have little 
or no control over this, especially if they are handing a website off  to a client who will 
eventually be updating and modifying the site. 

To help strengthen your layout for future modifi cation, you can use a CSS property called 
overfl ow. This will help you prevent the worst-case scenario of text that breaks your 
layout as it overfl ows its container. For this exercise, you’ll apply overfl ow to the Members 
Benefi ts sidebar.
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1 Click the bottom edge of the sidebar and then drag the bottom of the box upward 
until half of the list items are overfl owing out of the box.

Text that is overfl owing over the sidebar.

2 Double-click the #sidebar style in the CSS Styles panel and then click the 
Positioning category.

3 Click the Overfl ow menu and choose auto. This automatically adds scrollbars to 
any <div> element that has more text than can fi t inside. Click OK. You will see in 
Dreamweaver’s design view that the box has snapped to fi t the original height.

4 Choose File > Save, then File > Preview in Browser. Your div now has a scrollbar. 
While it may not be an ideal solution if you do not like scrollbars, at least it doesn’t 
break the layout. Close the browser and return to Dreamweaver.

The pros and cons of Absolutely Positioned CSS layouts
You will now take a look at the limitations and weaknesses of the layout you have just 
created. Absolutely positioned layouts in Dreamweaver are the quickest and easiest way to 
get a web page up and working, however, as noted earlier they are not the most fl exible. 

In this exercise, we hope to point out some of the limitations of Absolutely Positioned 
layouts so that you can judge for yourself whether they fi t all your needs or whether 
you need to be looking at the next step of creating pages using more advanced layout 
techniques, which are covered in Lesson 6, “Advanced Page Layout.”

To illustrate this, you will take a look at your existing layout with the premise that 
someone has asked you to make the entire container larger and also switch the position of 
the two columns on your page.
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1 In the Design view, click the edge of your #container div to select it and in the 
Property Inspector, change the Width from 840 to 960. The container width expands 
but when adding this extra 120 pixels of space, your header and the other sections are 
no longer well-aligned.

Your background image is now also too narrow. This cannot be easily resolved in 
Dreamweaver. You would have to go back to Photoshop, resize the image, and export 
it again. For now, you’ll simply turn it off  temporarily.

2 In the CSS Styles panel, click the #container style, and click the All button if 
necessary. Now select the background-image property. Click the Disable/Enable CSS 
Property button ( ) at the bottom of the panel to turn off  this image for now.

Clicking the Disable/Enable CSS 
Property button removes the style 
for the background image.

With the background image temporarily removed, it is easier to see the structure of 
your layout.

3 Click the right edge of the header and drag it to the right to expand the width. Drag 
the header beyond the container and notice it is easy to break your layout. This is 
because absolutely positioned elements don’t interact with the other elements on the 
page; you need to manually adjust them.

4 In the CSS Property Inspector, set the W (Width) value of the header to 960. It 
must match the width of the container exactly. Although you’ll also notice that the 
background image of the vegetables remains fl ush right.

5 Click the edge of the intro box, and, using your arrow keys, nudge it to the right until 
it is centered within the page.

Now you need to switch the position of the main and sidebar divs.
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6 Click the edge of the main div and use your arrow keys to nudge it to the right. 
Notice that it overlaps your sidebar. This is due to the behavior of absolutely 
positioned elements allowing them to occupy the same space on the page. 

The property that controls which element is highest in the stacking order is called the z-index. 
Dreamweaver sets this property automatically when you create AP Divs. Elements with the 
higher z-index value will always “win” and be visible over elements with a lower z-index. You 
can also modify z-index values if you choose to adjust this.

7 Click the edge of the sidebar div and using your arrow keys nudge to the left until it 
reaches the original position of the main div. 

You may need to nudge the position of the two boxes until you are satisfi ed with their 
position. Additionally, feel free to adjust the width of the boxes if needed.

Switching the position of the two boxes requires you to move them manually.

Adjusting the width of the layout and the columns is not signifi cantly diffi  cult but it’s 
also not very effi  cient. Wouldn’t it be nice if expanding the width of the container 
automatically readjusted the columns within the new space? In fact, there are 
techniques you can use to accomplish this. They are called fl oat-based layouts and you 
will learn these techniques in the next lesson. For now, save and close the fi les.

Congratulations, you have fi nished Lesson 5, “Creating Page Layouts with CSS.”

For a more in-depth look at Cascading Style Sheets see the Web Design with HTML and 
CSS Digital Classroom book, and for a discussion of CSS3 and HTML5 see the HTML5 
Digital Classroom book. Both of these titles are available in electronic and print formats.
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Self study
Get some practice with layout by creating a new div named footer in layout.html. Bring in 
the content from the footer.html fi le provided in your assets folder. Style the footer using 
the techniques learned in this lesson. 

Open the style for the sidebar and apply similar margins and borders to those that you 
applied for the main div.

Experiment with your layout by expanding the width of the container div, changing the 
background color and adding borders. You will be surprised at how small changes to these 
properties can have dramatic eff ects on the appearance of your page.

Review 
Questions
1 In what two ways can <div> elements be automatically created for the purpose of 

layout in Dreamweaver?

2 Which one of the following two buttons requires you to assign an ID name: the Draw 
AP Div button or the Insert AP Div button? 

3 What is the overfl ow property and why would you use it?

Answers
1 By using the Draw AP Div and Insert Div Tag buttons, located in the Layout section 

of the Insert panel.

2 The Insert AP Div button requires you to assign an ID name if it is a new ID, or 
choose a pre-existing ID name. The Draw AP Div button creates a generic name for 
your divs.

3 The overfl ow property allows you to change the way a box appears if there is too 
much content. For example, an overfl ow set to auto creates a scroll bar if there is more 
content than can fi t in the box.
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What you’ll learn in 
this lesson:
• Working with the CSS 
fl oat property

• Creating columns with 
fl oated div elements

• Working with the CSS 
clear property

• Creating a CSS 
navigation menu

Lesson 6

The best web layouts account for variable content on a page. As text 
and images are added and/or removed, your layout can adapt. In 
this lesson, you will create from scratch a two-column CSS layout 
using the fl oat and clear properties in order to create an adaptable 
page layout.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your 
workspace. See “Resetting the Dreamweaver workspace” in the Starting Up section of this 
book.

You will work with several fi les from the dw06lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw06lessons folder from 
the included DVD that contains resources you need for these lessons. Go to Site > New 
Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

Advanced Page Layout
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See Lesson 6 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Layout with AP divs versus layout with floats
In this lesson, you’ll learn an advanced method of layout in Dreamweaver using CSS boxes 
that are fl oated as columns. Unlike the infl exible nature of AP Divs, fl oated layouts can 
accommodate additional content more easily, and once you learn how to use them, they 
will allow you to use more creative layout options.

You may be asking: why are there two methods of layout in Dreamweaver, and why am I 
learning both? To understand this, it helps to keep in mind that historically Dreamweaver 
has been designed for use in the Design view (in other words, not working in code). As you 
will soon see, the CSS fl oat property that you will be using to create columns was not truly 
designed to be a tool for layout, and requires a good understanding of CSS to be useful.

Floated layouts are trickier to control and understand than AP Divs. Additionally, older 
web browsers such as Internet Explorer 6 have well-documented bugs and quirks that 
can prevent fl oated layouts from rendering correctly. To address these problems, coding 
techniques known as “browser hacks” have been developed over the years. The browser 
hacks involve adding additional code targeted toward one browser in order to make the 
pages look the same.

In Dreamweaver, it is likely that the program leans toward using the more reliable and 
easier to manipulate AP Divs because of its traditional user base. However, as users of 
Dreamweaver seek to duplicate some of the sophisticated sites they see online, they really 
have no choice but to work with fl oats. As you walk through this lesson, it is important 
to keep in mind that you do not necessarily have to choose between absolutely positioned 
layouts and fl oated layouts. Layouts that combine both AP Divs and fl oated layouts are 
commonplace and combine the strengths of both.

In addition to the two layouts described above, Dreamweaver CS6 has added a third 
category of layouts: “fl uid layouts.” The fl uid layout feature represents the latest 
development in web design and development: creating web pages designed to adapt to 
screens of diff erent sizes. You will have the opportunity to work with this feature at the 
end of the lesson; however, you should note that this form of layout is not for everyone, 
so understanding the fundamentals of fl oat-based layouts is still the recommended path for 
most Dreamweaver users.

To start creating more sophisticated and fl exible layouts, you will fi rst need to have a good 
understanding of the fl oat property.

6
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Creating a floated image
One of the reasons the fl oat property in CSS was created was to allow for the appearance 
of text to wrap around an image. This concept was borrowed from print design, where 
the eff ect is standard practice and often called text wrap or runaround. In CSS, this eff ect 
is achieved by allowing elements following a fl oated element in the HTML markup to 
surround the element, eff ectively changing position. This behavior also makes it possible to 
create columns on a page, although this may not have been the original intent of the rule. 

In this exercise, you will learn the basics of using the fl oat property by applying it to an 
image in order to wrap text.

1 From the dw06lessons site, open the fl oatimage.html page. You will see a page with 
a large paragraph block of text. Click in the middle of the paragraph, immediately 
before the sentence, “We also have added recyclable shopping bags.”

2 Now choose Insert > Image and in the Select Image Source dialog box, choose the 
image recycle_bag.gif from the images folder, and choose OK. In the Alt text fi eld, 
type shopping bag and click OK. The image has width and height dimensions of 
81 × 101 pixels and is inserted as a block inside the paragraph. 

An image with default styling placed inside a paragraph.

The amount of space between the two sentences is determined by the height of the 
graphic. This is the default fl ow of HTML when an inline image is inserted into a 
paragraph.

You’ll now wrap the text around the image by applying the fl oat property to the 
shopping bag graphic.
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3 Make sure the image is still selected and then click the New CSS Rule button in the 
CSS Styles panel. Click the menu for Selector Type and choose Class. In the Selector 
Name text fi eld, type .fl oatimage and click OK.

4 In the CSS Rule defi nition dialog box, click the Box category, then click the Float 
drop-down menu and choose right. Click OK.

5 Make sure the shopping bag graphic is still selected; if it is not, do so now. Look at the 
Property Inspector, there is a Class drop-down menu, which by default is set to None.

The default Class is set to None.

From the Class drop-down menu, choose fl oatimage. With the class applied, the 
image will now be removed from the fl ow of the text and be pushed far right to the 
edge of the container.

Change the Class to fl oatimage.

6 In the CSS Styles panel, double-click the .fl oatimage rule. In the Box category, click 
the Float drop-down menu and change the value from right to left, then press OK.

The image now fl oats to the left and the text wraps around it. This wrapping behavior 
is extremely important to keep in mind as you work with fl oated elements. You can 
fl oat elements to the left or right only.

7 In the CSS Styles panel, double-click the .fl oatimage rule and in the Box category 
uncheck the Same for All checkbox for the Margin, then type a value of 10 for the 
Top and 10 for the Right. Make sure the unit is pixels. Press OK. The image now is 
set off  from the text, adding needed space.

Set the Margin for the image.
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8 Choose File > Save, and then File > Preview in Browser to see the results in your 
browser. This technique is a simple and useful application of the fl oat property. The 
next step is to apply this same concept to other elements, not just images. In the next 
exercise, you will fl oat div elements to create columns. Close your browser and then 
close the fl oatimage.html document.

Creating columns with HTML and CSS
One of the most important aspects of working with fl oated elements is understanding 
how they interact with their surrounding elements. This relationship is easy to understand 
when you have an object with a fi xed width and height such as the shopping bag graphic 
from the last exercise. When fl oated elements are objects that are not fi xed in size, such as 
a column which is defi ned by the amount of text inside, things can get interesting. 

Creating the HTML Structure with div elements
To begin, you’ll start with a page similar to the Organic Utopia layout from Lesson 5, 
“Creating Page Layouts with CSS.” Specifi cally, the container div is 960 pixels wide and 
styled to be centered within the browser. The header has one inline image (the Organic 
Utopia logo). You will fi rst defi ne the structure of the page by adding div elements for the 
various sections.

1 In the Files panel, double-click the layout.html page. Your fi rst step will be to add the 
navigation section.

2 In the Insert panel, click the Insert Div Tag button, and the Insert Div Tag dialog box 
opens. Here you can choose where you would like the new div element to be inserted. 
You need the navigation div element to follow the header.

3 In the Insert Div Tag dialog box, click the Insert drop-down menu. Select the After 
tag option, then in the drop-down menu to the right, choose <div id=”header">. 
Type navigation in the ID text fi eld, then press the New CSS Rule button.

Set the properties in the Insert Div Tag dialog box.

The New CSS Rule defi nition dialog box opens. Click OK. You will now add a few 
simple styles to the navigation div.
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4 In the CSS rule defi nition dialog box, click the Background category and type 
#88b036 into the Background-color text fi eld to add a green background color. Then 
click the Box category and type 100 in the Width text fi eld, then from the drop-down 
menu to the right choose %. Click in the Height text fi eld and type 36, and leave the 
value set to px. Click OK. Click OK again in the Insert Div Tag dialog box. Your 
navigation section now spans across the width of the container.

You’ll now add three div elements for the main and sidebar columns, as well as the footer. 
These next three steps are essentially variations on step 3: You are adding structural 
elements to your page and giving the elements good names to begin styling them. 

5 Click the Insert Div Tag button in the Insert panel. Click the Insert drop-down 
menu and choose the After Tag option, and then in the drop-down menu to the right 
choose <div id="navigation">. Type main in the ID text fi eld and then click OK. 

6 Click the Insert Div Tag button in the Insert panel. Click the Insert drop-down menu 
and choose the After Tag option, then in the drop-down menu to the right, choose 
<div id="main">. Type sidebar in the ID text fi eld and then click OK. 

The last section you will add will be for the footer at the bottom of the page.

7 Click the Insert Div Tag button in the Insert panel. Click the Insert drop-down 
menu. Select the After Tag option, then in the drop-down menu to the right choose 
<div id="sidebar">. Type footer in the ID text fi eld, click the New CSS Rule 
button, then click OK. You will be adding a background-color style now so you can 
more easily see how the footer interacts with the two columns.

8 In the CSS Rule defi nition dialog box for the footer, click the Background category 
and in the Background-color text fi eld, type #CCC to add a light gray. Click OK, 
and then click OK again in the Insert Div Tag dialog box. You now have the main 
sections of your page, and you now have to start setting the widths of the columns.

The main sections of your web page are now created.
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Setting the width and floating the columns
With the basic structure of your page set up in HTML, you will now set the width of the 
main and sidebar columns and fl oat them using CSS. You will return to the navigation bar 
in a later exercise.

1 In the CSS Styles panel, click the New CSS Rule button and the New CSS Rule 
window appears. If the Selector Type menu is not set to ID, click on the menu and 
choose this option, then click on the Selector Name menu and from the list that 
appears choose main and then click OK.

2 In the CSS Rule defi nition dialog box that appears, click the Box category, and 
then type 600 inside the Width text fi eld. From the Float drop-down menu, choose 
right. Click OK and you will see the main column moves to the right and the sidebar 
column moves up to fi ll in the remaining space. Now you’ll add some content to see 
how it fi ts into the column.

3 In the Files panel, double-click the main_content.html page. Select all the text on 
this page, then press Ctrl+C (Windows) or Command+C (Mac OS) to copy it. Close 
the fi le, then select the placeholder text in the main div and press Ctrl+V (Windows) 
or Command+V (Mac OS) to paste. The column expands to accommodate all the 
content. Notice that the footer appears to be behind the main column. This is a result 
of the fl oated properties you just added. You’ll take a look at this shortly, but fi rst you 
will style the sidebar.

4 Click inside the sidebar div, then in the CSS Styles panel, click the New CSS Rule 
button. Press the Less Specifi c button once, and the Selector Name reads #sidebar. 
Click OK, and in the CSS Rule defi nition dialog box, click the Box category. In the 
Width text fi eld, type 360. From the Float drop-down menu, choose left. Click OK. 
Visually, very little will change, but the two columns now have explicit widths and 
both are fl oating. 
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5 In the Files panel, double-click the sidebar_content.html page. Select all the text on 
this page and copy it. Close the fi le, and then click inside the sidebar div and paste, 
replacing the placeholder text. The sidebar expands to fi t this content, which is a 
defi nition list.

The sidebar section is fl oated to the left and has a width of 360. The main section is fl oated to the right 
and has a width of 600.

We have cheated a bit in this exercise and created pre-existing styles for the sidebar content. Many 
of the techniques for modifying the margins of elements have been covered in earlier lessons. If 
you’re curious, you may look at the styles for the <dl> and <dd> elements within the styles 
panel or the code view to see the details.

What may be most confusing is the behavior and appearance of the footer div. As noted 
earlier, it appears to be behind your two columns. The reason for this has to do with the 
nature of fl oated elements. Floated elements are removed from the default fl ow of HTML 
and since both columns are fl oated, the footer ignores them and moves up directly below 
the navigation section. This is also why the height of the footer has expanded. From the 
perspective of the footer, there are no columns to interact with so it assumes its default 
behavior.

In order to push the footer below the columns, you need to add another CSS property to 
the footer called clear.
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Using the clear property
When you apply the clear property to an object, you are essentially adding a rule that 
says No fl oated elements are allowed on either side of me. In fact, you can specify whether the 
left, right or both sides can have fl oated elements. You’ll try two diff erent options in order 
to understand the clear property better.

1 In the CSS Styles panel, double-click the #footer style, and click the Box category. 
From the Clear drop-down menu, choose right. Click OK. This puts the footer box 
on the bottom of the page. You may need to scroll down to see it.

Although this seems to do the trick, there is a potential pitfall. You set the clear value 
to right, but what would happen if the content in the main column were shorter than 
the content in the sidebar? Understanding the answer to this question will go a long 
way toward your understanding of fl oats and clears, so you’ll do a short experiment.

2 In the main div, select the last three paragraphs and headings and then delete them. 
With less content in this column now, the footer still behaves the same and stops at the 
bottom of the main column, but the sidebar is longer now so the footer overlaps it.

Select and delete the last three paragraphs and headings in the “Main” div.

Of course, you could fi x this by switching the value of the clear property from 
Right to Left. This would prevent the footer from being next to the sidebar, but the 
problem is that you may never know which column will have the most content, so the 
safest solution is to apply the clear property to both sides.

3 Choose Edit > Undo Delete to bring the content back into the main div.

4 In the CSS Styles panel, double-click the footer style and from the Clear drop-down 
menu choose both, then click OK. The footer div will now always be at the bottom 
because no fl oated elements are allowed to the left or the right.
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Creating a list-based navigation bar
Floats can not only be used for simple image wrapping and creating columns, but also to 
create navigation. Here you’ll start creating a list-based navigation that uses CSS. This is 
a great way to create easily editable navigation bars that are also search engine-friendly 
because they use text instead of images. Additionally, you can think of navigation as 
simply a list of links to other pages, so it makes sense to use the list element. The fi rst step 
is to add the content and then style the list items and the navigation element. 

1 Select the placeholder text in the navigation div and then click the HTML button in 
the Property Inspector, if necessary. Click the Unordered List button ( ) and the text 
will become the fi rst bullet in an unordered list.

2 Replace the placeholder text by typing Home, and then press Return. This adds a 
new list item. Add the following navigation sections pressing Return after each one: 
About Us, Products, Services, Contact. Your layout will appear to break as the list 
items are added. Don’t worry; you will be using fl oat properties to turn this list into a 
horizontal navigation bar. 

Add the list items that will serve as your navigation.

You will now link the 5 items. The pages in this case have not been created so you 
will use a placeholder link for each item.

3 Select the Home list item, click inside the Link text fi eld in the Property Inspector and 
type # and then press Enter (Windows) or Return (Mac OS). This symbol creates a 
placeholder hyperlink. Repeat this step for each list item until all fi ve are hyperlinked.

Now you’ll apply the fl oat property and turn this vertical list into a horizontal one.
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4 Click the <li> element in the tag selector.

Select the <li> element in the tag selector.

Click the New CSS Rule button in the CSS Styles panel and choose Less Specifi c so 
the Compound Selector reads #navigation ul li. Click OK.

5 In the Box category, from the Float drop-down menu, choose left. Press the Apply 
button, and you will see that your list items are now stacked horizontally rather than 
vertically. By applying the fl oat property, you have overridden the list items’ default 
behavior. However, there is still more work that you need to do.

6 Click the List category, then from the List-style-type drop-down menu, choose none. 
This removes the bullet points from each list item. Click OK. 

You still need to do more work; specifi cally, you need to create styles for the <a> 
element that is for hyperlinks You’ll style the appearance and position of these links now.
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7 Click inside any link in the navigation, and then in CSS Styles panel, click the New 
CSS Rule button. The selector type is compound, but unnecessarily complex; press 
the Less Specifi c button so the Selector Name is set to #navigation ul li a, and 
then click OK.

Create a new CSS rule for the navigation hyperlinks.

8 In the Type category, check the Text-decoration checkbox labeled none. This will 
remove the default underline below your hyperlinks. Click the Color swatch and 
choose white.
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9 Click the Box category and uncheck the Same for all checkbox for Padding. Type 
8 px for the top and bottom values, and 15 px for the left and right values. Press 
Apply to see the space added between each hyperlink.

Apply padding to the hyperlink styles to create more space between your navigation.

10 Click the Block category, and then from the Display drop-down menu, choose block. 
This property and value changes the appearance of the list item: it expands and also 
allows the entire block to be clickable, not just the text. Click OK.

You’re almost fi nished; however, your navigation links are currently overlapping the 
boundaries of the green navigation bar. This is because of some default margins — a 
topic you have run into before. In this case, the default margins of the unordered list 
are the culprit.

11 Click anywhere inside the navigation, if necessary, and then click the <ul> tag in the Tag 
Selector. Then, click the New CSS Rule button in the CSS Styles panel. Press the Less 
Specifi c button, making sure the selector reads #navigation ul, and then click OK.
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12 In the CSS Rule defi nition dialog box, click the Box category and type 0 for Margin 
and Padding. Click OK and the hyperlinks are now centered within the navigation 
element.

Set the margins for the navigation to give it a more defi ned look.

The last piece to add is a little interactivity. Say that when the user mouses over any one 
of the navigation links, you would like it to change color. This improves usability by 
letting the user know the links are active. You can do this with the hover property for 
hyperlinks.
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13 Click within any link, then click the New CSS Rule button in the CSS Styles panel. 
In the New CSS Rule dialog box, choose the a:hover property from the drop-down 
menu to the right of the Selector Name text fi eld.

Select the a:hover property.

To make the style work in Dreamweaver, type #navigation in front of the a:hover 
property to create a compound selector. The fi nal selector name should read 
#navigation a:hover. Click OK.

14 In the Background category of the CSS Rule defi nition dialog box, click in the 
Background-color text fi eld, and type #9FCC41. This is the same green as the header. 
Click OK.
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15 Save your document and choose File > Preview in Browser to see your list-based CSS 
menu. Be sure to mouse over the links to see the hover eff ect.

Creating a style for the a:hover property produces a color rollover eff ect when the user’s cursor is on a link.

Changing column layout and size
Another benefi t of using fl oated containers for layout is that they are very easy to modify. 
For example, perhaps you would like to experiment with your sidebar being on the right 
rather than the left, or perhaps you would like to experiment with changing the width of 
the entire layout. This can all be accomplished with a few easy modifi cations of the styles.

1 In the CSS Styles panel, double-click the #main style. Click the Box category, change 
the Float value from right to left, and then click OK. This pushes the main box over 
to the left of the container and the sidebar slips to the right.
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2 In the CSS Styles panel, double-click the #sidebar style, click the Box category, 
change the Float value from left to right, and then click OK. There will be no visual 
change in this case, but it does ensure that the sidebar is fl ush against the container. 
That’s it! Two simple style changes create a completely diff erent layout.

Change the Float value of the #sidebar style from left to right.

If you’d like to change the overall width of your page layout you can do this by 
modifying the #container div. 

3 In the CSS Styles panel, double-click the #container style and click the Box 
category. Change the Width from 960 to 1100 and then press Apply. This expands your 
container, and because your columns are fl oating, they will both remain aligned to their 
respective sides. For the purpose of this exercise, the original value of 960 is better, so 
type this value back again. For now, the important part is to understand the concept.

4 While you are here, select the Height value and delete it, leaving it empty. Having a 
fi xed height is useful at the beginning of the layout progress, but it should be removed 
at some point in order to accommodate more content. Click OK.

Fine-tune your page: currently, the main column is aligned fl ush left against the 
container and the text is too close to the edge of the container. This is a common 
layout problem; you will now look at some techniques designed to help you create 
your own custom layouts and to better understand the behavior of fl oated elements.
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5 Double-click the #main style in the CSS Styles panel, and then click the Box 
category. Uncheck the Same for all checkbox for Margin, type 20 inside the left 
margin, and then click OK.

Adding 20 pixels of left margin to the #main column.

Notice that this change had the desired eff ect of adding space between the main 
column and the surrounding container. However, there is another eff ect: the sidebar 
has now “slipped” down below. This eff ect is to be expected because you are trying 
to squeeze two boxes into a fi xed width space. Remember that the container is 960 
pixels wide. The main column is 600 pixels wide, and you just added 20 pixels to it, 
thus making the true width 620 pixels. The sidebar is 360 pixels wide; adding the 
combined widths results in 980 pixels.

This is a common dilemma with fi xed width layouts, but as long as you understand 
the relationships, it is easy to fi x. In this case, you’ll try reducing the width of the 
main column.

6 Double-click the #main style in the CSS Styles panel, and then click the Box 
category. Change the width from 600 to 580 and press Apply. The width is reduced 
and the sidebar slips back up.

However, you can take this a bit further: the columns are actually very close to each 
other. You can add more space by reducing the width of the main section even further.
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7 Type 550 as the width, and then click OK. You now have an additional gap of space 
between the main section and the sidebar.

Keep in mind that you could have decreased the width of the #sidebar style if you preferred to 
keep the width of the #main column intact. There are no set rules for how to do this correctly. 
Layout in CSS becomes interplay between width, margins, padding, and content; every page 
has slightly diff erent requirements. Just be sure to keep track of all these relationships in your own 
designs, since it can get confusing as you add more elements. 

Creating the appearance of equal height columns
There is now another part of your layout that you need to pay attention to: the column 
height. Currently, the main column is longer than the sidebar; visually this isn’t really a 
problem because neither column has a background color, so the whole page appears white. 
But what happens if your design requires that explicit columns be defi ned by color? In this 
exercise, you’ll look at one solution for this issue. 

1 In the CSS Styles panel, double-click the rule for the sidebar div. Click the 
Background category, then, in the Background-color text fi eld, type #C8D9BC.

2 Click the Border category. Uncheck the Same for all checkboxes for Style, Width and 
Color. In the row labeled Left, choose solid in the Style column’s drop-down menu, 
and type 2 in the Width columns text fi eld. In the Color column’s text fi eld, type 
#060. Click OK.

Set the border for the #sidebar div.

The problem with the column is an aesthetic one. A column sometimes looks better 
when it spans to the bottom of the page rather than cutting off  abruptly. Additionally, 
if you are using this layout throughout your site, every page will likely have diff erent 
amounts of content. As a user moves from page to page, this would create irregular 
page appearance, as the column height jumps up and down based on the amount of 
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content. To solve this, you’ll add a background image to the container div, which 
simulates the appearance of the column from top to bottom.

3 In the CSS Styles panel, double-click the rule for the container div. Click the 
Background category, and for the Background-image property, press the Browse 
button and locate the container_bg.gif fi le in the images folder. Click Choose 
(Windows) or Open (Mac OS).

This graphic is 960 pixels wide (which matches the width of your container), but it is 
only 2 pixels high. Essentially, it is a thin horizontal slice of the page and includes the 
sidebar color and green border. 

4 From the Background-repeat drop-down menu, choose repeat-y. This ensures the 
graphic will only be tiled from top to bottom. Click OK and you will now see your 
columns fi lled in.

A “fake column” background image creates the eff ect of a column extending the height of the page.
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Now, the length of the column is irrelevant. The image background will always reach 
the bottom of the page and maintain a consistent appearance. 

Although this technique is useful, it relies on your layout being fi nalized. If the width of your 
container or the position of any of your columns changes, you must then change the background 
image. Additionally, other changes, such as the color of a column or any padding adjustments 
may also require you to modify your background image. For this reason, you should wait until the 
small changes and adjustments to your layout are complete before making a column background.

How to create a fake column background in Photoshop

The easiest way to make the fake column background is if you happen to have a mockup of 
your website as an image file or as a Photoshop file with layers. However, if you don’t have a 
mockup, you need to be more creative. Here’s how we created our page background.

1 Preview your web page in the browser. Look to make sure you have a clear cross-section 
of your columns from left to right. If there is any text or images in the column, you may 
need to go back to Dreamweaver and remove them temporarily.

2 Using your system’s screen capture program capture your screen. In the Mac OS, this 
can be done with the keyboard shortcut, Command+Shift+3. In Windows, use the Print 
Screen button to capture.

In the case of the Mac OS, this will create a png fi le that will be saved to your desktop. 
In the case of Windows, this will copy the screen image to your clipboard.

3 In Photoshop, either open the screen capture image directly (Mac OS) or if in Windows, 
choose File > New, then press OK and press Ctrl+V.

4 Click the Rectangular Marquee tool, then in the Options panel, change the style from 
Normal to Fixed Size. Type in a width of 840 px and a height of 2 px. If your original 
layout has a diff erent width, you will need to change this width value to match.

5 Click anywhere in the image with the Marquee tool to add a fl oating selection. Using 
your arrow keys, you must line up the selection exactly with the edges of the container. 
If the selection is even 1 pixel off  it will result in a mismatch between the image and the 
real HTML columns.

6 Choose Image > Crop, then choose Save for Web and Devices to save it as a gif, jpg or 
png. Try to optimize the image in order to make it as small as possible. For example, in 
our case, we saved it as a gif using only 4 colors.
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Browser compatibility
Up to this point, the concepts of creating a layout with fl oats and clears have made sense. 
There may have been some unusual or unexpected behaviors, but for the most part, once 
you understand the rules, you can begin to think about how you can apply this to your own 
designs. That’s the good news. The bad news is that the expected behavior of CSS boxes 
takes a bad turn when we factor older browsers such as Internet Explorer 6 into the equation. 

Due to certain rendering bugs in the browser, the behavior of fl oated elements can be hard 
to predict, and in some situations can completely “break” a layout. Web designers and 
developers have addressed this unfortunate behavior over the years by adding code fi xes 
for Internet Explorer 6 to their style sheets, or by coming up with scripting solutions. 

Adding code for IE 6
In the layout you have built, there is a code fi x you will need to add to make the layout 
function well in IE 6. The problem is that the footer div that you cleared will not always 
be pushed below your columns. The bug that causes this can be fi xed by “faking” a height 
for the footer. In general, IE 6 doesn’t like fl oated elements that have no height, so this fi x 
can solve many problems.

1 In the CSS Styles panel, double-click the #footer style, and in the Box category, 
type 1 for Height. Then click the drop-down menu and choose %.

Set the Height for the #footer div.

IE 6 needs this height value to prevent the layout from breaking.

2 Click OK and although you will not see any change, the layout is now fi xed in IE. 
This fi x might not have seemed too diffi  cult, but more complex layouts will reveal 
other potential problems, especially when fl oats become involved. There is also the 
question as to whether you need to add the fi x at all for this particular browser; 
however, this is a separate issue.
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3 Choose File > Save to save your work.

Do I need to optimize for Internet Explorer 6?

As of this writing, Internet Explorer 6 is a ten-year-old browser, and Internet Explorer 
7, 8, and 9 have been released. Each version has improved the rendering of CSS, and in 
any case, the latest statistics have shown that use of Internet Explorer 6 has dropped down 
below 1% in the United States. (Although it is still far larger in other parts of the world. See 
www.ie6countdown for specific details). 

For many years, the extra code and troubleshooting involved in solving layout issues with 
Internet Explorer 6 was a significant problem that added time to the development process. 
Although this issue is no longer as relevant, the general problem of browser compatibility 
has not gone away. There are still differences between the way browsers interpret pages. 
However, in the year 2012, many of these issues have to do with evolving technology, such 
as CSS3 and HTML5, a topic we cover in more depth in the chapters “Mobile Design and 
Layout,” and “Animation with CSS3.”

Applying finishing touches
You’ll now tidy up some loose ends with your layout. Specifi cally, you’ll add a background 
image to your header, and then move the rules in your current style sheet to an external 
style sheet so you can use these styles for other pages in your site.

1 In the CSS Styles panel, double-click the #header style to open it. Choose the 
Background category and then click the Browse button for Background-image. 
Navigate to your images folder, choose veggies.jpg, and then click Open.

2 Click the background-repeat menu and choose no-repeat. Click the Background-
position(x) property and choose right. Click OK. Notice that the veggies image has 
been applied to the right side of your header.

Adding a background image to the header.

Now you will move all the style rules to an external style sheet so you can use these 
styles on new pages.

3 In the CSS Styles panel, be sure the All button is selected, click the fi rst style (body), 
scroll down, and then Shift+click the last style (dd). This will select all the styles for 
the page.

4 Click the panel menu ( ) at the top right corner of the CSS Styles panel, and choose 
Move CSS Rules.
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5 Click the radio button labeled A new style sheet and click OK. You’ll be prompted to 
save your style sheet. Type styles in the Save As text fi eld and click OK (Windows) or 
Save (Mac OS). You now have an external style sheet that can be attached to new or 
existing pages in your site. (If you receive a message saying that duplicate names are 
being copied, confi rm the save, don’t cancel.)

6 Choose File > Save. Then choose File > Close to close this page. Save your CSS fi le, 
if prompted.

Creating more sophisticated layouts
The two-column layout you created represents a good foundation for a website. You 
would refer to this as a “Two-column fi xed-width layout with a header and footer.” 
However, you may be looking for more options. For example, what about a three-column 
layout, or a liquid layout in which the content adjusts to the width of the browser (also 
referred to as a fl exible or fl uid layout)? It is beyond the scope of this book to walk through 
all these options. However, Dreamweaver does off er a way to create diff erent layouts on 
the fl y. You can choose from a gallery of new layouts whenever you create a new page.

1 Choose File > New and make sure HTML is selected as the Page Type. In the Layout 
column, the None option is the default, but you can also choose from a number of 
pre-made options.

2 Choose the 2 column liquid, left sidebar, header and footer option. Notice that a small 
thumbnail with a description of the layout appears. Click Create.

The thumbnail preview of the two column layout.
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3 Choose File > Preview in Browser and when prompted, save this fi le as 2col_liquid.html. 
Adjust the width of the browser and you will see that the width of the container page 
adjusts, as well as the content within. Unlike the layout you created earlier, you might 
choose this layout because it is more adaptable for diff erent sized monitors. 

Take a moment to read the text in this page. It mentions that the code for this page has 
been commented. You’ll take a look at this code now, in order to better understand 
the pros and cons of using these pre-generated pages.

Close the browser and return to Dreamweaver.

4 Click the Code View button and scroll to the top if necessary. The code in light gray 
represents comments that describe virtually every line of the CSS. So why is there a 
need to comment this fi le so heavily? To make a long story short, the code in this fi le 
is very robust and is optimized for cross-browser display. This means there are styles 
that address various bugs across diff erent browsers, as well as other relatively advanced 
CSS code.

This presents a dilemma: You will benefi t most from these templates only as long as 
you know how to modify them. In order to modify them eff ectively, however, you 
need to understand the rules of HTML and CSS relatively well. There is a limit to 
how far a WYSIWYG (What You See Is What You Get) application can take you in 
learning these rules. 

This should not stop you in exploring these page layouts. They are extremely useful, 
and can be incredible time-savers. Just be aware that reverse-engineering how a 
page works can also be time-consuming, and that the answers may lie in the rules of 
HTML and CSS, and not in the Dreamweaver application.

5 Choose File > Close All and save any fi les if prompted.

Dreamweaver Fluid Grid Layout
A new feature in Dreamweaver CS6 is the addition of Fluid Grid Layouts. This is a system 
for creating websites that are alternatively known as adaptive or responsive, meaning that 
the layout of your pages changes depending on the size of the user’s screen. The model for 
this form of layout is in many ways radically diff erent than the techniques presented in this 
lesson. Fluid Grid Layout uses a combination of HTML5, CSS3, and JavaScript to create 
layouts that are optimized for mobile devices and monitor screens of diff erent sizes.

The techniques covered in this lesson are very well-tested and reliable in the current crop 
of web browsers; the techniques used for Fluid Grid layout introduce new complexities 
that are best covered in a separate lesson. This is why we cover them in Lesson 15 “Mobile 
Design and Layout.”
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Self study
Experiment with the fl oat property by opening the fl oatimage.html used in the fi rst 
exercise. Add fi ve or six instances of the shopping bag graphic in a row and apply the 
fl oatimage class to all of them. How could you create a thumbnail photo gallery using this 
technique?

Review
Questions
1 The fl oat property allows you to fl oat an element to the left, right and center. 

True or False?

2 What are the three possible values for the clear property? Name a situation where 
you might use this property.

3 How would you apply padding to a fl oated column?

Answers
1 False. The fl oat property only has three values: left, right and none. You cannot 

fl oat an element to center.

2 You can apply the clear property to an element with one of the following values: 
left, right or both. Elements with a clear property do not allow a fl oated element to 
the side specifi ed. A common situation where you might use this would be when you 
need the footer element on your page to appear below any fl oated columns.

3 Select the style for the column in the CSS Styles panel that you want to apply padding 
to by double-clicking on it. Once the CSS Rule Defi nition panel appears, click the 
Box category. Then set a value for padding.
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What you’ll learn in 
this lesson:
• The role of CSS3 in 

Dreamweaver CS6

• Creating a CSS Transition

• Adding Web fonts

Lesson 7 

Dreamweaver CS6 off ers two new methods for upgrading the style 
and appearance of your site, CSS3 Transitions and Web Fonts. 
CSS3 Transitions add a way to create basic animations using 
CSS properties such as background-color. Web Fonts off er a way 
to enhance your page by embedding custom fonts, even if visitors to 
your site do not have the font on their system.

Starting up
Before you begin, reset your workspace to ensure your tools and panels are consistent. 
For more information, see “Resetting the Dreamweaver Workspace” in the Starting Up 
section of this book.

In this lesson, you will work with several fi les from the dw07lessons folder. Make sure that 
you have loaded the dwlessons folder onto your hard-drive from the supplied DVD. For 
more information, see “Loading lesson fi les” in the Starting Up section of this book.

Before you can proceed with the exercises in this section, you need to create site settings 
that point to the dw07lessons folder. Go to Site > New Site, or for details on creating a 
site, refer to Lesson 2, “Setting Up a New Site.”

CSS3 Transitions 
and Web Fonts 
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See Lesson 7 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Understanding the role of CSS3
Cascading Style Sheets is a separate language from HTML; however, both languages are 
constantly evolving. The original CSS1 specifi cation was released in 1996 and included 
many of the basic CSS properties used today, such as background-color, font-family and 
so on. Over the years, new versions of CSS have emerged with revisions and additions to 
the original specifi cation. CSS3 is the latest version of the language and off ers a number of 
new CSS properties that give designers new tools for adding style to their pages.

The details of the evolution of CSS are not as important as understanding the key issue: 
browser support. Although CSS3 off ers a number of exciting and useful features, designers 
and developers need to know which features the diff erent web browsers can reliably 
support. There are a tremendous number of new features in CSS3, and these features have 
diff erent levels of browser support. Some features you can use today very reliably, others 
may not be supported for years. The architects of CSS3 have broken up the language into 
categories called “modules”; examples include Backgrounds, and Borders and Animation, 
among others. In this lesson, you’ll learn how to use CSS Transitions from the Animation 
module, and Web Fonts from the CSS Fonts module. 

Adding a CSS Transition
CSS Transitions in Dreamweaver CS6 off er you a way to create simple animations on your 
page using only CSS. This is in contrast to the traditional method of creating eff ects, such 
as image rollovers, using JavaScript or Flash. 

The basic concept of CSS Transitions is this: an object is animated by changing a property 
(or properties) over time. For example, in the following exercise you will start with a box 
that has its height property set to 350 pixels. You will then animate the height property 
down to 50 pixels over a period of two seconds. The result will be a slow collapsing eff ect 
when the user places their cursor over the box.

You’ll start with a simple example fi le, and then in a later exercise, you will apply CSS 
transitions to the Organic Utopia layout.

7

DWCS6_06Pass.indb   184DWCS6_06Pass.indb   184 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


7

185Lesson 7, CSS3 Transitions and Web Fonts  

Adding a CSS Transition

1 Open the 07_csstransitions.html document. Currently, this page has a single style rule 
for the ID #box. You should take a look at these styles before proceeding.

2 In the Design view, click the edge of the box to select it. To be sure that you have the 
actual box selected, check for the blue outline that will appear around the box, which 
confi rms that it is selected. In the CSS Styles panel, click the All button if necessary, 
and then click the #box style. This will expose the properties currently used. (If 
your Properties panel does not look like our screenshot, click on the “Show only set 
properties” icon in the lower-left corner of the CSS Styles panel).

The CSS properties associated with the CSS ID #box.

The properties used here are background-color, border, height, width, font-
family, and text-align. All these properties (and many more within CSS) can be 
animated using transitions.

Pay particular attention to the height property and the value, currently set to 
300 pixels. You will now create a single transition that will animate the height of the 
box from the original 300 pixels to a more narrow height.

3 Choose Window > CSS Transitions to open the CSS Transitions window. This 
window lists all the existing transitions used in a document, and also allows you to 
Create, Remove, and Edit transitions.
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4 Click the + sign in the upper-left of the CSS Transitions window; the New Transition 
window appears.

The New Transition window off ers a number of options for you to create transition eff ects.

5 Click the Target Rule menu. The only choice available is for #box, the rule you 
examined in Step 2. In more complex documents, you would see all the rules used and 
could choose any of them. Choose #box from this drop-down menu.
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Adding a CSS Transition

6 Click the Transition On menu to see all the options available. A transition starts 
in one state and then moves to another, but something must trigger the transition. 
This menu lists the various options: active, checked, disabled, enabled, focus, hover, 
indeterminate, and target. You’ll learn more about these options shortly. 

The options available within the Transition on menu.

7 Choose the Hover option.

8 Click inside the Duration fi eld and type 2.

CSS Transitions provide a way to control the speed of animation changes for one or 
more CSS properties. In this instance, you are stating that you want this transition 
to last 2 seconds. You will return to the two other options—Delay and Timing 
Function—in the next exercise, but fi rst you need to defi ne which property you want 
to animate.
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9 Click the + sign at the bottom of the Property section. A menu appears with the 
entire list of CSS properties you can control. Select the height property.

Choose the height property from the available list of CSS properties.

Note: As this list shows, you cannot animate every single CSS property. For the offi  cial list of 
available properties visit: 
http://www.w3.org/TR/css3-transitions/#animatable-properties-

10 Click inside the fi eld labeled End Value, type 50, and make sure the menu to the 
right remains on pixels (px). The starting height of the box is 300 pixels; using this 
transition, you will change it to 50 pixels over a period of two seconds when the user 
hovers over the box.

Click the Create Transition button to add it.
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11 Choose File > Save As, type 07_csstransitions_work in the File name and click Save 
to save this fi le in the dw07lessons folder. Choose File > Preview in Browser.

Place your cursor inside the top of the box; you will see the box animate from the 
original height of 300 down to 50 pixels. As you move your cursor off  the box, it 
begins to animate back to its original height.

When the user hovers over the box, it animates from a starting height of 300 pixels to an ending height of 50.

This is a very basic example of a single CSS transition. In the next exercise, you will 
add more transitions and learn how to edit your existing one.

12 Close both the browser window and the original 07_csstransitions.html page. Return 
to Dreamweaver. Keep the 07_csstransitions_work.html fi le open, since you’ll be 
working with it in the next exercise.

What if you can’t see the transition?

You might not be able to see the transition effect in the last exercise if your web browser 
does not support the transition property. The support for CSS3 Transitions is relatively new 
and not all properties are equally supported across all browsers, specifically the most popular 
versions of Internet Explorer 6, 7, 8, and 9. 

At the time of this writing, Microsoft has indicated that Internet Explorer 10 is scheduled to 
support CSS Transitions. The following online resource provides a useful table to help you 
see the level of support for CSS Transitions for past, present, and future (planned) browsers.

http://caniuse.com/#feat=css-transitions
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Modifying a CSS Transition
Now that you have seen how a CSS Transition works, you’ll now see how to modify 
the existing transition speed, add a delay, and adjust the timing of the animation using a 
feature called Easing.

Before you get started with the modifi cations, you’ll take a quick look at the CSS code 
that Dreamweaver creates in the background. 

1 Click the Code View in your document and locate the <style> section at the top; 
specifi cally, the #box rule. Notice that there are fi ve lines of code that were created 
by adding the transition, starting with -webkit-transition: all 2s; and ending 
with transition: all 2s;

The generated transition CSS that was created by Dreamweaver.

Five lines of code may seem like a lot; however, each line is exactly the same 
code, and each targets a specifi c web browser. The code -webkit-transition: 
all 2s; begins with a “vendor-specifi c prefi x” to target Webkit browsers such as 
Apple Safari and Google Chrome. The code -moz-transition: all 2s; targets 
Mozilla browsers (Firefox). The next two lines, -ms-transition: all 2s; and 
-o-transition: all 2s; target Microsoft and Opera browsers.

The last line, transition: all 2s; is the “offi  cial” CSS3 property name for 
transitions. The reason for having fi ve lines of almost-identical code is that each 
browser has its own timeline for supporting a new CSS3 property. For example, Google 
Chrome may have required the prefi x -webkit in version 8.0. When it becomes 
evident that transitions are working reliably and are well-liked by designers, Google 
Chrome might choose to drop the requirement for the prefi x in version 10.0. The 
goal is for all browsers to eventually support the “offi  cial” property transition; the only 
reason to use the vendor-specifi c ones would be to provide support for older browsers.
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2 Look below the code for the #box style; you will see the style #box:hover. This code 
represents the trigger you set for the transition in the last exercise.

3 Click the Design view to toggle back to your page. Most likely, you will not need to 
modify the CSS transition code by hand, but you should understand where you can 
fi nd it within the CSS, and understand some of the underlying concepts.

4 In your CSS Transitions window, click hover and then press the Pencil icon ( ) to 
edit the transition. 

Select hover and then click the Pencil icon 
to edit a transition.

The Edit Transition window opens, allowing you to modify the values you created in 
the last exercise.

You can also double-click hover or div#box to open this window.

5 Select the value 2 inside the Duration fi eld and type 0.5. This will change the 
duration from two seconds to half a second. 

6 Click inside the Delay fi eld, type 1, and make sure the menu to the right is set to s (for 
second). Delaying a transition simply means the transition will not begin until one 
second after the user hovers over the box.
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7  Notice that there is a value in the Timing Function fi eld set to ease. This is the default 
setting, so while you didn’t set this in the last exercise, Dreamweaver fi lls it in as 
though you had.

What is easing?

Easing is a term well known in computer animation that you might have seen before, 
particularly if you have used Adobe Flash. Easing allows you to vary the speed of a transition 
over time. For example, you may want an animation to start off slow and then speed up, or 
perhaps the reverse: start off quickly and then slow down.

Dreamweaver CS6 has six options for easing:

Linear

Maintains a constant speed for the duration of the transition.

Ease 

The animation starts slowly, accelerates, and then slows down when approaching the end of 
the transition.

Ease-in

The animation begins slowly, and then progressively accelerates until the end of the transition.

Ease-out

The animation starts quickly, and then progressively slows down until the end of the transition.

Ease-in-out

The animation starts slowly at the beginning, maintains a steady rate in the middle, and then 
slows down toward the end of the transition.

Cubic-bezier(x1,y1,x2,y2)

Allows you to create a custom animation using the cubic bezier model. A sample value 
might be cubic-bezier(0.4,0.2,0.8,0.7). This particular example would result in an 
animation that starts off slowly and speeds up toward the end of the transition.
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8 Click the Timing Function menu and choose ease-out. The ease-out timing will 
cause the animation to start off  quickly and then slow down. (Note that this eff ect will 
be diffi  cult to see with the new half second duration.)

Choose ease-out from the menu of Timing Functions.

9 Click the + sign at the bottom of the Property section. You will now animate a 
second property to go with the height transition.
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10 Choose background-color from the list, and then click the End-Value swatch; the 
color picker appears. Choose a dark pink color, such as #C36.

Choose a dark pink color for the background-color property.

Notice that the values for Duration, Delay, and Timing Function are the same. If you 
want to create separate values for the background-color animation, you would need 
to click the menu at the top of the Edit Transition window and change it to “Use a 
diff erent transition for each property.”
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11 Click Save Transition, and then choose File > Save. Preview the page in your browser 
and place your cursor at the top of the box. Remember that there is a one-second 
delay that you added in Step 5; after this delay, the box will change height rapidly and 
simultaneously fade from gray to pink.

CSS3 transitions are supported in all major browsers except Internet Explorer. The current 
release of Internet Explorer is version 9 (as of this writing), however the next version (10) 
will support CSS3 transitions. For a detailed look at browser support visit: 
http://caniuse.com/#feat=css-transitions.

After a delay of one second, the box quickly reduces its height and animates its background color.

12 Close the browser as well as the 07_csstransitions_work.html fi le.

In these two exercises, you learned the fundamentals of CSS Transitions on a sample 
fi le. Now you’ll apply what you’ve learned to a more realistic layout.
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Adding CSS Transitions to a navigation menu
User interface elements such as navigation bars, menus, or buttons are great to use with CSS 
Transitions. Subtle animation can add an extra bit of sophistication and style to your pages.

1 Open the 07_nav_transition.html document by double-clicking it in the Files panel.

2 Choose File > Preview in Browser to view this page in the browser. Hover over the 
navigation to see the default styles. The eff ect you are seeing is a traditional CSS2 
hover eff ect, the background color of a list item changes to a lighter green when the 
cursor is hovering over it. However, the change is instant, in CSS2 syntax, you have 
no control over how long it takes to go from the darker green to the lighter green. In 
CSS3 syntax, you do have this control using transitions. You will add a transition to 
make the hover eff ect more interesting.

The current hover eff ect is either on or off .

Close the browser and return to Dreamweaver.

3 If your CSS Transitions window is not currently open, do so now by choosing 
Window > CSS Transitions.

DWCS6_06Pass.indb   196DWCS6_06Pass.indb   196 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


7

197Lesson 7, CSS3 Transitions and Web Fonts  
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4 Click the + sign to open the New Transition window, and then click the Target Rule. 
Choose the #navigation ul li a style. (This is currently the style for list items 
that are also hyperlinks inside the navigation div.)

Choose the #navigation ul li a style from the menu.

5 Click the Transition On menu and choose hover.

6 Click the + sign in the Property section and choose background-color from the 
list. For Duration, type 400; click the menu to the right and change it from s to ms 
(milliseconds). Leave the delay set to 0. For the Timing Function, choose ease-in-out 
and for the End Value, type #9FCC41. (This color matches the one currently used.)

You’ll now combine another eff ect by changing the foreground color of the text inside 
the navigation.

7 Click the + sign in the Property section and choose color from the list. By default, 
this second property is inheriting all the values added for the fi rst value. You want 
more control, so you’ll have to defi ne separate rules for this color property.
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8 At the top of your New Transition window, click the menu and change it to Use a 
diff erent transition for each property.

You must specify whether you want to set diff erent transitions for each property.

9 Make sure the color property is selected. In the Duration fi eld, type 500; click the 
menu to the right and choose ms if it is not already selected. In the Delay fi eld, type 
100; click the menu to the right and choose ms. Leave the Timing Function set to 
ease-in-out. Lastly, click the End Value swatch and choose the dark green value #060.

Click Create Transition. Notice that your CSS Transitions panel now reads [5 
instances] for hover. This automatically refl ects the number of list items in your 
navigation.
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10 Choose File > Save All, and then preview your page in the browser. Hover over 
the navigation and you will see the navigation background color fade up and down 
slightly. The text also fades, but because you added the 100ms delay in the last step, it 
creates a subtle fading eff ect every time the user moves to another navigation.

Adding two separate transitions for the navigation: one for the background color, the other 
for the color of the text.

11 Close your browser. Choose File > Close All. Close the CSS Transitions window. You 
are done with this lesson fi le.

The basics of web fonts
The limited choice of fonts for the Web has been a problem for many years. (The way 
fonts work on the Web was outlined in Lesson 3, “Adding Text and Images.”) The core 
issue is that if you defi ne a specifi c font in your CSS and a visitor to your site does not have 
that font, a substitute font is used. Unfortunately, the list of fonts that are guaranteed to 
be installed on all users’ computers is very small. As a result, over the years designers have 
looked for alternatives and workarounds to this limitation, but none of these techniques 
have had overwhelming success.

However, there is now an accepted technique called Web Fonts in Dreamweaver CS6; 
technically, this is a feature of CSS3 called @font-face. The use of web fonts has gained 
industry support from designers and developers, and more importantly, from companies 
that make and license fonts. Simply put, web fonts allow you to embed any font within a 
page by declaring the font you want to display and placing this font on your web server. 
When a user visits your site, their browser renders the page using this font wherever 
specifi ed. Adding web fonts is a straight-forward process in Dreamweaver CS6; however, 
there are some details (technical and legal) that you need to be aware of.
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Adding web fonts to your site
In this exercise, you will add the web font “Droid Sans Bold” (which is licensed for web 
use) to your website, embed that font so that it is available for use on a page, and then style 
a heading with the new web font.

1 Open the 07_webfonts.html document by double-clicking it in the Files panel.

There are a few steps you should take before adding a web font. In this example, you 
will style the fi rst heading, “Welcome to organic utopia.” You should fi rst understand 
where the current style comes from.

2 In the Design view, click anywhere inside the heading, “Welcome to organic utopia.” 
You can easily determine this is a Heading 1 element in two ways: 1) The tag selector 
indicates this is an <h1>; and 2) In the HTML section of the Property Inspector at the 
bottom of your page, you can see that Heading 1 is the value of the Format.

You can identify this element as a Heading 1 using either the Tag Selector or the Property Inspector.

You should also determine the style that is currently used for the heading.
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3 Click the <h1> tag in the tag selector to highlight the tag. In the CSS Styles panel, 
click the Current tab. Adjust the height of the Rules and Properties sections inside the 
CSS Styles panel as needed. 

You are looking for the rules used to style this heading, and there are three: body, 
#container, and #main. This tells you that there is no CSS style for an h1 on this 
page. Click the body rule.

Identifying the styles applied to the h1.

The body rule indicates that the following properties are used: a color of #333; the 
font-family “Lucida Sans Unicode,” “Lucida Grande,” sans-serif; and the font-size 
small. Remember that the word “cascading” is part of Cascading Style Sheets, and you 
are seeing that eff ect here. The font Lucida Sans is defi ned in the body, and because 
there are no other styles for h1, the cascade is in eff ect, so it inherits the color and 
font-family styles.

Lucida Sans is a font that is extremely common on most users’ computer systems; 
you’ll now add a web font that is not so common.

4 Choose Modify > Web Fonts; the Web Fonts Manager window opens. This dialog 
box will allow you to embed fonts that are located in your system.
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5 Click Add Font; the Add Web Font dialog box appears.

The Add Web Font dialog box allows you to point to web fonts on your system.

6 Click inside the Font Name fi eld and type Droid Sans Bold. This typeface was 
created specifi cally as an open-source font for screen use and we have provided it for 
you in your lesson folder.

7 Click the Folder icon immediately to the right of the fi eld labeled EOT Font; the 
Open window appears. Navigate within your dw07lessons folder to the web fonts 
folder and locate the fi le DroidSans-Bold-webfont.eot. The only fi les you are allowed 
to select are .eot fi les. There are actually additional font fi les in this folder that you 
will be adding shortly.
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8 Choose DroidSans-Bold-webfont.eot and click Open; the EOT font is selected as well 
as the other three options: WOFF, TTF, and SVG. All four of these fonts should be 
used to ensure maximum compatibility across all web browsers.

Browser Font Support

The use of web fonts has been complicated because you cannot use a single font format and 
have it supported across all browsers. The following table lists the level of browser support 
for the different font types. Essentially, it comes down to the need to include them all if you 
want your font styles to be consistent.

The following table lists the various levels of support for the different font-types:

BROWSER OTF & TTF SVG WOFF EOT

IE IE9 — IE9 IE5+

FIREFOX FF3.5 FF3.5 FF3.6 —

CHROME Chrome 4 Chrome 0.3 Chrome 5 —

SAFARI 3.1 3.1 — —

OPERA Opera 10.00 Opera 9 — —

iOS — iOS 1 — —

ANDROID 2.2 — — —

• OpenType (OTF): A widespread font format that is heavily supported by the industry. 
Initially developed as a collaboration between Adobe and Microsoft, one of the primary 
advantages of OpenType is cross-platform support. However, there are additional 
typesetting features, including glyph support, that make OpenType fonts the primary font 
of choice for professional font foundries.

• TrueType (TTF): Originally developed by Apple and later adopted by Microsoft, 
TrueType fonts are still widely in use today as they are largely cross-platform compatible 
and also offer sophisticated typesetting controls, such as hinting, which is a technique that 
improves the quality of the font in low resolution screens.

• SVG: A vector-based format that is notable because it is currently the only font type 
supported by Apple’s iOS for iPod and iPad devices. SVG fonts are text documents that 
define the font outlines as vector objects within the SVG (Scalable Vector Graphic) language.

• Web Open Font Format (WOFF): The latest addition to the world of web fonts, WOFF 
has the potential to become a standard for web fonts, since it is in the final stages of being 
recommended as a standard by the World Wide Web Consortium (W3C). One of the key 
benefits of WOFF is the ability to heavily compress the font files and optimize them for 
distribution over an Internet connection.

• Embedded OpenType (EOT): A variation on OpenType created by Microsoft and 
largely supported only by Internet Explorer. EOT has a variety of copy-protection features 
built-in, designed to prevent copying of fonts.
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9 Click the checkbox labeled, “I have properly licensed the above font(s) for website use.” 
This is a required step and will be explained in more detail at the end of this lesson.

10 Click OK. You will now see Droid Sans Bold listed in your Available Web Fonts.

Click the Done button in the Web Fonts Manager.

The Web Fonts Manager lists the available fonts for your current site.

At this point, your new web font, Droid Sans Bold, has been made available to all existing 
pages and any new pages in the current site. Additionally, this web font will be available to 
any document in Dreamweaver, even if it is part of another site.

Font Licensing

Understanding the rules of font licensing is an important part of using web fonts. You can 
technically add a font to a page, but this does not mean you are always allowed to. The fonts 
on your system may have specific licenses that only let you use them in print or for other 
specific uses. Even if you have paid for a font, this still does not necessarily mean you have 
paid for the web license of this font. You will need to ensure that you are allowed to use the 
fonts you add with the Web Font Manager. 

For more information on web font licensing issues, visit the Web Font Licensing FAQ from 
the Adobe Type Team:

http://blogs.adobe.com/typblography/web-font-licensing-faq
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Styling your heading with a web font
In addition to the legal licensing limitations involved with web fonts, there is also an 
aesthetic consideration. Not all fonts are designed to be rendered on the screen. The 
creators of a typical font are often more concerned with how the font renders in print or 
how the font looks at small sizes versus large sizes (or vice-versa). The web font you are 
using, Droid Sans Bold, was specifi cally designed to render well on small and large screens 
alike. Many designers still feel the majority of web fonts work best as headings rather than 
as large blocks of body text in paragraphs. This is a matter of interpretation and will likely 
change as more fonts are released for web use. 

In this exercise, you will style your main heading with your new web font option. 

1 Make sure you have clicked inside the Heading 1 labeled, “Welcome to organic 
utopia.” In the tag selector, make sure you click the <h1> tag.

This highlights your Heading 1 and makes it easier for Dreamweaver to understand 
that you want to target this style.

Click the <h1> tag in the Tag Selector to select the top heading.
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2 Click the CSS button in the Property Inspector if you are not currently in this view. 
Now click the Font menu; toward the bottom of this list, you will see Droid Sans 
Bold. Select this choice to apply it, and the New CSS Rule window will appear 
because there has not been a style defi ned for a <h1> element yet.

3 Click the Selector Type menu and choose Tag. Dreamweaver will recognize you 
have selected an h1 element, so this is the style that will be created. In other words, 
all Heading 1 elements will have the Droid Sans Bold font style. If Dreamweaver is 
attempting to create a Compound selector, press the Less Specifi c button until only h1 
remains in the Selector Name fi eld.

Although you have applied the web font style, it may not be refl ected in the Design view.

4 Click OK. You have just applied the font style to your heading, but you might not see 
this change in your Design view. This is a limitation for some web fonts; you will only 
see an accurate view in the browser or in Dreamweaver’s Live View.

5 Click Dreamweaver’s Live View; you will see your heading set in Droid Sans Bold. You 
may not notice the diff erence immediately because Droid Sans and Lucida Sans are fairly 
similar; however, if you compare the letter “g” in the word organic to the letter “g” in 
the heading further down the page (One stop shopping), you will see the diff erence.

You can still use certain CSS formatting to make the web font-styled heading more 
distinctive. You’ll now add a style to make the heading uppercase.
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7 In the CSS Styles panel, choose All and locate the stylesheet.css link. Notice that 
@font-face is listed. You will likely never modify this style—it is simply worth 
pointing out that is has been created. Double-click this h1 rule to open the CSS rule 
defi nition window.

8 Click the Text-transform menu and choose uppercase. Click OK to apply it, and now 
your Live View updates to show your new heading.

Your web font-styled heading now has an uppercase style.

9 Exit Live View by pressing the Live button. Choose File > Save All, and then preview 
your page in the browser. If your browser supports web fonts, you should see your style.

Congratulations! You have fi nished this lesson.

Where can I get more fonts?

As noted earlier, you should only use web fonts that have been licensed for that purpose. 
Many individual font foundries, such as Adobe and Monotype, have their own policies and 
systems for using web fonts. However, there are a growing number of online resources that 
provide designers and developers with web fonts that are properly licensed, and in many 
cases, are free or open-source. You should explore these options, but be aware that you may 
not find your favorite fonts listed here.

Fontsquirrel

This site offers a number of free fonts that are licensed for commercial work. The site is also a 
good resource for creating your own web fonts using the @font-face.

www.fontsquirrel.com

Google Web Fonts

Google Web Fonts provides a large number of free open-source fonts for use in your projects. 
It also provides a convenient way to sort and filter through the numerous options.

www.google.com/webfonts
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Self study
Using your new knowledge of creating CSS3 Transitions and web fonts in Dreamweaver, 
try some of the following tasks to build your experience.

To practice CSS transitions, build a web button labeled “Subscribe Now!” and give it 
transition eff ects such as background color and border eff ects. You can make a copy of the 
07_transitions.html document and base your button upon the original #box style. You will 
have to set the starting width and height to a number more appropriate for a button, such 
as 25 pixels high and 100 pixels wide.

The transition eff ects that you created for the 07_nav_transition.html exercise were 
designed for educational purposes to show you how the eff ects work; however, they 
might be too slow for real-world use. Try experimenting with the Duration and Delay 
va lues; specifi cally, try lowering the values. Also try experimenting with diff erent Timing 
Functions, such as Ease, Linear, Ease-in, and Ease-out.

To practice working with web fonts, add the other set of fonts we provided in the lesson 
folder for the Droid-Sans font. Try applying this font to your paragraph styles and headings 
to see the eff ect.

Review 
Questions
1 How would you add a CSS Transition to a document in Dreamweaver CS6? 

2 Where can you fi nd the available list of properties that can be animated using CSS 
properties?

3 Name at least one benefi t and one drawback of web fonts in Dreamweaver CS6.

Answers
1 CSS Transitions can be added by going to the menu bar and choosing Window > CSS 

Transitions.

2 You can fi nd the list of CSS properties that can be animated by clicking the + sign 
located below the Property section in the CSS Transitions window. 

3 Some benefi ts of web fonts in Dreamweaver include the variety of choices available for 
use in your designs, the ease of adding multiple fonts using the Web Manager, and the 
fact that web fonts will work in virtually all browsers. Drawbacks to web fonts include 
the need to use fonts with a specifi c web license (which means your favorite font may 
not be available for web use), the fact that Dreamweaver does not display them reliably 
in the Design view, and the fact that even if a font is licensed for web use, it may not 
be optimized for the computer screen.
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What you’ll learn in 
this lesson:
• Creating and modifying 

tables

• Styling tables in CSS vs. 
HTML

• Importing Table Data

• Sorting Table Data

Lesson 8

Tables have a long and storied history in web design. In this lesson, 
you will learn how to structure and style tabular data using tables. 
Additionally you will understand the basics of using tables for layout 
and be able to compare and contrast them with Cascading Style 
Sheets (CSS) for layout.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw08lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw08lessons folder from 
the included DVD that contains resources you need for these lessons. Go to Site > New 
Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

Working with Tables
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See Lesson 8 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Using tables in web design
Tables are ideally suited for displaying tabular data. As discussed in Lesson 5, “Creating 
Page Layouts with CSS,” in the beginning days of the Web, tables were the best tools 
available for designers when it came to layout. Over the years, Dreamweaver has 
steadily introduced a number of tools and visual aids to help people work with tables. 
Dreamweaver has mirrored the Web in that it has begun to shift its focus to CSS layout 
rather than table layout. Slowly, the table is reclaiming its original purpose: displaying 
tabular data.

In this lesson, you will learn how to automatically import and format existing data into a 
table. You will also explore how to modify rows and columns, style tables with CSS, and 
create new tables from scratch. 

Importing table data
You’ll get a chance right away to see tabular data in action by importing a .csv fi le into 
Dreamweaver. A majority of tabular data is exported from spreadsheet programs in the 
.csv (comma-separated values) and .txt (text) fi le formats. These are called comma, tab, or 
other delimited fi les. Essentially this means that a spreadsheet application converts the data 
within its rows and columns to an intermediate format that Dreamweaver can read.

Although Dreamweaver can open these fi les, it does not format them directly. With a 
comma-delimited fi le, for example, each column value is separated by a comma and each 
line break starts a new row. For example, here is how Dreamweaver displays the raw .csv 
fi le that you are going to be working with:

The text editor’s view of a comma-delimited fi le.

When imported into Dreamweaver, this fi le will be translated accordingly into the rows 
and columns of a new table.

8
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1 In the Files panel, double-click the tips.html fi le to open it. This is a styled page for 
the tips section of the OrganicUtopia site. You will be inserting a .csv fi le with data on 
the vegetable-growing zones of North America.

2 Click after the last sentence in the main paragraph and press Enter (Windows) or 
Return (Mac OS) to make sure your cursor is below the text. Choose File > Import > 
Tabular Data. The Import Tabular Data dialog box opens.

3 In the Import Tabular Data dialog box, press the Browse button and locate the 
temperate_zones.csv fi le in your dw08lessons folder. Press Open.

4 Click on the Delimiter menu to see the various options that are available. In your case, 
you will be choosing Comma. In the Table width section, leave the Fit to data option 
selected. 

The settings in the Import Tabular Data dialog box aff ect the way a table is created.

You can either set a specifi c width for the generated table or let Dreamweaver construct the table 
automatically, based on the line-length of the incoming data.
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5 Press OK and your table is imported into your document below the text. Your table is 
imported with 3 columns and 12 rows. A quick way to confi rm this is to look in the 
Property Inspector, where there is a fi eld for columns and rows as well as other useful 
ways to work with tables.

A three-column and 12-row table generated by Dreamweaver from a comma-delimited fi le.

6 Press Dreamweaver’s Code view button to see the code that makes up this table. It’s 
safe to say that this is something you would not want to code by hand.

The table is now ready to be formatted according to your specifi cations. As you can 
see, you can save yourself a lot of time if your source data is properly formatted. 
Dreamweaver creates a table for you with all the data properly placed, eliminating the 
need for you to build a table, and type, or copy and paste, content into each cell.
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Selecting table elements
It’s worth taking a few moments to learn how to select the various elements of your table. 
Selecting a specifi c part of a table can be little tricky until you learn how. In this exercise, 
you’ll look at ways to select a table’s rows and columns both by hand and using controls 
in the Property Inspector. The components of a table include rows, columns, and cells, 
and other elements such as table headers and footers. The table you created needs some 
modifi cation. It’s rare that a table is created exactly right, and making small tweaks to the 
column widths and the row heights is the norm.

1 Press the Design view button in the Document toolbar and click anywhere on the 
background of the page. In this case you do not want the table to be selected. Without 
clicking, place your cursor over the edges of the table; you see the diff erent sections 
of the table light up with a red border. Also notice that your cursor switches to a black 
arrow. The red border is Dreamweaver’s visual cue for which part of the table you will 
be selecting, and the black arrow points in the direction of the row or column to be 
selected.

2 Place your cursor high in the upper-left corner until the entire table is outlined in red. 
Click once, and the table is selected.

A red border designates which section of the table you are selecting—in this case, the entire table.
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3 Place your cursor to the left of the word Zone until you see the top row outlined; 
click once to select the row.

4 Move your cursor to the top of the word Zone until you see the numbered column 
outlined in red; click once to select the column. 

Selecting a single cell is a little trickier, as the red outlines only appear when your 
cursor is on the edge of a table, not inside of one.

5 Click inside the cell with the word Zone. In order to select the cell, use the tag 
selector at the bottom left of your document window. These tags are an alternative 
way to select parts of the table.

6 Click on the <table> tag fi rst; this selects the table just as you did in step 2. Click 
on the <tr> tag next; this selects the table row. The <tr> tag appropriately stands for 
table row. Lastly, click on the <td> tag, and the cell itself is selected; <td> is defi ned 
as a table cell in HTML. Note that in each of these cases the selected element is 
outlined in black.

Clicking on the appropriate table tag in the tag selector selects that part of the table.

Some people prefer this method of selecting elements of their tables because it removes 
the chance that clicking on the table will move or modify it.

7 Click inside any cell in the table again, and choose Modify > Table > Select Table. 
This is yet another way to select tables. The Modify > Table command is one 
you’ll be returning to. You can also select the table by right-clicking (Windows) 
or Ctrl+clicking (Mac OS) the table and choosing Table > Select Table from the 
contextual menu.
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Modifying table size
Although importing tabular data from a text fi le is quick and easy, the data is seldom 
formatted perfectly. When you fi rst imported the data, there was a choice to Fit Table 
Width To Data. The width of the table, when you choose this option, isn’t always 
predictable due to the way Dreamweaver does its calculations. Although it is possible 
to set the width of the table during the import stage, this isn’t always convenient if you 
don’t know what the data looks like. Luckily, it’s easy to change the size of tables in 
Dreamweaver. The fi rst thing you’ll do is set a fi xed width for the table.

1 If your table is not currently selected, select it now using any of the methods you 
learned in the last exercise. In the Property Inspector, type 550 in the W text fi eld 
and make sure the drop-down menu to the right is set to pixels, then press Enter 
(Windows) or Return (Mac OS). This expands the table to a width of 550 pixels. 

Look closely at the top of your table; there is a visual guide outlined in green that 
displays the width of your table as well as the width of each column. This guide will 
come in handy when you are trying to create precisely measured tables, although it 
can also be turned off .

You can turn off  this guide by choosing View > Visual Aids > Table Widths.

2 Choose File > Save, then File > Preview in Browser and open this page in your 
browser. Resize the browser window a few times. Because the table has a fi xed width 
of 550 pixels, its width stays constant. Close the browser and return to Dreamweaver.

3 In the Property Inspector, your table should still be selected. In the W (Width) text 
fi eld, type 75 and choose % from the drop-down menu to the right; notice a change 
in your table width in the Design view.

You can set the table width to a percentage of the browser window by using the Property Inspector.
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Choose File > Save, then preview the page in your browser again and resize the 
browser window. The table width now resizes because you set it to be a percentage 
rather than a fi xed width. Close the browser and return to Dreamweaver.

4 Reset your table to the original width by typing 550 in the W text fi eld and choosing 
pixels from the drop-down menu. 

You also have the ability to resize the columns and rows in the Design view. You can 
do this manually using the Property Inspector

5 Place your cursor inside the table and then over the dividing line between the fi rst 
column and the second column. Your cursor changes to a double-arrow. Click and 
drag slowly to the right to expand the width of the fi rst column notice at the top 
of the two columns that there are blue numbers that update with the width of the 
columns. This has the eff ect of reducing the second column’s width, although it leaves 
the third column’s width alone. 

6 Expand the fi rst column to at least 50 pixels; the content in the second column breaks 
to the next line. Place your cursor on the dividing line between the second and third 
column, and click and drag slowly to narrow the width of the third column (thereby 
expanding the width of the second column). This example uses values of 390 pixels for 
the third column and 88 pixels for the second. 

If you are mathematically inclined, you may have noticed that the three column values don’t 
add up to 550. This is because there are additional factors of cell padding, cell spacing, and 
borders to consider.

Oftentimes, approximate column widths are not suffi  cient; Dreamweaver allows you 
to apply exact column widths in the Property Inspector.

7 Place your cursor above the fi rst column until the red outline appears, and click once 
to select the column. The bottom half of the Property Inspector expands, allowing 
you to adjust the properties of only this column. Type 45 into the W text fi eld. The 
width does not appear to change dramatically, but it is now 45 pixels.

Selecting a column and entering a specifi c width in the Property Inspector sets the column to that width.
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8 Click above the second column to select it. Type 100 into the W text fi eld. Click 
above the third column and type 400 in the W text fi eld. (This will have little eff ect 
on the appearance of the table.) 

You also have the ability to create a fi xed height for rows.

9 Click on the left edge of the top row to select the whole row. In the Property 
Inspector, type 35 in the H text fi eld, and press Enter (Windows) or Return (Mac OS) 
to apply the change.

Modifying table structure
In addition to modifying the width of columns and rows, the structure of a table often 
needs to be modifi ed (for example, adding and deleting rows and columns, as well as 
merging cells in the column). First, you’ll add a new row to the top of your table and 
then convert it to a header row. There are a few ways to add rows and columns in 
Dreamweaver, you’ll begin with the Modify > Table command.

1 Click inside any of the cells within the fi rst row. Dreamweaver needs to have some 
frame of reference when adding a row.

2 Choose Modify > Table > Insert Rows or Columns. The Insert Rows or Columns 
dialog box opens.

3 The Insert Rows radio button should be selected. For Number of rows, leave the 
default value of 1. In the Where section, select Above the Selection. Press OK to add the 
new row to the top of the table.

Use the Insert Rows and Columns dialog box to add 
new rows or columns to an existing table.

4 Place your cursor on the left side of the new row until the red outline appears. Click 
once to select it. In the Property Inspector, locate the Header checkbox and check it to 
designate this row as a Header row. Behind the scenes, Dreamweaver uses the HTML 
<th> tag to defi ne this as a table header. This will help you style your table later on.

Now you’ll merge the three cells in this top row in order to add the header text that 
will span across your columns.

5 With the top row still selected, right-click (Windows) or Ctrl+click (Mac OS) to open 
a contextual menu. Choose Table > Merge Cells, and the three cells merge into one. 
This is referred to as columnspan.
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6 Click inside this merged cell and type US temperate zones with average min. 
temperatures.

Merging cells creates a columnspan, allowing you to add header text.

7 Choose File > Save to save your work.
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Creating a table
In addition to creating a table from tabular data, you can also create a table from the 
ground up using Dreamweaver’s Insert Table command.

1 Click to the right of your existing table, and then press Enter (Windows) or Return 
(Mac OS) two times. You will be placing a second table two lines below the fi rst.

2 Choose Insert > Table, and the Table dialog box opens. Type 12 in the Rows text 
fi eld, and 2 in the Columns text fi eld. Type 550 in the Table width text fi eld to match 
the width of your fi rst table and make sure the drop-down menu is set to pixels. Set 
the Border thickness value to 1 if it is not already. 

The Cell padding and Cell spacing values should have no value; you’ll return to these 
properties shortly.

The Insert > Table command creates a new table.
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3 In the Header section, select the third option, Top, in order to designate the top row 
as the header. 

4 In the Caption fi eld, type Best months to plant vegetables (Zones 4–7). Table 
captions are a bit more specifi c than table headers. A table caption is a short description 
of the table contents and has its own <caption> element; by default, they are 
displayed centered and at the top of the table. 

Table captions are not required, but they are useful, especially from an accessibility 
perspective, as they supply useful information to screen readers and other devices. 
Press OK to insert the table.

5 Below the caption, in the fi rst cell of the fi rst column, type Month. In the fi rst cell of 
the second column, type Vegetables to Plant. Your columns may shift; in order to 
adjust them, click on the divider between the two columns, and click and drag it as 
necessary to visually divide the two columns evenly.

6 In the second row of the Month column, type April, then fi ve rows below, type May.

7 Below the Vegetables to Plant column, type Broccoli. Press the down arrow on your 
keyboard to move to the next row. Using this technique, fi rst type Cabbage and 
then type each vegetable name in its own row—fi rst Carrots and then Spinach. Skip 
one row and, making sure you are beginning in the same row as May, type Corn, 
Tomatoes, Peppers, Cucumbers.

Press keyboard arrows to quickly move from one cell to another when typing text.

8 To delete the two extra rows at the bottom of the table, click in the fi rst cell of row 
11, and then drag down and to the right. The four cells are selected. Press Delete to 
remove the rows.

9 Choose File > Save, and keep this fi le open for the next exercise.
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Formatting and styling tables in HTML
There are two diff erent paths to take when it comes to styling a table. The fi rst method 
is to use HTML tag properties to modify attributes such as the cell padding, border, and 
background color in a table. However, these same attributes can also be controlled with 
the second method, CSS. It’s fair to say that there are more options for styling a table with 
CSS; however, styling a table with HTML tags is faster for most people. Which method 
you choose often depends on the project specifi cations. You’ll be learning both methods 
here so that you have the option to choose. You’ll also get a chance to consider the pros 
and cons of both methods. First, you’ll start off  with the traditional method of styling tables 
with HTML tags and properties. 

1 In the second table you created (Best months to plant vegetables), click on the edge of 
the header row to select it. In the Property Inspector, click on the HTML category, 
if necessary, and then click the Bg (Background) color swatch. In the left column of 
swatches, choose the light gray (#CCCCCC). The background color of the header 
row changes to gray.

Select a row and click the Bg color swatch to apply a background color.

2 Click inside the April cell, then drag down and to the right until you reach the cell 
containing the text Spinach; this selects all the cells in these four rows and two columns.

3 Click in the Bg swatch text fi eld and type #FFFCCC, a light yellow swatch in the 
lower-right corner. All four rows now have the same background color.

4 Click on the left edge of the empty row above the row labeled May. Click the Bg color 
swatch and choose white for this background color. Then click in the May cell and drag 
down and to the right to the last cell containing the text Cucumbers. Click the Bg color 
swatch and choose the light pink color swatch, #FFCCFF, in the bottom-right corner.

Now, you will center the text in your columns.
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5 Click at the top of the fi rst column to select it. In the Property Inspector, from Horz 
(Horizontal) drop-down menu, select Center. Select the second column and repeat 
this step to center this text.

Select a column and click the Center option in the Horizontal menu of the Property Inspector.

6 Choose File > Save, then File > Preview in Browser. Your text is visually categorized 
by background color now, but it would be a stretch to say that this is a visually 
pleasing table. There are a few other properties that you can adjust to make this table 
look a bit better. Close the browser and return to Dreamweaver. 

You’ll now examine the properties of cell padding.

7 Click in one of the corners of the table until the entire table is outlined in red. Then 
click on the table to select it. In the Property Inspector, locate the text fi eld for 
CellPad and type 10. Press Enter (Windows) or Return (Mac OS) to apply the change. 
There are now 10 pixels of space added to the inside of all cells. This has the eff ect of 
giving your text a bit more breathing room from the borders around it. 

Cellpadding is a property that determines the amount of space, measured in pixels, 
between the sides of a cell and its contents.

DWCS6_06Pass.indb   222DWCS6_06Pass.indb   222 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


8

223Lesson 8, Working with Tables

Formatting and styling tables in HTML

8 With your table still selected, locate the text fi eld for CellSpace in the Property 
Inspector. Type 10 in the CellSpace text fi eld, then press Enter (Windows) or Return 
(Mac OS) to commit the change. The table changes appearance again. This time, the 
width between the cells is increased.

Cellspacing is the property that determines the amount of space between your cells.

A table with cellpadding of 10 pixels and cellspacing of 10 pixels.

The space between the cells (the cellspacing) is taking on the properties of the 
background color. Unfortunately, you cannot control the color of the cellspacing, and 
so you will actually remove it completely.

9 In the Property Inspector, type 0 in the CellSpace text fi eld and press Enter 
(Windows) or Return (Mac OS). This removes cellspacing completely. At this point, 
you only have properties for cellpadding. 
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10 With the table still selected, locate the text fi eld for Border; it is currently set for 1 pixel, 
which is the default setting used when a table is created. Replace this value with 0 and 
press Enter (Windows) or Return (Mac OS). This removes the border completely. 

This trick of removing borders completely is used quite a bit with pure HTML tables. 
This is because there are no good ways to control the appearance of borders using pure 
HTML. Increasing the border size creates a thick, beveled look that can detract from 
the rest of your page. Better control for borders exists in CSS.

11 Place your cursor on the small black square on the lower-right of the table until you 
see the double-arrow. Click and drag the table to the left to reduce its width. You can 
use the value at the top of the table if you choose, or just change the width until you’re 
satisfi ed. This example uses a new width of 350 pixels. 

Click and drag the edge of a table to reduce the width.
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12 With the table still selected, press the Split view button in order to see the code 
generated for this table. In the fi rst line of the table, you see the settings for the width, 
height, border, and cell padding. In all the <td> or cells, you see the properties for 
alignment and background color repeated for every row. This extra code is part of 
the tradeoff  for the easy application of the color and alignment. Part of the dilemma 
with this table now is that the alignment and background color settings, as well as the 
cellspacing, cellpadding, and border settings, are not linked to your CSS in any way.

The visual styling of the table elements is combined with the structure.

One problem of creating pure HTML tables is the inability to quickly copy the style 
of one table and apply it to another. Because the content of the table and the style are 
intertwined, it’s hard to separate one from the other. The larger problem is that pure 
HTML tables have none of the benefi ts associated with CSS. If your tables are not linked 
to any CSS, what happens when you redesign your website? As you saw in the last lesson, 
a simple change in CSS code can change the background color of your entire site. If the 
design of your tables clashes with your page, you have a lot of work to do as you locate 
each table and tweak it to fi t.
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Formatting and styling tables with CSS
In this exercise, you’ll style your initial table using many of the same concepts covered in 
the previous exercise, such as padding and borders, but this time you’ll do it with CSS. 
There is a little bit more work involved initially, but the result will be a table that not only 
is more visually appealing than an HTML-based table but also has a reusable style that can 
be applied to new tables. It’s possible to create tag-based styles for all your tables—in other 
words, to create CSS rules for the various HTML table elements (<td>, <tr>, and so on). 
In fact, this is not a bad idea when creating a default style for tables in a website. In this 
example, however, you will be creating a class style that can readily be applied to diff erent 
tables. It’s not unusual to have three or four diff erent styles of tables in a large website, each 
with their own CSS class defi nitions.

First you’ll start by creating general rules for the background color, border, and font 
appearance of the table; then you’ll create more specifi c rules as you drill down into the table.

1 Press the Design View button to return to this view. Select the fi rst table you created 
(US Temperate Zones…) by clicking on one of the corners when you see the red 
outline. If necessary, choose Window > CSS Styles to open the CSS Styles panel. In 
the CSS Styles panel, click on New CSS Rule button at the bottom of the panel; the 
New CSS Rule dialog box appears.

2 In the Selector Type drop-down menu of the New CSS Rule dialog box, leave the 
default choice of Class selected. In the Selector Name text fi eld, type styledtable. 
Remember that class names are up to you, and choosing a name that is easy to identify 
and remember is the goal.

3 From the CSS Rule defi nition drop-down menu, select the mystyles.css external style 
sheet. This is an important step because you would like to add these styles to your 
external style sheet rather than writing them to the tips.html page only. 

Creating a new class for the style of the table and defi ning it in the external style sheet.
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4 Press OK, and the CSS Rule defi nition dialog box opens. Select the Background 
category and click the Background-color swatch. Choose the color white (#FFF) and 
press OK. 

You see no changes onscreen because you need to apply the .styledtable class to 
the table. You’ll do that now, and then return to adding more styles.

5 Your table should still be selected; if it isn’t, then select it now. In the Property 
Inspector, the table properties should be active. (If you are seeing the HTML and 
CSS properties, you have not selected the table.) On the right side of the Property 
Inspector, choose styledtable from the Class drop-down menu to apply the class. The 
background of your table changes to white.

Apply a class to a table by choosing the class name in the Property Inspector.

6 Now you’ll return to the styledtable class style and add additional properties. You 
could have created all your rules fi rst and then applied the styledtable class; however, 
doing it this way allows you to preview your styling in real-time. Now you’ll add 
some borders and change the font-styling for the entire table.

7 Double-click on .styledtable in the CSS Styles panel to reopen the CSS Rule 
defi nition dialog box. From the Font-family drop-down menu, choose the Verdana, 
Geneva, sans-serif. In the Font-size text fi eld, type 10, and leave the drop down menu 
to the right set to px. In the Color text fi eld, type #006 (a dark blue), and press Apply 
to see your changes to the table. Now you’ll add a thin border around the entire table.
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8 Select the Border category, and choose Solid from the Top drop-down menu under 
“Style.” In the Width text fi eld, type 1. In the Color text fi eld, type #006, which is 
the same dark blue you used for the font-color. Press OK. 

Your styled table with background-color, font styling and a border.

The last property you’ll add to the .styledtable class is one that is not available 
in the standard CSS Rule defi nition dialog box. It’s important to realize that the 
language of CSS is quite large to begin with, and will continue to expand in the 
future. There are CSS properties that may not be used every day but nonetheless can 
be very useful. You’ll semi-automatically add one such property now called border-
collapse. This property removes the space between table cells.

9 In the bottom half of the CSS Styles panel in the section labeled Properties for “.styledtable,” 
click on the blue underlined text, Add Property. (You may need to expand this panel in 
order to see it at the bottom of the list.) In the resulting text fi eld, type border-collapse, 
then press Enter (Windows) or Return (Mac OS) to commit the change.

Click Add Property and type border-collapse to add a new CSS property.

When it is typed correctly, Dreamweaver recognizes this property as part of the CSS 
language and makes the values available in the next fi eld. (You can also click the Add 
Property menu to see the entire list of available properties.)
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10 Click in the column to the right of the border-collapse property to activate the fi eld. 
From the drop-down menu, choose collapse. You will not see an obvious change on 
screen; this property and value will help older browsers render the table correctly.

11 Choose File > Save All. Preview your page in your browser to see your styling. Close 
the browser and return to Dreamweaver.

Advanced CSS styling of tables
You have created a basic style for this table. You will now sharpen up the appearance of 
this table by adding a background image to the header, setting the text alignment and 
padding, and fi nally, creating subtle borders between each of the data cells.

1 Click anywhere inside the header, and in the lower-left corner of your document 
window, click on the <th> tag to select the header. You defi ned this top row as a table 
header earlier in the lesson. 

2 In the CSS Styles panel, press the New CSS Rule button ( ) to open the New CSS 
Rule dialog box. In the Selector Type drop-down menu, the Compound option is 
listed. This is what you want because you are creating a specifi c rule for <th> tags, but 
only those found inside the styledtable class.

Create a compound rule to style all header rows within the styledtable class.
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3 The Selector Name text fi eld has been automatically populated as .styledtable 
tr th. Remember that compound rules are read from left to right. So, within the 
styledtable class, you are targeting table rows (tr) and specifi cally, table headers (th) 
within table rows.

4 Press OK and the CSS Rule defi nition dialog box opens. Select the Background 
category to access these options.

5 Press the Browse button to the right of the Background-image text fi eld, and in 
the Select Image Source dialog box, locate the bg_header.jpg image and press OK 
(Windows) or Open (Mac OS).

6 From the Background-repeat drop-down menu, choose repeat-x from the list. The 
source image is a gradient that is designed to tile horizontally. Press Apply to see a 
preview of this eff ect on your table. You’ll add a few other touches to this header row.

Choose a background image and tile it horizontally in the header row with repeat-x.

7 Select the Border category and uncheck the Style Same for All checkbox. Choose 
Solid from the Bottom style drop-down menu.
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8 Uncheck the Width Same for All checkbox, and then type 2 in the Width text fi eld 
of the Bottom style. Uncheck the Color Same for All checkbox and type #006 in the 
Color text fi eld of the Bottom style; this is the same dark blue color that you’ve been 
using for other styling in this table.

Applying a two-pixel-wide, solid, blue border to the bottom of the header row.

9 Select the Type category, and type 14 into the Font-size text fi eld to make the text 
slightly larger. From the Text-transform drop-down menu, choose capitalize. This 
property adds a capital letter to the beginning of each word.

10 Press OK to see your styled header.

Your header row is now styled.

Choose File > Save All. Keep this fi le open as you will continue working on it in the 
next exercise.
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Controlling cell alignment, padding, and borders with CSS
You’ll now make the content within your table a bit more readable by aligning your text 
and padding your cells, as well as creating borders around each cell. Controlling borders 
and padding is much more fl exible in CSS than in HTML; for example, the cellpadding 
values in HTML are uniform—there is no control over left, right, top, and bottom, as 
there is in CSS. The same applies to borders. However, before you begin styling padding 
with CSS, it’s a good idea to remove these values from the HTML so that there are no 
surprises.

1 Click any corner of the table in order to select it. In the Property Inspector, notice the 
values for CellPad and CellSpace; they are empty, but this stands for default, not zero. 
You must specifi cally instruct Dreamweaver to use a value of zero.

2 For all three properties of CellPad, CellSpace, and Border, type 0. Press Enter 
(Windows) or Return (Mac OS) when you have added the last value.

Type 0 for CellPad, CellSpace, and Border to make sure they are removed.

3 Click inside any cell of your table, and in the bottom-left corner of your document 
window, click on the <td> tag to select a cell. You could also Ctrl+click (Windows) 
or Command+click (Mac OS) a cell to select it.

4 Press the New CSS Rule button ( ) at the bottom of the CSS Styles panel, and 
the New CSS Rule dialog box appears. As in the last exercise, you are creating a 
Compound rule that applies only to cells within the .styledtable class. Your 
selector name reads .styledtable tr td. Click OK. The CSS Rule defi nition 
dialog box appears.
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5 Select the Block category, then from the Text-align drop-down menu, choose center. 
Press Apply to see this center.

Applying a text-align of center to the <td> element centers all text in your cells.

6 Select the Box category, and in the Padding section, type 5 in the Top text fi eld. 
Uncheck the Same for All checkbox. In the fi eld for Left, type 2 and press Apply to 
see your text shift slightly. One of the main diff erences between HTML cellpadding 
and CSS cellpadding is the ability in CSS to control all four sides of a cell’s padding 
individually.

7 Select the Border category, and in the Style section, choose Dashed from the Top 
drop-down menu.

8 Type 1 in the Width text fi eld, and in the Color text fi eld, type #9AA8BD, the 
hexadecimal number for a light blue-gray. Press OK to apply the style.

9 Select the row below the header row, and, if necessary, click on the HTML button 
in the Property Inspector, then press the Bold button to bold the text for Zone, 
Fahrenheit, and Example Cities. 
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10 Choose File > Save All. Then preview your page in your browser to see your table. 

The table as rendered in a web browser.

You’re nearly fi nished. Now you’ll add some fi nal touches to your table to give it a 
little extra polish and readability. Close your web browser.

Creating alternate row styling with CSS
A common feature found in many tables is to alternate colors for every other row. When 
done correctly, this increases the contrast between the rows and allows the user to visually 
separate the content of the table. This is easily done in CSS by creating a new class solely 
for background color.

1 Click on the edge of the row labeled 1 to select it. In the CSS Style panel, press the 
New CSS Rule button ( ). The New CSS Rule dialog box opens. 

Unlike the last few exercises, you will not be using a compound selection. Instead, 
you will be creating a new class. The reason for this is that you only want to style 
every other row. There is no automatic way to do this in CSS; after you create the 
class, it will have to be applied manually.
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2 Choose Class from the Selector Type drop-down menu. In the Selector Name text 
fi eld, type oddrow and press OK.

Create a new class named oddrow to style individual rows.

3 Select the Background category, and type #EAF1F4, the hexadecimal color for a light 
blue, into the Background-color text fi eld. Press OK. Now you will apply the oddrow 
class to every other row.

4 The row labeled 1 should still be selected; if not, do so now. In the Property Inspector, 
press the HTML button. From the Class drop-down menu, choose oddrow. The 
light-blue background color is applied.
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5 Starting with the row labeled 3, apply the oddrow class to all the odd-numbered rows. 

Styling alternating rows with a background color can improve readability.

6 Choose File > Save All. Preview your page in the browser, then close the browser 
when you are fi nished.

Reusing CSS for other tables
As you have seen, CSS styling for tables is very powerful and capable of spicing up the 
appearance of tables without sacrifi cing their structure. Like CSS for text and layout, the 
real power is obvious when you apply and link the style to another table.

1 Double-click on the fi le veggie_names.html. This page is currently linked to the same 
external style sheet as the tips.html page, and includes an unstyled table. All that needs 
to be done is to apply the styledtable class you created to this table.

2 Click anywhere in the table, and then click the <table> tag in the lower-left corner 
of the document window to select the table. 
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Reusing CSS for other tables

3 In the Property Inspector, choose styledtable from the Class drop-down menu on the 
far right. The style is applied, and the appearance of this table matches the other. The 
style is fl exible enough that, even though the top row has three cells, it has the header 
style applied.

Applying the styledtable class to a previously unstyled table.

That’s it! The hard work of creating the original style pays off  when it comes time 
to creating new tables with identical style. Better yet, if you need to make a global 
change such as changing the background-color or font color, changing a property in 
the external sheet will ripple through to all tables.

4 To add the alternating rows of color, click on the third row. In the Property Inspector, 
press the HTML button, and from the Class drop-down menu, choose oddrow. 
Repeat this step with every other row to add the style. 

The added benefi t of having this class handy is that some tables benefi t from this style 
more than others, and so it is your decision whether or not to use it.

5 Choose File > Save All. Keep this fi le open for the next exercise.
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Data sorting tables
There are a few other features related to managing tables that you may fi nd useful. The 
structure of tables can be both a blessing and a curse. For example, take a look at the 
table from the previous exercise. What if you wanted to swap the order of the fi rst two 
columns? There is no easy way to do this with a static HTML table. Another limitation of 
tables, especially tables created from tabular data where you may not have control over the 
order, is the diffi  culty of sorting the data. Dreamweaver has a feature that allows you to 
sort your data alphabetically by the column of your choice. 

In the fi rst part of the exercise, you will do some copy-and-pasting in order to switch the 
fi rst two columns.

1 Click the edge of the table to select it. Choose Edit > Copy to copy the table.

2 Click to the right of the table, press Enter (Windows) or Return (Mac OS) twice, and 
choose Edit > Paste. You can copy and paste tables in Dreamweaver within a page, or 
from one page to another.

3 In the fi rst table, click at the top of the second column (Common Name) to select the 
entire column. Choose Edit > Copy to copy the contents of the column. Now click 
at the top of the fi rst column (Latin Name) to select it. Choose Edit > Paste to replace 
the content of the fi rst column. You now have duplicate columns momentarily, but 
the next step is to copy content from the second table.

4 In the second table, click on the top of the fi rst column (Latin Name) to select it. 
Choose Edit > Copy to copy this column’s contents. Return to the fi rst table and click 
on the top of the second column; then choose Edit > Paste. 

5 Click on the second table and delete it now, as you no longer need it. 

Now you’ll sort the fi rst column alphabetically using Dreamweaver’s little-known Sort 
Table feature.
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Data sorting tables

6 Select the fi rst table and choose Commands > Sort Table to open the Sort Table dialog 
box. You do not have to make any changes here because the default settings are fi ne, 
but take a quick look at the options. The Sort By menu allows you to choose which 
menu Dreamweaver will use to sort. The Order menu allows you to choose how the 
table should be sorted, either alphabetically or numerically. Alphabetically is correct 
for now.

Choose Commands > Sort Table to sort a table alphabetically.

7 Press OK, and the table is sorted, with the fi rst column now in alphabetical order.

8 Choose File > Save All. 

Congratulations, you have fi nished this lesson.
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Self study
Using your new knowledge of creating tables to display data in Dreamweaver, try some of 
the following tasks to build on your experience:

Use the Import Tabular Data command to import a tab-delimited .txt fi le, setting the 
table’s fi xed width on import. Select the table using the Tag Selector, and change its width 
to 50 percent of the page size using the Property Inspector. Preview the table in a browser, 
noting the way the table changes as the browser window is resized. 

Build another table using the Insert Table command, and add a caption to it. Type text 
into the cells, center the text, and drag the row and column dividers to make them 
consistent in size. Add a background color and a border to the table using the Property 
Inspector, and switch to Code View to note the changes to your HTML code. 

Create and use an internal CSS rule to change the font used, add padding to the cells, 
and alternate the colors of your fi rst table’s rows. Experiment with applying the class rule 
to your second table, and note how its appearance changes. Finally, use the Sort Table 
command to organize both your tables’ data alphabetically.

Review 
Questions
1 What’s the diff erence between a percentage-based table and a fi xed-width table?

2 What is tabular data and how does it relate to tables in Dreamweaver?

3 Name an advantage and a disadvantage of using CSS to style your tables.

Answers
1 A percentage-based table stretches to fi t the size of the browser window. A fi xed-

width table does not resize because it is pixel-based.

2 Tabular data is text often exported from a database or spreadsheet in a delimited 
format. Dreamweaver creates tables from these fi les through the Import Tabular Data 
command found in the File menu. Rows and columns are automatically created in 
Dreamweaver based on the structure of the text fi le.

3 One advantage of using CSS to style tables is the ability to link a single style to 
multiple tables using an external style sheet. A disadvantage might be that the process 
requires more time in the beginning, and a good understanding of HTML table tags 
and CSS selectors.
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What you’ll learn in 
this lesson:
• Customizing panels and 

panel groups

• Resizing the document 
window

• Using guides and grids

• Exploring the tag selector

Lesson 9 

Once you become familiar with building web pages in Dreamweaver 
CS6, you’ll fi nd yourself using some features more often than others. 
In this lesson, you’ll learn how to save time by customizing the 
Dreamweaver environment to streamline your workfl ow.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw9lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw9lessons folder from 
the included DVD that contains resources you need for these lessons. Go to Site > New 
Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

Fine-Tuning Your Workflow
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See Lesson 9 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Customizing panels and panel groups
Panels can be moved, grouped, and docked to help keep everything you regularly use at 
your fi ngertips. In the next part of this lesson, you’ll create a custom workspace for CSS 
layouts. You’ll start by removing certain panels and repositioning the remaining panels. 

1 Make sure your dw09lessons folder has been defi ned as a site as described in the 
Starting Up section. This fi rst exercise does not require any of the lesson fi les, as you 
will be focusing on the workspace.

To ensure you are starting from the same workspace as we are, choose 
Window > Workspace Layout > Designer. Then choose ‘Reset Designer’. 
You will now customize your panels.

2 Locate the Business Catalyst tab, click the panel menu in the top right, and then 
choose Close Tab Group.

3 Right-click or Control+click (Mac) the Adobe Browserlab tab and choose Close 
Tab Group.

4 Click once on the Files tab to expand this panel. (To show a closed panel, click once. 
To hide it, double-click it.)

Click the Files tab to show the Files panel.

There are two panels within the CSS panel group: CSS Styles and AP Elements. The 
AP Elements panel is currently hidden. In order to see both panels simultaneously, 
you’ll drag the AP Elements panel out of the tab group.

9
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Customizing panels and panel groups

5 Click and hold the AP Elements tab. Drag this tab into your workspace to remove it 
from the CSS panel group. This now becomes a fl oating window, which you can keep 
fl oating if you want. Many users prefer to have all their panels within a single column, 
so you’ll add it back in now.

Dragging the AP Elements panel out of the CSS panel group turns it into 
a fl oating window.

6 To keep the AP Elements panel from interfering with your workspace, you can dock 
it with the other panels. Place your cursor over the AP Elements tab at the top of the 
panel, and click and hold. 

7 Drag the AP Elements panel immediately above the title bar of the Files panel group. 
Be careful here: if the entire Files panel is highlighted blue, you will be adding to 
the group. You are looking for a thin blue line above the Files tab; this indicates that 
you are creating a new group. When a solid line appears above the Files panel group, 
release the AP Elements panel to snap it into place. 
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8 If necessary, adjust the width and height of the panels by placing your cursor on the 
edges of any panel group. When the black double-arrow appears, you can click and 
drag to adjust as needed. When you’re fi nished, the panels should look similar to the 
example shown here. This confi guration gives you quick access to the panels you’ll use 
the most when creating the CSS-based layout in this exercise.

The customized panels.

9 Dreamweaver CS6 also has the same Icon view as the other applications in the 
Creative Suite. Click the double-arrows on the top-right corner of the entire column 
of panels; they will collapse to the icon view.

10 Click the Files icon; that group will expand so you can work with it. This group will 
temporarily stay open until you start working on the document or click another icon.

You can decide whether you prefer to work in the expanded panel view or the icon 
view. For now, you’ll return to the panel view.

11 Click the double-arrows to return to the expanded panel view.
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Using the Favorites tab on the Insert bar

12 To save this workspace, choose Window > Workspace Layout > New Workspace. 
When the New Workspace Layout dialog box appears, type CSS Layout into the 
Name text fi eld and press OK.

13 Choose Window > Workspace Layout > Designer to switch to the default workspace; 
then choose Window > Workspace Layout > CSS Layout to switch back to the 
custom workspace you just created.

Using the Favorites tab on the Insert bar
To help organize the many options available in the Insert bar, Dreamweaver groups similar 
items into categories. You may have already found yourself using some items more often 
than others. The Favorites category is a great way to group commonly used items into one 
place for quick access. 

1 Double-click the index.html fi le in the Files panel. In this exercise, you’ll be inserting 
a number of images and AP Divs to create two pages in the Sounds of Nature website. 
These options are currently hidden within the insert panel, so you’ll need to expand it.

2 Expand the Insert panel by clicking the Insert tab at the top of the panel. If necessary, 
adjust the heights of your available panels by dragging the borders between them.

The Insert panel has a large number of options available within numerous categories. 
If you fi nd yourself inserting the same objects over and over, you might want to group 
them. You can do this with the Favorite category of the Insert panel.

3 Click the Favorites category in the Insert panel’s drop-down menu. Right-click 
(Windows) or Ctrl+click (Mac OS) in the empty gray area beneath the Favorite 
category, and choose Customize Favorites from the resulting contextual menu. The 
Customize Favorite Objects dialog box appears.

Right-click (Windows) or Ctrl+click (Mac OS) in the empty gray area beneath the Insert panel’s 
Favorite category and choose Customize Favorites.
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4 On the left side of the Customize Favorite Objects dialog box, the list of available 
objects is organized by the tabs, which indicate where each object can be found in the 
Insert bar. Select Image, then press the Add button (>>) in the middle of the dialog box.

Select Image, and press the Add button.

5 Click the Available Objects menu and choose the Layout category. Locate Draw 
AP Div from the list of available objects; then press the Add button. Press OK. The 
Favorites category now features the Image and Draw AP Div elements.

Resizing the document window
If you’re familiar with any page layout or graphics programs, adjusting the size of the 
window in which you’re working is probably something that you do regularly. However, 
when you’re working on web pages in Dreamweaver, it’s a good idea to think carefully 
about the size of your document. Because a number of diff erent hardware and software 
confi gurations may be used to view your content, it can be tricky to make sure your 
website looks well on every user’s computer. In the next part of this lesson, you’ll resize 
the document window to make sure the Sounds of Nature website is being designed with 
the target audience in mind.

1 Index.html should still be open in your document window. If not, open it now. Also, 
make sure you’re in the Design view. If necessary, press the Design View button in the 
Document toolbar.
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Resizing the document window

2 Look at the very bottom of your document window; there are several controls relating 
to the Window Size on your screen.

A
B
C
D

A. Mobile Size (480 × 800). B. Tablet Size (768 × 1024). C. Desktop Size (1000 × 620). D. Window Size.

Pay particular attention to the numbers 779 × 489 in our figure; this is the Window 
Size. It is quite likely your numbers will be different. This number represents the full 
width Dreamweaver is capable of displaying given the user’s screen size. Because we 
are using a monitor set to 1024 × 768, this is as wide as Dreamweaver can display the 
page on our screen.

3 Click the Window Size numbers to access a menu. The default setting is actually set to 
the “Full Size” option. Dreamweaver calculates these numbers instantly.

You will also that see there are other monitor size options in this menu. From the menu, 
choose the option that reads 1260 × 875. What happens on your screen depends on the 
size of your monitor. On our 1024 × 768 monitor, a scroll bar appears that allows us to 
scroll over to the right of the document. Generally speaking, you can leave this setting to 
Full Size unless you have a specifi c need to preview your page in diff erent size screens.

The second value seen in this step, 1280 × 1024 Maximized, refers to the “true” size of the 
page as if the user were maximizing their browser window to the fullest. The 1260 × 875 
number is a more realistic estimate of the available space a web browser would occupy on the 
screen (accounting for browser features, such as scroll bars).

There are three monitor icons that will allow you to change the window size to three 
diff erent presets.
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4 Click the fi rst icon immediately to the right of the menu labeled 100%. This is the 
Mobile Size (480 × 800) preset.

The Mobile Size preset changes the dimensions of the screen to 480 pixels wide by 800 high.

This will set the window size to 480 pixels wide by 800 high and have the eff ect of 
cropping your current page. The goal here is to show you the window size as if you 
were viewing the site with a mobile device. Although this can be a useful feature, it’s a 
bit deceptive. Dreamweaver is not trying to reproduce the behavior of a web browser 
on a smartphone, it’s simply limiting the width and height of your current window.

A more sophisticated method of designing your pages for mobile devices is covered in 
Lesson 15 “Mobile Design and Layout,” using the Multiscreen feature.

5 Click the next icon to the right, which is the Tablet Size. Note the change in the 
screen. Click the last icon, which is the Desktop view and is set to 1000 pixels by 620. 
All these settings can be useful if you want to see how your designs appear in these 
diff erent size screens. Just remember that there is no substitute for seeing your design 
in a web browser.

6 Click the Window Size menu, and then click the “Full Size” option to set the screen 
back to the maximum amount of space on your monitor.
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Changing the Zoom level

Changing the Zoom level
Changing the Zoom level or magnifi cation of a web page is very diff erent than changing 
the window size as you did in the last exercise. You need to understand the diff erence 
between the two: changing the zoom level in Dreamweaver is very similar to zooming in 
an image program, such as Photoshop or Illustrator. In those applications, there are good 
reasons for changing the zoom level, since they are used for photography and illustration. 
On the Web, there’s not as much of a need to examine objects at a magnifi ed level.

Changing the magnifi cation level in Dreamweaver can be helpful for exact positioning or 
viewing multiple documents at once, but we recommend that you return to 100 percent 
when you’re fi nished. Now, you’ll use the Zoom and Hand tools to navigate throughout 
your document.

1 At the bottom of the document index.html page, select the Zoom tool ( ). Click 
twice inside the document window to zoom to 200 percent.

2 With the Zoom tool still selected, press and hold the Alt (Windows) or Option 
(Mac OS) key and click once inside the document window. The About page zooms 
out to 150 percent. These zoom shortcuts are standard across Adobe’s applications.

3 At the bottom of the document window, select the Hand tool ( ) to the left of the 
Zoom tool. Click and drag the document in any direction within the document 
window. The Hand tool allows you to drag a document around in its window like a 
piece of paper.

Use the Hand tool to drag a document around in its window.
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4 Double-click the Zoom tool at the bottom of the document window to return to 
100 percent. Now, choose 66% from the Set magnifi cation drop-down menu to the 
right of the Zoom tool. Depending on the size of your monitor, this magnifi cation 
level may allow you to see the entire About page. If not, use the Zoom tool or the Set 
magnifi cation drop-down menu to fi nd the appropriate size.

Occasionally, this option will be useful if you have a lot of content on the page and 
you want to see the basic structure of the layout. Don’t forget to set the view back to 
100% when you are done.

5 Click the Selection tool ( ) in the bottom of the document window and choose 100% 
from the Set magnifi cation drop-down menu. 

Using guides
In Lesson 5, “Creating Page Layouts with CSS,” you learned how AP Divs can be added to 
a page for precise layout. Guides can be a useful tool for AP Divs, as well as the other types 
of layout techniques, because they allow you to line up and measure diff erent elements on 
your page. In this exercise, you’ll add an AP Div to index.html, and then place an image 
inside the div. First, you’ll draw some guides to help you size and position the div.

1 If your rulers are hidden, choose View > Rulers > Show to turn them on.

Rulers can use inches, centimeters, or pixels in Dreamweaver. Because pixels are the most 
common unit of measurement on the Web, they are the default. If you prefer inches or 
centimeters, right-click (Windows) or Ctrl+click (Mac OS) on the rulers to access a context menu 
where you can choose your preferred unit. In this lesson, you’ll be using pixels, so it’s a good idea 
to stick with them for now.

2 Click inside the vertical ruler on the left side of your document window, and then 
drag a guide into the center of the page. Notice, as you drag, that a yellow box appears 
with the pixel number of your horizontal ruler. When you let go and move your 
cursor off  the ruler, it will disappear.

Dragging a guide manually is useful, but you can also set a guide’s position precisely.

3 Double-click on this guide to open the Move Guide dialog box. From this dialog box, 
you can set an exact location for guides. This feature can be especially helpful when 
building a web page based on sketches or mockups. 

4 Type 38 in the Location text fi eld and press OK. The guide is repositioned 38 pixels 
from the left side of the document.

5 Create another vertical guide and set its position to 494 pixels, either by dragging it to 
this position or setting its value precisely. 

What if you wanted to determine the exact width between these two guides you just 
added? Instead of using a calculator, you can allow Dreamweaver to do it for you.
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6 Press and hold the Ctrl (Windows) or Command (Mac OS) key and move your 
cursor across the three sections of your page as defi ned by the guides. A blue line with 
arrows on either end indicates the distance between each of your guides, as well as 
the distance between guides and the edge of the document window. Between the two 
guides, you can now see that the width is exactly 456 pixels.

Hold down Ctrl (Windows) or Command (Mac OS) and hover over the 
vertical areas defi ned by guides.

7 Drag two horizontal guides down from the ruler at the top of the document window. 
Double-click on each of them, and then use the Move Guide dialog box to position 
one of them 152 pixels from the top of the document, and the other 380 pixels from 
the top of the document.

8 Next, you’ll draw an AP Div and start adding some content; but fi rst make sure that 
Snap to Guides is turned on, by choosing View > Guides > Edit Guides. The Guides 
dialog box appears, with a number of options for customizing your guides. 

If you happen to be using a color in your web page that makes the guides hard to see, 
you can change their color here. Also, the Lock Guides option can be a helpful way to 
avoid accidentally repositioning guides. For now, make sure Snap to Guides is checked 
and press OK.

The Guides dialog box allows you to change the color 
of guides and turn snapping on and off .
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9 Now that your guides are set up, you’re ready to add some content. With the Favorites 
category selected in the Insert panel, click the Draw AP Div object. Draw an AP Div 
inside the box created by your four guides. 

10 The edges should snap to the guides easily. If they don’t, select the div by clicking an 
edge and dragging it until it snaps to a guide.

11 Click inside the div to place your cursor, and then select the Image object in the 
Favorites category of the Insert panel.

12 In the Select Image Source dialog box, select hp_photo.jpg from the Images folder 
inside the dw09lessons folder, and press OK (Windows) or Open (Mac OS).

13 In the Image Tag Accessibility Attributes dialog box, type Soothing Lakefront into 
the Alternate text fi eld and press OK. The hp_photo.jpg image fi ts nicely inside the 
div you created earlier.

The hp_photo.jpg placed inside of the AP Div.

14 Choose File > Save and leave index.html open.
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Using grids
Much like guides, grids are a great way to help keep your layout precise and uniform. 
In the next part of this lesson, you’ll be adding AP Divs and images to the About page 
of the Sounds of Nature website. Creating a custom grid will help you align and evenly 
distribute these new elements on the page.

1 Double-click on the about.html fi le in your Files panel to open the About page. You 
may notice that this page has a white background and uses a default typeface. Later on, 
you’ll use the tag selector to change this.

2 Choose View > Grid > Grid Settings to open the Grid Settings dialog box. Much like 
the Guides dialog box, the Grid Settings dialog box can be used to specify the grid 
color and turn on snapping. Type #CCCCCC in the Color text fi eld and check Show 
Grid and Snap to Grid to turn the grid on and enable snapping.

3 For this layout, type 38 in the Spacing text fi eld and make sure pixels are selected as 
the unit of measurement. Choosing a spacing of 38 pixels creates a series of squares 
that are 38 pixels high by 38 pixels wide. Press OK.

The Grid Settings dialog box.

4 With the grid established, add the AP Divs that will house your images. Click the 
Draw AP Div object in the Favorites category of the Insert panel. Draw a square div 
that is 3 grid units wide and 3 grid units high. Use the fi gure below for reference.

Draw a square AP Div.
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5 Press the Draw AP Div element in the Favorites category of the Insert panel again, 
and draw a second AP Div one grid unit below the fi rst. Use the fi gure for reference.

Draw a second AP Div one grid unit below the fi rst.

6 Click inside the fi rst div to place the cursor, and then press the Image element in the 
Favorites category of the Insert panel.

7 In the Select Image Source dialog box, select tree.jpg from the images folder inside the 
dw09lessons folder, and press OK (Windows) or Open (Mac OS).

8 In the Image Tag Accessibility Attributes dialog box, type tree into the Alternate text 
fi eld and press OK. The tree image is positioned inside the AP Div on your page.

9 Repeat steps 7 and 8 to add forest.jpg to the second div. Type forest into the Alternate 
text fi eld of the Image Tag Accessibility Attributes dialog box. 

The about.html page after inserting the tree and forest images.

10 Choose File > Save and leave about.html open for the next part of this lesson.
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The tag selector

The tag selector
In HTML, the organization of elements takes the form of a family tree. In the previous 
two exercises, you created AP Divs and then inserted images into them. In HTML terms, 
all these images are children of the AP Divs within which they reside. The tag selector 
is a feature of Dreamweaver that allows you to select HTML elements based on their 
relationship to one another. The tag selector has been used in previous sections of this 
book, but in this exercise you’ll use it to apply a single style that will aff ect the entire 
about.html page.

1 With the About page open, click once on the forest image that you inserted at the 
end of the last exercise. At the bottom-left corner of the document window are a 
number of HTML tags. This is the tag selector. The <img> tag at the end of this line 
is highlighted to indicate that the forest.jpg image is selected. In addition, the Property 
Inspector displays information and options related to this image.

With the forest image selected, the <img> tag in the tag selector is highlighted and the Property Inspector 
displays information and options related to this image.

2 In the tag selector, click on the <div#apDiv2> tag to the left of the <img> tag. 
Notice that the options in the Property Inspector change to refl ect the selected div. In 
this case, you’ve selected the parent of the forest image.

3 To further illustrate this relationship, choose Edit > Select Child from the main menu. 
The <img> tag becomes highlighted in the tag selector, and the Property Inspector 
changes to refl ect the selected element.
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4 Now, select <body> on the far-left side of the tag selector. The Property Inspector 
displays options and information related to the <body> tag. Press the CSS button 
in the Property Inspector if necessary and then, from the Targeted Rule drop-down 
menu, choose body_style.

With the <body> tag selected in the tag selector, choose body_style from the Targeted Rule drop-down menu.

Because many CSS properties are inherited throughout the document, it is possible 
to write generalized rules that will be applied to all the elements on a page. In this 
case, body_style changes the font and text color for the entire document because every 
element is a descendant of the body.

5 Choose File > Save and leave about.html open for the next part of this lesson.

Tiling documents
By default, Dreamweaver organizes open documents with a series of tabs in the upper-left 
corner of the document window. If you’d like to compare documents, or you simply prefer 
to use separate windows for each document, the tiling option provides an alternative for 
viewing open fi les. Next, you’ll use this feature to simultaneously view the index page and 
the about page of the Sounds of Nature website.

1 Both index.html and about.html should still be open. If they are not, open them now.

2 Choose Window > Tile Vertically (Windows) or Window > Tile (Mac OS). This 
will send the two pages into two windows side-by-side. This feature can be useful for 
dragging and dropping objects from one page to another or to work on both pages if 
you have a big enough monitor.

The fastest way to group these two pages back together is diff erent depending which 
platform you are on PC or Mac.

3 On the Mac, click the index.html tab, drag it to the about.html tab, and then release 
it. They will now be grouped as tabs again. On the PC, the best way to group the two 
document windows again is to click on the maximize button in the top right corner 
of one of the documents.

You have fi nished Lesson 9, “Fine-Tuning Your Workfl ow.”
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Review 

Self study
In this lesson, you followed a predetermined workfl ow that was tailored toward producing 
two pages in the Sounds of Nature website. The key to creating a streamlined workfl ow 
is planning ahead. Imagine you were creating a website for a local bakery. Make some 
sketches of what the pages would look like. In Dreamweaver, spend some time setting 
up a workspace that would make building the bakery website easier. Think about which 
elements you might use the most. Then, use the guides and the grid to help create a layout 
that refl ects the sketches you made earlier.

Review 
Questions
1 Is it possible to resize the document window to preview how a web page will appear 

on diff erent users’ monitors?

2 How can you position guides on the page without dragging them?

3 Are tabs the only way to organize open documents?

Answers
1 Yes. The Window Size drop-down menu at the bottom of the document window 

contains a number of preset sizes that correspond to common monitor sizes.

2 To more exactly position guides, simply double-click on any guide to open the Move 
Guide dialog box.

3 No. If you prefer to use tiling, you can choose Window > Tile Vertically or Tile 
Horizontally to place two documents side by side. (On a Mac OS, you can choose 
Window > Tile.)
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What you’ll learn in 
this lesson:
• Insert Flash animations 

into your web pages

• Insert Flash video into your 
web pages

• Insert QuickTime video 
into your web pages

• Insert Windows Media 
Video into your web pages

• Insert audio content into 
your web pages

Lesson 10

To meet the expectations of users with increased bandwidth, 
designers are increasingly turning to animation, sound, and video to 
help make web content more compelling and visually engaging. 

Starting up 
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw10lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create a site defi nition that points to the dw10lessons folder. 
Go to Site > New Site, or, for details on creating a site defi nition, refer to Lesson 2, “Setting 
Up a New Site.”

See Lesson 10 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

10

Adding Flash, Video, 
and Sound Content
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Making web content interesting
Adding video, sound, and animation to a web page is one way to make your pages more 
interesting and engaging. Video, for example, plays a key role in supplying interesting and 
varied web content. The barrier to creating original video has decreased dramatically in 
recent years as has the barrier to distributing these videos online. Videos allow individuals 
and companies to post commercials, speeches, and other content that otherwise would be 
diffi  cult or cost-prohibitive to reach a large audience.

Sound allows you to enhance web pages by supplementing visual content with music or 
sound eff ects. Sound also inspires user interaction (as you’ll see later in this lesson), thereby 
giving the user a more interesting online experience. 

Animation gives web pages a whole new life by adding movement and eff ects to images 
that still pictures just can’t match. Something moving on a web page automatically draws 
a visitor’s eye. Movement is especially eff ective for banner ads, buttons, and whatever else 
you’d like your visitors to pay attention to.

Inserting Flash movies
Adobe’s Flash CS6 Professional application is used primarily to create animation and 
interactive projects. In terms of animation, you can use Flash to create animated web 
banners, buttons, splash pages, slide shows, and more. Inserting Flash animations into your 
web page is a great way to bring life to an otherwise static environment.

Web banners are a signifi cant component of online advertising, and if a web banner 
includes moving elements, that movement automatically draws the user to the banner. In 
this exercise, you will add a fl ash banner to place on a website.

1 In the Files panel, navigate to the dw10lessons folder, and double-click the banner.
html page to open it.

2 If the page opens in Split view, click on the Design view button.

If you have just fi nished Lesson 9, you may still have your grids and rulers turned on. They 
are not necessary for this lesson and you may turn them off  by choosing View > Rulers and 
unchecking Show and choosing View > Grid > and unchecking Show Grid.

DWCS6_06Pass.indb   260DWCS6_06Pass.indb   260 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


10

261Lesson 10, Adding Flash, Video, and Sound Content 

Inserting Flash movies

3 Click in the empty div element at the top of the sidebar on the right. A div element of 
220 by 250 has been created for you.

Click in the empty div element named #sidebar _ ad.

4 Click on the Assets tab of the Files panel, and locate the fourth button down, the Flash 
button, labeled SWF. Click on this button to see the list of .swf fi les in this site.

Press the Flash button in the Assets tab 
of the Files panel.

Flash movies are labeled with the .swf extension. However, other programs, including After 
Eff ects and Dreamweaver, can create .swf fi les as well.
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5 Select the ou_sidebar_ad.swf fi le and drag it to the sidebar_ad div to insert it.

6 Type Organic Utopia sidebar ad in the Title text fi eld when the Object Tag 
Accessibility Attributes dialog box appears, then press OK.

As you can see, inserting a Flash movie into a web page is much like inserting an 
image. The width and height of the .swf are automatically established based on the 
fi le’s physical size, just as they are for images such as .jpeg and .gif fi les. 

The .swf fi le appears with a generic Flash icon on a gray image.

You must have Flash Player, which is available free from Adobe, installed to view an .swf fi le. If 
you don’t have the application installed, visit adobe.com/products/fl ashplayer to download 
and install it. Note that visitors to your website also must have Flash Player installed to view 
your Flash content. A good rule of thumb when including Flash content on a website is to let 
visitors know as soon as they get to your site that they’ll need to have Flash Player. Be sure 
to include the link to the Flash Player web page (the URL provided at the beginning of this 
paragraph) so that visitors can download the Flash Player, if necessary.

7 To see the page in the browser choose File > Save, then File > Preview in Browser. 
If the Copy Dependent Files window appears, press OK. These are fi les that 
Dreamweaver automatically adds to the site. Included here is code to help users who 
may not have the Flash plug-in installed.

Your Flash web banner as seen in the browser.
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Adding video

8 After previewing, close the browser. There are other options in the Properties panel 
available for Flash fi les. If you have the Flash authoring program installed you could 
click on the Edit button, for example, and locate the .FLA authoring fi le connected 
with the .swf fi le. This would allow an easy link if you needed to update or modify 
your sidebar ad.

When designing web pages, be sure to include space in your design for .swf fi les, if you’re going 
to incorporate them into the page. The fi les can vary in size, depending on what you’re using 
them for. To learn more about Flash, visit adobe.com/products/fl ash.

Adding video
Adding video to a web page is relatively easy, assuming the video has already been 
optimized for the Web. A full discussion about the various fi le formats and how to convert 
digital video to a web optimized format is beyond the scope of this book. However, the 
decision to include web video should be based on an evaluation of your audience. The 
large fi le sizes associated with video can aff ect the experience of users who don’t have 
high-speed Internet connections. In this section, you will learn how to integrate video 
into your web pages using three of the most popular formats: Flash Video, QuickTime and 
Windows Media.

Flash Video
Flash Video has been widely used for web video for a number of years, and is still the 
format of choice for a large number of sites. This is changing somewhat due to the rise 
of mobile devices (and specifi cally the lack of support for Flash video on these devices). 
Nevertheless, one of the primary advantages of Flash Video is that playback is enabled for 
any browser with the Flash plug-in. Since more than 95% of all desktop web browsers 
have some version of the plug-in installed, this means your video will fi nd the widest 
possible audience. Again, this is not always true on mobile. Additionally, Flash video can 
be compressed to a reasonable size while maintaining image quality.

Diff erent programs create Flash video, including the Adobe Media Encoder, Premiere 
Pro, and even Photoshop. Creating the video is a separate process, so you’ll want to do 
your homework and learn as much as you can about how it works in order to get the best 
results. There are essentially two fi le formats that are used in Flash video: .fl v and .f4v. The 
.fl v format is the traditional fl ash video format and .f4v is a newer format. In this exercise, 
you’ll add a pre-existing .fl v video fi le into your page and add simple player controls to 
allow users to control the playback of the movie.
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1 Click the Files panel if necessary, then double-click the fl ashvideo.html fi le. In the 
Design view, click below the heading, A look at our vegetables.

2 Choose Insert > Media > FLV. The Insert FLV dialog box will appear. Make sure the 
video type is set to Progressive Download Video and then, to the right of the URL 
fi eld, click Browse. The Select FLV window opens. Browse to your assets folder and 
select the ou_veggies.fl v fi le and then press OK (Windows) or Open (Mac OS).

The Insert Flash Video dialog box.

In this example, Progressive Download Video was chosen instead of Streaming Video because the 
former is the more common method among web developers. Progressive Download Video works 
by downloading the video to the user’s hard-drive; however, the video will start to play as soon as 
it is able. In other words, the user doesn’t have to wait for the entire video to download in order 
to see it. Streaming Video streams video content and plays it on a web page after a short buff er 
period. The buff er period ensures smooth playback. The catch is that to enable Streaming Video, 
your videos must be accessible through a web streaming service such as Adobe Flash Media 
Server. If you want to learn more about the process, click the Help button on the Insert Flash 
Video dialog box.

Next, you’ll want to select a skin. A skin is a control panel that shows up on the 
bottom of the video, and allows the user to control video playback. In other words, 
this is where users can play, rewind, and fast-forward their videos.
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Adding video

3 Click on the Skin drop-down menu to examine your choices. You see a preview of 
the skin just below the menu. In our case, we used Corona Skin 3.

A number of skins are available in the Skin drop-down menu.

If your video is ten seconds or longer, choose a skin that includes a slider control so that users can 
scroll through the video at their convenience.

4 Click on the Detect Size button so that Dreamweaver can establish the physical space 
the video will occupy on the page. The size is based on the size of the actual video.

You can manually type in a size, too, although be sure you are aware of the dangers 
here. Entering a size that’s bigger than the original video will either blur or pixelate 
your video. Additionally, the width and height of a video is called the aspect ratio, and 
if you enter a width and height that do not match the original aspect ratio, then your 
viewers will see distorted video. In general, there’s no reason not to let Dreamweaver 
detect the video size.
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5 Press OK to insert the video.

You can’t see the video in Dreamweaver, so choose File > Save, then File > Preview 
in Browser to preview it in a web browser. This particular skin will allow you to scrub 
through your playback as well as mute and change the volume. Close the browser 
when you are fi nished previewing.

The Flash video and player controls on your page.

QuickTime video and Windows Media
QuickTime and Windows Media are also common video formats used on the Web. In 
many ways they are similar; both off er compressed video with various levels of image and 
sound quality. When adding either fi le format to a page the key thing to keep in mind is 
that viewers must have the necessary plug-in to view the video. Unlike Flash video, this 
is not necessarily a sure thing. QuickTime is traditionally Mac OS-based and Windows 
Media Video is traditionally Windows-based.

You can download QuickTime from Apple.com/quicktime/download. To view Windows Media 
fi les, you need Windows Media Player, which you can download at Microsoft.com/windows/
windowsmedia/download. (At the time of this writing, there was no plug-in support from either 
Apple or Microsoft that allowed Windows Media Video to play on a Mac.)

QuickTime and Windows Media video are inserted into a page the same way as Flash 
Video. The diff erence between the video formats is that users create QuickTime and 
Windows Media video using diff erent software applications, for example Adobe Premiere 
Pro and Apple Final Cut Pro. 
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QuickTime video and Windows Media

The process for inserting either QuickTime or Windows Media Video is the same. In this 
example you may choose either format depending on your platform.

1 In the Files panel, open the insertvideo.html fi le. Click below the heading, A look at 
our vegetables, if necessary.

2 Go to the Assets panel and select the Movies button to show the videos available in 
your site.

3 Right-click (Windows) or Ctrl+click (Mac OS) on the veggies.mov fi le (or the 
veggies.wmv if in Windows), and choose Insert from the contextual menu to insert it 
into the page. You’ll see a plug-in icon (  ) on the page, indicating that a plug-in is 
required to see the fi le.

Inserting QuickTime or Windows Media Video fi les creates a generic plug-in icon.

4 When you insert a plug-in fi le, you need to manually enter the size of the fi le; 
Dreamweaver will not automatically detect it for you. You will also need to add 
20 pixels to the height to make room for built-in player controls. The source video 
here is 320 by 240 so in the Property Inspector, type 320 in the W (width) window 
and 260 in the H (height) window. 

Again, you are using 260 for the height to allow space for the controller. QuickTime 
and Windows Media fi les already have a controller built in with the plug-in. You need 
to allow a little extra space for the video controls when you’re entering a size manually.
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5 To preview the fi le within Dreamweaver, choose File > Preview in Browser. 

If you see a message that Dreamweaver was unable to fi nd the plug-in that handles this 
media type, it does not necessarily mean your system cannot play the video (although 
this is still possible). It only means that Dreamweaver can’t fi nd the correct plug-in. 
If this should happen, try to preview the video in your browser; you may fi nd it 
works there.

The problem of playing video on your system may also have to do with the lack of a codec. Web 
video can get a little tricky because there are fi le formats (such as .mov or .wmv) and there are 
codecs. The codec does the job of actually compressing the frames of your video and there may be 
any number of codecs used for a particular fi le format. Both QuickTime and Windows Media 
Player are generally good at identifying which codec you or your users may be missing and then 
providing links to download and install the necessary codec.

Save your fi le if prompted and your video will now appear on your web page.

A Windows browser playing the WMV fi le.
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Other web video considerations

In addition to size, consider the following when you’re preparing video for the Web:

Length: Unless you’ll be offering video through a streaming video service, keep the video 
length down to keep the file size manageable and the progressive playback smooth.

Audio: Although stereo is nice, using stereo files on the Web is a little iffy, as many home 
users don’t have stereo speakers hooked up to their computers. Stereo creates a larger file size 
and doesn’t add that much to the quality of the sound unless you’re doing some tricks with 
the balance between the speakers, which people without speakers won’t hear anyway. Keep 
your video sound set to mono to help manage the file size a bit more effectively.

Movement, animated graphics, and effects: These things make a video look nice, but 
increasing the file size can interrupt playback. 

Copywritten material: Be careful when choosing material for your video, especially when 
it comes to music. Pirating is a big issue today. Unless you have the rights to the music or you 
have permission from the music publisher and are paying royalties, you can’t use music for 
promotional or commercial purposes when it comes to publishing material on the Web.

Inserting sound 
Sound is another element you can use to enhance your website. Sound has the same 
considerations as video: it can take a while to download and it requires a plug-in, such as 
QuickTime or Windows Media Player, to hear it.

You can incorporate diff erent types of sound fi les into a web page. Select a format that will 
run on any computer, whether the user is on the Windows or Mac OS platform. Three 
formats are common: .aif, .wav, and .mp3.

Files in the .aif or .wav format are similar; the main diff erence is where they originate. 
Windows is generally linked to the .wav format, and Mac OS is associated with the .aif 
format. The Windows and Mac OS platforms can read both formats. In addition, these 
fi les sound similar to one another: both are dynamic and depending on the settings can 
result in high-quality fi les.

You can also play .mp3 format fi les on both the Windows and Mac OS platforms. The 
big advantage to using an .mp3 fi le is that it’s typically smaller in size than an .aif or .wav 
fi le. Depending on the compression settings, the .mp3 format may not reproduce full CD-
quality sound, but it downloads faster and takes up less hard drive space. In this exercise, 
you’ll add an mp3 fi le to your page.

1 In the Files panel, double-click the sound.html fi le. Click in the empty paragraph just 
below the What fruit is being eaten in this clip? paragraph.
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2 Choose Insert > Media > Plugin.

Choose the generic Plugin option to insert sound.

3 In the Select File dialog box, go to the assets folder located in the dw10lessons root 
folder. Choose the crunch.mp3 fi le and click OK (Windows) or Open (Mac OS).

A plug-in icon (  ) appears in the table, indicating that a plug-in is required to hear 
the sound. This plug-in will play in the handler application set for .mp3s in your 
browser. On the Mac, for example this will be the QuickTime player and in Windows 
this will be the Windows Media player. Again, this may be the fi rst time your system 
has encountered an MP3 fi le in the browser, and you may be prompted to download 
an additional plug-in.

Even though there is no visual element to an audio fi le, by setting the width, you can 
allow the handler application to display a controller.

4 Click the edge of the plug-in icon and drag it to the right to extend it to 
approximately 150 pixels wide.

5 Choose File > Save, then preview the page in a browser by pressing the File > 
Preview in browser button. In most browsers, the sound will play automatically.

To give users the ability to control the playback of the sound fi le you will need to 
change a parameter back in Dreamweaver.

6 Close the browser.
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Inserting sound 

7 With the plug-in still selected, press the Parameters button in the Property Inspector. 
This opens the Parameters dialog box, it is located immediately below the Border fi eld.

In the Parameters dialog box, type Autoplay in the Parameter column and False in 
the Value column. Press OK.

The Parameters dialog box.

8 Choose File > Save, then preview the page in a browser again, and note that you need 
to press the Play button in the plug-in application in order to hear the sound.

9 Close your browser. 

Preparing audio for the Web

Audio has the same considerations as any other digital file type. You need to pay attention to 
file size while trying to maintain quality. 

Various programs offer audio-editing and format capabilities. This includes programs such 
as Adobe Soundbooth, Apple Soundtrack Pro, and Audacity (which is available as a free 
download on the Web).

Once you’ve edited a sound to your liking, you need to set up certain technical specifications 
for the final file. This includes the type of file you’ll output (.mp3, .aif, and so on), whether 
the sound is in stereo or mono, and a sample rate. For the Web, a good sample rate is in the 
22kHz–32kHz range; 22kHz is at the low end of acceptable quality, and anything higher 
than 32kHz starts to weigh down the file size. 

Stereo is nice, but unnecessary, unless you’re moving sound from the left speaker to the right 
speaker and vice versa. You can save a significant amount of file space by keeping the sound 
file set to mono.

There are a number of compression choices when it comes to audio. Your best bet is to 
experiment and see what gives you the results you want. Creating audio files is very much 
like creating video for the Web: there are no definite answers, and you need to experiment to 
find the best balance between file size and quality.

To learn more about digital audio go to http://help.adobe.com/en_US/audition/cs/using/ 
and select the Digital Audio Fundamentals link.
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For a look at the future of delivering multimedia and interactive content on the Web see the 
HTML5 Digital Classroom book available in electronic and print formats.

Self study
Try inserting and compressing videos using diff erent codecs and fi le types. You’ll fi nd that 
the results will vary, depending on the fi le type and codec you choose.

Review
Questions
1 When inserting a Flash animation, what type of fi le is inserted into the web page?

2 What plug-in is needed to view an .fl v fi le?

3 What is a skin when referring to a Flash Video fi le?

Answers
1 When a Flash animation is inserted into a page in Dreamweaver, an .swf fi le is used.

2 In order to view an .fl v fi le, a user must have the Flash Player plug-in installed on 
their computer.

3 A set of controls on the bottom of the video that control video playback.
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What you’ll learn in 
this lesson:
• How to use snippets

• Working with library items

• Creating and modifying 
templates

• Creating a repeating region 
in a template

Lesson 11

Dreamweaver site defi nitions allow you to take advantage of 
extensive management and maintenance tools, including the ability 
to reuse, repeat, and maintain common items such as menus, logos, 
code, and even entire page layouts. Dreamweaver’s unique snippets, 
library items, and page templates are indispensable for maintaining a 
consistent appearance and making sitewide updates a snap. 

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw11lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create a site defi nition that points to the dw11lessons folder 
from the included DVD that contains resources you need for these lessons. Go to Site > New 
Site, or, for details on creating a site defi nition, refer to Lesson 2, “Setting Up a New Site.”

Maximizing Site Design
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See Lesson 11 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Creating modular page elements
You may have heard the term modular before; whether referring to a prebuilt house that 
you can cart away and place on your property, or a well-built, scalable website. Modular 
refers to anything you can break down into standardized, reusable components.

Most websites contain common elements such as headers, footers, and menus that appear 
consistently across each page. The ability to convert these elements into reusable items 
is essential for maintaining a consistent look and feel across your pages. Add the ability 
to make components manageable from a single place and to make sitewide updates, and 
editing becomes a breeze.

Dreamweaver provides three modular features: snippets, library items, and templates. 
Each feature off ers a diff erent level of reusability, from simple code tidbits to entire pages, 
complete with navigation, content, and styling.

Introducing snippets
As you build pages and websites, you’ll fi nd yourself creating many similar items several 
times over. Whether you’re creating a two-column layout table or a contact form, snippets 
make it possible to add any piece of code to a common library, where you can reuse it by 
simply dragging and dropping it into the page. You can store virtually any item on a page 
as a snippet. 

The Snippets panel is like a super clipboard, and using a snippet is similar to copying and 
pasting an element onto your page. Changes to a snippet in the Snippets panel do not 
update snippets you’ve already used in your pages. For this reason, snippets are a great way 
to store and place any common page elements that you don’t need to manage globally.

Examples of snippets might include common navigation bars, form elements, tables, and 
even JavaScripts. Snippets are stored as part of the Dreamweaver application, and they 
are not specifi c to any Dreamweaver site. You can add your own snippets directly within 
Dreamweaver, and they will be available for you to use at any time on any site.

11
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The Snippets panel
The Snippets panel displays all available Dreamweaver snippets, broken down by category. 
You can add and edit snippets and categories directly from the Snippets panel. Using a 
snippet from the Snippets panel is as simple as locating it and dragging it from the panel to 
the page. 

Dreamweaver provides many ready-to-use snippets that serve as great starting points for 
forms, lists, and navigation bars (to name a few); many of these require little more than 
text changes and some basic styling. In the following lesson, you will use some of these 
snippets to quickly build existing pages for the product display component of the Organic 
Utopia site. 

1 Double-click the home.html fi le in the Files panel to open it. Choose Window > 
Snippets to launch the Snippets panel (you can also click on the Snippets tab). In the 
category list, locate the Text folder and click on the arrow to the left to expand it. 
You’ll use the service mark snippet to add a service mark to this page.

The Snippets panel contains many categories 
of pre-built snippets for your use.

2 Click to the right of the heading, Welcome to organic utopia. Inside the Text folder, 
double-click the service mark snippet, and a superscripted sm appears in the heading.
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3 At the top of the Snippets panel is a preview of the code that was inserted. In the 
Snippets panel, click on the panel menu ( ) in the upper-right corner and choose Edit. 
The Snippets dialog box appears with a name, a description, the snippet type, and then 
the actual code. This snippet is using the <sup>, or superscript, HTML element.

The Snippet dialog box.

4 Press Cancel, as you won’t be making any changes at this time.

5 Choose File > Save.

Creating new snippets
Whenever you have something on a page that you’d like to reuse, creating a new snippet is 
a good option. You can create new snippets directly from the Snippets panel, and from any 
selected element(s) on a page. 

In this section, you’ll convert a pre-existing table to a snippet.

1 Choose File > Open, and choose the gardentips.html page. This page has a pre-styled 
table. Converting this table to a snippet will allow you to place it anywhere you like. 

2 Click anywhere inside the table, and then choose Modify > Table > Select Table. You 
could also click on the edge of the table to select it.

3 For this next step, you need to make sure the Text folder within the Snippets panel 
is not selected. If the folder is still open, click the minus sign (-) (Windows) or arrow 
(Mac OS) to collapse it. This also ensures that the folder is no longer highlighted. At 
the bottom of the Snippets panel, click on the New Snippet icon ( ). The Snippet 
dialog box opens, and all the code within the table is automatically copied into the 
Insert before window.
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4 In the Name fi eld, type Vege_table. In the Description fi eld, type A three column 
styled table listing the latin and family names of common vegetables. For the 
Snippet type, select the Insert block option. For Preview type, select the Design option 
and press OK.

Choosing the Insert Block option ensures that the table is inserted as a stand-alone 
element. Setting the Preview type to Design allows you to see a preview of the table in 
the Snippets panel, rather than the code.

Setting options in the Snippet dialog box.

In the Snippets panel, you see the new snippet listed. By default, it is located in the last 
folder you used (Text). Before you do anything else, you’ll organize your Snippets panel.

5 In the bottom of the Snippets panel, click on the New Snippet Folder icon ( ). A new 
folder appears; rename this folder ou snippets, then press Enter (Windows) or Return 
(Mac OS). Click on the Vege_table snippet and drag it on top of this new folder. 

Snippets are actually external fi les with the extension .csn and are stored deep within 
your operating system. If someone else has used your current computer to do this 
lesson, you may see this snippet already present. You may remove it by clicking on the 
snippet and then clicking the Remove icon ( ) at the bottom of the Snippets panel.
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6 Click once on the Vege_table snippet, if necessary. In the top half of the panel, there is 
a design preview of the table. It is most likely cropped. Depending on how much space 
you have, it may not be possible to view the entire table; however, you can expand this 
window by clicking on the dividing line of the panel, and dragging up or down. 

Click and drag the dividing line in the Snippets panel to 
expand or contract the view.

7 Choose File > Open, and choose the latin_names.html fi le. Click once below the 
Heading, Latin and Family names for common vegetables. In the Snippets panel, 
double-click the Vege_table snippet, and it is inserted into the new page.

In many ways, a snippet is just a faster way to copy and paste. However, there are a few 
things to be aware of. Snippets only copy the HTML code and none of the associated 
CSS. If you look at the preview of the table snippet in the Snippets panel, you will 
see that it is unstyled. However, when you inserted it into the latin_names page, it 
appeared styled. This is because the Snippets panel only previews the raw HTML in 
the design view. The CSS rules for the table are being saved in an external stylesheet 
and all the pages in this site are already linked to this stylesheet. If you inserted this 
table into a blank page, it would appear unstyled until you attached the style sheet to 
the page.
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8 In the Snippets panel, click on the panel menu in the upper-right corner and choose 
Edit. The Snippet dialog box appears. In the fi rst line, change the table width value 
to 350 and press OK. This has no eff ect on the current table because there is no link 
between the code in the Snippets panel and the code on your page. However, all 
future tables will use the new value.

Changing the table width when editing a snippet.

9 Choose File > Save All. Keep this document open for the next exercise.

The Snippets panel lets you modify a snippet only through its HTML code. Here’s a shortcut: 
if you make a change in the Design view, you can recreate the snippet by selecting it and then 
choosing New Snippet from the Snippets panel. If you select the folder containing the original 
snippet and save it under the same name, you will be prompted to replace it.
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Introducing library items
While snippets are useful, they are perhaps most useful for items that will never change, 
like a person’s name or a logo. However, a more powerful concept is an item that you 
can add to multiple pages and have linked to an original master item. This is where 
Dreamweaver library items come in.

With Dreamweaver library items, you can save any common element and manage it 
from a master copy in your site folder. When you place a library item on a page, the item 
remains attached to its master; any changes you make to the master automatically update 
any instances of the item placed throughout your site. Dreamweaver makes sure that any 
instances of a library item are synchronized.

Library items (unlike snippets) are specifi c to each Dreamweaver site, and they are stored as 
separate .lbi fi les in your site’s Library folder. 

1  Library items are located in the Assets panel. Choose Window > Assets, if it isn’t 
already open, and then click the Library icon ( ) at the very bottom. The panel is 
empty because there are no library items in your site, yet.

The Library Items category of the Assets panel.

You can add, edit, and manage all library items in your site directly from this panel. 
You will now convert the Global Navigation menu in your header to a library item. 

2 Click on the home.html tab in the top of your document window to open this page. 
Click on the border of the GlobalNav <div> element in the upper-right corner to 
select it. (This is the small box that contains the “Site Map | Login” text.)

DWCS6_06Pass.indb   280DWCS6_06Pass.indb   280 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


11

281Lesson 11, Maximizing Site Design

Introducing library items

3 In the Assets panel, click the New Library Item button ( ). You will see a dialog 
box appear, warning you that this style sheet information will not be copied with 
this item. Press OK. The selected menu is added as a new library item; name it 
GlobalNav. If you’re prompted to update links, choose Update. This ensures that any 
hyperlinks or references to image fi les are preserved. The GlobalNav div is now linked 
to the new library item you created. Note that your GlobaNav div is now highlighted 
in yellow; this is the visual indicator Dreamweaver uses for library items. Now you’re 
ready to add this library item to other pages.

The GlobalNav <div> element is highlighted yellow because it is now a library item.

4 Click on the gardentips.html tab at the top of your document window to view this page 
(or open the fi le it if it is closed). Locate the GlobalNav library item in the Assets panel, 
and drag it onto the header of the page. An instance of the GlobalNav <div> element is 
placed. 

5 Click on the latin_names.html tab (or open it if it is closed) from the Files panel. As you 
did in step 4, drag a copy of the GlobalNav library item from the Assets panel to the 
header section. Just as before, an instance of the GlobalNav <div> element is placed.

The GlobalNav is now set in the exact location across three pages of your site. You 
will now modify your library item and all three pages will change.
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Modifying and updating library items
The convenience and power of library items are apparent when you need to update a 
common item across several pages. Because all instances of a library item remain attached 
to a master copy, when the master item is edited from the library item list, every instance 
mirrors these changes.

You can edit library items from the Assets panel or by choosing the Open button from the 
Property Inspector when a library item instance is selected on the page. 

1 From the Library Items list in the Assets panel, double-click the GlobalNav library 
item to open it for editing. A new tab opens because the library item is actually a new 
fi le: GlobalNav.lbi. 

The GlobalNav library item opens as a separate document and has no style associated with it.

It’s important to realize that there is no style information associated with this fi le, 
as Dreamweaver warned you when you created the item. However, this is actually a 
good thing; it simply takes getting used to the idea that you are modifying the HTML 
content—all the style information resides in the style sheet.

2 Where it currently reads Login, select the text, then type Your Account. You will 
now link the text within the GlobalNav menu to the appropriate HTML pages. Select 
the text Your Account, then in the Property Inspector, click on the HTML button, if 
necessary. Next, click on the Browse for File folder icon ( ) to the right of the link 
fi eld. In the Select File window, choose login.html. Press OK (Windows) or Open 
(Mac OS).
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3 Select the Site Map text. In the Property Inspector, click on the HTML tab if 
necessary, and click on the Browse for File icon ( ) to the right of the link fi eld. In 
the Select File dialog box, choose sitemap.html, then press OK (Windows) or Open 
(Mac OS). 

4 Choose File > Save. The Update Library Items dialog box appears with a list of the 
three fi les. Whenever you modify a library item and save it, a list of all fi les using the 
item appears, and you are given the choice to update or not. 

When saving library items, any pages aff ected will appear in the 
Update Library Items dialog box.

5 Click Update. The fi les update and the Update Pages dialog box appears.

6 Click on the Show Log option in the Update Pages dialog box. A list of the fi les that 
were updated appears; this is where you can check to see if there were any problems 
and how many fi les were updated. Press Close.

7 Open home.html, gardentips.html, and latin_names.html if they were not already 
open, and you see that all instances of the menu have been updated in all three pages. 
Library items are tremendously powerful; the larger the site, the more useful they 
become. They are tremendously useful with hyperlinked navigation, where they can 
help prevent broken hyperlinks. 

For example, currently you have three documents all using a library item that is linked 
to the login.html and sitemap.html pages. But what happens if you move those two 
pages into a new folder? You will do this now so you can see how Dreamweaver keeps 
track of the move and prompts you to update the links.
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8 Click on the Files tab, if necessary, to view the list of fi les in your site. Click on the 
root folder at the top of the panel (Site – dw11lessons), and then right-click (Windows) 
or Ctrl+click (Mac OS) to open a context menu. Choose New Folder. Rename the 
new folder GlobalNav and press Enter (Windows) or Return (Mac OS).

Right-clicking on the root folder allows 
you to create a new folder.

9 In the Files panel, click and drag the login.html fi le into this new GlobalNav folder. As 
soon as you do, the Update Files dialog box appears with the list of all the fi les that need 
to be updated. This is a huge time-saver if you need to restructure your site. Traditionally, 
you would have to go to each page and relink everything that pointed to this page. Now 
click Update, and the links on each page are all updated behind the scenes.

10 Click and drag the sitemap.html fi le to the GlobalNav folder; press Update, and all the 
fi les are updated. 

11 Choose File > Save All, update your pages if prompted, and then close all your open fi les.

Occasionally you may need to detach a library item from its master. In order to do this, you must 
select the library item and then click Detach from original from the Property Inspector. Just be 
aware that once a library item is detached, any future changes must be made manually. Also, it is 
sometimes easier to select a library item in the Code view rather than in the Design view.
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Introducing templates
If you are creating several pages that need to share the same look and layout, Dreamweaver 
templates are for you. A Dreamweaver template is a master document from which other 
pages can be created; these pages inherit all the elements from the original template, but 
you can modify each page to include unique content and elements. As with library items, 
when you edit a template, all pages based on that template update to refl ect your changes.

When you create a template, you specify editable regions, or areas of the page that you can 
modify. By default, all elements of a page created from a template are locked for editing. 
You can make changes only from the original master template. You can set sections 
of a page as editable so that you can add or modify content without accidentally (or 
intentionally) disturbing the original layout.

Templates are also a great mechanism for controlling access to pages on a site. If you need 
to provide editing ability to others, you can lock out important page elements and give 
users access to only certain sections of the page.

Templates are site-specifi c and are stored in a Templates folder under your site’s root folder. 
You open, edit, or create templates from the Templates list in the Assets panel.

Dreamweaver templates work with Contribute, a basic but powerful web content management tool. 
You can design and manage templates that can be modifi ed and published by Contribute users.

Creating a new template
For the Organic Utopia site, imagine that you need to create many diff erent category and 
product detail pages for the products in the store. To do this, you’ll set up templates for 
each page so that new pages can be easily created but will remain visually consistent with 
the master layout.

1 In the Files panel (Window > Files), locate and double-click the product_detail.html 
page to open it for editing. This page has generic text and a placeholder image that 
will serve as your template.

2 Click on your Assets panel, and then click on the library item. As you did with the 
other pages, click and drag the GlobalNav item onto the header. This page will shortly 
serve as a template, and by including a library item, you are maximizing automation.
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3 Save the product_detail.html page as a template by choosing File > Save as Template. 
The Save As Template dialog box appears. 

Naming a new template.

4 Choose Save to save the template. If prompted, allow Dreamweaver to update any 
links by choosing Yes from the dialog box.

Working with editable regions
Next, you will need to defi ne editable regions that you can modify on any pages created 
from this template. When new HTML pages are generated from templates, there may be 
certain sections you would like to be editable and other areas that should remain uneditable. 

1 Select the placeholder text in the product_detail template that reads Product Category. 
Choose Insert > Template Objects > Editable Region. The New Editable Region 
dialog box appears.

2 Name the new editable region ProductCategory and click OK. The placeholder text 
now appears inside a black box with a blue tab at the top. This portion of the page and 
the content within it will now be editable in any pages created from this template.

3 Select the placeholder text in the product_detail template that reads Product Name. 
Choose Insert > Template Objects > Editable Region. The New Editable Region 
dialog box appears. Name this ProductName and click OK.

4 Select the image placeholder, then choose Insert > Template Objects > Editable 
Region. The New Editable Region window appears. Name this ProductImage and 
click OK.

Naming the Editable Region of the image placeholder.
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5 Finally, select all the text in the sidebar. Choose Insert > Template Objects > 
Editable Region. The New Editable Region dialog box appears. Name this 
ProductDescription and click OK.

6 Choose File > Save to save the template. You may see a warning about putting the 
editable region within a block tag; click OK.

At this point, you can create any number of pages and manage them from this 
template. The editable regions you created will allow you to add content to any new 
pages based on this template, but will protect the main layout and page elements from 
unintended changes.

Creating new pages from templates
Now you’re ready to create multiple product pages that will be based on the new template 
you have built. You’ll create two pages, enough to give you a sense of how templates work.

1 Choose File > New. In the New Document dialog box, click the Page from Template 
option. The Site column lists all the sites you have defi ned; click the dw11lessons site. 
In the second column, the product_detail template should be selected. Press Create. 
This opens a new, untitled document based on the template. Choose File > Save. 
When prompted, navigate to the products folder in the dw11 lessons folder. Name this 
fi le eggplants.html and press Save.

2 Click inside the header of your page and notice that you are unable to select or move 
anything. This section is uneditable. Notice, in the upper-right corner, the yellow 
highlighted box that reads Template:product_detail. In a similar fashion to library 
items, this yellow highlight indicates that the page is based on a template.

Dividing a page into editable and non-editable regions can be useful for any situation 
where the designer of the site would like some control over how the site is modifi ed. 
Someone not familiar with Dreamweaver could easily learn to update the editable 
regions, and at the same time, there would be little risk that they click on something 
by accident and modify it.

3 Select the text inside the ProductCategory editable area and type Vegetables. Select 
the text in the ProductName area and type Eggplants. Select the Product_image 
placeholder, and in the Property Inspector, press the Browse for File button ( ) to the 
right of the Src text fi eld.

Click on the Folder icon to locate the eggplant image.

Navigate through your dw11lessons folder and locate the images folder. Select the 
eggplant.jpg image and press OK (Windows) or Open (Mac OS).
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4 Double-click on the products folder in the Files panel to open it, and then double-
click on the eggplants.txt fi le to open it in Dreamweaver. Select all the text, choose 
Edit > Copy, and then close the text fi le.

5 Select the text in the Product Description area of the sidebar, then choose Edit > 
Paste. Place your cursor after the word Eggplant in the fi rst line, and then press Return 
to add a new line and separate the heading from the paragraph. Choose File > Save.

Another way to base a new page on a template is by using the File > New command.

6 Choose File > New. In the New Document dialog box, click the Page from Template 
option. The Site column lists all the sites you have defi ned; click the Lesson 11 site. In 
the second column, the product_detail template should be selected. Press Create; the 
new page is created.

Choose File > New, and then click the Page from Template option.

7 Choose File > Save, and save this fi le as beets.html in your Products folder. Select the 
text inside the ProductCategory editable area and type Vegetables. Select the text in the 
ProductName area and type Beets. Select the Product_image placeholder, and in the 
Property Inspector, press the Browse for File button ( ) to the right of the Src text fi eld.

Navigate through your dw11lessons folder and locate the images folder. Select the 
beets.jpg image and press OK (Windows) or Choose (Mac OS).

8 In the Files panel, double-click on the products folder to open it, if it is not already 
open, and double-click on the beets.txt fi le to open it in Dreamweaver. Select all the 
text, choose Edit > Copy, and then close the text fi le.

9 Select the text in the Product Description area of the sidebar, and choose Edit > Paste. 
Place your cursor after the word Beets in the fi rst line, and then press Return to add a 
new line and separate the description from the heading. Choose File > Save. 
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Modifying templates
In a similar fashion to library items, when you make changes to the original template, all 
linked pages are updated.

1 In the Templates list in the Assets panel, double-click the product_detail template to 
open it for editing. 

2 Place your cursor after the image placeholder, and press Enter (Windows) or Return 
(Mac OS) twice; then type This vegetable is in season.

Insert text after the placeholder image.

3 If you were to save right now, your text would be updated on your two linked pages; 
however, you need to convert it to an editable item unless you want the text to be 
locked on those pages.

4 Select the text and choose Insert > Template Objects > Editable Region. Name this 
region inseason and press OK. Choose File > Save. (If you see the Editable Region 
warning, press OK.) The Update Files dialog box appears; any fi les linked to this 
template will now be changed. Press Update, then close the Update Pages dialog box.
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5 Click on the beets.html fi le; notice that it has automatically been updated. In the 
inseason editable region, update the text to read This vegetable not in season.

Updating your new editable region on the beets.html page.

6 Choose File > Save All, and then choose File > Close All to close all your open 
documents.

Repeating regions
A single region may not be the best way to display the content you add to a template-based 
page. You may require a template that can handle a number of items, such as a table that 
displays products in a category. If you need to build a fl exible template that can hold any 
number of uniform items, you can add a repeating region to it.

Repeating regions allow you to defi ne an element on a template as repeatable. When you 
create a page based on that template, you can increase, or repeat, the number of regions 
to accommodate the information. You’ll also be able to reorder these repeated regions at 
any time without having to move the content. For example, you could set elements such 
as a table row, paragraph, or small display table as a repeating region, and then duplicate as 
many as you need to fi t the content at hand.

A repeating region is not automatically editable. You need to set editable regions inside 
any repeating element in order to add to or edit its content.

In the following steps, you’ll add a repeating region to your category.html page and 
convert it to a template so that you can use it to display any number of products in a 
specifi c category.

1 Open the category.html page from the Files panel. 
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2 The table in the center contains one row with two columns, each containing a 
placeholder image and product title placeholder. Click on the edge of the table to 
select it.

3 Choose Insert > Template Objects > Repeating Region. Because you haven’t saved 
this page as a template yet, a dialog box appears, letting you know that you need to 
convert the page to a template before you add regions. Press OK.

4 When the Repeating Region dialog box appears, assign the new region the name 
Products, and press OK. 

The row is now a repeating region, which you can duplicate 
in any page created from this template.

5 Choose File > Save As Template, and save the new template as category_display. 
Press Save and Update Links if asked.

6 In the left cell, highlight the Product text. Choose Insert > Template Objects > 
Editable Region. Name the new region ProductName, and press OK. 

7 Select the placeholder image below the new editable region, and choose Insert > 
Template Objects > Editable Region. Name the new region ProductImage, and 
press OK. 

8 In the right cell, highlight the Product text. Choose Insert > Template Objects > 
Editable Region. Name the new region ProductName2, and press OK.

9 Select the placeholder image below the new editable region, and choose Insert > 
Template Objects > Editable Region. Name the new region ProductImage2, and 
press OK.

10 Choose File > Save to save this template. 

Templates can’t contain duplicate region names. If you try to set two editable regions with the 
same name, Dreamweaver gives you an error message.

Putting repeating regions into action
You’re now ready to create a page from the new category_display template and see how 
repeating regions work. 

1 Open the Assets panel if necessary, then select the category_display template, and 
choose New from Template from the Assets panel menu.

DWCS6_06Pass.indb   291DWCS6_06Pass.indb   291 5/2/12   5:16 PM5/2/12   5:16 PM

www.it-ebooks.info

http://www.it-ebooks.info/


11 Repeating regions

Dreamweaver CS6 Digital Classroom292

2 Save the new document as category_chocolate.html in your site’s root folder. 
Notice the new repeating region in the middle of the page—its tab features four 
buttons that allow you to add, remove, and shift repeating regions up or down in the 
stacking order. 

A repeating region has four buttons you can use.

3 Click the plus sign button (+) on the top of the repeating region; a new table row with 
two more product display tables appears. Press the plus sign button two more times to 
see how it will automatically add new rows. Press the minus sign button to see how to 
remove a row. In the next step, you’ll fi ll in the fi rst four products with information to 
complete your page. 

4 In the fi rst row, type Belgian Chocolate in the ProductName text fi eld and 
French Chocolate in the ProductName2 text fi eld. In the second row, type 
German Chocolate in the ProductName text fi eld and Swiss Chocolate in the 
ProductName2 text fi eld. 

The four products now appear in the category page, and as an added benefi t, if you 
wanted to reorder the rows you could do so using the repeating region toolbar.
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5 Click on the up arrow in the repeating region toolbar to push the second row to the 
top. This feature is especially useful for repeating regions with many rows.

A repeating region has four buttons you can use.

6 Choose File > Save All. 

Detach from Template command
If you want to modify a template-based page beyond what the editable regions allow, you 
can use the Modify > Templates > Detach from Template command, which breaks the 
current page away from the master template, allowing you to edit it freely. Keep in mind 
that a page detached from a template will no longer be updated if you make any changes 
to the original template.

Congratulations! You have fi nished Lesson 11, “ Maximizing Site Design.”
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Self study
Create a new template based off  of home.html and then create new pages based off  
the template for the following pages: about_us.html, products.html, services.html and 
contact.html. Then return to the template and create links to these pages from the 
navigation bar. Which sections need to be editable and which do not?

Open one of the product detail pages you created, and use Detach from Template to 
break it away from the product_display template. You’ll then be able to freely edit other 
elements on the page that you did not include in the original editable regions. Create some 
variations on the newly detached page by trying a new layout, modifying product and 
picture positioning, or applying a new style to the product title, price, or description. Use 
the Templates section of the Assets panel to create a new template from the page.

Review 
Questions
1 What are two key diff erences between snippets and library items?

2 How do you add a new snippet to a page in Dreamweaver?

3 Where are library items and page templates stored? Which panel do you use to 
manage them?

4 What happens to pages based on a template when you modify the original template?

5 True or false: Repeating regions are automatically editable in pages that use them. 

Answers
1 Snippets are stored as part of the Dreamweaver application, and are available, 

regardless of which site or document you’re working on; library items are specifi c to 
a site defi nition. Copies of a snippet never update when the original snippet is edited; 
a library item updates all instances of itself throughout a local site when a change is 
applied to it.

2 You can drag a snippet from the Snippets panel onto the page, or position your cursor 
in the page and double-click the snippet in the Snippets panel.

3 Library items and page templates are stored in the Library and Templates folders 
(respectively) under your local site. You can manage both, using their specifi c 
categories on the Assets panel.

4 Dreamweaver updates all pages based on that template to refl ect any changes made to 
the original template.

5 False: You must fi rst set editable regions within a repeating region to add content.
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What you’ll learn in 
this lesson:
• Using the Code and Design 

views

• Working with the Coding 
toolbar

• Validating your code

• Formatting and 
reformatting your code

Lesson 12

Dreamweaver provides exceptional code-editing support to 
complement its powerful visual layout tools and application 
development features. You can adapt the coding environment so that 
it fi ts the way you work. Learn how to change the way you view 
code, reformat your markup, or use your favorite tag library.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw12lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw12lessons folder. Go to 
Site > New Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

Working with 
Code-editing Features
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See Lesson 12 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Working with code 
Although Dreamweaver’s traditional audience has been for those who prefer to work in the 
Design view and not with code, there are many good reasons to dive into the code editing 
view. In this lesson, you will look at some of the unique functions available in the Code 
view by taking a look at an older web page.

Accessing code with the Quick Tag editor 
In this exercise, you will use a feature called the Quick Tag editor. This feature is 
generally for users who are more familiar with their code. The Quick Tag editor off ers an 
easy way to add CSS class or ID names as well as attributes to your code without having to 
leave the Design view. The Quick Tag editor works in conjunction with the tag selector. 
In this exercise, you’ll apply a CSS class to an image to fl oat it to the right.

1 Open the oldcode.html fi le, and click on the image of the beets. In the bottom-left of 
the document window is the tag selector which now has the <img> tag selected.

2 Right-click (Windows) or Ctrl+click (Mac OS) the <img> tag in the tag selector. A 
contextual menu appears with all the code for the selected image. Choose Quick Tag 
Editor from the menu. The Quick Tag Editor appears, displaying the code for this tag.

Viewing the attributes and properties of a tag in the Quick Tag Editor.

Instead of switching to the Code view to make changes to this code, you can make 
changes within the editor.

12
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Working with code 

3 Click once after the align="left" code and press the spacebar. A code-hinting 
menu is triggered, allowing you to choose from a list of possible choices. Double-
click the class option; the code will be written for you. Notice that the only option, 
fl oatright, is listed; press the Return (or Enter) key to apply this class. Your image 
now has the class applied and is fl oating to the right.

You can also use the Quick Tag Editor to remove unnecessary code. For example, this 
page uses the older <font> tag to style text.

4 Click anywhere inside the main paragraph of your document. In the tag selector, click 
on the <font> tag and then right+click (Windows) or Ctrl-click (Mac OS) and from 
the context menu choose the Remove Tag option. 

Quickly remove a tag by choosing Remove Tag.

This removes both the opening and closing font tags and the text now reverts to its 
default unstyled appearance.
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Inserting tags with the Tag Chooser
You can use the Tag Chooser to insert any tag into your page with the Dreamweaver tag 
libraries—these include the Macromedia ColdFusion, ASP.NET, and PHP tag libraries 
among others. 

1 Switch to Code view by choosing View > Code or by pressing the Code View button 
on the Document toolbar.

2 Click in line 5 immediately before the <style> tag and press return. Now click back in 
the empty line 5. You will now add the title tag, which this document does not have.

3 Right-click (Windows) or Ctrl+click (Mac OS) and select Insert Tag. The Tag 
Chooser appears. The left pane contains a list of supported tag libraries, and the right 
pane shows the individual tags in the selected library. 

4 Expand the HTML tags library if necessary, and then click the Page Composition 
subcategory; click the General category, and then click the <title></title> tag. 
Click the Tag Info button to expand this window. This info gives you a brief synopsis 
of the function of the tag and is a great way to learn more about HTML tags. 

 
Use the Tag Chooser to add from a list of tags. Click on the Tag Info button to learn more about the tag.

5 Click the Insert button to add the tag to your code, then click the Close button. Your 
cursor is inside the <title> tags so type The Lowly Beet.

Now let’s look at some other features of Dreamweaver CS6 that allow you to work 
with HTML code.
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Inserting and editing comments
Comments are descriptive text that you insert in HTML code to explain the code or 
provide other information. By default, the text of the comment appears only in the Code 
view and is not displayed in a browser. You can also modify existing comments. In this 
exercise, you’ll add your own comment to the HTML code, and edit a comment already 
in the code.

1 Go back into Design view by clicking on the Design view button in the Document 
toolbar. Click in front of the fi rst character in the fi rst paragraph and choose Insert > 
Comment. 

2 Dreamweaver displays the Comment dialog box. Type We need to add two or 
three links to other websites in the text below and then press OK.

Type the comment into the Comment dialog box.

3 If you have not already set this up on your system, a box will appear warning that you 
will not be able to see comment markers in the Design view. If this message appears, 
select View > Visual Aids > Invisible Elements. Press OK. You will now enable the 
preference to view Invisible Elements.

4 Choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and click on the Invisible Elements category. Check the box for Comments, and 
click OK. You now see a small icon with an exclamation point (!)—this is the visual 
representation of your comment. Click on the icon and the Properties panel will 
display the comments.

Comments are a good way to communicate to members of a team who may be 
working on the same fi le. These comments are also visible in the Code view.
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5 Switch back to the Code view by choosing View > Code or by pressing the Code 
view button on the Document toolbar. 

In the line that corresponds to the location of your comment, Dreamweaver has 
inserted a comment tag (in gray, by default) that looks like this: 

 
Comments inserted into your code can be seen in both Design and Code view.

To delete a comment, select it in Design view and press Delete. In the Code view, highlight the 
entire line and delete it.

6 Choose File > Save to save your work.

Using HTML5 Code-hinting
The internal library of code that is available to Dreamweaver CS6 evolves as the 
language of the Web evolves. If you are working with the next generation of web pages, 
Dreamweaver has access to the latest HTML5 elements.

1 In the Code view, locate the <img> element on or around line 20. Place your cursor 
immediately before the opening <img> tag and press Return (Mac OS) or Enter (PC) 
to move this code to the next line. 

Click once in the empty line you just created above the <img> element. You will now 
be adding a new HTML5 element.

2 Type a left bracket ([); Dreamweaver’s code-hinting panel appears. This is a complete 
list of every element that is a part of Dreamweaver’s library of HTML tags.
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Type the letters fi ; notice that as you type, the list automatically narrows down to the 
available choices. Using the arrow keys on your keyboard, select the <fi gure> tag and 
press Return (Mac OS) or Enter (PC).

 
Use code-hinting to select the HTML5 fi gure tag.

3 Type the closing bracket. Dreamweaver will not automatically do it for you.

The HTML5 <fi gure> element is designed to help structure your web pages by 
giving you a more specifi c way to defi ne images on your pages. For example, you 
could add a common style for all fi gures on your page.

4 You need to add the closing tag for the fi gure element, so click once at the end of the 
line of the <img> code and press Return.

5 On this new line, type a left bracket and a forward slash: </. Dreamweaver will 
automatically complete (auto-complete) the rest of the tag.

 
Dreamweaver will auto-complete your closing tags.

You can choose to turn off  the code-hinting and auto-complete options within your preferences. 
Choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS). Select the 
Code Hints category. To turn off  code-hinting, click to clear the Enable Code Hints checkbox. To 
prevent Dreamweaver from auto-completing your tags, select Never from the Close tags section.
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Working in the Code view
As you’ve seen, the Code view is a hand-coding environment for writing and editing 
HTML and CSS. More experienced users who work in scripting languages such as 
JavaScript, PHP, and ColdFusion, can modify their workspace to suit the way they prefer 
to work with code.

View options

You can set word wrapping, display line numbers for the code, highlight invalid code, set 
syntax coloring for code elements, set indenting, and show hidden characters from the View 
> Code View Options menu. The Code view options are not available when you are in the 
Design view, only when in Code or Split view.

Word Wrap: wraps the code so that you can view it without scrolling horizontally. This 
option doesn’t insert line breaks; it just makes the code easier to view. 

Line Numbers: displays line numbers along the side of the code. 

Hidden Characters: displays special characters in place of white space. For example, a dot 
replaces each space, a double chevron replaces each tab, and a paragraph marker replaces each 
line break. 

Highlight Invalid Code: causes Dreamweaver to highlight all HTML code that isn’t valid 
in yellow. When you select an invalid tag, the Property Inspector displays information on 
how to correct the error. 

Syntax Coloring: enables or disables code coloring.

Auto Indent: makes your code indent automatically when you press Enter or Return while 
writing code. The new line of code indents to the same level as the previous line.

Syntax Error Alerts: in Info Bar conveniently displays mistakes in your code.
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Modifying the Code view workspace
You can view the source code for Dreamweaver documents in several ways. You can 
display it in the document window by switching to the Code view, you can split the 
document window to display both the visual page and its related code in Split view, or you 
can work in the Code Inspector, a separate coding window. The Code Inspector works 
like a detachable version of the Code view for the current page.

1 Choose View > Code and Design, to view the code and visually edit the page in the 
document window at the same time. By default the Code view is split with the Code 
on the left and Design view on the right.

2 From the View menu choose Design View on Left to swap the views. 

 
Choose Design View on Left to switch the location of the Code and Design views.

3 Place your cursor over the splitter bar between the Design view and the Code view. 
Click and drag the bar to the right and the Design view will expand as the Code view 
contracts. 
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4 Choose Window > Code Inspector. Working in the Code Inspector is just like 
working in the Code view, except that it is in a separate window. This might be 
useful, depending on how you choose to manage your workspace (for example, users 
who have two monitors could put this window in a separate window). 

 
You can also view your HTML code in the Code Inspector window.

Press the Close button to close the Code Inspector for now. From the View menu, 
choose Design View on Left to return the split screen to its original orientation.

5 Choose View > Code. You will now look at some of the coding features available in 
the coding toolbar in Dreamweaver.
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The Coding toolbar
The Coding toolbar contains buttons that let you perform many standard coding 
operations, such as collapsing and expanding code selections, highlighting invalid code, 
applying and removing comments, indenting code, and inserting recently used code 
snippets. The Coding toolbar is visible only in the Code view and appears vertically on the 
left side of the document window. To see what each button does, position the cursor over 
it until a tooltip appears.

ICON TOOL NAME USE

Open Documents Lists the documents that are open. When you select a 
document, it is displayed in the document window.

Show Code Navigator Displays a list of code sources related to a particular selection 
on your page. Use it to navigate to related code sources, 
such as internal and external CSS rules, server-side includes, 
external JavaScript files, parent template files, library files, 
and iframe source files. You can access the Code Navigator 
from Design, Code, and Split views, as well as from the Code 
Inspector.

Collapse Full Tag Collapses the content between a set of opening and closing 
tags (for example, the content between <body> and </
body>). You must place the insertion point in the opening 
or closing tag and then click to collapse it.

Collapse Selection Collapses the selected code.

Expand All Restores all collapsed code.

Select Parent Tag Selects the content and surrounding opening and closing 
tags of the line in which you’ve placed the insertion point. If 
you repeatedly click this button, and your tags are balanced, 
Dreamweaver will eventually select the outermost <html> 
and </html> tags.

Balance Braces Selects the content and surrounding parentheses, braces, 
or square brackets of the line in which you’ve placed the 
insertion point. If you repeatedly click this button, and 
your surrounding symbols are balanced, Dreamweaver will 
eventually select the outermost braces, parentheses, or 
brackets in the document.

Line Numbers Hides or shows numbers at the beginning of each line of 
code.

Highlight Invalid Code Highlights invalid code in yellow.

Word Wrap Changes the Word Wrap from Soft Wrap to Hard Wrap (or 
vice-versa)
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ICON TOOL NAME USE

Syntax Error Alerts in 
Info Bar

Enables or disables an information bar at the top of the page 
that alerts you to syntax errors. When Dreamweaver detects 
a syntax error, the Syntax Error Information bar specifies 
the line in the code where the error occurs. Additionally, 
Dreamweaver highlights the error’s line number on the left 
side of the document in Code view. The info bar is enabled 
by default, but only appears when Dreamweaver detects 
syntax errors in the page.

Apply Comment Wraps comment tags around selected code, or opens new 
comment tags.

Remove Comment Removes comment tags from the selected code. If a 
selection includes nested comments, only the outer 
comment tags are removed.

Wrap Tag Wraps selected code with the selected tag from the Quick 
Tag Editor. 

Recent Snippets Inserts a recently used code snippet from the Snippets panel.

Move or Convert CSS Lets you move CSS to another location, or convert inline CSS 
to CSS rules.

Indent Code Shifts the selection to the right.

Outdent Code Shifts the selection to the left.

Format Source Code Applies previously specified code formats to selected code 
or to the entire page if no code is selected. You can also 
quickly set code formatting preferences by selecting Code 
Formatting Settings from the Format Source Code button, or 
edit tag libraries by selecting Edit Tag Libraries.

The number of buttons available in the Coding toolbar varies depending on the size of 
the Code view in the document window. To see all the available buttons, resize the Code 
view window or click the Show More arrow at the bottom of the Coding toolbar.
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Working in the Code view

Collapsing and expanding tags and code blocks
Dreamweaver lets you collapse and expand code fragments so that you can hide and show 
various sections of your code. This can help reduce the amount of screen space that is 
taken up and also prevent mistakes since code that is collapsed cannot be edited. When 
you select code, Dreamweaver adds a set of collapse buttons next to the selection (minus 
symbols in Windows; vertical triangles in Mac OS). You can collapse code only in the 
Code view.

1 Make sure you are in the Code view by pressing the Code view button on the 
Document toolbar. Scroll to the top of the screen if necessary and click anywhere 
between lines 6 and 14, which is the <style>, tag that contains all your CSS. 

2 Click the Collapse Full Tag button in the coding toolbar. You can also choose Edit > 
Code Collapse > Collapse Full Tag. The <style> tag is now collapsed. This feature is 
useful for reducing the amount of screen space that your code occupies on the screen.

 
The Collapse Full Tag button collapses the relevant tag.

Click on the plus sign (Windows) or arrow (Mac OS) on the left to expand the code again.

3 In the Coding toolbar click on the Select Parent Tag button. This will select the code 
that is nesting your existing selection. In this case, the parent is the <head> tag, which 
is now selected.

The Select Parent Tag button is a great alternative to selecting code by hand. Selecting by hand 
can often introduce mistakes; the Select Parent Tag will always be more reliable and faster.

4 In the Coding toolbar click on the Collapse Selection button to collapse the <head> 
tag and all its content. You could have also chosen Edit > Code Collapse > Collapse 
Selection. 

5 Click anywhere within your document and note that you could begin to work in your 
HTML and the <head> tag will always remain collapsed until you need to access it.
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6 Double-click the head tag to expand it again.

 
Double-clicking collapsed code will expand it.

To expand all code at once, you can also choose Edit > Code Collapse > Expand All. All your 
code fragments are now restored to their original view.

Validating your code
In addition to the many options available for formatting your code, you can also use 
Dreamweaver to fi nd out if your code has tag or syntax errors. Dreamweaver can validate 
documents in many languages, including HTML, XHTML, PHP, ColdFusion Markup 
Language (CFML), Java Server Pages ( JSP), Wireless Markup Language (WML), and 
XML. You can validate the current document or a selected tag. 

Highlighting and correcting invalid code
You can set Dreamweaver to highlight invalid code (in yellow) in the Code view. When 
you select a highlighted section, the Property Inspector off ers information on how to 
correct the error. Invalid code is not highlighted by default in Code view. In order to view 
the invalid code, you must enable this option in the View menu.

1 Select View > Code View Options and turn on the Highlight Invalid Code option by 
selecting it from the menu.

2 Two tags become highlighted in yellow the <b> and the <i> tags.

 
Invalid code is highlighted in yellow in both the Design and Code views.
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Validating your code

3 Click once on the fi rst highlighted (invalid) code for the <b> tag. In the Property 
Inspector, this has been identifi ed as invalid markup because there is an unclosed or 
overlapping tag. (In this case, the author used two opening tags and no closing tags.)

 
The Property Inspector identifi es the invalid code and suggests how to correct it.

4 Correct the error by removing the incorrect markup. Individually select each of the 
four highlighted tags and then delete them. You can now style them correctly either in 
the Design view or the Code view; for now, you will leave them as is.

Running a Report
Site reports allow you to scan your code using a set of criteria. Code which doesn’t fi t the 
criteria is identifi ed, allowing you to fi x it. In this exercise, you’ll run all the reports for HTML.

1 Choose File > Save. Then choose Site > Reports and in the site Report window that 
appears, check all fi ve boxes for HTML reports. Be sure that the Report on menu is 
set to Current Document. You can also run reports sitewide, for certain fi les only or 
an entire folder.

 
Check the HTML Reports you would like to run.
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2 Press Run; the results of the Report appear in a new Site Reports panel below the 
Properties panel. In this case, there are two warnings that the alt attribute is missing 
from your images. The alt attribute improves accessibility for images on your page for 
assistive devices, such as screenreaders. This is not technically required, but you should 
add them.

3 In the Site Reports panel, double-click the fi rst warning. You will be sent directly to 
the code and the image will be selected. In the Properties panel, locate the Alt text 
fi eld and type Logo and then press Enter (Windows) or Return (Mac OS) to commit 
the change.

 
Clicking on a warning in the Site Reports panel sends you to this code.

4 Repeat this step and double-click on the second warning. This will select your other 
image. Type Beets in the Alt text fi eld, then press Enter or Return to commit the change.

5 Choose File > Save to save your fi le. You should also close the entire group of the 
report tabs. You can do this by clicking on the context menu at the top-right of the 
panel and choosing Close Tab Group.
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Formatting code
Once you’ve validated your code, you can further change its look by specifying formatting 
preferences, such as indentation, line length, and the case of tag and attribute names. Many 
developers who code by hand have certain conventions or preferences for the way their 
code appears on the page or for the formatting used. Dreamweaver helps automate certain 
code formatting tasks that would otherwise be time-consuming and tedious.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS). 

2 When the Preferences dialog box appears, select Code Format from the Category list 
on the left. The Code Format preferences appear on the right. 

 
Choose from the Code Format preferences to further change the look of your code.

The Code Format preferences allow you to change the way code is written in 
Dreamweaver. For example, when you press the Tab key, your cursor indents four 
spaces. Using this preference window, you could increase or decrease the amount of 
the indent. 
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3 In the Advanced Formatting section, click the CSS button; the CSS Source Format 
Options window appears. This window allows you to specify the way your CSS code 
is written. 

 
The CSS Source Format Options window allows you to change the way CSS syntax is written.

Press the Cancel button to close this window, and then press the Cancel button to 
close the Preferences window.

Apply Source Formatting

If you make changes in the Code Format preferences, those options are automatically applied 
only to new files created in Dreamweaver. To apply new formatting preferences to an 
existing file, you would need to then select Commands > Apply Source Formatting.
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Indenting
Dreamweaver also off ers indentation options for you as you write and edit code in the 
Code view or the Code Inspector. You can change the indentation level of a selected block 
or line of code, shifting it to the right or left by one tab. 

1 In the Code view, click in front of the div element for the header and press the Tab 
key twice. Alternatively, you could select Edit > Indent Code or use the indent button 
on the Coding Toolbar. 

2 To outdent the selected block of code, press Shift+Tab, or you can select Edit > 
Outdent Code.

You can also select multiple elements and Indent and Outdent them.

3 Choose File > Save to save your work, then close the fi le by choosing File > Close.

Congratulations! You’ve fi nished Lesson 12, “Working with Code-editing Features.”
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Self study
Choose File > Save As and make a copy of the oldcode.html page. In the design view, 
experiment with the Quick Tag Editor and try some of the following: Convert the H2 tag 
of The Lowly Beet heading to an H3 tag. Use the Quick Tag editor to open the <img> 
tag for the beets and remove the align attribute as it is no longer needed.

In Code view make sure you understand the tools covered in the chapter by clicking on 
elements and collapsing them. Try clicking within a paragraph and clicking the Select 
Parent Tag button. Click it again to see what happens. Before you click a third time can 
you predict what will be selected?

Try formatting the readibility of your code by indenting the nested elements in the fi le. 
Selecting multiple elements at once and then pressing the indent (or outdent) buttons will 
allow you to shift entire blocks of code to the left or right.

Review 
Questions
1 What is the purpose of working in the Code view in Dreamweaver?

2 When are the code formatting options that you specify in Code Format preferences 
applied?

3 What advantages are there in using the tag selector to select, edit, and remove 
HTML code?

4 How do you know where invalid code exists in your document and how to fi x it?

Answers
1 The Code view is a hand-coding environment for writing and editing HTML, JavaScript, 

server-language code such as PHP and ColdFusion, and any other kind of code.

2 The code formatting options that you specify in Code Format preferences are 
automatically applied only to new documents that you subsequently create with 
Dreamweaver. However, you can apply new formatting preferences to existing 
documents using the Apply Source Formatting command.

3 You can use the tag selector to select, edit, and remove tags without exiting the 
Design view. The tag selector, situated in the status bar at the bottom of the document 
window, displays a series of tags that correspond to elements on your page.

4 With the Highlight Invalid Code option selected, Dreamweaver highlights invalid 
code in yellow in both the Design and Code views. When you select a highlighted 
section, the Property Inspector off ers information on how to correct the error.
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What you’ll learn in 
this lesson:
• The basics of creating 

forms

• Working with the 
<form> tag

• Adding form elements

• Styling forms with CSS

• Choosing form processing 
options

• Validating forms

• Working with Behaviors

Lesson 13

HTML forms allow you to gather information from visitors to your 
website. In this lesson, you’ll learn how to add form elements such 
as text boxes and radio buttons to make your site more interactive.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw13lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create a site defi nition that points to the dw13lessons folder . 
Go to Site > New Site, or, for details on creating a site defi nition, refer to Lesson 2, “Setting 
Up a New Site.”

Building Web Forms
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See Lesson 13 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

The basics of HTML forms
HTML forms are commonly used for questionnaires, hotel reservations, order forms, data 
entry, and a variety of other applications. Users provide information by entering text, 
selecting menu items, and so on, and then submit that information to you through a server.

Here’s the simple form you will be creating that includes labels, radio buttons, and push 
buttons (used to reset the form or submit it):

Forms are a great choice when you want to gather information from your audience.

How forms work
An HTML form is a section of a document that often contains content such as text or 
images, markup, special elements called controls (checkboxes, radio buttons, and menus, 
among others), and labels on those controls. A form is completed when a user modifi es its 
controls (by entering text and selecting menu items), and submits the form to an agent for 
processing.

13
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Building a contact form

When you add form controls in Dreamweaver, you are essentially creating the front-end 
of the form. A user can add all the data required on the page, but this data needs to saved 
and processed at a specifi c location when the user presses the Submit button. It’s important 
to understand that Dreamweaver does not provide this location for you. You will need to 
work with your hosting provider or another service in order to have a system for accepting 
user data and then processing it in some way. You will learn more about this process a bit 
later in the lesson.

Building a contact form
In this lesson, you’ll build a contact form for OrganicUtopia. This form allows users to be 
added to a mailing list for news of sales and special events, and it provides the site owners 
with relevant data, such as name, email, and which information they would like to receive.

Inserting the <form> tag
The fi rst step in building a form in Dreamweaver is to add a form element, which serves 
as a container for the form fi elds you’ll be adding to it. In hand-coded HTML, you do 
this by inserting the <form> tag into your code. In the Design view, you can add a form 
element using the Form button.

1 Choose File > Open. When the Open dialog box appears, navigate to the dw13lessons 
folder. Select the formbase.html fi le and press Open. We have added most of the form 
content for you, but you will have to remove the placeholder text and add the proper 
form controls.

2 In the Design view, place an insertion cursor where you want your form to appear. 
Because this is an existing page, click with your mouse in the white area immediately 
to the left of the word Name.

Insert your cursor before the Name text fi eld label.

3 In the Insert panel on the right side of your screen, choose the Forms category from 
the drop-down menu to display options for adding form elements to a page.
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4 From the Forms category of the Insert panel, select the Form element ( ).

Options for adding form elements to a 
page are found in the Forms category 
of the Insert panel.

5 You should now see a red outline on your page. This is how a form is displayed in 
the Design view. If you don’t see this outline, choose View > Visual Aids > Invisible 
Elements to turn on the form element’s visibility.

A dotted red outline on your page indicates a placed form element.

Now you’ll take a look at the code generated by the steps you just completed in the 
Design view. This is for educational purposes to help you understand the foundations 
of how forms work.

6 In the Document toolbar just above your document window, click the Code view 
button to switch to your page’s HTML code view.
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Building a contact form

7 In line 214 of your code, you should see the newly added <form> element. Take note 
of the default attributes and values (ID="form1" name="form1" method="post" 
action=""). You’ll learn more about these attributes shortly. For now, simply note 
that these were created.

In HTML code, a form element is added using the <form> tag.

Since this form element is currently empty, you’ll need to move the existing content 
(Name, Address, and so on) from the current location on the page to the form element 
you just created. 

8 In the Document toolbar just above your document window, click the Design view 
button to switch to your page’s visual layout view.

9 Starting with the text labeled Name, click and drag downward to select all the text 
below your form element.

10 Choose Edit > Cut to copy the text to your clipboard and remove it from its current 
location on the page.

11 Click inside the red outline that represents your form element to place an insertion 
cursor there. 

12 Choose Edit > Paste to place the text from the clipboard into your form element.
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All the text for your element labels is now located inside the form element.

Cut and paste existing content from your page into the form element.

Setting form properties
As indicated previously, the <form> tag includes four diff erent attributes and values by 
default. These attributes are listed as ID, name, method, and action, and they represent 
the HTML form element’s properties. The default values for these attributes are not 
necessarily ideal, so you’ll modify them. 

1 Make sure the form element you added in the previous exercise is selected by clicking 
on the edge of its red outline. A form fi eld element must be selected before you 
modify its properties.

2 In the Property Inspector at the bottom of your document window, you now have 
access to some of the properties associated with the <form> tag.

The fi elds in the Property Inspector refl ect properties found inside the <form> tag in HTML code.

The Form ID makes it possible to identify and control the form with a script, as well 
as to style the form with CSS. It is also very important for form validation, which is 
discussed later in this lesson.

A form ID is the same ID attribute you have been using to style divs. This form, for example, 
would have the ID #form1 by default, which is not a useful name.
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3 In the Form ID text fi eld, type the name contact. Press Enter (Windows) or Return 
(Mac OS).

The Action fi eld allows you to specify the script, for example, a Common Gateway 
Interface (CGI) script or a PHP page, that processes the user’s form data. You can type the 
path to this fi le, or use the Browse button to navigate to the desired fi le. In most cases, 
you’ll need to get this information from your system Administrator or hosting provider.

4 Because you have not yet defi ned the processing method for this form, leave the 
Action text fi eld blank. 

5 For method, make sure the POST method for this exercise is selected, which it likely 
is by default.

The Method menu

The Method drop-down menu is where you choose the method used to transmit the data to 
a server. The Method drop-down menu includes the following choices:

Default uses the browser’s default setting to submit the form data to a server. Most browsers 
use the GET method by default.

GET includes the form data as part of the URL of the request to the server. GET has a 
length limitation of 8,192 characters in the URL and is less commonly used to send long 
forms than the POST method.

POST is similar to GET, but it embeds the form data in the header of the server request 
instead of in the URL. Although the POST method is the most commonly used, be aware that 
pages sent by this method cannot be bookmarked and are not encrypted for security purposes.

6 Choose application/x-www-form-urlencoded from the Enctype drop-down menu. The 
Enctype fi eld defi nes the encoding type of the data being submitted to a server. 
Application/x-www-form-urlencoded is used in most situations, unless you’re asking 
the user to upload a fi le, in which case you would choose multipart/form-data.

The optional Target property specifi es the window or frame in which to display the data that is 
returned. The target value is included in the <form> tag only when you choose to specify it.

Form properties are set in the Property Inspector.

Now that you’ve defi ned the properties of the form, you’ll use options in the Insert 
panel’s Forms section to add elements to the form.
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Adding form elements
A Dreamweaver form is not a working form until you add the elements, or fi elds, that 
allow the user to provide information to you. Thankfully, the Forms category in the Insert 
panel contains everything you need to insert any kind of form fi eld into your page.

The Forms category in the Insert panel 
contains everything you need to add 
interactive fi elds to your form.

Common form elements

Of the many form elements you can add using the Insert toolbar, these are the most 
commonly used ones:

Text fields accept alphanumeric text entries, in single- or multiple-line formats, or in a 
password (bulleted) format.

Checkboxes allow users to make as many choices as they want from a list of options.

Radio buttons allow only mutually exclusive choices in that selecting one radio button 
deselects all others in the group.

List menus permit the selection of single or multiple items from a scrolling list, whereas 
Jump menus allow you to set each option from a scrolling list to link to a document or file.

Buttons perform actions when clicked. You can assign the default Submit or Reset action to 
buttons, or define other processing tasks in a script.

A good way to understand all the options available in Dreamweaver for adding elements to a 
form is to add them to the form you created earlier.
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Adding text fields
The simplest and most common type of form fi eld is the text fi eld. Users can enter 
anything, from their name, to their credit card number, to their dog’s name, into a text 
fi eld. You control the formatting of their responses using the Property Inspector.

1 Within your form, click immediately to the right of the word Name.

2 Press the Text Field button ( ) in the Insert panel. The Input Tag Accessibility 
Attributes dialog box opens, allowing you to set attributes to make your form fi eld 
more accessible for users as well as whoever is receiving the data after submission.

Make your form more accessible by changing your settings here.

3 In the Image Tag Accessibility Attributes dialog box, specify the following:

In the ID section, type Mailing_list_name.

In the Style section, choose No label tag. The label element in a form provides 
additional usability for the user. You will take a look at how to use the label tag shortly.
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4 Press OK. A new text fi eld appears within the form outline on your page.

The settings you entered defi ne the look of the Name text fi eld as it’s 
added to your form.

5 If it’s not already selected, select the text fi eld by clicking on it, and notice the options 
that are available in the Property Inspector. 

6 Type 55 in the Char Width text fi eld to set the text input area to a width of 55 characters.

7 Type 30 in the Max Chars text fi eld to set the maximum number of characters that 
can be entered. For example, if this were a telephone number fi eld, you probably 
would have limited it to ten characters.

8 Choose Single Line from the Type options. Choosing the Password option would 
cause the user’s entry to appear as black dots, even though the correct value would be 
submitted to the server. The Multi-line option is discussed later, in the “Adding a text 
area” section.

9 Repeat steps 1 to 9 to add Address and City/State/Zip text fi elds beneath the Name 
fi eld. When creating the Address text fi eld, give it the ID Mailing_list_address and 
give the last text fi eld the ID Mailing_list_city_state_zip. When naming form 
elements, you should stay away from using spaces between words. It is better to use 
underscores or hyphens instead.

10 Choose File > Save As. In the Save As dialog box, navigate to the dw13lessons folder 
and type organicform.html into the Name text fi eld. Click Save.

Now preview the open page in a browser by pressing the Preview/Debug in browser 
button on the Document toolbar. Your form should look like this:

This is what your form should look like with text fi elds added.

11 Close the browser and return to Dreamweaver.
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Adding checkboxes
Checkboxes are another valuable tool in your form control toolkit. They’re valuable when 
you want to get specifi c responses from your users and you don’t want to give them the 
opportunity to enter incorrect information into text fi elds. Again, you control the formatting 
of their responses using the Property Inspector. In this exercise, you will take a look at the 
use of form labels as well as the importance of setting the names of your form elements.

1 Click and drag to select both the word Sales and the (Checkbox) placeholder text. 
Press Delete to remove it from your form and place an insertion cursor.

2 Click on the Checkbox element ( ) in the Insert panel. The Input Tag Accessibility 
Attributes dialog box opens.

3 In the Input Tag Accessibility Attributes dialog box, type Sales for ID, then type 
Sales for the Label. Choose the Wrap with label tag and make sure that Before form 
item is selected for the Position. The label tag is an optional element that adds an extra 
level of usability to your checkboxes. Users will now be able to click on the text (in 
addition to the checkbox) in order to make their selection. The Before and After form 
item options allow you to change the position of the checkbox.

4 Press OK. A new checkbox appears within the form outline on your page.

5 If it’s not already selected, click to select the checkbox, and notice the options that 
become available in the Property Inspector.

Settings that are specifi c to the checkbox you’ve just added to your form appear in the Property Inspector.

6 In the Checkbox name text fi eld on the left side of the Property Inspector, type 
Receive_Info and press Enter (Windows) or Return (Mac OS). It is important to 
understand what you are changing here. The name of the checkbox is diff erent from 
the ID of a checkbox. An ID is used to style an element, the name is what gets passed 
when the user presses submit. The problem is that Dreamweaver automatically sets the 
name based on what you enter for ID back in the Input Tag dialog box, however this 
is not always a good choice. In the case of checkboxes, you want all the checkboxes 
to have the same name. To do this you will need to override Dreamweaver’s default 
naming to make this fi eld accessible for scripting and validation.

7 Type Sales in the Checked value text fi eld to defi ne the data that’s passed to the server 
when the user checks this checkbox.

8 In the Initial State section, the value Unchecked should be selected; if it is not, do so 
now. This setting defi nes how the checkbox appears when the page is fi rst loaded.
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9 Next, select the word Events and the placeholder (Checkbox) text and delete them. 
Click on the Checkbox element in the Insert panel. In the Input Tag box, type Events
and for Label, type Events. Additionally, be sure that Before form item is selected for 
the Position and click OK.

10 Click on the checkbox and change the checkbox name to Receive_Info. Because this 
name is the same as the fi rst checkbox, users will be able to check both and have the 
values passed. In the Checked Value text fi eld, type Events and press Enter or Return.

11 Repeat steps 9 and 10 with diff erent values for the ID and Label to add a third 
checkbox for Charity Drives. Again, be sure to rename the checkbox, Receive_Info.

Now, preview the open page in a browser. Your form should look like this:

Your form, with checkboxes inserted, should look like this.

12 With the page open in the browser, click the text next to the checkboxes; notice that 
this action selects the box. This is a function of the label tag. Try clicking on the text 
of your Name and Address text fi elds. They do not have the same behavior because 
they do not have labels.

Labels improve accessibility for all users, in particular for those who may be using 
screen readers or other devices.

13 Close your browser and return to Dreamweaver.

Adding radio buttons
When you add radio buttons to your form, you encounter the same settings in the 
Property Inspector as you do when you add checkboxes. The only diff erence between 
checkboxes and radio buttons is that from a group of radio buttons, only a single option 
can be selected. Checkboxes allow the selection of multiple options.

To make two or more individual radio buttons mutually exclusive, you select two or more 
radio buttons and give them the same name in the Property Inspector.

Creating a group of radio buttons by adding buttons one by one is often more time-
consuming than it’s worth. Thankfully, Dreamweaver off ers a more effi  cient method for 
creating a list of mutually exclusive options: the radio group.
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Adding radio groups
The Radio Group element in the Insert toolbar provides a quick and easy way to add a list 
of radio buttons to your form. The same rules regarding naming and values apply, but the 
Radio Group dialog box allows you to include several entries in a group at once.

1 Click and drag to select the three (Radio Button) placeholders and their labels (Yes, 
No, and Can’t Remember). Press Delete to remove them from your form. You’ll 
create your own labels for this group.

2 Click on the Radio Group button in the Insert panel. The Radio Group dialog box 
opens, and off ers several property options.

Set properties for your radio group in the Radio Group dialog box.

3 In the Name text fi eld of the Radio Group dialog box, type Membership Status to 
give the group a name that associates all the radio buttons together.

You will now create a unique label for each button.

4 Click on the fi rst entry in the Label column and type Member. 

5 In the Value column of the Radio buttons section, you assign a value to each button to 
be passed back to the server. Click on the fi rst entry in this column and type member. 
This returns a value of member when the user clicks on the Member radio button.

6 Make sure Line breaks (<br> tags) is selected in the Layout using section at the bottom 
of the dialog box. This will place a hard return after each radio button.

7 Repeat steps 4 to 6, but this time create a label called Non-Member and a value of 
nonmember.
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8 Click OK. Choose File > Save, and then preview the open page in a browser. Click 
on each of the two radio buttons and note that only one radio button can ever be 
selected. This is a function of a radio button group: for cases where you want more 
than one option to be selected and returned, you could use a checkbox.

After adding the radio group, your form should look like this.

9 Close your browser and return to Dreamweaver.

Checkboxes can also be added as groups using the Checkbox Group option in the Insert panel.

Adding lists and menus
Lists and menus show choices within a list that permits users to choose single or multiple 
options. The List option displays as a scrolling list, and the Menu option displays as a drop-
down menu. As is the case with most form fi elds, you set the properties for lists and menus 
in the Property Inspector.

1 Click and drag to select the placeholder text—(List) Store Events, Planting Season, 
Anything—that follows your radio group. Press Delete to remove it from your form. 
You’ll create your own labels for this list.

2 Press the Select (List/Menu) button ( ) in the Insert panel. The Input Tag 
Accessibility Attributes dialog box opens. 

3 Type Volunteer in the ID text fi eld and leave the additional settings as is, then press 
OK. A new list or menu appears within the form outline on your page.
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4 Click the list menu control to select it, and notice the options that are now available in 
the Property Inspector.

Enter the settings for your newly added list or menu in the Property Inspector.

5 The Type options let you defi ne whether the fi eld is displayed as a scrolling list or a 
drop-down menu. Click on the List radio button to choose this option. Notice that 
more settings become available on the right side of the Property Inspector.

6 Type 3 in the Height text fi eld to set the number of items to be visible at any given 
time in the scrolling list.

7 Click in the checkbox to the right of the Selections option to allow multiple 
selections. With this feature activated, users can choose more than one option from 
your list at a time.

8 Click on the List Values button to enter items for your scrolling list. The structure of the 
List Values dialog box is identical to that of the Radio Group dialog box. Type Store 
Events as your fi rst Item Label and store_events for the fi rst value to be returned. 

Now you will add two more items to the list.

9 Click the Plus button (+) in the left corner of the List Values window, and type 
Planting Season as the second Item Label. Then click under the Events value and 
type plantingseason. Click the Plus button (+) again. Type Anything as the third 
Item Label, and, fi nally, click under the Planting value and type anyevent. Click OK.

Adding the labels and values for a list control.

10 Choose File > Save to save your work. Preview your page in the browser and 
click one of the labels to see how it is selected. Close your browser and return to 
Dreamweaver.
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Adding a text area
Sometimes within a Dreamweaver form, you want to have a fi eld that simply provides an 
open area into which users can enter text. For this form, you’ll add a Textarea element to 
provide a region for users to type in their comments about the site.

1 Click and drag to select the placeholder text, (Comments), and retype it without the 
parentheses, to use as a label for this fi eld.

2 Press Enter (Windows) or Return (Mac OS) to move your cursor to the next line.

3 Click on the Textarea element ( ) in the Insert panel. The Input Tag Accessibility 
Attributes dialog box opens.

4 In the ID text fi eld, type Comments. In the Style section, select Wrap with label tag.

5 Click OK. A new text area appears within the form outline on your page.

6 Click the text area, and notice the options that are now available in the Property 
Inspector.

7 Type 40 in the Char width text fi eld to set the text input area to a width of 40 
characters.

8 Leave the Num lines text fi eld set to 5, and leave Type set to Multi line. 

9 Leave the Init Val and Class settings at their defaults and choose File > Save; then 
preview the open page in a browser. The text area will allow users to type inside 
of the box, and if the amount of text goes below the bottom of the text area, then a 
scrollbar will automatically appear.

The form so far, as rendered by Mozilla Firefox.
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Adding a File Upload field
If you want users to be able to upload a fi le to your server—for example, a photo for ID 
purposes—you’ll want to add a File Upload fi eld.

1 Close the browser and return to organicform.html in Dreamweaver. Click and drag to 
select (Upload), and delete it to place an insertion cursor next to your label.

2 Click on the File Field button ( ) in the Insert panel. The Input Tag Accessibility 
Attributes dialog box opens.

3 In the Input Tag Accessibility Attributes dialog box, type fi lefi eld for the ID. 
Additionally, make sure the Wrap with label tag fi eld is selected.

4 Click OK. A new fi le fi eld, with the Browse button included, appears within the form 
outline on your page.

5 Click to select the fi le fi eld, and notice the options that become available in the 
Property Inspector.

6 Type 30 in the Char width text fi eld to set the text input area to a width of 30 
characters.

7 Type 30 in the Max chars text fi eld to set the maximum number of fi lename 
characters that can be entered.

Set the properties for your File Upload fi eld in the Property Inspector.

8 The Class drop-down menu allows you to apply CSS to style this form fi eld. Using 
CSS to style form fi elds is discussed in more detail later in this lesson.

You are now fi nished with the fi le fi eld section of your form. Users can now either 
enter the desired fi le name or click Browse to navigate to it.

For the fi le fi eld element to actually upload a user’s fi le to your server, you’ll need to ask your 
server Administrator how the server is confi gured to accept fi les.
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9 Choose File > Save, then preview the open page in a browser. Your form should look 
like this:

You’re almost fi nished adding form fi elds to your form.

10 Close the browser and return to Dreamweaver.

Creating Submit and Reset buttons
As you might expect, none of the fi eld elements you’ve been adding to your form do any 
good if the user doesn’t have a way to send the information to you. Buttons provide the 
means for the user to either submit form data, or reset the fi elds and start over.

1 Place your cursor after the Upload fi eld, then press Enter (Windows) or Return 
(Mac OS) to specify where you want your button(s) to appear.

2 Click on the Button element ( ) in the Forms category of the Insert panel. The Input 
Tag Accessibility Attributes dialog box opens.

3 In the dialog box, specify the following:

In the ID section, type Submit.

In the Style section, choose No label tag.

4 Click OK. A new button, labeled Submit by default, appears within the form outline 
on your page.
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5 If it’s not already selected, click to select the button, and notice the options that are 
now available in the Property Inspector.

Button properties are set in the Property Inspector.

6 The word Submit is displayed in the Value fi eld as well. You could change this value to 
a more user-friendly name if you wanted such as Send, however for now you’ll leave it 
as is.

7 The three options in the Action section specify the action carried out when the user 
clicks this button. Select the Submit form radio button in the Actions section. Submit 
and Reset form are self-explanatory, but the None option builds a generic button that 
you can set to trigger a JavaScript behavior, which is discussed later in this lesson.

8 The Class drop-down menu allows you to apply CSS to style this form fi eld—another 
technique that is covered later in the lesson.

9 Repeat steps 1 to 9 to add Reset and Validate buttons next to the Submit button. 
Choose Reset from the Action section in the Property Inspector for the Reset button, 
and None for the Validate button. Additionally, you will need to type Validate in the 
Value fi eld to change the default value. 

The Submit, Reset, and Validate button are now placed in the form.

10 Choose File > Save All to save your work.

Now that you’ve fi nished adding the necessary form fi elds to your Contact Form page, 
you’ll add style to the form and its elements, using CSS.
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Styling forms with CSS
In Lesson 4, “Styling Your Pages with CSS,” you explored the many ways you can use 
CSS to format text and position content on an HTML page in Dreamweaver. However, 
the usefulness of CSS is not limited to static page content. Dynamic content, such as form 
fi elds, can also be successfully and creatively styled using CSS.

Attaching external styles
This exercise assumes you have already learned some of the basics of working with styles 
covered in previous lessons. You will now focus on applying some existing styles to the 
form elements that you’ve added in this lesson. The styles you apply have been created for 
you, but you must attach them to your form page in order to access them.

1 If your CSS Styles panel is not currently open, open it now by choosing Window > 
CSS Styles.

2 In the CSS Styles panel, click on the Attach Style Sheet button ( ) in the lower-right 
corner of the panel. The Attach External Style Sheet dialog box opens.

Select the CSS fi le you want to attach using The Attach External Style Sheet dialog box.

3 Next to the File/URL fi eld, click the Browse button and select formstyles.css from the 
dw13lessons folder. Press OK (Windows) or Open (Mac OS) to exit the Select Style 
Sheet File dialog box. 

4 In the Attach External Style Sheet dialog box, click the Link radio button to create a 
link <href> tag in the code for this page, and reference the location of the published 
style sheet. Most major web browsers support the link method.

5 In the Media drop-down menu, you can defi ne the target medium for your style 
sheet. For this exercise, leave this setting at its default, which is blank.

For more information on media-dependent style sheets, see the World Wide Web Consortium 
(W3C) website at W3.org/TR/CSS21/media.html.

6 Press OK to attach the style sheet to this document.

DWCS6_06Pass.indb   334DWCS6_06Pass.indb   334 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


13

335Lesson 13, Building Web Forms

Styling forms with CSS

Setting a background color
Once the formstyles.css style sheet is attached, the backgrounds of your form fi elds change 
to a light blue color. This happens because formstyles.css contains a tag selector rule, 
which instructs the <form> tag you added earlier in the lesson to include a background 
color. The rule redefi nes the <form> tag, so the color is applied only to the background of 
the form fi elds themselves, and not to the entire body of the page.

The formstyles CSS contains a rule that specifi es a background color.

A major benefi t of using CSS is that once you complete the initial styling, you can revisit 
the CSS fi le and change the included style rules. Because the blue background doesn’t fi t 
in with the color scheme of your site, you’ll edit the form rule to change the background 
to a light gray.

1 In the CSS Styles panel, click the All button (if necessary) to show all styles attached 
to this document. Locate formstyles.css in the list of All Rules, and expand it by 
clicking on the Plus button (+) (Windows) or triangle button ( ) (Mac OS) to the left 
side. (You can collapse the <style> tag and the SpryMenuGarHorizontal.css style 
sheet to make more room in the panel.)
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2 From the list of style rules included within formstyles.css, click on the input rule to 
select it for editing.

Selecting the input style in your 
formstyles.css style sheet reveals the 
style being used.

3 Double-click the input style. The CSS Rule Defi nition dialog box opens.

4 Select the Background category to the left, and, in the Background color text fi eld to 
the right, type the hexadecimal code #d7d7d7, to replace the current color.

You’ve successfully changed the background color of your form fi elds by editing an attached CSS.

5 To preview the change to the background color, press Apply. Press OK.

You’ve just used a tag selector CSS rule to change the background color of your form. 
Next, you’ll use a class style to change the appearance of the labels on your form fi elds. 
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Styling form elements
You may have noticed another CSS rule included in formstyles.css along with the <form> 
defi nition. It’s a class style called .labels, and it contains properties that change the font, 
color, and weight of your form fi eld labels.

1 In the CSS Styles panel, click the .labels CSS rule to select it; in the bottom half of 
the panel, you can see the properties currently set for the class.

The font-family has been changed to Arial, Helvetica, sans-serif.

The font-weight is set to bolder.

The color has been set to a hexadecimal notation of #9FCC41, or green.

The .labels rule can also be edited in the 
CSS Styles panel.

You’ll now apply this style.

2 In the document window, click anywhere within the Name label, which precedes the 
fi rst text fi eld in your form.
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3 In the Property Inspector, click the HTML button if necessary; click the Class menu 
and choose labels from the list. Because the Name, Address, and City/State/Zip are all 
within the same paragraph, the style will be applied, making them all green. 

The .labels class applied to your form.

These are just a few of the ways you can use CSS to style form elements. Experiment 
further with diff erent properties to make your form more visually pleasing.

Form processing and validation
As attractive as CSS styling can make your form in Dreamweaver, you can’t collect form 
data without using a server-side script or application (for example, CGI, PHP, ASP) to 
process the data. 

CGI scripts are perhaps the oldest method of server-side scripting used to process form 
data. Several websites off er free CGI scripts that you can use. The hosting company for 
your website may also provide CGI scripts that perform many common tasks, such as 
collecting e-mail addresses or allowing visitors to send you comments through a web form. 
Other methods include the use of other scripting languages, such as PHP, ASP, and others. 
It is beyond the scope of this book to cover all the various ways to process form data.

It’s also worth noting that form validation, a method for ensuring that the user has entered 
the correct type of data in the form’s fi elds, also requires scripting to work correctly. 
Thankfully, Dreamweaver is capable of adding JavaScript code that checks the contents of 
specifi ed text fi elds. This code is added through the use of the Validate Form behavior.
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Adding form validation
The Validate Form behavior provides checks and balances for users when they complete 
forms on your site. You can make certain fi elds required, make sure a user has entered a 
value in a required fi eld, or make sure a user has entered the correct type of information in 
a fi eld. You can run validation on all fi elds in a form, or on individual fi elds contained in 
that form.

The fi rst step, however, is to get to know the Behaviors panel.

A look at the Behaviors panel
Generally speaking, the Behaviors panel provides a means for you to add JavaScript 
code to your page without actually having to type in the code. The code it inserts adds 
interactivity to your site, and is usually triggered by some user action. For example, when 
the user clicks on or hovers over a link, the behavior performs a task. Behaviors are hardly 
limited to use with forms, as they’re commonly used to add rollovers, open new windows, 
check for plug-ins, and add navigation elements, among other functions.

Specifi cally, you use the Behaviors panel to add, modify, and remove behaviors. Because 
you can apply multiple behaviors to the same object, you can also reorder them in the 
Behaviors panel.

1 Access the Behaviors panel by choosing Window > Behaviors. It docks with the 
Tag Inspector panel on the right side of your screen. If necessary, expand the panel 
grouping and click on the Behaviors tab to bring it to the front.

The Behaviors panel.
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2 In the document window, click the Validate button you created earlier. You need to 
attach a behavior to objects on your page. For this exercise, the object you need to 
attach a behavior to is the Validate button.

3 Click the Plus button (+) at the top of the Behaviors panel to see the list of available 
options for the selected object. In this case, the menu displays options associated with 
a button element. If an option is grayed out, that action is not available for the selected 
object.

The list of available behaviors for your selected button element.

4 Select the Popup Message action. The Popup Message dialog box appears.

5 Type Validate this form! into the Message text fi eld, and click OK.

Enter text into the Popup Message dialog box to have it appear on the screen.

The behavior is set, but it needs an event, or trigger.
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Setting an event or trigger
An event (or trigger) is generally a specifi c user action needed for the Popup Window (or 
other behaviors) to work. In this case, you’ll set the window to appear when the user clicks 
the Validate button.

1 In the top-left corner of the Behaviors panel, click on the Show All Events button ( ). 
The Show All Events button provides a complete list of all possible triggers for this 
behavior.

There are a number of choices for the 
event that triggers your specifi c behavior.

In this case, the default option “onClick” is the correct choice.

2 Choose File > Save All and preview your page in a browser.

3 Press on the Validate button at the bottom of your form. The popup message you set 
earlier appears.

Use this feature to warn your viewers, 
or to guide them in a certain direction.

Depending on the security confi gurations of your browser, you may be prompted to allow blocked 
content. If you’d like to change your preferences to avoid confl icts with scripts created in the Behaviors 
panel, refer to your browser’s documentation for instructions on changing the default settings.
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4 Press OK to close the message, and close your browser window and return to 
Dreamweaver.

To further explore the Behaviors panel and its features, you’ll add a Form Validation 
behavior to the same button.

Validating form fields
The Validate Form action allows you to prevent the submission of a form unless a certain 
fi eld (or fi elds) is fi lled in by the user. You’ll apply this action to the Validate button you 
created.

1 In the document window, select the Validate button at the bottom of your form. The 
Behaviors panel should display the Popup Message action you added in the last exercise.

2 At the top of the Behaviors panel, click the Plus button (+), and select Validate Form 
from the drop-down menu that appears. The Validate Form dialog box opens. 
Dreamweaver automatically identifi es the fi elds you have used on the page and lists 
them in the fi elds section.

3 Choose “Mailing_list_name,” the fi rst entry in the Fields list. Click the Required 
checkbox to require data entry into this fi eld before the user can submit the form.

4 Click the Anything radio button so the fi eld accepts any alphanumeric entry. If you 
want to require that only numerical data be entered, you would select the Number radio 
button. If you want to check for an @ symbol within the entered data, you would click 
the Email address radio button. Finally, if you want to check for a number within a 
specifi c range, you could enter that range in the Number from and to fi elds.

Specify which form elements get validated, and what is accepted.

5 Click OK to close the Validate Form dialog box.
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6 Choose File > Save, then preview the form page in your browser. Leave the Name 
fi eld blank, and click on the Validate button at the bottom of your form.

Unfortunately, the Popup Message behavior you added earlier runs before the Validate 
Form behavior, requiring you to close the Popup Message window to see the results of 
your validation. After you dismiss the Popup Message you will see the error message 
stating that the Mailing list name is required. 

This means you have just a little more work to do; you’ll now adjust the Validate Form 
behavior to correct these errors.

Changing a form field’s behavior order
To keep the popup message from appearing before the results of your validation, you’ll 
need to change the Validate Form behavior’s position in the behavior order, delete it, and 
reapply it to the correct button.

1 In the Dreamweaver document window, click on the Validate button to select it. 

2 Click the Show Set Events button in the Behaviors panel to toggle over to this view 
(if necessary). You will now see your two actions, Popup Message and Validate Form, 
which share the same event, or trigger.

Use the Behaviors panel to reorder behaviors 
and make them behave diff erently for the viewer.

3 Click on the Validate Form behavior to select it, and click the up arrow at the top of 
the panel to move it to a position above the Popup Message behavior. Although this 
makes the Validate Form action run fi rst, the popup message still appears after the 
validation window is closed. It actually makes more sense not to have the Validate 
Form behavior attached to the Validate button at all. You will now remove this 
behavior and attach it to the Submit button instead.
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4 Click on the Minus button (–) to delete it from the behaviors associated with the 
Validate button.

5 Click on the Submit button at the bottom of your form to select it. Repeat steps 2-4 
in the preceding exercise to add the validation action to the Submit button.

Now it’s time to see the fruits of your labor.

Verifying field contents
Now that you’ve adjusted the Validate Form behavior, you’ll need to make sure the form 
functions as you expect it to.

1 Preview the open page in your browser, and click on the Validate button. This should 
now display only the popup message. Close it.

2 Click on the Submit button. Even though the data is not actually submitted (for lack 
of a CGI script), the Validate Form warns you that required fi elds have not been fi lled.

The Validate Form behavior functions as 
you originally intended, thanks to some 
editing in the Behaviors panel.

You’ve successfully added validation to your form, and completed this lesson in the 
process. Congratulations!

For a more detailed look at adding modern forms to a website, see the HTML5 Digital 
Classroom book available in electronic and print formats.
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Review 

Self study
Using your new knowledge of building and editing web forms in Dreamweaver, try some 
of the following tasks to build on your experience:

Edit the Validate Form behavior you applied to the Submit button in the last exercise. 
Apply validation to the other text fi elds in your form, providing checks for the specifi c 
content to be fi lled out in each fi eld. Preview the page in your browser to ensure that the 
validation works. 

Create an internal CSS that redefi nes the <input> tag. Set the background color of each 
form fi eld to light green to match your page’s color scheme. Experiment with the other 
styling options available to you in the CSS Rule Defi nition dialog box to further style 
your form elements.

Explore the other form fi eld elements in the Forms category of the Insert toolbar. Add a 
hidden fi eld to return the creation date of the form when it is submitted, while keeping 
this information hidden from the user. Add an Image fi eld to turn a placed image into a 
button with a behavior attached. Group your form fi elds into labeled sections, using the 
Fieldset button.

Review 
Questions
1 Why is it important to add a form element when building a web form in Dreamweaver?

2 When should you use a radio button group, as opposed to a set of checkboxes, in a form?

3 How does CSS add creativity and effi  ciency to the form creation process?

4 What do you need in order to collect the form data that a user enters into your form?

5 Where would you access the diff erent JavaScript actions that can be applied to a button 
in Dreamweaver?

Answers
1 The form element serves as a container for the fi elds you’ll be adding to the form. If 

you simply add form fi elds to a page in Dreamweaver, the user’s browser won’t know 
what to do with the user’s information when they click the Submit button. To identify 
this information as part of a package, and to specify the route that information should 
take when submitted, you need to create a Dreamweaver form.

2 The diff erence between adding checkboxes and radio buttons in a form is that from 
a group of radio buttons, only a single option can be selected. Checkboxes allow the 
selection of multiple options. 
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3 Because CSS allows you to apply several formatting attributes with a single mouse 
click, both static and dynamic content (such as form fi elds) can be successfully and 
creatively styled using CSS. CSS also streamlines your workfl ow by allowing you to 
revisit CSS fi les and change the included style rules once you’ve completed the initial 
styling.

4 You can’t collect form data without using a server-side script or application such as 
CGI, JSP, or ASP to process the data. CGI scripts are the most popular form of server-
side scripting mechanism to process form data. Several websites off er free CGI scripts 
that you can use. Your site’s ISP may also provide CGI scripts for you.

5 The Behaviors panel provides a means for you to add JavaScript code to your page 
without actually having to type in the code. The code it inserts adds interactivity to 
your site, and is usually triggered by some user action. For example, when the user 
clicks on or hovers over a link, the behavior performs a task. Behaviors are commonly 
used to add rollovers, open new windows, check for plug-ins, and add navigation 
elements. You use the Behaviors panel to add, modify, remove, or reorder behaviors.
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What you’ll learn in 
this lesson:
• The basics of the Spry 

Framework

• Adding a Spry Menu bar

• Customizing a Spry Widget 
with CSS

• Adding a Spry Tabbed Panel

• Adding a Spry Collapsible 
Panel

• Working with the Spry XML 
data set

Lesson 14

The average user’s expectations of how a website looks and feels 
has changed signifi cantly over the years. Highly interactive websites 
that function more like traditional desktop applications are becoming 
more the norm. Dreamweaver CS6 includes Spry Widgets and 
Data Objects: a library of interactive menus, animated user interfaces, 
and XML-driven containers that can be added to your projects and 
customized to take your pages to the next level.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw14lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw14lessons folder. Go 
to Site > New Site, or, for details on creating a site, refer to Lesson 2, “Setting Up a New 
Site.”

Adding Interactivity 
with the Spry Framework
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See Lesson 14 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Introducing the Spry Widgets
Introduced in Dreamweaver CS3, Spry Widgets give you the ability to create powerful, 
interactive navigation and user interface elements with easy-to-use insert bar objects. 
Spry Widgets include drop-down and accordion menus, expanding panels, and tabbed 
containers, all of which harness the power of CSS for easy customization and styling to 
match any project. They are a great way to enhance navigation, organize content, and add 
dynamic style to your web pages.

In addition, the Spry framework off ers a set of data elements and display items that allow 
you to create dynamic page content that can read from an XML fi le. You can fi nd the Spry 
Widgets in their own category on the Insert panel, and within the Layout category as well.

The Spry framework for AJAX
Developed by Adobe, Spry is a JavaScript library and features data-driven and interface 
elements that can be easily added to a page and customized. Many of these elements can 
incorporate real-time data from XML or HTML fi les. These can be integrated into your 
existing pages to add features not available with HTML alone.

What is AJAX?
AJAX is an acronym for Asynchronous JavaScript and XML, and represents a combination 
of technologies: JavaScript, XML, and DHTML (more commonly referred to as DOM 
Scripting). AJAX is used to develop what is sometimes referred to as Rich Internet 
Applications (RIAs). RIAs are a great example of how the Web continues to evolve and 
progress beyond the static web page. RIAs exchange data behind the scenes and can easily 
update the appearance and display of the web page without the need to reload the page 
over and over again.

A great example of an RIA is Google’s Gmail, which has the ability to update messages, 
create online chats, and retrieve address book contacts in real-time without the need to go 
to another page or even reload the existing one. Here, AJAX is used to send and retrieve 
XML-based data behind the scenes and updates the appearance and information on the 
page in real-time.

14
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A look at the project

A look at the project
In this lesson, you’ll be completing the OrganicUtopia home page by using and 
customizing diff erent Spry Widgets. Before you get started, take a look at the completed 
version of the page to get an idea of what you’ll be working toward.

If you haven’t already created a site defi nition for this lesson in Dreamweaver, follow the 
instructions in Lesson 2, “Setting Up a New Site,” to do so before moving ahead.

1 In the Files panel, locate the index_done.html page, and double-click it to open it.

2 To view the Spry Widgets in action, choose File > Preview in Browser, and select 
a browser to preview the page. Depending on which browser you are using, you 
may see a message indicating that scripts are being blocked. Press the Allow Blocked 
Content button to allow the scripts to be run.

The completed Spry page contains numerous interactive elements.

3 With the page open in a browser, move over the Navigation bar at the top. Notice that 
hovering over each menu item expands it to reveal more menu items. 

4 On the right, click on the accordion-style menu to expand and contract diff erent 
categories of products. 

5 In the center of the page, locate the three tabs labeled featured, what’s new, and 
testimonials. Click on each one to reveal a diff erent content area—notice that the page 
doesn’t refresh when you do this.

6 In the lower-right corner, click the Contact Us bar to reveal a signup box.

7 Close the browser and return to Dreamweaver. Then, choose File > Close to close the 
current fi le.
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The Spry Menu bar
In Lesson 6, “Advanced Page Layout,” you created your navigation bar from scratch using 
an HTML list styled with CSS. However, imagine that you are asked to create a more 
interactive menu, one which activates a drop-down menu of the sub-categories of your 
site. Although this is possible to do using CSS with perhaps some help from JavaScript, it is 
not necessarily easy or fast. The Spry Menu bar creates a multi-tiered horizontal or vertical 
menu that can be easily added as a master navigation element in your page(s). These menus 
are easy to add, and the Spry Menu bar is a great alternative.

The Spry Menu bar can be added from the Insert panel and customized using the Property 
Inspector and CSS Styles panel. 

1 From the Files panel, locate and open the index_start.html fi le for editing. 

2 Choose File > Save As, and save the page as index_work.html into your site’s root folder. 

If you can’t locate your current site folder, click the Site Root button at the bottom of the Save As 
dialog box to automatically locate and set it as your save location.

3 At the top of the page, locate the div with the placeholder text that reads {menu bar 
here} and select the text. 

Locate the placeholder text where the menu bar will go.

Now, delete the text, and be sure to leave your cursor in its place.

4 Open the Insert panel if necessary, and then select the Spry category from the drop-
down menu at the top to display the Spry data objects and widgets.
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The Spry Menu bar

5 Click the Spry Menu bar icon to insert a new menu bar at your cursor position. Choose 
Horizontal from the dialog box that appears, and click OK to add the menu bar to your 
page. The bar will be added with four generic navigation items as well as the default Spry 
Menu bar style which is a light grey background and black text. You will be restyling the 
appearance of the menu a bit later, but fi rst you need to add new menu items.

The inserted Spry Menu bar.

To select an entire widget and make it active in the Property Inspector, click the blue tab that 
appears above its top-left corner.

6 The Property Inspector now displays all the options for the new widget. This includes 
three columns, each of which represents a new level of navigation for a drop-down 
menu. Locate the leftmost column, which lets you add and customize the top level 
links on the menu bar. Select the fi rst item titled Item 1.

7 Locate the Text fi eld on the right side of the Property Inspector. Type the name 
Home to rename the item. Press Enter (Windows) or Return (Mac OS).

Use the Property Inspector to modify and rearrange menu bar items and links.

8 Repeat steps 6 and 7 for Item 2, Item 3, and Item 4, renaming them Products, 
Services, and Contact Us, respectively.

This covers the top level navigation for now; next, you will quickly add two more 
levels to your navigation. For each top-level menu item, you can add up to two 
additional tiers of menus.

9 Select the Products link in the leftmost column on the Property Inspector. 

Locate the plus sign above the second column, and click it to add a new submenu item. 

Add a second level to the menu by clicking the plus icon in the second column.

DWCS6_06Pass.indb   351DWCS6_06Pass.indb   351 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


14 The Spry Menu bar

Dreamweaver CS6 Digital Classroom352

Locate the Text fi eld on the right, and rename the new item Gourmet Foods. Press 
Enter/Return.

10 Click the plus sign above the second column twice more to add two new submenu 
items. Rename them Lifestyle and Beauty. Next, you’ll add a third tier by creating a 
submenu for the Lifestyle link you just added.

11 Select the Lifestyle link in the center column. Locate the plus sign above the rightmost 
column, and click it twice to add two new submenu items to the Lifestyle link.

12 Select each of the new items and use the Text fi eld on the right side of the Property 
Inspector to rename them Furniture and Accessories, respectively. Press Enter/
Return. In addition to adding levels, you can delete them as well. Your fi rst link to 
Home has three sub-items that Dreamweaver added by default. You will delete them 
as they don’t refl ect your site structure.

13 In the leftmost column, select the top-level link named Home. Click on Item 1.1 and 
then press the minus icon to remove this link. Repeat this step for Item 1.2 and Item 
1.3 so there are no sub-items.

You’ll now reorder some of the items in the Services menu.

14 In the Property Inspector, click on the Services link and then press the up arrow. This 
moves the item up one level and Services is now the second category.

Use the up and down arrows above the fi rst list to re-order the top-level links to set the fi nal order.

15 Choose File > Save to save your page. The Copy Dependent Files dialog box appears 
to let you know that fi les will be copied to your site directory to support the new 
menu. Click OK to save the page.

Spry Support Files

The first time you save a page that includes a Spry Widget, you are prompted to save new and 
necessary files to your site. If you look at your Files panel, you will notice that a new Spry 
Assets folder has been added to your site files. This folder contains essential JavaScript, CSS, 
and image files that style your new widget and make it work. Be sure to copy this folder to your 
web server when publishing your site—your widgets will not work without it.

16 Press the Live View button on the Document toolbar to test your new menu. Mouse 
over each menu item to see the rollover eff ects and submenus you created. Press the 
Live View button again to return to your editing view. 
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Customizing Spry Widgets with CSS 

Customizing Spry Widgets with CSS 
Now that you’ve added a new Spry Menu bar and customized the navigation options, 
you’re ready to start giving it some style. Each new widget added to your page includes its 
own, attached CSS fi le that you can modify to have your new menu match the look and 
feel of your site. All CSS rules can be managed from the CSS Styles panel just like your 
existing page styles.

1 Locate and, if necessary, expand the CSS Styles panel. Double-click the Insert panel to 
collapse it and give yourself more screen space. You have two groups of CSS styles in 
this page: styles.css is the external style sheet that contains the majority of the styles for 
the page, and SpryMenuBarHorizontal.css is the external style sheet for just the menu 
bar. Click the All tab to locate the attached SpryMenuBarHorizontal.css style sheet, 
and expand it to view all its rules. 

Click the minus sign (Windows) or down arrow (Mac OS) to the left of styles.css to 
collapse this list and view only the Spry menu styles.

A new style sheet has been attached to 
your page that controls the formatting 
of the Spry Menu bar.

There are more than a dozen style rules for this menu; you will now modify a few 
of them in order to match your page design. A word of warning: the style names for 
these menu items are very similar and long, so you will need to pay careful attention 
to which style you are modifying. It may help you to expand the width of the CSS 
Styles panel in order to see the style names.
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2 Select the ul.MenuBarHorizontal rule to view its properties. This rule controls the 
overall appearance and size settings for the menu bar.

Click Add Property to add a new CSS rule.

3 Click Add Property at the bottom of the existing property listing. An empty fi eld 
appears with a menu to the right.

Note that depending on your workspace you may need to expand the Properties 
section of the CSS Styles panel to see the properties.

4 Click on the drop-menu and scroll down the resulting list to select the font-family 
property. This triggers a new fi eld to the right. Click on this drop-menu and choose 
the Verdana, Geneva, sans-serif family.

5 Locate the font-size property, which has a default value of 100%. Click the 100% value 
and type 11, then click the rightmost drop-down menu and choose px for the unit 
value. This will have the eff ect of making the entire menu bar slightly smaller.
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Customizing Spry Widgets with CSS 

6 Select the ul.MenuBarHorizontal a rule to view its properties. In the Properties 
section, click on the value for background-color (#EEE) and type #88B036 
(green) as the new color and press Enter (Window) or Return (Mac OS). This sets 
the background color of the menu bar which happens to be the same shade as the 
navigation div.

Modify the background-color property of the rule 
to change the appearance of the menu bar items.

7 Click the color swatch (currently set to #333) under the color property and change 
the color to #FFFFFF (white) and press Enter (Window) or Return (Mac OS). This 
changes the color of the hyperlinked text on each menu item.

8 In the list of rules, select the 

ul.MenuBarHorizontal a.MenuBarItemHover, ul.MenuBarHorizontal 
a.MenuBarItemSubmenuHover, ul.MenuBarHorizontal 
a.MenuBarSubmenuVisible rule 

to view its properties. This rule controls the appearance of linked menu items as you 
roll over them in the menu; it is currently set to a dark blue.

Because this long CSS rule will be diffi  cult to locate in the panel, you can count upward from 
the bottom of the rules. It is the seventh from the bottom and the default background color is 
#33C (blue).

9 Click the color swatch under the background-color property and type #9FCC41 
(light green) as the new color. 
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10 Click the Live View button on the Document toolbar to test your page and see the 
new style changes you’ve made. 

Use Live View to preview the style changes and interactivity on your new menu.

11 Click Live View again to return to the standard view. Choose File > Save All to save 
your project. You’ll now take a look at another navigation element: the tabbed panel.

The Spry Tabbed panel
The Spry Tabbed panel widget organizes content into several panels that you can toggle 
between by clicking on tabs. This is a great way to organize items on a page: it saves space 
and can improve usability when used correctly. 

Editing the content of the tabbed panels is a bit easier to edit than the Spry Menu bar, 
instead of using the Property Inspector to add and modify content, you can type directly 
within the tabs or containers in the document window. Tabbed panels can contain almost 
any type of content, including text, images, video, and Flash movies.

You’ll now add a Spry Tabbed panel to your page to display three pieces of featured content.

1 Near the top of your page, select the placeholder text that reads {tabbed panels here}, 
and delete it. Leave your cursor at this position.

2 Click the Insert panel if necessary to expand it. Locate and click the Spry Tabbed 
Panels button and click it to add a new tabbed panel set.

Add a new Spry Tabbed Panel at the top of the page, as shown.

DWCS6_06Pass.indb   356DWCS6_06Pass.indb   356 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


14

357Lesson 14, Adding Interactivity with the Spry Framework 

The Spry Tabbed panel

3 Locate the Panels column in the center of the Property Inspector below. This shows 
you the current panels (and tabs) in your panel set, and lets you add new ones. Click 
the plus sign at the top of the column to add a third tab to your panel set.

The new tab is out of order, so press the down arrow in the Panels section to move 
Tab 3 to the bottom of the list.

4 In the Property Inspector, click Tab 1 to activate it. On the page and within the tab, 
select the text “Tab 1”and type What’s New in its place. 

Select the text inside Tab 1 and rename it to What’s New.

5 Select the text within Tab 2 and type Featured. Select the text within Tab 3 and type 
Customer Testimonials. Be careful as you move from one tab to the next: if the eye 
icon appears and you click it, the tab will open up. For now, you just want to rename 
the tab headings.

Next, you will add content into the areas inside each tab.

6 Below the tabbed panel, you’ll see three paragraphs of content that you’ll move and 
organize into the new panel group. Highlight the entire fi rst paragraph, beginning 
with the headline Shop In the Green and be sure to include the recycle bag image. 
Choose Edit > Cut.

7 Select the placeholder text within the fi rst tab (Content 1), then choose Edit > Paste to 
paste the content directly into the What’s New panel. You will now place content into 
the Featured panel.
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8 Place your cursor over the Featured tab but don’t click yet. 

Clicking the eye icon will bring that tab to the front.

9 Wait for the eye icon to appear and then click once to bring the tab to the front.

10 Select the Featured Stuff ! heading, paragraph and the image of the couch and choose 
Edit > Cut. Select the placeholder text Content 2 and then choose Edit > Paste.

11 Repeat steps 7, 8, and 9; cut the remaining content (Our loyal customers) from the 
page and paste it into the third panel (Customer Testimonials).

12 Click the Live View button on the Document toolbar to preview the tabbed panel so 
far. Click each of the three tabs in order to view the contents of each. 

Your new Spry Tabbed panels set after moving the page contents to each of the three tabs 
(shown in Live View).

Click the Live View button again to return to Design view. Now it’s time to style this 
panel to match your page theme.

If you want to change which panel is open by default, you can use the Default Panel drop-down 
menu on the Property Inspector to determine which tab and panel are loaded fi rst.
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13 In the CSS Styles panel, locate and expand the style sheet named SpryTabbedPanels.css, 
which was attached when you added the tabbed panel group. Like the Spry Menu bar, 
the tabbed panel has a dedicated style sheet that you can modify to change its appearance.

14 Select the rule named .TabbedPanelsTab to display its properties. Click on the 
background-color value, and type #88B036 (dark green)., then press Enter (Windows) 
or Return (Mac OS). This changes the color of the non-active tabs.

Modify the .TabbedPanelsTab rule to change the 
appearance of non-active tabs.

15 Select the rule named .TabbedPanelsTabSelected. Click on the background-
color value, and type #CF9 (light green), then press Enter/Return. This changes the 
color of the currently selected tab.

16 Select the rule named .TabbedPanelsContentGroup. Click on the background-
color value (#EEE) and type #CF9 and press Enter/Return. This sets the background 
color of the entire panel to the same shade of green as the tab.

The panels height is currently being defi ned by the amount of content. If you wanted 
to override this, you could set an explicit height for the panels.
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17 Still within .TabbedPanelsContentGroup, click Add Property at the bottom of 
the properties list; this adds an empty fi eld. Click the drop-down menu to the right 
and choose the height property. In the new fi eld that appears, type 250 (make sure 
px is specifi ed) and then press Enter/Return. This increases the overall height of the 
content panels.

You can override the height of the panels by modifying 
the .TabbedPanelsContentGroup style.

18 Choose File > Save All. Then preview your page in the browser to see your tabs in 
action. The copy dependent fi les dialog box will appear. Click OK to accept. There 
are a few other styles that you could modify here, but for now, you’ll move on to the 
next Spry Widget: the Accordion Panel.

The Spry Accordion panel
At fi rst glance, the Spry Accordion panel resembles a standard vertical menu bar. As the 
name suggests, however, each item contracts and expands to reveal a content panel where 
you can add text and images. The accordion panel allows you to have only one panel open 
at a time. 

Accordion panels are great for navigation, tree-style navigation or lists, or organizing 
related content (such as a Frequently Asked Questions list) into a clean, panel-style format. 
As with the other Spry Widgets, the Spry Accordion uses its own style sheet, which you 
can easily modify to make it match your current theme. 

1 In the right-hand column, locate the placeholder text that reads {accordion here}. 
Select and delete the placeholder text, and leave your cursor in place.
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2 From the Insert panel, click and add a new Spry Accordion at the cursor position. 

The Spry Accordion added to the sidebar.

The Property Inspector below now displays the properties for the new widget.

3 In the Property Inspector, you see a list of the panels currently in your accordion 
(Label 1 and Label 2). Click the plus sign (+) above the list twice to add two new 
panels for a total of four. A label displays above each new panel. 

4 Click on Label 2 and then press the up arrow twice to push Label 2 back under 
Label 1. This step is not mandatory, but it helps to keep your label order straight.

5 On your page, highlight the Label 1 text. Delete it and type Food Products in its 
place. Do not press Enter (Windows) or Return (Mac OS) after typing.

Type directly within the accordion labels to 
rename them.
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6 Repeat step 5 for the labels 2, 3, and 4, renaming them Clothing, Home Products, 
and Lifestyle, respectively. Next, you’ll add content to each panel that corresponds to its 
label.

7 In your Files panel, locate the text folder and expand it. Double-click and open the fi le 
named accordiontext.html. This contains the text you’ll add to the accordion panel.

8 Select the text below the Food Products heading (don’t include the heading itself ), and 
choose Edit > Cut. Return back to your index_work.html page.

9 Click the blue tab labeled Spry Accordion: Accordion 1 to ensure it is selected; then, 
in the Properties panel, click the Food Products panel to open it. 

Open the Food Products panel by clicking it in the Properties panel.

Highlight the placeholder text on your page, and then choose Edit > Paste to paste it 
in the text from your content fi le.

10 Repeat steps 8 and 9 for the remaining paragraphs in the accordiontext.html fi le, 
pasting them into the Clothing, Home Products, and Lifestyle panels, respectively.

As with the other Spry Widgets, the default style will need to be changed to match 
the look and feel of your site.

11 Under the CSS Styles panel, locate the attached style sheet named SpryAccordion.css, 
and expand it to reveal its rules.

12 Select the .AccordionPanelTab rule. To the right of the background color property, 
click the color swatch and notice that your cursor is an eyedropper. Place the eyedropper 
in the green area immediately above the accordion, and click once to sample the green 
color from the header. This sets the background color to #88B036 (green).

Using the eyedropper, sample the green from the header to apply it as a background-color.

13 Select the .AccordionPanelOpen .AccordionPanelTab rule. Click on the 
background-color value and type #CF9, then press Enter (Windows) or Return 
(Mac OS). This sets the open panel color to a light green,
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14 Select the .AccordionPanelContent rule. Locate the height property shown in the 
Properties list, and change its value from 200px to 100px. This changes the height of 
the content panels when shown.

There are a few more styles to change before you are done styling the accordion. One 
of the default styles for this widget is a Focused style which defi nes the appearance of 
the accordion when it is selected. By default, it is blue (although you cannot see this 
unless you preview in a browser), so you will change this now.

15 Select the .AccordionFocused .AccordionPanelTab style in the CSS Styles 
panel. Here you will match the background color you set in step 12. Click the color 
value for the background-color property and type #88B036, then press Enter/Return 
to commit the change.

Setting the .AccordionFocused .AccordionPanelTab style.

16 Select the .AccordionFocused .AccordionPanelOpen .AccordionPanelTab 
style. This rule defi nes the appearance of any panel tab that is open. Click the color 
value for the background-color property and type #CF9 to set it to the same light 
green used in step 12.

17 Choose File > Save All to save your page. If the Copy Dependent Files dialog box 
appears, press OK to allow Dreamweaver to copy any necessary fi les for your new 
widget to the site folder.

18 Choose File > Preview in Browser to see your new tabbed panel group in action. 
When you are done, close the browser and return to Dreamweaver.

DWCS6_06Pass.indb   363DWCS6_06Pass.indb   363 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


14 The Spry Collapsible panel

Dreamweaver CS6 Digital Classroom364

The Spry Collapsible panel
This simple panel displays or reveals its contents when clicked, and is a great way to hide 
information that doesn’t need to be visible at all times. You can think of the Spry Collapsible 
panel as a piece of the Spry Accordion that can only display a single panel and label.

You’ll add a single Spry Collapsible panel to create a hidden e-mail signup form at the 
bottom of your page.

1 In the bottom half of the right column, locate the placeholder text that reads {Email 
signup box here}. Select and delete the placeholder text and leave your cursor 
positioned in its place.

2 On the Insert panel, locate and click the Spry Collapsible Panel button to add a button 
at your cursor position.

3 Select the text that reads Tab at the top of the panel, and type Contact Us in its place. 

4 Below the panel, select the paragraph that reads Enter your e-mail address to receive 
specials, event notifi cations and more! and also select the form elements.

Select all the content immediately below the 
Spry Collapsible panel.

Choose Edit > Cut.

5 Select the word Content shown in the panel area of your collapsible panel, and paste 
the content you cut in its place. The text and form fi eld now appear inside the panel.
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6 In the CSS Styles panel, locate and expand the attached style sheet named 
SpryCollapsiblePanel.css. Select the rule named .CollapsiblePanelTab to display 
its properties. 

7 Click the background-color value, and type #88B036 to change the label’s 
background color from grey to green.

You can also defi ne the default appearance of the collapsible panel; in this case, you 
would like it closed by default.

8 Click the blue tab above the Collapsible panel to select it. In the Property Inspector, 
choose Closed from the Display menu to close the panel. Choose Closed from the 
Default state menu so that the panel will appear closed by default until clicked. 

Use the Property Inspector to set the new panel’s Display State and Default appearance to Closed.

9 Choose File > Save All to save your page. When the Copy Dependent Files dialog 
box appears, click OK to allow Dreamweaver to copy any necessary fi les to your site 
folder.

10 Choose File > Preview in Browser, and select a browser to test your page and see your 
new Collapsible panel in action. When you click the Contact Us label, the sign-up 
text and form appears—click it again to close it.

11 Close the browser and return to Dreamweaver.

Working with Spry Data Widgets
In addition to what you’ve seen so far, the Spry panel includes a whole group of powerful 
data widgets that can read from an external XML fi le. This is perfect for creating pages 
and page elements (such as calendars, news, and blogs) that otherwise would require 
manual formatting. 

You can connect XML information to a pre-confi gured data widget from the Spry panel 
(such as the Spry Table), or build your own display components using common page 
objects such as lists, tables, and div tags. You can even use CSS to format Spry data widgets 
so they blend perfectly with your existing design. 
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What is XML?
XML stands for eXtensible Markup Language, and is the standard now used to describe 
and exchange data between seemingly unrelated systems. XML, like HTML, uses a 
series of tags—however, that’s where the similarities end. Unlike HTML, XML doesn’t 
use a series of pre-defi ned tags; instead, XML developers create tags using names they 
understand and that are relevant to the data they’re trying to work with.

A typical XML document may look like the following:

<meeting>
<attendee>

<name>John Smith</name>
<dept>Payroll</dept>
<extension>2225</extension>

</attendee>
</meeting>

Each tag is referred to as a node; the nodes and structure of an XML fi le are referred to as 
a schema.

XML can exist on a web server outside your local site, or as a local XML fi le. How this 
XML fi le is created, or where it comes from, is up to you, and this will be diff erent 
for every project. Because XML documents are plain text, they can be created in 
Dreamweaver, as well as a variety of other popular text editors.

Creating a Spry XML data set
Before you can add a data widget to your page, you must fi rst create a Spry XML data set. 
These are pointers to XML data sources (such as an XML fi le in your site folder) that let 
Dreamweaver know where the fi le is and what information it contains. A single page can 
use multiple data sets, and you can manage all data sets from the Bindings panel.

1 Click the Spry Data Set button ( ) at the top of the Insert panel’s Spry category. The 
Spry Data Set dialog box appears.

2 At the top, choose XML from the Select Data Type drop-down menu. Type events as 
the Data Set Name.

3 Click the Browse button next to the Specify Data File fi eld. When the Select XML 
Source dialog box appears, navigate to the data folder in your site’s root directory. 
Select the events.xml fi le in the folder and press OK (Windows) or Open (Mac OS).
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The schema panel below displays the node structure of your XML document.

Pointing to the XML fi le to be used as a Data Set.

4 Click on the <event> node; the xData path at the bottom of the dialogue box should 
read calendar/event.

This node is a Row Element which is a repeating node: this is appropriate because many 
events are held and they all have the same structure: Month, Date, Year.

5 Press Done to create the data set. You will now created data bindings to this data.
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6 A new Bindings panel will now be visible (if not, choose Window > Bindings to 
display it). This is where you can view and manage your data sets and see the nodes 
that they contain. You may need to adjust the height of the Bindings panel or the 
surrounding panels to see the contents better.

The Bindings panel displays the data set of your XML fi le.

7 Choose File > Save All to save your page. If you are prompted to Copy Dependent 
Files, press OK.

Adding a Spry Data Widget: The Spry Repeat List
Once you’ve created a Spry data set, you are ready to add a Spry Data Widget to your 
page. A Spry Data Widget is simply an HTML structure (such as a list or table) that is 
designed to build itself from information it fi nds in a Spry Data Set. Rather than having 
to manually add bullet points or rows, the widget builds as many as it needs to display the 
records found in a specifi c data set.

An easy way to display data from your new XML Data Set is by using a Spry Repeat List, 
which uses one of three HTML list styles (unordered, ordered, or defi nition list) to display 
data. As with any standard HTML structure, you can fi ne-tune its look with basic CSS 
properties. To get you started, the lesson fi le includes some pre-created CSS classes that 
you will apply to your generated content.

1 Locate the section in the right column of your page that begins with the header 
events. Select the placeholder text {calendar here}.

2 Under the Spry category on the Insert panel, click the Spry Repeat List button to add 
a new list. The Insert Spry Repeat List dialog box appears.
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3 From the Container Tag drop-down menu, you can choose one of three list types, or 
even use a form SELECT menu. Select the DL (Defi nition List).

Choose the DL (Defi nition List) as your structure.

A Defi nition List displays information in tiered Title/Defi nition sets. It is similar to a standard 
ordered or unordered list, except that each bullet contains a set of two pieces of information.

4 From the Spry Data Set drop-down menu, make sure events is selected, which is the 
XML data set you created earlier. The new list will build itself dynamically from 
information it fi nds in this dataset. 

5 From the DT Column drop-down menu, make sure date is selected. This corresponds 
to the date node found in your data set, and will display the date as the header for each 
list item created.

6 From the DD Column drop-down menu, select title. This will display the event title 
below the date in each list item created.

Choose the DL (Defi nition List) as your structure, and set it to display 
the date and title fi elds from your XML fi le.

7 Click OK. If a dialog box appears prompting you to Add a Spry Region, make sure to 
press Yes. Without it, the data will not load into the widget.

If you forget to add a Spry Region, or need to recreate it, you can use the Spry Region button, 
found underneath the Spry category of the Insert panel. Just make sure that any Spry Data 
Widgets are placed inside the new region!
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8 A new Spry Region is added to your page, as well as a new defi nition list. You will see 
placeholders for the information in your data set. Preview your page in the browser or 
Live View; these will be replaced with actual data from your data set.

The Spry Region displays placeholders for your data from your events data set loads dynamically into the list when 
the page is previewed.

Styling and fine-tuning data widgets
Once you’ve added a data widget, you can fi ne-tune it by adding additional data fi elds, 
rearranging the order of data fi elds, and of course, styling it with some basic CSS. Your 
current lesson fi le contains an attached style sheet with some pre-created styles that you 
can assign to your new Spry Repeat List to give it some style. You will also add data fi elds 
to your list that aren’t currently being displayed, such as the time and description for each 
calendar event.

Before you begin, make sure that you turn Live View off  in the Document toolbar if 
necessary.

1 Locate your new Spry Repeat List in the right-side column, and click to position your 
cursor directly after the {date} placeholder text. 

2 Add a space, and type a colon (:). You’ll follow this colon with the actual event time 
from your XML data set, which the list is not currently using.

3 If it is not currently visible, choose Window > Bindings to display your Bindings 
panel. You’ll see your events data set listed, as well as the data fi elds below it. Locate 
and select the time data fi eld in the list—this contains the time for each event.
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4 Click and drag the time data fi eld from the Bindings panel, and release it next to the 
{date}: text on the page. This adds a placeholder for the time to your repeat list. It 
should read {date}:{time}.

Drag fi elds from the Bindings panel to add placeholders to your repeat list. The 
new {time} placeholder will fi ll in the time information from your XML fi le.

5 Directly below the date and time, click to position your cursor after the {title} 
placeholder. Press Shift+Return/Enter to create a line break. Here is where you’ll 
place a caption for each event as defi ned in the XML fi le.

6 On the Bindings panel, locate the caption fi eld within the events data set. Click and 
drag it from the Bindings panel and place it in the new line you created on your page 
below the {title}. This adds a new placeholder for {caption}.

7 Now you’ll use some pre-created CSS rules to dress up your list. Select the entire line 
in your list that reads {date}:{time}. On the left side of the Property Inspector, press the 
HTML button, if necessary, to switch to HTML view. Select .eventDate from the 
Class drop-down menu to apply it to the selected text.

Select text in your repeat list and apply a class from the Property Inspector to style it.

8 Select the text that reads {title}. Select .eventTitle from the Class drop-down menu 
to apply the rule to the selected text.
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9 Highlight the text in your list that reads {caption}. Select .eventCaption from the 
Class drop-down menu to apply the rule to the selected text.

10 Choose File > Save to save your page. Click the Live View button on the Document 
toolbar to preview your list with the newly added data and CSS rules.

The fi nished and styled Spry Repeat List, shown in Live View.

11 Click Live View again to turn it off .

From this point, you can simply update the attached XML fi les without the need 
to modify the data widgets in any way. Because each Spry Data Widget populates 
dynamically, new data will fl ow into the widget each time the page is loaded.

12 Choose File > Close. You are done with this lesson!
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Review 

Self study
As you can see, creating highly interactive web pages is made easy with Spry Widgets. 
Whether it’s a fancy drop-down menu, or a dynamic list of events, the addition of a few 
widgets can make the diff erence between a good page and a great one. Further explore the 
diff erent data widgets, and experiment with XML data from diff erent sources. Identify areas 
on your site that could benefi t from Spry Data Widgets, such as blog, news, or calendar 
pages, and follow the steps in these lessons to apply these same concepts to those pages.

The Spry Repeat List you added in the last two exercises does not have a style consistent 
with the rest of your page. Locate the styles associated with the list and update them to 
match your other Spry Widget styles.

Review 
Questions
1 What are the four Spry Widgets that you can use for navigation and content 

presentation?

2 What is the signifi cance of the Spry Assets folder that is copied to your site when using 
a Spry Widget?

3 What must fi rst be created before you can use a Spry Data Widget?

Answers
1 The Spry Menu bar, Spry Accordion panel, Spry Tabbed panel, and Spry Collapsible 

panel.

2 It contains necessary support fi les such as CSS, JavaScript, and image fi les that your 
widgets need in order to function.

3 A Spry Data Set.
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What you’ll learn in 
this lesson:
• Using the Multiscreen 

Feature

• Working with Media 
Queries

• Creating styles for a 
smartphone device

• Working with Fluid Grids

Lesson 15

The Web is no longer only about desktop screens. Users of the Web 
are looking for their sites to function on many diff erent size screens 
and devices. Dreamweaver has a few features designed to help you 
make your site compatible for mobile devices.

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw15lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard-drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Before you begin, you need to create site settings that point to the dw15lessons folder. Go to 
Site > New Site, or for details on creating a site, refer to Lesson 2, “Setting Up a New Site.”

See Lesson 15 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

15

Mobile Design and Layout
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The rise of the mobile web
Creating websites has always presented certain challenges. Among these challenges is the 
fact that the people who visit your site might have diff erent size monitors; therefore, the 
page layout that works well on one screen might not work so well on another screen. 
Another challenge is the diff erent versions of web browsers that users might have. A 
page that looks one way in Internet Explorer 9 might not look the same way on Internet 
Explorer 6. Despite these challenges, the Web has thrived and grown tremendously 
because the benefi ts it off ers far outweigh the downsides. Instant access to information, 
the ability to easily share information through hyperlinks and email, the convenience of 
online shopping and payment: these are all major benefi ts.

The mobile web has all these benefi ts and more. The Web is now portable. It is no 
longer tethered to a desktop and is accessible wherever a user has a connection. In many 
cases, external peripherals, such as the keyboard and mouse, have dropped in favor of 
touchscreens’ miniature keyboards. Built-in features such as GPS and cameras can also come 
into play, allowing the user to interact with the Web in new and diff erent ways.

However, with all these benefi ts come new challenges. Portable screens also mean 
smaller screens. Consequently, your great desktop design suff ers as it scales. Navigation 
that works well on the desktop may become diffi  cult to click at ¼ the size. Other 
challenges include the still-limited bandwidth that currently exists when using a cellular 
network, the inability to play certain media such as fl ash or web video, and web browser 
incompatibility, which is an issue that has not been quite resolved.

Dreamweaver tools for mobile layout
Dreamweaver CS6 has a few diff erent tools for designers and developers who want to 
optimize their content for mobile devices. Before proceeding, you should learn about the 
diff erent categories of the mobile web, which are explained next.

• Native Applications

Smartphones, such as those on iOS, Android, and Windows Mobile platforms, 
have achieved a tremendous amount of growth and popularity since 2007 and the 
introduction of Apple’s iPhone. Native applications, or “apps,” live on a user’s device. 
Apps are tightly integrated with the Web and display content from the Web, but 
they are not exclusively dependent on the Web. Dreamweaver CS6 is capable of 
creating native applications for iOS, Android, Blackberry, webOS, and symbian; 
however, it does so with the help of the Phonegap framework. With PhoneGap and 
Dreamweaver CS6, you start with an HTML and JavaScript document and are able 
to then build multiple apps for the diff erent platforms. We do not cover PhoneGap 
functionality in this lesson or in this book. For more information go to phonegap.com. 
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You can also launch the PhoneGap service in Dreamweaver CS6 by choosing Site > 
PhoneGap Build Service.

The PhoneGap service integrated with Dreamweaver CS6 
allows you to build native applications for mobile devices.

• Websites

All websites that can be accessed on a desktop browser can also be accessed on a mobile 
browser; therefore, every web page is part of the mobile web. However, as you will 
soon see, when a mobile web browser visits a website, the appearance of that site might 
be diff erent from the desktop version. There are a few diff erent explanations for this: 

 – The appearance of a web page on a mobile device might be diff erent than the 
desktop version due to the scaling eff ect that the device’s web browser applies. 
Apple’s popular mobile Safari browser, for example, scales a web page to fi t the 
screen and also allows for touch gestures such as pinch, zoom, or swiping in order to 
navigate through a page. Websites that were never intended for mobile viewing will 
still have these features because they are built-in to the browser itself.

 – The appearance of a web page on a mobile device might be diff erent than the 
desktop version because the designer or developer has created a separate version 
designed for mobile. All web browsers, whether they are mobile or desktop, 
advertise themselves with something called a user agent. The creator of a website can 
let in all desktop user agents to their “standard site” and redirect all mobile users to 
a separate “mobile site.”
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Mobile website features in Dreamweaver
This lesson focuses on two methods for creating websites optimized for mobile. The fi rst 
method focuses on using the Multiscreen feature and CSS3 Media Queries. In the exercise 
for this method, you will take the existing layout created in Lesson 6 and create a layout 
optimized for a mobile device, such as a smartphone. The second method focuses on the 
new Fluid Grid Layout feature in Dreamweaver CS6. This method also uses CSS3 Media 
Queries, but in a slightly diff erent and more advanced way than the fi rst exercise.

Dreamweaver does its best to simplify the process used to create mobile optimized sites, 
but you should note that this is the most advanced and diffi  cult lesson in this book. You 
should also realize that at the time of this writing, there is no application on the market that 
makes designing a website for multiple screens “easy.” We fi rmly believe that a thorough 
understanding of the fundamentals of HTML, particularly CSS, is important when 
working with your sites. Therefore, once you have learned some of these fundamentals, you 
will fi nd the tools in Dreamweaver to be extremely helpful and effi  cient.

Viewing your web page with the Multiscreen feature
Dreamweaver CS6 has improved the Multiscreen feature introduced in CS5.5. This 
feature helps you preview your pages in diff erent screen sizes. Specifi cally, this preview 
shows you your design in three diff erent views by default: one for the desktop, and the 
other two for the smaller screens found in smartphone and tablet devices. Given that 
mobile device screens come in diff erent sizes, you can also customize these views to any 
resolution you want. Additionally, Dreamweaver takes advantage of CSS3 Media Queries 
to let you build individual style sheets customized for each view. If you have not worked 
with Media Queries before, this exercise is designed to introduce you to the concept and 
also to help you learn how to use them in Dreamweaver.

1 In the Files panel, double-click the media_queries folder and then double-click 
15_index.html to open it. The basic design here is based on the one you created in 
Lesson 6 and uses fl oats and clears to create columns.
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2 Choose File > Preview in Browser and select a browser. This page has a fi xed-width 
size of 960 pixels and works well on most desktop monitor resolutions. 

To preview this page as it would appear on a mobile device such as a Smartphone or 
tablet device, you can use Dreamweaver CS6’s Multiscreen option.

3 Return to Dreamweaver and click the Multiscreen icon immediately to the right of 
the Live button. A menu appears showing you the various sizes you can choose from. 
Select Multiscreen Preview.

You can fi nd Dreamweaver’s Multiscreen Preview button next to the Live view button.
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The Multiscreen Preview window appears. This window is divided into three different 
screen resolutions: Phone (320 × 300), Tablet (768 × 300), and Desktop (1126 × 181). 
Note that the height of the Desktop view may be different on your screen. This 
window adapts to the amount of space on your screen, which is dependent on your 
monitor resolution. In fact, if your monitor resolution is lower than 1280 pixels wide, 
you will have a difficult time working with Multiscreen Preview in general.

Dreamweaver’s Multiscreen Preview shows three views by default: Phone, Tablet, and Desktop.

As you can see from the preview, the Phone view and the Tablet view are not wide 
enough to fi t your fi xed-width page. You should note that Multiscreen is not an 
emulator. (An emulator is software that attempts to imitate a hardware phone or other 
computer device.) Most modern smartphones would actually scale your entire page to 
fi t in the browser window. The Multiscreen feature is showing you the page based on 
a strict interpretation of the viewport.

A viewport, as it relates to mobile devices, is best described as a viewing area on the 
screen through which a user views a web page. 
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4 Click the Viewport Sizes button in the top right corner; the default Viewport sizes 
appear. The default values for the Phone viewport is 320w by 300h; the default values 
for the Tablet viewport is 768w by 300h. The default width for the Desktop viewport 
is 1126w, but no height is defi ned. (If your sizes are diff erent, click the Reset to 
Defaults button.)

These numbers are not arbitrary; the Phone viewport width is 320 and the Tablet 
viewport width is 768 because these are typical screen resolutions for devices such as 
the iPhone, iPad, and others. 

Screen resolutions actually do vary among devices, but Dreamweaver has chosen these as standards.

5 Click Cancel. You can modify the viewport sizes to fi t your needs; however, we 
recommend you use the default sizes until you become more familiar with the reasons 
for modifying the sizes.

These viewport sizes are important because you can create unique style sheets that 
will only apply to viewports of a certain size. For example, for the smallest viewport 
you might want a layout that is only a single column, instead of the current three-
column layout designed used for the desktop layout. You can do this in Dreamweaver 
using MultiScreen Preview and a related feature called Media Queries.

6 Keep the Multiscreen Preview window open; you’ll use it in the next exercise. First, 
we will present a brief overview of Media Queries before continuing.

Media Queries defined
Media Queries in Dreamweaver take advantage of a feature in CSS3, which is the latest 
version of CSS. This feature is part of the CSS3 specifi cation called CSS3 Media Queries. 
Media Queries are a way of delivering diff erent page layouts to users based on the 
capabilities of their screen or screens.

You can think of a CSS3 media query as a combination of HTML and CSS syntax that 
examines the capability of a user agent, typically a web browser, and lets you send it styles 
based on certain values. The most common capability queried is the width of a screen or 
a mobile device; other capabilities, such as the device orientation (landscape or portrait), 
can also be detected. Since media queries detect the capabilities of a user’s screen and 
serve styles that fi t that screen, they are well-suited for today’s web environment with its 
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diff erent monitor resolutions. The following diagram shows a simplifi ed version of how 
media queries work: each device gets a specifi c style sheet based on the size of its screen.

desktop.css

tablet.css

phone.css

Server

Unique style sheets are delivered to users depending on their screen capabilities.

Here is a diff erent example: suppose a user has a smartphone with a screen resolution of 
320 pixels wide by 480 pixels high, and the phone is in portrait mode (vertical). This user 
visits a website that uses media queries. When the user visits the site, the media queries 
built into the page detect the capabilities of the phone and serve it a specifi c style sheet 
with a single column layout. When the user rotates the phone into landscape position, the 
change is detected and the media queries send a style sheet designed for a 480 pixel-wide 
screen (the layout might have two columns instead of one).

From the perspective of users, they are simply getting the ideal layout for the screen 
size they are using. Users might notice this change in layout momentarily as they rotate 
their screen or visit the site on diff erent devices, but the overall goal is to improve 
their experience on the site by improving aspects such as readability, navigation, and 
presentation of content.

For more details on the technical aspects of CSS Media Queries, 
visit http://www.w3.org/TR/css3-mediaqueries/.
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Creating a site-wide media query file
As noted earlier, Media Queries are a relatively new advance in web design and are part of 
the CSS3 specifi cation. (Most of the CSS you have been working on throughout this book 
has been part of the CSS2.0 specifi cation.) There are many benefi ts to using media queries, 
but their use is a tradeoff  because they are not fully supported by all browsers (particularly 
older browsers).

There are a few ways to add Media Queries to a page. The fi rst method adds the Media 
Queries code within your existing style sheet (either an internal or external style sheet). 
The second method is the one that Dreamweaver CS6 uses by default, and is called a site-
wide media query fi le. A site-wide media query fi le is a special type of external style sheet 
that has no style rules; instead, its only job is to import any number of other style sheets 
into your page.

In this exercise, you’ll learn how to create a site-wide query fi le as well as new style sheets 
for a Phone layout and a Tablet layout. You’ll also learn to link your existing style sheet to 
the site-wide media query fi le.

1 Your Multiscreen Preview window should be open from the last exercise. If it is not, 
click the Multiscreen button.

2 Click the Media Queries button in the Edit section at the top right of the preview 
window. The Media Queries window appears.

The Media Queries window in Dreamweaver CS6.

The site-wide media queries fi le you are about to create will function as a hub to 
import style sheets with rules designed for Phone and Tablet screens. 
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3 In the Write Media Queries to section, click the option button for Site-wide media 
query fi le, and then click the Specify button. In the window that appears, click the 
CSS File menu and choose Create new fi le. Type mobilestyles in the CSS File fi eld 
and click OK.

Specify a new site-wide media query fi le.

As noted earlier, this site-wide media query fi le has a very specifi c job: it imports 
external style sheets that contain styles for your diff erent screen sizes. It’s currently 
empty and so you will now create those style sheets.

After you have defi ned a site-wide media query fi le, the information is stored within your site 
defi nitions. To access it, choose Site > Manage Site. Choose your current site and click Edit. 
Click the Advanced Settings; the path to your site-wide media query fi le appears. 

4 Make sure the “Force devices to report actual width” check box is selected. This option 
overrides a smartphone’s default behavior of scaling a web page to fi t the screen. 

Selecting this option places the following line of HTML in the head section of your page: 
<meta name="viewport" content="width=device-width" />.

5 In the Media Queries window, click the Default Presets button; three media query 
presets appear in the middle window. 

The three default presets for Media Queries.
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The first preset is called Phone, and you can use it for screens up to 320 pixels wide. 
This preset is selected automatically; you can see the properties of this media query in 
the Properties section at the bottom. The important value here is max-width, which is 
set to 320px.

6 Locate the CSS File section and make sure Create new fi le is selected. Click the Folder 
icon on the far right and the Save File As window appears. Navigate to the media_
queries subfolder in your dw15lessons folder, type phone in the File name fi eld, and 
then click Save.

7 Click the second preset for Tablet and note the properties for min-width and max-
width. These properties are the media queries designed to detect the width of the 
user’s browser viewport; the value for Min Width is set to 321 and value for Max 
Width is set to 768. In practical terms, this means that the tablet style sheet will be 
used for any browser width between those two values.

Furthermore, any browser less than 321 pixels wide will use the Phone style sheet 
defi ned in the last step. 

8 Click the Folder icon on the far right side of the CSS File section; the Save File As 
window appears. Navigate to the media_queries subfolder in your dw15lessons folder, 
type tablet in the File name fi eld, and then click Save.

Setting the media queries and style sheet for tablet devices.

The last media query you need to add is for Desktop screens; in this case, any 
viewport wider than 768 pixels.

9 Click the Desktop preset. This preset has a min-width set to 769; there is no need 
to add a max-width. This time, click the CSS File menu and choose Use Existing 
fi le. Click the Folder icon, and within your media_queries folder, click the styles.css 
document, and then click OK (Windows) or Open (Mac OS). Since this is the current 
style sheet that contains your page’s styles, you only need to point to it. 
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10 Click OK in the Media Queries window, and then close the Multiscreen Preview 
window. Locate the fi les you just created within the Files panel (mobilestyles.css, 
phone.css, and tablet.css). 

11 In the Files panel, double-click the mobilestyles.css fi le to open it. This is the site-wide 
media query fi le you created in Steps 3 and 4. Note that it uses the @import syntax to 
link to the other three external style sheets. Keep this fi le open; you will modify it in 
the next exercise.

The site-wide media query fi le mobilestyles.css with the added media query fi les. 

The preceding steps might seem long, but you only need to do them the fi rst time you 
set up media queries. Once you have them set up, you have a framework for creating 
unique styles for screens of diff erent sizes.

Organizing your style sheets
Dreamweaver CS6’s media queries feature simplifi es complicated tasks when creating site-
wide media queries, but it’s not perfect. To ensure your style sheets are most eff ective, you 
need to manually fi ne-tune them. In this exercise, you will organize the style sheets you 
created in the last exercise.

1 Your mobilestyles.css fi le should still be open from the last exercise. If not, open it by 
double-clicking the fi le in the Files panel. 

2 Select the following code, and then choose Edit > Cut, Ctrl+X (Windows), or 
Cmd+X (MacOS).

/* Desktop */ 
@import url("styles.css") only screen and (min-width:769px);
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3 Place your cursor on the fi rst line, and then choose Edit > Paste, Ctrl+V (Windows), 
or Cmd+V (Mac OS) to paste the code at the top of your document. This step is 
necessary to ensure that the desktop style sheet is used fi rst, followed by the styles for 
the phone and tablet style sheets.

Your Desktop preset links to your original external style sheet.

4 Next, select the following code (highlighted in red) and delete it. Do not delete the 
semicolon at the end of the line, or your styles will no longer work.

/* Desktop */ 
@import url("styles.css") only screen and (min-width:769px);
This step is necessary for older browsers that don’t support media queries and only 
need a standard style sheet to use. Since this line is now a reference to your original 
style sheet, you should not encounter problems with older browsers.

5 Choose File > Save to save this style sheet. Your next step is to remove the reference 
in your HTML page to your original style sheet.

6 If it is not already open, click your 15_index.html document to open it. Click the 
Source Code button in the top-left corner to view the HTML of your document.
Click on the Code button to enter the Code view. 

7 In the Code view, locate the following line in your head section (it should be on 
line 7):

<link href="styles.css" rel="stylesheet" type="text/css" />

Select this entire line and then press Delete to remove it.

This code is the original link to your style sheet, but you don’t need it because you 
added a reference to this fi le in your mobilestyles.css document.

8 Choose File > Save All.
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Creating a layout optimized for mobile
Now that you have prepared your site with a site-wide media query fi le and the associated 
style sheets, you can begin using them. The general principle of CSS3 Media Queries is 
that you use the exact same names for the style rules in your phone and tablet style sheets 
as the style rules in your desktop style sheet. By using the same names, you override the 
desktop style wherever needed. For example, you will fi rst apply this rule with the ID 
style called #container. In your desktop style sheet, this ID style defi nes the width of the 
entire page as 960 pixels. In your phone style sheet, you will create another rule with the 
name #container, but you will set the width to 100% for this style. 

In the following exercise, you will only work with the phone style sheet; use the tablet 
style sheet for practice.

1 Click the Multiscreen button to preview your page, and for this exercise, focus on the 
Phone view. From all appearances, the multiscreen preview looks exactly the same 
as it did at the beginning of the lesson, and yet all the work you did in the last few 
exercises will now begin to pay off . Close your Multiscreen Preview window.

2 In your Related Files toolbar, click the phone.css link. The blank style sheet opens 
in the Code view indicating that there are no styles in this fi le, yet. (The line labeled 
@charset "utf-8"; is not a style, it helps the browser understand the language being 
used.) Your fi rst task is to change the width of your container.

3 In the CSS Styles panel, click the New CSS Rule button, and then in the Selector Type 
menu, choose ID. Click the Selector Name menu and choose container from the list.

Creating a new rule for the container ID in your phone.css style sheet.
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4 Click OK. In the CSS rule defi nition window, click the Box category and type 100 in the 
width box. Click the menu to the right and change the value from px to %. Click OK.

To see the eff ect this has on your phone style sheet, you will need to preview your 
page in the Multiscreen Preview.

5 Since you cannot open the Multiscreen Preview when you have a style sheet selected, 
click the Source Code button in your Related Files toolbar to switch to your HTML 
page. Now click the MultiScreen button to view your page. 

6 When the Multiscreen Preview page opens, you will see your page has dramatically 
changed in the Phone viewport. By setting the width of the container to 100%, it will 
only be as wide as the viewport and most of the content within will have shifted or is 
overlapping. For example, the background image of the vegetables is now under the logo. 
Also notice the navigation bar does not fi t all the way across the screen and has broken to 
the next line. Scroll down the page and note that your side columns have shifted. 

The Phone view shows the eff ect of changing the container 
width to 100%.
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As you can see, creating a page optimized for mobile is not as simple as setting the 
container width to 100%. The page has changed, and you will need to modify it. The 
layout elements inside the container need to be addressed as well, since most of them 
have height or width values set as pixels. Also, some of the elements are fl oating. To 
fi x the rest of the page, you will add rules that remove fl oats and override any explicit 
pixel width or height value. The goal is to create a single column layout.

Tips and strategies for optimizing pages for mobile

The following is a list of tips and strategies to consider when designing pages for mobile. 
Navigating and using websites on smaller screens or screens that are touch-enabled is very 
different from the desktop, and you should take it into consideration.

• Navigation should be at or near the top of the screen to be easily accessible. Repeat 
navigation at the bottom of all your pages so the user does not have to scroll up after 
reading a page.

• For touchscreen devices, use a large target size for navigation links to prevent accidental 
clicking.

• Touchscreen devices do not always have a hover capability as triggered by the mouse cursor 
on desktops. Plan your styles accordingly and avoid rollover styles.

• Avoid image-based navigation; use list-based navigation styled with CSS.

• Single-column layout is much easier to navigate and read on a smaller screen. A general 
strategy for accomplishing this with media queries is by removing f loated elements and 
most layout containers with fixed width and height pixel values.

7 Close your Multiscreen Preview; you’ll now add more styles to your phone.css style 
sheet and create a single-column layout.

Since the Multiscreen Preview is large, it can become cumbersome to constantly open it and close 
it. If you have dual monitors, you can drag this window to a second monitor. Alternatively, 
you can collapse the Multiscreen Preview window by clicking the double arrows in the top-right 
corner. Click the arrows again to expand it.

8 Click the phone.css button in the Related Files toolbar. You’ll now add styles for the 
header section.

9 In the CSS Styles panel, click the New CSS Rule button, and then in the Selector 
Type menu, choose ID. In the Selector name box, click the Selector Name menu and 
choose header.
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10 Click OK. In the CSS rule defi nition window, click on the Background category. 
Click the Background-image menu, and then choose none. Click OK. We will 
remove the image of the vegetables, which works well in the desktop version, but not 
in the phone version. 

Setting the background-image to none removes the image of the vegetables from the header.

11 Choose File > Save all. Choose Source Code and then click the Multiscreen button 
to see your progress. The background image no longer appears in the header for the 
Phone viewport. Close your Multiscreen Preview window.

Your next step is to address the styles of the navigation bar. Typically, CSS navigation 
bars have a few diff erent rules that you need to modify.

Creating styles for navigation and a single-column layout
Creating easy-to-use mobile navigation is very important because you want users to read 
your content and not be frustrated by content that’s diffi  cult to access. The hit target for 
mobile navigation should be large enough for touchscreens and easy to read. You’ll add 
these styles now.

1 Click the phone.css button in the Related Files toolbar. In the CSS Styles panel, click 
the New CSS Rule button, and then in the Selector Type menu, choose ID. In the 
Selector name box, type #navigation and click OK.

In the CSS rule defi nition window, click the Font-size menu and choose the keyword 
medium to override the 36 pixel value set in the original style sheet. This action 
prevents issues when there are diff erences between device screen resolutions.

2 Click the Positioning category, click the Height menu, and choose auto to override the 
fi xed height of 36 pixels from the original style sheet. Click OK to create these styles.

You will need to do more work to make the navigation look better. There are often 
diff erent rules for CSS navigation menus, so you also need to modify these.
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3 In the CSS Styles panel, click the New CSS Rule button, and then in the Selector 
Type menu, choose Compound. In the Selector name box, type #navigation ul li. 
This targets the style of the list items.

Create a compound selector to make a style for the navigation list items.

Click OK. In the CSS rule defi nition window, click the Box category, click the Float 
menu, and choose none. This overrides the fl oat:left rule set in your original style 
sheet. Click OK.

4 Click the Source Code button to switch to your HTML page, and then click the 
Multiscreen button. Notice that by setting the fl oat property of the list items to none, 
the list reverts to its default positioning, which is vertical.

Changing the fl oat value of list items to “none” creates 
a vertical navigation instead of a horizontal one.
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Your page is starting to improve: the navigation is now a single column. Place your 
cursor over the links and notice that the original hover styles are still present. One of 
the benefi ts of CSS3 Media Queries is that the original styles that have no overrides 
are still used.

Scroll down and notice that you still need to improve other areas: the main content 
and the sidebar still appear broken, but this is relatively easy to fi x.

5 Close the Multiscreen Preview window, and then click the phone.css button in the 
Related Files toolbar.

6 In the CSS Styles panel, click the New CSS Rule button, and then in the Selector 
Type menu, choose ID. Click the Selector name menu and choose the main ID.

Click OK. In the CSS rule defi nition window, click the Box category, click the Float 
menu, and choose none. This overrides the fl oat:left property and value set in your 
original style sheet.

7 Click the Width property menu and choose auto.

Set the fl oat value of the main column to none and the width to auto.

8 Click OK and repeat Steps 6 and 7, but use the Selector name sidebar instead of main.

9 Choose File > Save All Related Files, click the Source Code button, and click the 
Multiscreen button. Scroll down your page and notice that your content section and 
sidebar now fi ll the screen from edge to edge. Also, notice that by removing the fl oats, 
your sidebar is now located below the main content.

10 Close the Multiscreen Preview menu window. You can also test your page in 
Dreamweaver’s Live view. First, click the Design button to switch to this view. Then 
click the Live view button. Live view uses the WebKit rendering engine, which is the 
same as Apple Safari and Google Chrome browser. 
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11 Click the Window Size menu located on the bottom right of your document window, 
and from the list that appears, choose 320 × 480 Smart Phone; your window will 
automatically adjust to this size and your media query fi le will be applied. This 
will also work in the Design view; however, you should place your cursor over the 
navigation. Note that in Live view the rollovers are active.

In Live View, you can see the values of your window width. When the width is less than 321, the layout switches to the 
phones.css styles.

You can also preview your page in the browser and reduce the width of the window. 
Note that some browsers will not let you make the window that small. The phone.css 
is designed for phone browsers, not desktop browsers.

You can create and add other styles to the phone style sheet. You now have the 
foundations of how to create diff erent layouts using media queries in Dreamweaver 
CS6, and apply this foundation to the table style sheet. You can close the currently 
open fi les; you will not need them.

The basics of Fluid Grid Layout
Dreamweaver’s Fluid Grid Layout expands on the concept of media queries. To understand 
fl uid grids, think about page layout. Remember that the layout you began working with 
at the beginning of this lesson was a “fi xed-width” layout set to a width of 960 pixels 
wide. Fixed-width layouts are very common on the Web because they are reliable to work 
with and control. However, one of the downsides of fi xed-width layouts is that they do 
not respond well to diff erent size screens. Many designers feel that fi xed-width layouts do 
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not refl ect the nature of the Web and that “fl exible” or “fl uid” layouts are better suited 
for content. Flexible layouts generally use percentages or em units to defi ne the various 
sections on the page. For example, the width of a sidebar might be defi ned as 33% of the 
page rather than 450 pixels.

If you would like to see the results of this exercise before you begin, navigate to the done folder 
within the fl uidgrid folder, open the index.html fi le within a browser that supports media queries 
and resize the browser window.

1 Chose File > New Fluid Grid; the New Document window appears with the Fluid 
Grid Layout settings on the screen.

The fi rst major change that you will see is that Fluid Grids actually create three 
layouts at a time: Mobile, Tablet, and Desktop. Each of these layouts is defi ned as 
media queries; in this way, the settings are very similar to the ones you saw in the 
last exercise. However, notice that fl uid grids use media queries, and they add grid 
structure to help you align content on the page.

The Fluid Grid Layout has layout settings for mobile, tablet, and desktop.

Each of the three layouts has a number of columns that will be created by default. The 
Mobile layout has fi ve columns, the Tablet layout has eight columns, and the Desktop 
layout has 10 columns. You can type any number of columns you want for each type 
of layout, but for now, you will use the defaults. Notice that the mobile layout has a 
unique setting, “25% of column width.” This represents the space between each of the 
columns, otherwise known as the gutter width. Additionally, each of the three layouts 
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has a default page width listed at the bottom. For mobile, this is 91%; for tablet, this 
is 93%; and for the desktop, this is 90%. This means all the layouts will have a small 
amount of padding on the left and right sides.

If you do not see these values, click the Reset to Default button.

2 Click Create; you will be prompted to generate a new external style sheet. Navigate 
to your dw15lessons folder, locate the fl uidgrid folder, save this style sheet as base.
css, and then click OK. A new document opens; you are in the unique fl uid grid 
mode with a fi ve column layout and a default grid layout div element with placeholder 
text. You’ll learn more about both of these features shortly. For now, we’ll discuss the 
structure of this page and the related fi les created for Fluid Grid Layouts.

The default grid layout with a fl uid grid layout div and placeholder content.

3 Choose File > Save and navigate to the fl uidgrids folder if necessary. Save this 
document as index.html and click OK. You will be prompted to copy two dependent 
fi les: boilerplate.css and respond.min.js. You’ll learn more about the role of these fi les 
shortly; for now, click Copy. The two fi les will be saved into your fl uidgrids folder.

Working with Fluid Grids is diff erent from what you might be used to. This initial view 
of fi ve columns is the Mobile view for your web page. There are two other views as 
well: Tablet and Desktop. These views can be accessed by clicking any of the three icons.

A B C D

A. Mobile size (480 × 800). B. Tablet size (768 × 1024).
C. Desktop size (1000w). D. Window Size.

DWCS6_06Pass.indb   396DWCS6_06Pass.indb   396 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


15

397Lesson 15, Mobile Design and Layout

The rise of the mobile web

4 Click the Tablet Size icon; the size of the window changes to 768 by 1024 and displays 
8 columns.

5 Click the Desktop Size icon; the size of the window changes to 1000 wide; the height 
is set to the vertical space on your screen.

Regardless of the view you are in, you should note that the columns are visual aids 
only and are designed to help you align the Fluid Grid Layout Divs.

6 Choose View > Visual Aids and select the Fluid Grid Layout Guides option to turn 
off  the guides. The reason for turning off  the guides is to see your page design better; 
however, these guides are key to working with the Fluid Grid feature, so choose 
View > Visual Aids and select Fluid Grid Layout Divs to turn them back on.

7 Click the Mobile Size icon to return to the default fi ve-column view. Dreamweaver 
opens this view initially because one of the foundations of Fluid Grid Layout is a 
concept called “mobile fi rst.” The basic idea is that when designing a website from 
scratch, you start with the mobile design and layout fi rst, and then move upward to 
the larger tablet and desktop sizes.

The foundations of “mobile first” design

Mobile first is a concept in web design that has been gaining popularity among designers in 
recent years. The basic idea is that when you are creating a new website design, you begin 
working with the mobile design first, and then move on to your larger screen designs. The 
rationale is that technique forces you to identify your most important or “core” features first, 
thus ensuring that they are folded into the mobile experience for your users. 

The traditional technique of starting with your complex desktop layout and removing 
or restyling parts until you arrive at your mobile layout can lead to design compromises 
and inefficient styles. By incorporating mobile first concepts into Fluid Grid Layouts, 
Dreamweaver is helping to promote the adoption and importance of designing for different 
size screens.
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Creating your mobile layout
In the fi rst half of this lesson, you covered the basics of using site-wide media query fi les. 
Note that you are still using media queries with Fluid Grid Layouts. However in this case, 
rather than dividing your media queries into separate style sheets, the rules for your three 
layouts are gathered in one style sheet (in this case, base.css). Specifi cally, as you begin to 
create the styles for the single column layout in this exercise, keep in mind that all these 
styles will automatically be applied to your larger tablet and desktop layouts.

1 Click in the default div that was created by Dreamweaver. In the Properties panel, 
locate the Div ID fi eld, select the default value, and type header.

Change the name of the default fl uid grid layout div to “header.”

2 Select the placeholder text inside the header and delete it. Choose Insert > Image. 
Navigate to the images folder inside the fl uidgrid folder and locate the ou_logo.png 
fi le. Click Open (Mac OS) or OK (Windows). Type logo in the Alternate Text fi eld, 
and then click OK. 

You just added the image to a “Fluid Grid Layout Div Tag”. Dreamweaver always adds 
a Fluid Grid Layout Div Tag to your page when you start a new Fluid Grid Layout. 
You can add new ones to your page as needed.

3 Click the edge of the header div if necessary to make sure it is selected. Then, in the 
Insert panel, click the Insert Fluid Grid Layout Div Tag object; a dialog box appears. 
Make sure that the Start new row check box is selected, type introcontent, and then 
click OK.

A new fl uid grid layout div appears below the header. Select the placeholder text and 
then press delete to remove it.
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4 In your fi les panel, double-click the intro_content.html document. Select everything 
on the page by pressing Cmd+A (Mac OS) or Ctrl+A (Windows) and then copy it. 
Toggle back to your index page, click inside the introcontent div, and press Cmd+V 
(Mac OS) or Ctrl+V (Windows) to paste it.

The introcontent fl uid grid div with content.

5 Click the edge of your introcontent div to select it. Then, in the Insert panel, 
click the Insert Fluid Grid Layout Div Tag object; a dialog box appears. Type 
secondarycontent and click OK.

A new fl uid grid layout div appears below the header. Select the placeholder text that 
appears and delete it.

6 In your fi les panel, double-click the secondary_content.html document. Select 
everything on the page by pressing Cmd+A (Mac OS) or Ctrl+A (Windows) and then 
copy it. Toggle back to your index page, click inside the secondarycontent div, and 
press Cmd+V (Mac OS) or Ctrl+V (Windows) to paste it.
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7 Click the edge of your secondarycontent div to select it. Then, in the Insert panel, 
click the Insert Fluid Grid Layout Div Tag object; a dialog box appears. Type events 
and click OK.

8  In your fi les panel, double-click the events.html document. Select everything on the 
page by pressing Cmd+A (Mac OS) or Ctrl+A (Windows) and then copy it. Toggle 
back to your index page, click inside the events div, and press Cmd+V (Mac OS) or 
Ctrl+V (Windows) to paste it.

The events fl uid grid layout div is located below secondarycontent.

9 Click the edge of your events div to select it. Then, in the Insert panel, click the Insert 
Fluid Grid Layout Div Tag object; a dialog box appears. Type footer and click OK. 
You’ll leave the placeholder content in here for now.
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10 Within the secondarycontent div, click below the heading “Celebrate Vegetables.” 
Choose Insert > Image. Navigate to your images folder, select beets_fl uid.jpg, and 
click Open (Mac OS) or OK (Windows). Type beets in the Alternate Text fi eld and 
click OK. The image is inserted below the heading.

An image added below your heading.

11 Choose File > Save All.

This is the foundation of a mobile layout. There is much more you could do in regards 
to styling, but now that you have a basic layout with content, you’ll take a look at the 
way Fluid Grid Layouts work with additional layouts.
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Creating a tablet layout
You have seen the three views that are part of Fluid Grid layouts, and you just created a 
simple single-column layout for a mobile device. Note that Dreamweaver created styles for 
the mobile view, the tablet view, and the desktop view. In fact, it has placed these styles in 
three separate media queries (one for mobile, one for tablet, one for desktop). You’ll now 
modify your mobile layout so that it is better suited for a tablet device.

1 Click the Tablet Size icon to switch to this view. As you begin adjusting the layout to 
two columns, keep in mind that the new styles will only apply to the tablet layout.

2 Click the edge of the introcontent div to select it and place your cursor on the anchor 
point located on the right of the div. Click and drag to the left to begin resizing the 
container.

Resize a fl uid grid div by clicking and dragging the right edge.

Note as you drag that the indicator shows you the width and how many columns you 
have. Drag until you reach three columns and approximately 35% width.

3  Click the edge of the secondarycontent div to select it and notice on the top-right 
corner there is an arrow. Hover over this for a moment, and the tool tip indicates the 
arrow will move the edge up a row. Click the arrow; notice that the edge doesn’t shift 
position. This is because you need to resize the div in order to fi t in the space above.

4 Place your cursor on the resize anchor point (on the right edge of the div) and drag 
to the left. When the div width reaches fi ve columns, it will jump up into the space 
above. Keep resizing the div until it is four columns wide.
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5 Now place your cursor on the anchor point on the left edge of this div and wait for 
the tooltip. This indicates that it will shift the div. Click and drag to the right until the 
right edge of the div snaps to the furthest column.

Resize a fl uid grid div by clicking and dragging the right edge.

At this point, you have the basics of a two-column layout, but for the tablet view only.

6 Click the Mobile Size icon to switch back to this view; note that the mobile layout has 
remained in its single column view. Click the Tablet Size icon to see the two-column 
view you just created, and then click the Desktop view. This view is still using the 
single column layout; it has not been aff ected by the changes made in the Tablet view.

7 Choose File > Save All to save your work, but keep this document open. In the next 
exercise, you will build a three-column layout for the desktop.

Creating a three-column fluid layout for the desktop
In keeping with the mobile fi rst philosophy, the desktop is the last design you will work on.

1 Click the Desktop view icon if you are not currently in this view.

2 Click the edge of the introcontent div to select it, and place your cursor on the anchor 
point located on the right of the div. Click and drag to the left to begin resizing the 
container. Resize this div until you reach three columns.

3  Click the edge of the secondarycontent div to select it and click the arrow on the top 
right. This will attempt to move the div up a row, but because it is too wide, you have 
to resize it in order to fi t in the space above. 
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4 Place your cursor on the anchor point located on the right of the div and drag it to the 
left. When the div is narrow enough, it will jump up into the space above. Continue 
resizing the div until it snaps to four columns, which is a width of approximately 38.7%.

Resize a fl uid grid div by clicking and dragging the right edge.

5 Click the edge of the events div to select it, and click the arrow at the top right to 
move it up a row. As with the other divs, you need to resize it in order to fi t into the 
available space.

6 Place your cursor on the anchor point located on the right side of the div and drag 
to the left. When the div is narrow enough, it will jump up into the space above. 
Continue resizing the div until it snaps to three columns, which is a width of 
approximately 28.5%.

7 Choose File > Save All. At this point you have the foundations of a fl uid and adaptive 
layout. 
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8 Click the Live button to see your layout in the Live View. When using Fluid Grid 
Layouts, the Live View behaves a bit diff erently. Typically, the Live View acts as a web 
browser and only allows you to view your content, not edit it. However, you can see 
that the Visual Aids are still visible. Additionally, if you click the edge of any of your 
divs, it will become active and you can then adjust their size or shift them as needed.

In the Live view, the Fluid Grid layout is still visible and the layout divs can be adjusted as well.

If you need to see your layout in action, the browser is still the best place.

9 Choose File > Preview in Browser; your page will load in the three column layout 
view (most likely). Slowly reduce the width of your web browser and note how the 
columns of text begin to resize. This is the “fl uid” part of fl uid layouts: because your 
columns are defi ned by percentages, not pixels, this is the expected behavior. At the 
same time, the amount of space between these columns also remains proportional.

10 Keep reducing the width of the browser; it will eventually switch to the two-column 
layout. Continue reducing the width of the browser until it switches to the single-
column Mobile layout.
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11 Continue resizing your browser window back and forth between the three views, and 
pay particular attention to the image in the middle column. This image is also fl uid; in 
other words, it will resize according to how much space it has available. This is most 
obvious in the single-column mobile view.

The images added to your layout will be fl uid or responsive by default.

This fl uid image behavior is actually made possible by the inclusion of the 
boilerplate.css support fi le that all Fluid Grid Layouts include by default. (You saw 
these dependent fi les created in step 1 of the fi rst exercise.)

12 Close your browser and return to Dreamweaver. You will now take a look at how to 
style your pages.

Looking deeper into the dependent files

When you create a f luid grid layout, the two dependent files that are created are 
boilerplate.css and respond.js. For the most part, you will not touch any of these files. If you 
are familiar with what they do and need to modify them, you can.

boilerplate.css: This is a popular framework for modern websites that has been customized 
and modified for Dreamweaver’s f luid grid layout documents. Essentially, you can think 
of this as a well-tested and documented CSS reset file that pays special attention to the 
formatting of page styles in older browsers and supports some of the newer media query 
features. For detailed information on this page, visit http://html5boilerplate.com/docs/The-style/.

respond.min.js: This external JavaScript file provides support for CSS3 media queries in 
web browsers that do not support them natively. For detailed information on what this code 
does, visit https://github.com/scottjehl/Respond.
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Styling elements in your fluid grid layout
The layout you created is fairly minimal at the moment. The method of creating and 
applying styles is not new when working with Fluid Grids; however, there is added 
complexity you have to take into account. Remember that every time you create a style, 
it is not just created in one place, but three. To see how to manage this, you’ll style the 
header of your page.

1 Click the Mobile size icon to view your single-column layout.

2 Look within your CSS Styles Panel and click the All tab, if necessary. Expand the 
base.css external style sheet to see all the rules. You might also need to expand the All 
Rules section of the panel as seen here.

The list of rules within your base.css style.

3 Starting at the top of the list, scroll down until you fi nd the fi rst #header style. After 
you locate it, keep scrolling down the list to fi nd a second #header rule. Continue 
scrolling down through the list to fi nd the third #header style.

Although it is not immediately obvious, the fi rst header rule sets the style for the 
mobile styles, the second header sets the style for the tablet, and the third header rule 
sets the style for the desktop.
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3 Double-click the fi rst #header rule. In the CSS Rule defi nition window, click the 
background category. In the Background-color fi eld, type #b1d564. This is the same 
shade of green as the background color of the organic utopia logo. Click OK to apply it.

Applying a background color to the header.

4 In the Design view, note that your header is now the same color as the background. 
Click the Tablet and Desktop views, and note that they have inherited the same 
background color.

Generally, this is not a problem since you don’t want to style the header three diff erent 
times. However, there might be times when you do want the style of an element to be 
diff erent in your tablet or desktop views.

5 In your CSS styles panel, double-click the second #header style (the one for the 
tablet). Click the background category, then click the Background-color swatch, and 
then choose a dark red (the exact shade is not important). Click OK.

This header style is now specifi c only to the Tablet view. Click the Tablet view to see it.
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6 Choose File > Save All, and then preview your page in the browser. Resize your 
browser window until it switches to the tablet view layout. You will see the 
background color of the header change.

The header in your tablet view has a diff erent background color style.

Typically, you wouldn’t change the background color style of a header. This exercise 
was just a demonstration of how to apply styles for specifi c layouts.

7 Close your browser and return to Dreamweaver. Double-click the second #header 
rule in the CSS Styles panel, click the background color property, and remove the 
color you added in Step 5. Click OK.

8 Choose File > Save All to fi nish the lesson.

Congratulations, you have fi nished Lesson 15, “Mobile Design and Layout.”
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Self study
Using your new knowledge of media queries and fl uid grid layouts in Dreamweaver, 
perform the following tasks to build your experience:

To practice with media queries, return to your exercise fi le within the media queries 
fi le, and start building styles for the tablet.css style sheet. Answer some of the following 
questions: should navigation in a tablet layout refl ect the mobile or desktop model? What 
about the number of columns?

The navigation bar used for the phone.css style sheet is only one option for creating layout. 
Come up with another model, such as separating the navigation into two columns. You 
will have to create new and unique styles for the unordered and list elements to do this.

For the Fluid Grid layout, continue styling your page elements. Think of styles that you can 
add to the mobile styles that will “cascade” down to the tablet and desktop styles.

Review 
Questions
1 What are the two main functions of the Multiscreen Preview feature in Dreamweaver CS6?

2 Min-width and max-width are two examples of media queries. Describe a scenario 
in which you would use the min-width media query and describe a scenario in 
which you would use the max-width media query.

3 What is a site-wide media query fi le?

4 When you create a new fl uid grid layout, what defaults can you change in the very 
fi rst step of the process?

Answers
1 The two main functions of the Multiscreen Preview feature are: 1) To show you a 

preview of your current web page in three views (Phone, Tablet, and Desktop) 2) To 
create the rules for any media queries you would like to add to your site.

2 The min-width media query can be interpreted as “greater than or equal to” and the 
max-width media query can be interpreted as “less than or equal to.” For example, if 
you have a media query that uses a min-width value of 700 pixels, a style that applies 
only to screens 700 pixels wide or higher is set. A media query that uses a max-width 
value of 320 pixels means a style that applies only to screens 320 pixels wide or less is set.

3 A site-wide media query fi le is an external style sheet that imports other external style 
sheets based on rules you have created for the width of a user’s screen.

4 When creating a new fl uid grid layout, you are prompted to set up the number of 
columns for your mobile, tablet, and desktop layouts. Additionally, you can change 
the percentage width of each of these layouts, and within the mobile layout, you can 
change gutter space between columns.

DWCS6_06Pass.indb   410DWCS6_06Pass.indb   410 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


411Lesson 16, Managing your Website: Reports, Optimization, and Maintenance

What you’ll learn in 
this lesson:
• Uploading and managing 

fi les

• Optimizing pages for 
performance and search 
engines

• Using Site Reports

• Using the CSS Advisor & 
SEO reports

Lesson 16

When it’s time to release your website to the world, you’ll want to 
take some fi nal steps to make sure your site works at, and looks, its 
best. Dreamweaver has a powerful set of reports, link checkers, and 
problem-solving tools to locate and fi x any potential issues before fi nal 
upload. When you’re ready, the built-in FTP and synchronization 
features of the Files panel will get you up-and-running. 

Starting up
Before starting, make sure that your tools and panels are consistent by resetting your workspace. 
See “Resetting the Dreamweaver workspace” in the Starting Up section of this book.

You will work with several fi les from the dw16lessons folder in this lesson. Make sure that 
you have loaded the dwlessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting Up section of this book.

Managing your Website: 
Reports, Optimization, and 
Maintenance
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Before you begin, you need to create a site defi nition that points to the dw16lessons folder. 
Go to Site > New Site, or, for details on creating a site defi nition, refer to Lesson 2, “Setting 
Up a New Site.”

See Lesson 16 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Working with the Files panel
You’ve already used the Files panel throughout this book to locate and open fi les within 
your site projects. In addition to serving as a useful fi le browser, the Files panel also serves 
as a full-featured fi le transfer application and synchronization tool. From the Files panel, 
you can upload your site to a web server, synchronize local and remote fi les, and manage 
fi les and notes between multiple designers.

Creating a remote connection
The Files panel uploads, retrieves, and synchronizes fi les between your local site and a web 
server. Typically, this is done using File Transfer Protocol (FTP), which connects to and 
allows interaction between your local machine and a web server (there are other options as 
well, including SFTP, WebDav, and more). Before you can transfer fi les, you’ll fi rst need 
to establish a remote connection to the web server that stores your website fi les.

You will not be able to proceed with this portion of the lesson if you do not have FTP 
information available for a web server. If you do not have this information or do not have a 
connection to the Internet, you can choose to read through the steps or skip to the Testing Site 
Integrity exercise in this lesson.

To get started, make sure you have the following:

• The FTP address of the web server and specifi c directory. This would be 
provided by your web-hosting provider as part of your account details, or from 
your company or organization’s IT department. A typical FTP address looks like 
ftp.mysite.com.

• A user login and password for access to the server. Most web servers require 
a user login and password for access. This information should be available from your 
web-hosting provider as part of your account details, or from your organization’s IT 
department.

16
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• The specifi c directory to which your fi les should be uploaded. In many cases, 
this is the main directory or folder that appears when you connect to your web server. 
However, in certain cases, you’ll need to upload fi les to a specifi c directory other than 
the main directory.

• The web address (URL) or IP address where you can view your uploaded fi les 
on the server. Sample addresses would be www.mysite.com/, www.mysite.com/2007/, or 
http://100.0.0.1. 

1 To begin creating a remote connection, choose Site > Manage Sites. The Manage 
Sites dialog box appears.

2 Select the dw16lessons folder for the site defi nition (you set this up at the beginning 
of the lesson) and click the pencil icon in the lower-left corner (Edit the currently 
selected site). If you haven’t created a site defi nition for this lesson, make sure you do 
so now, as discussed in Lesson 2, “Setting Up a New Site.”

3 The Site Setup window appears. Click on the Servers button to access the server setup 
screen. Click on the Plus button in the lower left.

Press the Add new Server button.

This opens up the Basic tab where you will need to add the required information to 
access your server.
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4 Enter your specifi c FTP information in the text fi elds (not our sample information). 
The Server Name should be a common sense label that will help you identify which 
site you are modifying. The FTP Address, Username, and Password are the mandatory 
pieces of information.

Sample remote connection information. Your information should include an FTP address, login, and password, 
with a possible folder name.

Connection options

Clicking the Connect Using menu reveals additional options. FTP is still the default choice 
in Dreamweaver CS6; however, FTP is an aging protocol. Many people are wary of security 
concerns related to FTP because data sent over FTP is not encrypted.

• SFTP stands for “SSH File Transfer Protocol” and represents a more secure version of FTP.

• FTP over SSL/TLS is another more secure version of FTP that relies on encryption. For 
this option, a server must have previously been specifically set up as trusted.

• Local/Network allows you to define a remote folder on a network drive you may be 
connected to. Depending on the setup, this network may or may not also be connected to 
the internet.

• WebDAV is a technology that allows file access to a remote server. It is often used 
collaboratively with multiple users allowed access to the same file system.

• RDS is a security component of ColdFusion Server that permits users to access files and 
databases through a remote HTTP connection.

DWCS6_06Pass.indb   414DWCS6_06Pass.indb   414 5/2/12   5:17 PM5/2/12   5:17 PM

www.it-ebooks.info

http://www.it-ebooks.info/


16

415Lesson 16, Managing your Website: Reports, Optimization, and Maintenance

Working with the Files panel

5 Click the Test button to verify that Dreamweaver can connect to your server. If 
the information you’ve provided is valid and you have a live Internet connection, a 
dialog box appears, confi rming that Dreamweaver has successfully connected to your 
web server. 

A dialog box lets you know if your connection was successful. 
If you receive an FTP error, double-check your FTP information, 
and make any necessary corrections.

6 Press the Save button and you will see your site listed in the Server window.

Your site is now listed in the Server window.

7 Press the Save button in the Site Setup window. This may trigger an activity window 
that updates your site settings. Now that you’re fi nished editing the site defi nition, 
press Done in the Manage Sites dialog box.
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Viewing files on a remote web server
Once you’ve established a connection to your web server, you can expand the Files panel 
for a split view that displays both your remote and local fi les. You can easily drag and drop 
between both sides to upload or download fi les and update existing fi les.

1 If necessary, choose Window > Files to open the Files panel. Click the Expand button 
( ) at the top of the Files panel to ungroup and expand it to full view.

2 Locate and click the Connect button ( ) above the left-hand column at the top of 
the panel. Dreamweaver attempts to connect to your remote server, and, if successful, 
displays all its fi les on the left side of the Files panel.

It’s important to note that web servers can be confi gured in many diff erent ways, 
and you may need to edit your site settings again once you have made a successful 
connection (in particular, the folder information). A discussion of the diff erent ways 
that web servers might be confi gured is outside the scope of this book. If you have 
specifi c questions regarding your site, you should contact an IT professional or your 
web-hosting company.

Click the Connect button to view fi les on your remote server in the left column of the Files panel.
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Transferring files to and from a remote server with Get and Put
The built-in FTP and fi le transfer functionality of the Files panel makes it a snap to 
place fi les on your remote server or download fi les onto your local machine. This can be 
accomplished using the Get and Put buttons, or by dragging and dropping fi les between 
the Remote and Local fi le listings in the Files panel. Please note again, this exercise 
involves publishing your sample documents to a remote server, and therefore publishing 
them to the Internet. Be very careful not to overwrite any pre-existing fi les that may be 
crucial to your website.

1 Make sure you’ve connected to the remote server as described in the previous exercise, 
and that you can see your remote fi les in the left-hand column of the Files panel. 

2 Select the index.html fi le from the local fi le listing on the right side of your Files 
panel, and press the Put button ( ) at the top of the panel. Choose No when asked if 
you would like to include dependent fi les.

Select a fi le and click the Put button to upload it to the remote server.

When you transfer a document between a local and remote folder, a window may open, off ering 
you the option of transferring the document’s dependent fi les. Dependent fi les are images, 
external style sheets, and other fi les referenced in your document that a browser loads when it 
loads the document. This feature can be very useful: think of it as a way to make sure that any 
fi les which are linked to a particular document come along for the ride. For the purposes of this 
exercise, it will not be necessary to transfer dependent fi les.
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Alternatively, you can click and drag a fi le from the right (local) column to the left 
(remote) column.

Drag a fi le from the right column to the left to upload it to the remote server.

To get (download) a fi le from the remote server:

1 Make sure you’ve connected to the remote server as described in the previous exercise, 
and that you can see your remote fi les in the left-hand column of the Files panel.

2 Select the index.html fi le from the remote fi le listing on the left side of your Files 
panel, and press the Get button ( ) at the top of the panel. Note that in your case this 
does not make a lot of sense since you just uploaded your index.html document.

You can update the local or remote fi le listing at any time by clicking the Refresh button ( ) at 
the top of the Files panel.
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Using Check In/Check Out and Design Notes
If you’re collaborating with others on a project, you’ll want to set up an environment 
where everyone can edit fi les independently without overlapping or overwriting someone 
else’s work. For these situations, the Check In/Out and Design Notes features can help 
you manage workfl ow and communicate with others on a Dreamweaver site project.

Check In and Check Out
Dreamweaver’s Check In/Check Out feature is a way of letting others know that you are 
working on a fi le and don’t want it disturbed. When Check In/Check Out is enabled, a 
document that you’re editing becomes locked on the remote server to prevent others from 
modifying the same fi le at the same time. If you attempt to open a fi le that’s been checked 
out by another user, you see a warning that lets you know that the fi le is in use and also 
who is currently working with it. Check In/Check Out doesn’t require any additional 
software to run, and other Dreamweaver users can check out fi les if they also have Check 
In/Check Out enabled in their site defi nition. 

The Check In/Check Out system does not work with a testing server. To transfer fi les to and 
from a testing server (if one is set up), use the standard Get and Put commands.

1 Choose Site > Manage Sites. Select the Dreamweaver site that you want to enable 
Check In/Check Out for and choose the pencil icon to edit the currently selected site.

2 In the Site Setup window, click on the Servers button, then select your site and click 
on the pencil icon at the bottom to edit the server settings.
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3 Click on the Advanced button and then click on the Enable fi le check-out checkbox.

Type your name and email. This information will appear to other users who attempt 
to retrieve a fi le that you have checked out (as long as they are using Dreamweaver). 
Press Save and then press Save again to exit.

Enable check in/check out in the Site Defi nition panel to manage workfl ow between several users.

How does Check In/Check Out work?

Dreamweaver creates a lock (LCK) file for every document that is checked out; this basic text 
file contains the name and e-mail address of the user who has checked out the file. LCK files 
are written to both the remote server and local folder using the same name as the active file. 
When files are checked back in, the LCK files are deleted from both the remote server and 
the local folder.

Although LCK files are not visible in the Files panel, they work behind-the-scenes to let 
Dreamweaver know what’s checked out and what isn’t. Checked-out files appear on both 
the local and remote file listings with a checkmark next to them. Note that a colleague not 
using Dreamweaver can potentially overwrite a file that’s checked out; however, LCK files 
are visible in applications other than Dreamweaver, and their appearance alone can help avoid 
any overwriting issues.

A user will be allowed to override your lock and switch checkout status to themselves. Make sure 
you establish rules with others about how to share and manage locked fi les.
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Checking files in and out
When you check a fi le out, you are downloading it from the remote server to your local 
root folder, and placing a lock on the remote copy. Both your local copy and the remote 
copy appear with check marks next to them, which indicate that the fi le is currently 
checked out for editing. When you check a fi le back in, you are uploading the modifi ed 
version to the remote server, and removing any locks currently on it.

1 Launch the Files panel and click the Expand button to expand it so that you can see 
both your local and remote fi les listed. 

2 Select the fi le in your local folder that you want to check out, and use the Check Out 
button ( ) at the top of the panel. Note that Dreamweaver overwrites your local copy 
of the fi le, as it needs to get the remote fi le from the server. The local and remote 
versions of the fi le appear with check marks next to them in the Files panel. 

Check fi les out before modifying them so other users won’t accidentally overwrite your work.

3 Open the checked fi le from your Local Files panel for editing. Make any necessary 
changes to the fi le, then save and close it.
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4 From the Files panel, select the fi le again in the local Files panel and check it back in, 
using the Check In button ( ) at the top of the panel. The fi le is uploaded to—and 
unlocked on—the remote server. 

When you transfer a document between a local and remote folder, a window may open off ering 
you the option of transferring the document’s dependent fi les. Dependent fi les are images, 
external style sheets, and other fi les referenced in your document that a browser loads when it 
loads the document. For this exercise, it won’t be necessary for you to transfer dependent fi les.

Your local copy becomes read-only, and appears with a padlock next to it. Next time 
you open the fi le for editing, Dreamweaver will automatically check out and get the 
latest copy from the server.

5 Collapse the Files panel to return it to the dock.

Using Design Notes
Design Notes store additional information about a fi le or media object in your Dreamweaver 
site. These notes can be for your own use, or they can be shared with others using the same 
root folder. Design Notes can be set to appear automatically when the fi le is opened, making 
it easy to display up-to-date information to others working on the same site. All Design 
Notes are stored as separate fi les in a _notes folder inside of your site’s root directory.

What can be put in Design Notes?

Design Notes can contain any information that is important to the fi le or project; you 
can store design instructions, updates about the project, or contact information for project 
managers and supervisors. You can also store sensitive information that you ideally would 
not want in the fi le itself, such as the name of the last designer to work on the fi le or the 
location of important assets. You can even set the status of the fi le to indicate what stage of 
the revision the fi le is in.

1 To create a Design Note, under the Files panel, open the store.html fi le from the 
current site. 

2 Choose File > Design Notes. The Design Notes dialog box appears.

3 Type a message in the Notes fi eld. If you want to insert the current date stamp, you 
can click the Calendar button ( ) above the Notes fi eld on the right side. If you want 
the note displayed when the fi le is next opened, check Show when fi le is opened.

The Status menu is used to set the document status; this can be useful in letting other 
collaborators know the revision stage of the current document.
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4 Press OK to create the Design Note.

To view a Design Note, choose File > Design Notes when a fi le is open in the 
document window. As mentioned earlier, you can also choose to have Design Notes 
automatically appear when the fi le is fi rst opened.

Design Notes can also be created or viewed directly from the Files panel. Simply right-click 
(Windows) or Ctrl+click (Mac OS) a document in the fi les list and choose Design Notes from the 
contextual menu.

Sharing Design Notes
By default, Design Notes are stored only in the local site folder, and are not automatically 
copied to the remote server. However, you can share Design Notes with other collaborators 
by having Dreamweaver automatically upload and update them on the remote server.

1 Choose Site > Manage Sites. Select your site and choose Edit (the pencil in the 
bottom-left corner of the Sites dialogue box). The Site Setup window appears.

2 Click on the Advanced Settings options and choose Design Notes from the left.

3 Under the Design Notes panel, check Enable Upload Design Notes for sharing. 
Design Notes are now copied and updated on the remote server so that other users can 
share them. 

Set up Design Notes for sharing so other Dreamweaver users can see and modify Design Notes on the remote server.

4 Choose Save to update the site defi nition, then press Done to close the Manage Sites 
dialog box. 
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Displaying Design Notes in the Files panel
A convenient way to view and access Design Notes is by enabling the Design Notes 
column in the Files panel. An icon that can be used to open and edit Design Notes 
accompanies documents that have an associated Design Note. This feature also allows you 
to see all available Design Notes at a glance. 

1 Choose Site > Manage Sites. Select your site from the Sites panel and choose Edit. In 
Advanced Setting options, choose File View Columns.

Use the Site Defi nition panel’s File View Columns category to show Design Notes in both the local and remote fi le listings.

2 Double-click the Notes item from the list and click the Show checkbox and then press 
Save.

3 Choose Save to update the site defi nition, then press Done to close the Manage Sites 
dialog box. You will likely see the Background File Activity window appear; wait 
for this to complete. A Notes column appears in the Files panel; a Notes icon ( ) is 
displayed next to each fi le that is currently associated with a Design Note.
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Testing site integrity
Catching potential issues on a page before your visitors do is key to ensuring success 
from the start. Broken links, display issues, or unreadable pages can make the diff erence 
between a great fi rst impression and a poor one. To help you identify and address problems 
before you publish your site, Dreamweaver provides many useful tools that can point out 
potential hazards and, in some cases, help you fi nd a solution.

Using Check Links
The Check Links feature detects any broken links between pages in your local site and 
will identify orphaned fi les that are not linked to or used by any document within the site. 

1 From the Files panel, double-click and open the index.html document.

2 Choose File > Check Page > Links.

Choose File > Check Page > Links to check for broken links in the current document.

3 The Link Checker panel appears; you see one listing here. A link to the exhibits.html 
page is misspelled; you need to fi x the error.
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4 Click the misspelled “exhbits.html” item under the Broken Links column. The link 
name becomes editable.

Clicking on the link in the Broken Links column allows it to be edited.

5 Click on the Folder icon to the far right. A Select File dialog box appears. Select the 
fi le exhibits.html and then press OK (Windows) Open (Mac OS). In the Link Checker 
tab, press Enter (Windows) or Return (Mac OS), and the broken link disappears.

6 Close the Link Checker panel by right-clicking (Windows) Ctrl+clicking (Mac OS) 
the Link Checker tab and choosing Close Tab Group. Save and close the current 
document.

Checking links sitewide
Check Links can be used on a single document, on multiple documents (through the Files 
panel), or on an entire local site.

1 Choose Site > Check Links Sitewide.

2 The Link Checker panel appears; by default, all broken links are displayed. All the 
broken links here are referencing the same incorrect link to category_books_cds.html. 
This could have happened if you or a collaborator on the site changed the name of the 
fi le within the operating system or another web editor.

Choose Site > Check Links Sitewide to check for broken links throughout the current local site. 
The Link Checker panel opens and displays any broken links found.
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3 To view external links, choose External Links from the Show drop-down menu at the 
top of the panel. This site will have none, but any links to outside web pages that you 
have on your site would be listed here.

External links are displayed, but aren’t validated by Dreamweaver. The Link Checker can only 
validate links between local documents and fi les.

4 To view orphaned fi les, choose Orphaned Files from the Show drop-down menu at 
the top of the panel. In this site, a number of fi les will appear. Orphaned fi les are fi les 
in your site that are not currently being linked to. This may include stray multimedia 
fi les that have not been added to a page yet. You will not be doing anything with 
these fi les at this time. 

5 Choose Broken Links from the Show drop-down menu to return to the broken links 
report. Click on the fi rst of the broken links shown to edit it. Click on the Folder icon 
and browse through your site folder to locate the category_bookscds.html fi le. Select 
this fi le, press OK and then press Enter (Windows) or Return (Mac OS). 

6 A dialog box appears, asking if you’d like to make the same correction throughout the 
entire current local site. 

Adjust a link directly from the Link Checker panel to correct it across the site.
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Click Yes. Behind the scenes Dreamweaver will go through all the pages and 
automatically update to the correct link. This feature is an amazing timesaver as you 
don’t even have to open the fi les to make the changes!

Viewing Link Checker results

If and when the Link Checker returns results, you can jump to any problem document to 
view and fix any issues. The Link Checker panel’s Show menu (located at the top of the 
panel) toggles between three different Link Checker reports: Broken Links, Orphaned Files, 
and External Links.

Broken Links are lists links that point to files not found within the local site. To jump 
to a page that contains a broken link, double-click the filename shown in the left column 
of the Link Checker panel. To correct a link directly from the Link Checker panel, click 
the link shown under the Broken Links column of the panel to edit it. Type in the proper 
page name or use the folder to browse to the proper file. If you edit a broken link this way, 
Dreamweaver can apply the same correction throughout other pages on your site.

Orphaned Files are any pages, images, or media files not linked to, referenced, or used by 
any files in your site. This report can be useful in identifying unused files that can be cleaned 
up from the local site, or pages that should be linked to (like a site map) but were overlooked.

External Links list any links to outside websites, pages, or files; and like the Broken Links 
panel, allows you to directly edit them or jump to the page that contains them. It’s important 
to note, however, that Dreamweaver does not validate external links—you will still be 
responsible for double-checking these links on your own. You’ll also notice that e-mail 
(mailto:) links are included in this list.

Generating site reports
Dreamweaver’s site reports feature is an indispensable asset for detecting potential design 
and accessibility issues before publishing your site to the Web. Reports can be generated 
in several categories to give you a virtual picture of health, and the opportunity to locate 
and fi x minor or major issues across an entire Dreamweaver site. These issues can include 
missing alternate text or titles, CSS issues, and recommendations for better accessibility 
practices, based on the W3C’s Web Consortium Accessibility Guidelines (WCAG). 

Reports can be generated for a single page, selected documents, or the entire current local 
site. Any results open and display in the Results panel, where you can see a list of issues 
and the pages on which they are located.
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1 To run a site report, choose Site > Reports. The Reports dialog box opens, displaying 
two categories of reports: Workfl ow and HTML. 

It is not necessary to have a document open in order to run sitewide reports.

Workfl ow reports display information about Design Notes, Check In and Check Out 
operations, and recently modifi ed fi les. HTML reports display potential design, 
accessibility, and display issues based on best practices and W3C/WCAG accessibility 
guidelines.

2 In the Reports panel, check all the reports under the HTML category. At the top of 
the panel, select Entire Current Local Site from the Report on drop-down menu.

Choose Site > Reports, and select the reports you’d like to run in the Site Reports dialog box.

3 Click Run in the top-right corner of the Reports panel. The Results panel appears, 
displaying any potential issues. Note that depending on the size of your site and 
number of issues found, it may take a few moments for all results to display.

4 Leave the Results panel open; you’ll learn how to read and address issues in the next 
exercise.

The Results panel displays issues found across your entire current local site.
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Understanding report results
At fi rst glance, you may be overwhelmed at the amount of information returned by site 
reports. Keep in mind that many of the listings returned are recommendations or possible 
issues that should be looked into, not necessarily items that will prevent a site from 
working. Learning to read these site reports a little more closely will enable you to decide 
which items are crucial to your site’s performance, requiring immediate action. Listings 
are displayed with three distinct icons. 

ICON NAME USE

Question Mark These listings suggest possible accessibility issues that should be 
investigated. Many of these issues have a reference to a specific 
W3C/WCAG guideline.

Red X These listings indicate a failure to meet a certain guideline or 
requirement. Possible listings could include missing header 
information, deprecated HTML markup, or page titles that are not 
defined properly.

Warning Sign Warnings indicate missing information that may be potentially 
detrimental to a site’s performance, such as missing ALT text for 
images.

Addressing a listed item
After you’ve sifted through the report results, you’ll want to use the Results panel to 
address items listed in the Site Reports tab.

1 Go to the Site Reports tab on the Results panel. Click the Description column header 
to sort the results. Scroll to the bottom of the page as needed, and locate the store.html 
listing.

 
Select a listing and click the More Info button to display a detailed description about the issue found.

The Description column shows that an image on this page is missing the ALT 
attribute and alternate text. This attribute can potentially aff ect accessibility of your 
site; you don’t need to fi x it, but we highly recommend you do.

2 Double-click the store.html listing to open the page for editing. Your document 
window will divide into the Code view and Design view; the image appears selected 
in the Design view and highlighted in the Code view.
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3 In the Property Inspector, type MKI Gift Cards are now available! in the Alt fi eld 
and press Enter (Windows) or Return (Mac OS).

Select the problem image and enter text in the Alt fi eld to rectify the problem.

Whenever you have multiple results as you do here, you might want to save them for 
future reference. Reports can be saved as XML for import into databases, existing 
template fi les, and archival fi les. You can sort report results using the Results panel 
before saving them.

4 Click the Save Report button ( ) on the left edge of the Results panel. When the 
Save Report dialog box appears, assign the report a name, and choose a location for 
the fi le.

5 Save and close the page, and close the Results panel.

A full listing of accessibility guidelines, or WCAG, for web page designers and developers is 
available at the World Wide Web Consortium (W3C) website at W3.org.
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The Browser Compatibility Check 
When you format page content or create layouts with CSS, you’ll want to be certain that 
your pages appear consistently across a variety of browsers. Some combinations of HTML 
and CSS can unearth some nasty display bugs in specifi c browsers. In fact, some browsers 
may not support certain CSS properties at all. To seek out and fi x any potential CSS 
display problems, you’ll use Dreamweaver’s Browser Compatibility Check (BCC) reports 
in conjunction with the CSS Advisor.

Optimizing pages for launch
Although page optimization is discussed at this latter point in the book, it is by no means 
an afterthought. A big part of preparing a site for success involves making it accessible 
to users with special needs, such as those who are visually impaired, or preparing it for 
indexing by various search engines. In addition to clean design and well-written content, 
pages can be optimized through the use of keywords, descriptions, and often-overlooked 
tag attributes, such as alternate text (alt) for images and a page’s Title area. Combined, 
these pieces of information facilitate site usability and visibility in several essential ways. 

Search engine visibility and Search Engine Optimization 
A big part of a website’s success stems from its visibility. Visibility comes through good 
advertising, networking with other sites, and, above all, proper indexing and listings on 
the Web’s major search engines. Search engines can be a key to generating business and 
visits to your site, but only if your website can be easily found. Major search engines such 
as Google (which powers AOL, MySpace, and Netscape searches), Yahoo! (which powers 
AltaVista and others), and LiveSearch (formerly MSN Search) use a variety of factors to 
index and generate listings for websites. Many of these factors start at home, or more 
appropriately, on your home page.

Titling your documents with the <title> tag
Each document’s head area contains a <title> tag, which Dreamweaver automatically 
inserts with any new HTML/XHTML document. At its most basic, the <title> tag sets 
a display title for a page that appears at the top of the browser window. You can modify 
the <title> tag contents using the Title text fi eld that sits at the top of your document 
window. By default, each new document is issued the default title of Untitled Document. 
The <title> tag and its contents, however, can be a powerful and eff ective way to assist 
search engines in indexing your page.
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What makes a good title?

A good document title ideally should include keywords that describe your site’s main 
service, locale, and category of business or information. In addition to the obvious—your 
company’s name—think about the categories you would want your site to appear under 
on a web directory or as the result of a web search. For instance, the McKnight Institute 
would ideally want users looking for science museums or exhibits in the Philadelphia, 
Pennsylvania, area to fi nd them fi rst. A possible title could be: The McKnight Institute: 
Science Museum, Educational Exhibits and Attractions, Philadelphia, Pennsylvania.

This title contains several important keywords that describe the Institute’s off erings, and 
features the Institute’s name and location. In addition, reshuffl  ing these phrases and words 
produces several other search terms that could be benefi cial to the Institute, such as:

• Science Exhibits

• Philadelphia Museum

• Pennsylvania Attractions

Avoid the rookie mistake of including only your company name in the document title. 
Remember, web searchers who haven’t used your business before will only search by terms that 
apply to the service they are seeking ( for example, wedding photographers, Washington, D.C.). 
Even the most recognized names on the Web, such as eBay and Amazon, include generic search 
terms in their page titles.

To add a title to your web page:

1 From the Files panel, select and open the index.html document to open it for editing.

2 Locate the Title text fi eld at the top of the document window. It currently displays 
the default title of Untitled Document. Select its contents and type The McKnight 
Institute: Science Museum, Educational Exhibits and Attractions, 
Philadelphia, Pennsylvania and press Enter (Windows) or Return (Mac OS).

Add a well-constructed title to the index.html page to make it more search-engine and bookmark friendly.

3 Choose File > Save to save the document, and then choose File > Preview in Browser 
> [Default browser] to open the document in your system’s primary browser.
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4 Note the title that now appears in the bar at the top of the browser window. Close the 
browser window and return to Dreamweaver.

The most basic purpose of the <title> tag is to display a title at the top of the browser window. If used properly, it can also be 
used as a powerful hook for search engines.

While there is technically no limit to title length, the W3C’s Web Consortium Accessibility 
Guide recommends that page titles be a maximum of 64 characters to be considered ‘well-
defi ned.’ Titles exceeding this length may generate warnings in the Site Reports Results panel. 
Longer titles may also appear truncated (cut off ) when displayed in some browser windows.

Bookmark-ability: another benefit of the <title> tag

It’s common for users to bookmark a site or specific page they’ve found so that they can easily 
return to it. Every browser has a bookmark feature, which allows users to mark and display 
favorite sites in an organized list; sometimes, favorite sites are listed in a Bookmarks bar in 
the browser window.

The document title determines the text that appears with a bookmark, so it’s important to 
consider this when creating a good document title. Using a vague or nondescriptive title 
(or even worse, the default Untitled Document text) can make it impossible for a user to 
remember which bookmark is yours. A good title appears as a descriptive bookmark in a 
browser’s Favorites list or Bookmarks bar.
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Adding meta keywords and descriptions
While Search Engine Optimization (SEO) is a broad topic that’s far beyond the scope of 
this book, good SEO methods begin at the design level. Search engines use a variety of 
factors to rank and list web pages. Keywords and descriptions can help specify the search 
terms that are associated with your site and how it’s listed. The HTML <meta> tag enables 
you to associate any page with a specifi c list of search terms, as well as a brief description 
of the page or the website itself. Like the <title> tag, <meta> tags are placed in the 
<head> section of a page, and can be added from the Common Insert bar on the right side 
of your workspace.

1 If it’s not already open, open the index.html document for editing.

2 From the Common Insert bar, choose the Keywords button from the Head tags group.

3 When the Keywords window appears, add a comma-separated list of search keywords 
that you’d like associated with this page, or the site in general. While there is no 
general consensus on the limit of how many keywords you can use, common sense says 
that you should be able to categorize your site in roughly 20 keywords or fewer. For 
example, type museum, technology exhibits, attractions, family attractions, 
philadelphia, pennsylvania museums. Click OK to add the keywords.

From the Common category of the Insert bar, choose the Keywords object from the Head tags group and enter a list of 
keywords in the resulting dialog box.
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4 Now you’ll add a description that a search engine can use to summarize your page 
when creating a listing for it. Choose the Description button from the Head tags 
group on the Common Insert bar.

5 When the Description dialog box appears, type in a brief descriptive paragraph (fewer 
than 250 characters, including spaces). For example, type The McKnight Center is 
a family-oriented education center and museum that explores the history of 
technology and scientifi c discovery through hands-on exhibits and events. 
Click OK.

Add a short description that search engines can use to display a caption 
for your site listing.

6 Choose File > Save, then choose File > Close to close the fi le.

Launching your site
Before launching your site for the public—and to ensure that your site looks and works at 
its best—take a moment to go over this pre-fl ight checklist.

Site Launch Checklist
• Enter FTP or upload information and test your FTP connection.

• Check links sitewide and repair missing or broken links and images.

• Run site reports and address crucial issues. Put special emphasis on:

 – Missing document titles

 – Missing alt text

 – Invalid markup that may cause display issues

• Open the homepage (index.html, and so on) and navigate through your site, using 
menus, links in copy, and linked images to check page fl ow. Do this in several browsers, 
and, if possible, on both Windows and Macintosh platforms.

• View your home page and major section pages in a web browser in the three most 
common screen resolutions: 640 × 480, 800 × 600, and 1024 × 768. 
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Uploading your site
From this point forward, the exercise assumes that you have access to a remote FTP server.

1 If you’re ready to upload your site to the remote web server, make sure that the Files 
panel is open (Window > Files).

2 Click the Expand button ( ) at the top of the Files panel to display it in two-column 
expanded view.

3 Click the Connect button ( ) above the left (remote view) column to connect to 
your remote web server.

You need to have created a valid connection, as described earlier in the lesson.

Once a successful connection is made, the remote fi les (if any) display in the left-hand 
column.

4 In the right column, click and select the Folder icon at the very top of the fi le 
listing. This should be the root folder, and displays the current site defi nition title 
(dw16lessons).

5 Click the Put button at the top of the Files panel to copy the entire current local site 
and all included fi les to the current directory on the remote server. A dialog box 
appears with the message, Are you sure you wish to put the entire site?

Select the root folder of your local site, and click the Put button to upload the entire site to the web server.
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6 Click OK to begin copying the fi les to the remote server. The Background File 
Activity window appears with a progress bar and a list of the fi les being transferred.

Files being transferred in the Background File Activity window.

7 Collapse the Files panel to return it to the dock. Your site is now live!

Getting help and using the reference guides
Whether you are seeking a solution to a Dreamweaver-specifi c problem, or looking up 
the appropriate CSS rule to format a page item, you can use Dreamweaver’s built-in Help 
system and integrated reference guides. In addition, the Help menu provides direct links 
to many online resources and Adobe support areas where you can seek help from Adobe 
professionals and the Dreamweaver user community.

1 To access the Help system, choose Help > Dreamweaver Help. The Adobe Help 
Viewer panel appears. 

2 Enter a search term at the top of the panel, or browse by topic on the left-hand side of 
the panel.

3 For more help options and a searchable knowledge base, choose Help > Dreamweaver 
Support Center. For the Dreamweaver support forums, choose Help > Adobe Online 
Forums.
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The Reference panel
Dreamweaver’s Reference panel is like a full library of technical books, including reference 
guides for HTML, CSS, JavaScript, and Dreamweaver-friendly, server-side languages such 
as ColdFusion and JSP.

1 To open the Reference panel, choose Help > Reference.

2 From the menu at the top-left corner of the panel, select the Usablenet Accessibility 
Reference from the Book menu.

3 Click on the Rule menu and a list of various guidelines that will help you make your 
websites more accessible appears. Choosing any topic reveals detailed information in 
the window below.

Suggested next steps
Congratulations on launching your fi rst Dreamweaver site project! There’s nothing more 
exciting than having your hard work on the Web, and available for the world to see. The 
important thing to remember is that your website should not be static; part of maintaining 
a successful website requires continuously evolving it to meet the needs of your viewers, 
and keeping the content fresh and new.

Whether your site is for business, pleasure, or self-promotion, be sure to solicit feedback 
from friends, family, and colleagues after you’ve launched. Alert a small and trusted group 
about the launch by sending out an e-mail, mailing a postcard, or posting a notice on a 
blog (sometimes this is referred to as the ‘beta’ stage). Feedback and constructive criticism 
(a little praise is OK, too) are the best ways to objectively know what needs improvement. 
You’ll probably receive more feedback and suggestions than you can handle, so focus on 
points that are common across multiple users, and address any major issues before making 
a more public launch (for instance, to your entire client base).

Focus on focus groups

Focus groups are an excellent way to get nonbiased feedback on a major new site or 
product launch, and they have been a regular practice in product marketing and research 
for years. A focus group is composed of a group of individuals who are brought together to 
analyze, try out, and comment on a specifi c product—in this case, your website—for the 
purpose of obtaining feedback and testing the product’s eff ectiveness. 
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Groups can be guided through certain portions or processes on the site, or may be 
encouraged to navigate it on their own. Afterwards, they are polled with specifi c questions 
about their experience, and the results are put together to form a picture of the site’s 
usability, eff ectiveness, and impact. This may include questions such as the following:

• Did you feel the website was easy to navigate? On a scale from 1 to 10, how would you 
rate the diffi  culty level in locating specifi c pages or topics?

• Did the design, including graphics and color themes, eff ectively help communicate the 
website’s off erings?

• On a scale from 1 to 10, how would you rate the quality of the written content on the site?

Focus groups are often interactive, encouraging participants to talk with each other and 
share their opinions. In some cases, a moderator may be used to regulate group discussions 
and hand out questionnaires. Participants can be composed of a focused demographic 
group (for instance, 25- to 35-year-old technology professionals), or they can represent a 
diverse professional and demographic range.

Focus groups are reasonable for any size company to organize—even if it’s just you and 
fi ve friends—and are a highly eff ective way to fi nd out what’s currently working and 
what’s not. Give it a try; you may fi nd the results encouraging, surprising, or even slightly 
discouraging. The trick is to use this feedback wisely toward the main purpose of making 
a better website, and you’ll be glad you did.

Website design resources
There is a vast amount of information, and many tutorial-based websites, covering topics 
from web page standards to advanced CSS design. Here is a small sampling of some useful 
sites that can help you take your skills and knowledge further. Use these in conjunction 
with Dreamweaver’s built-in reference guides and Adobe’s online support forums:

• W3C (World Wide Web Consortium) — www.w3.org

• Adobe’s Dreamweaver Developer Center — www.adobe.com/devnet/dreamweaver

• DigitalClassroom — www.DigitalClassroom.com
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Review 

Self study
Import a site from a previous lesson from this book or import your own site, and run a site 
report for broken links, orphaned fi les, and so on.

Investigate Dreamweaver’s CSS Advisor by examining various fi les from this lesson and 
previous lessons. Using the CSS Advisor is a great way to learn more about CSS and 
browser compatibility issues.

Review 
Questions
1 What does FTP stand for, and what is it used for? 

2 What three purposes do document titles serve, and why are they important? 

3 What are three possible pre-fl ight checklist items you need to address before launching 
a website? 

Answers
1 File Transfer Protocol. FTP is used to connect to and transfer fi les between your local 

machine and a web server.

2 Document titles display a title at the top of the browser window, in a user’s bookmarks 
bar, and are an important hook for search engines.

3 a.  Enter and test your FTP connection information in the Site Defi nition panel. 

b.  Run site reports to rectify any potential design or accessibility issues, such as 
missing alternate text for images or empty document titles. 

c.  Run the Link Checker site wide to check for broken links between pages or 
incorrect image references.
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What you’ll learn in 
this lesson:
• CSS Transitions

• Fluid Grid

• Web Fonts

• jQuery Mobile Swatches

• PhoneGap basics

Lesson 17

Dreamweaver’s features evolve as the Web evolves. In this lesson, 
you’ll take a tour of Dreamweaver’s new features.

What’s new in Dreamweaver CS6?
The version of Dreamweaver prior to CS6 was Dreamweaver CS5.5; the fact that Adobe 
released a “.5” version might indicate that Adobe is increasing the speed at which it 
releases updates. This increase in speed makes sense for a program such as Dreamweaver, 
due to the speed at which web technology evolves. In fact, most of the major additions in 
5.5 were new features for the rapidly evolving landscape of mobile design, including the 
Multiscreen feature (with support for CSS3 media queries), support for jQuery mobile, 
and support for the development of iOS and Android applications using the Phonegap 
Framework, among others. 

Some of the new features in 5.5 have been integrated into the exercises in this book, most 
notably in Lesson 15, “Mobile Design and Layout.” However, given that many users might 
have upgraded directly to Dreamweaver CS6 from CS5, we cover the 5.5 features in a 
separate section at the end of this lesson.

Dreamweaver CS6 
New Features
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Dreamweaver CS6 introduces three major new features: Fluid Grid Layout, CSS3 
Transitions, and Web Font Integration. These features have also been integrated into 
some of the lessons in this book, primarily in Lesson 15, “Mobile Design and Layout” 
and Lesson 7, “CSS3 Animation and CSS3 Web Fonts.” In addition to these major new 
features, there are a few upgrades to pre-existing features such as Business Catalyst, jQuery 
Mobile, and PhoneGap.

Fluid Grid Layout
Dreamweaver’s new Fluid Grid Layout feature is essentially a combination of two 
advanced layout techniques currently used by a number of web designers today: 1) a 
grid system; and 2) responsive web design. Grid systems have been a staple of print and 
web design for many years, and involve the designer using a “grid” structure (composed 
of rows and columns) on a page to make the aligning and grouping of content more 
structured. Responsive web design is a relatively new layout technique for the Web that 
allows page layout to respond or adapt based on the user’s screen size.

An empty Fluid Grid Layout page with its default columns.
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What’s new in Dreamweaver CS6?

Fluid Grid Layout allows a designer or developer to build a new page with an empty grid, 
and then add Fluid Grid Layout Divs into which they can add content such as text and 
images. These layout containers are unique in that they snap to the grid columns, but just 
as importantly, you can also control the way the layout containers appear based on the size 
of the user’s screen. For example, you could create a fi ve-column layout for users with 
extremely wide desktop monitors and users with small screen sizes, such as mobile phones, 
would see just a single column layout.

The Fluid Grid feature creates three layouts by default: one for mobile screens, one for tablets, and one for desktops.

The goal of Fluid Grids is to allow your website to respond or adapt to the user’s screen 
while maintaining the degree of structure and composition that a grid layout provides.
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CSS transitions
Dreamweaver CS6 has a new CSS Transitions feature that includes the ability to add 
animation eff ects to objects on your page. An example of a transition is a button that 
gradually changes color when the user hovers over it, known as a rollover eff ect. In 
previous versions of Dreamweaver, you had to use some form of JavaScript to create 
a rollover eff ect, perhaps even use one of the Spry eff ects (which are JavaScript). CSS 
Transitions in Dreamweaver are built with CSS3 syntax that allows you to set the 
duration, delay, and easing of many CSS properties, including background-color, opacity, 
font-size, and much more. 

CSS Transitions allow you to add eff ects, such as an animated navigation menu with fade eff ects.

One of the benefi ts of CSS Transitions is that you can create basic visual eff ects within 
Dreamweaver without JavaScript or Flash. A good use of transitions, for example, is to 
create a smooth fading eff ect on the user interface, such as menus.
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What’s new in Dreamweaver CS6?

Web fonts
Dreamweaver CS6 takes major steps toward addressing the lack of choice in fonts to use on 
the Web with the new Web Fonts feature. This feature takes advantage of the @font-face 
property in CSS3 to give Dreamweaver users a much easier way to add new fonts to their 
page. When you choose Modify > Web Fonts, the Web Fonts Manager appears, allowing 
you to link to any commercially-licensed web font you want to embed on your page.

Adding a web font to your site requires linking to the font fi les in your local folder.

After you embed a specifi c web font on your page, you can easily apply the style of the 
font using the Property Inspector. The addition of web fonts in Dreamweaver means it is 
quite easy to add unique styles to page elements such as headings and still maintain the 
benefi ts of CSS.

A heading with a Web Font style applied.
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jQuery Mobile Swatches
Dreamweaver CS5.5 introduced support for jQuery Mobile (see the following section 
New Features in Dreamweaver CS5.5 for a full description). In addition to the features 
found in the previous version, there is now the addition of jQuery Mobile Swatches 
in CS6. This feature allows you to quickly style jQuery layout elements as well as user 
interface elements by dragging and dropping color swatches onto your page. You can 
choose from a preset number of element themes within Dreamweaver as well as download 
additional themes for your use. This feature is accessed within a jQuery site by choosing 
Window > jQuery Mobile Swatches.

PhoneGap Build Service
This feature is an upgrade of the PhoneGap integration introduced in Dreamweaver CS5.5 
(see the following section New Features in Dreamweaver CS5.5 for a full description). 
The PhoneGap Build Service allows you to connect with your online PhoneGap account 
in order to build native applications for the following mobile operating systems: iOS, 
Android, Blackberry, webOS and symbian. This integration dramatically reduces the 
complexity involved in compiling these applications and also provides online emulators as 
well as the ability to download your compiled applications from your PhoneGap account. 
This feature can be accessed by choosing Site > PhoneGap Build Service.
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New Features in Dreamweaver CS5.5

New Features in Dreamweaver CS5.5
The Multiscreen Preview option and the related CSS3 Media Queries are perhaps the 
biggest change in Dreamweaver CS5.5, but there are several other new additions, many of 
which are related to mobile design and development.

CSS3 and HTML5 authoring support 
Dreamweaver CS5.5 has added to its internal library of code many of the new HTML5 
elements and CSS3 styles. Examples of HTML5 elements now available include 
<header>, <nav>, <aside>, and others. In previous versions of Dreamweaver, there was 
no code that indicated the use of these elements. Users could still add the elements, but 
they were not readily available in Dreamweaver’s code-hinting interface.

You can easily create HTML5 pages in Dreamweaver with 
code-hinting support for the new HTML5 elements.

Similarly, CSS3 includes several new styles to help you enhance your pages, including 
features such as rounded corners, gradients, border images, and more. These CSS3 
properties are now readily available in Dreamweaver’s code-hinting library. (This library 
also includes the vendor-specifi c prefi xes needed to ensure that styles are visible on specifi c 
browsers, such as Firefox, Chrome, Safari, and Internet Explorer.) 

You can easily add CSS3 styling in Dreamweaver with 
code-hinting support for the new CSS3 styles.
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jQuery Mobile integration
Designers and developers who need to create web pages and user interfaces optimized for 
mobile devices can create Dreamweaver projects using the jQuery Mobile Framework. 
jQuery is generally used for desktop applications to enhance websites with the reliable 
JavaScript code included in this open-source JavaScript library. The jQuery Mobile 
Framework is a relatively new addition that lets you add features such as animations and 
components for touchscreen interfaces, form fi eld validation, pattern matching, and more.

You can create a site optimized for mobile by choosing File > New Page From Sample 
> jQuery Mobile to open a layout that has placeholder content and several built-in user 
interface features. Some examples of these built-in interface features are a multi-page 
design with styles formatted for mobile, animated pages and collapsible panels, and buttons 
designed for the touch-sensitive capabilities of smartphones, tablets, and other touch-
enabled screens.

The default layout for a jQuery Mobile project includes page 
elements targeted for touchscreen interfaces.
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Support for building native mobile apps for iOS and Android with PhoneGap 
In addition to the jQuery Mobile support, designers and developers can now use 
Dreamweaver to build native applications for iOS and Android applications with help from 
the PhoneGap Framework. This framework packages HTML, CSS, and JavaScript fi les 
into native applications to let designers and developers with limited or no programming 
nowledge build native apps. 

You can build an entire site as a native application by choosing Site > Mobile Applications 
> Build. For the Android operating system, Dreamweaver helps install the necessary SDKs 
on your system using the Easy Install option. For iOS, you need to manually install Apple’s 
Xcode or the Apple iOS SDK to compile the applications from Dreamweaver.

You can create native applications for Android or iOS with Dreamweaver CS5.5 or CS6 and 
support from the PhoneGap framework.

W3C Validation
Designers and developers have long used the World Wide Web Consortium (W3C) as 
a resource to help troubleshoot problems. The W3C provides a free service that checks 
HTML, XHMTL, and CSS documents for syntax errors. In the past, you would have had 
to go to the W3C website and either upload your fi le, or copy and paste your code into 
their web interface. Starting with the release of CS5.5, Dreamweaver now allows you to 
send your fi le directly by clicking the W3C button at the top of your document window. 
The results then appear within a W3C Validation window in Dreamweaver.
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. (period character), 129
# (pound sign), 129

A
absolute hyperlinks, 76
absolute links, 78
absolute positioning, 136–138
Absolutely Positioned CSS layouts, 

153–155
action attribute, <form> tag, 320
Action section, Property Inspector, 333
Active links fi eld, Page Properties 

dialog box, 52
Add new Server button, Site Setup 

dialog box, 413
Add property, CSS Styles panel, 354
adding

additional content and styles to 
page, 148

descriptions to page, 435–436
elements to web forms, 322–333

checkboxes, 325–326
File Upload fi eld, 331–332
lists and menus, 328–329
radio buttons, 326
radio groups, 327–328
Submit and Reset buttons, 332–333
text area, 330
text fi eld, 323–325

image placeholders, 88–89
images

brightness and contrast, 89
gallery page, 84–86
image formats, 83–84
image resolution, 83
linking, 87
resizing, 90–91
updating, 91

main content area to page, 146–147
meta keywords to page, 435–436
pages to website

fi xed columns, 46
liquid columns, 46
overview, 45–48
saving pages, 48

sidebar content area to page, 146–147
text

hyperlinks, 74–79
lists, 80–81
overview, 63
previewing pages in web 

browser, 73–74
styles, 69–73
typography and images on web, 64
using Text Insert panel, 82–83

validation, 339–342
video, 263–266

addressing listed item, 430–431
Adobe Flash

adding video, 263–266
inserting movies, 260–263
making web content interesting, 260
overview, 259

Adobe Flash CS6 Professional 
application, 260

Adobe Flash Media Server, 264
Adobe Flash player, 6
Adobe Media Encoder, 263
Adobe Photoshop CS6, 10
Adobe Soundbooth program, 271
Advanced Formatting CSS button, 312
advanced page layout

AP divs, 158
browser compatibility

adding code for IE 6, 178–179
applying fi nishing touches, 

179–180
changing column layout and size, 

172–175
creating appearance of equal height 

columns, 175–177
creating columns with CSS

setting width and fl oating 
columns, 163–164

using Clear property, 165
creating columns with HTML, 

161–162
creating more sophisticated layouts, 

180–181
fl oat property, 158–161
list-based navigation bar, 166–172
overview, 157

Advanced Settings option, Site Setup 
dialog box, 40, 43

advanced site-creation options
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
overview, 43–44
Spry category, 44
Templates category, 44

advanced text formatting, CSS, 112–114
.aif format, 269
AJAX (Asynchronous JavaScript and 

XML), 348
All button, CSS Styles panel, 179
alt attribute, <img> tag, 85
alternate row styling, 234–236
Alternate text fi eld, Image Tag 

Accessibility Attributes dialog 
box, 85

ancestor elements, CSS, 116
Android, 203, 451
animation

CSS properties, 188

description of, 260
Anything radio button, Validate Form 

dialog box, 342
AP Divs

advanced page layout, 158
positioning content

adding additional content and 
styles, 148

adding images to layout, 144–145
adding introduction section to 

page, 142–143
adding main and sidebar content 

areas, 146–147
creating header section with 

Draw AP Div tool, 
139–141

Photoshop integration, 145–146
AP Elements panel, docking, 243
Appearance (CSS) category, Page 

Properties dialog box, 49
Appearance (HTML) category, Page 

Properties dialog box, 51
Apple Soundtrack Pro program, 271
Apply Class section, Property 

Inspector, 338
Apply Comment button, Coding 

toolbar, 306
Apply Source Formatting command, 312
Arial font, 66
ASP.NET

coding environment, 11
collecting form data, 346
form processing and validation, 338
inserting tags, 298
Server Model menu, Testing Server 

section, 43
Assets panel

Library Items category, 280
managing library items and 

templates, 294
Templates list, 285

Assets tab, Files panel, 261
Asynchronous JavaScript and XML 

(AJAX), 348
Attach CSS setting, 47
Attach External Style Sheet dialog 

box, 334
Attach Style Sheet command, CSS Styles 

panel, 122
attached style sheets, 122–124
attributes

action, 320
alt, 85
id, 320
method, 320
name, 320
overview, 24–26
Src, 85, 91

Audacity program, 271

Index
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audio
compressing, 271
inserting, 269–271
making web content interesting, 

260
overview, 259

authoring support, 449
Auto Indent option, 302
automatic margins, containers, 132

B
background color

alternate row styling in CSS, 235
Cascading Style Sheets (CSS), 

335–336
Background color option, Page 

Properties dialog box, 50
background image, 145
Background image fi eld, Page 

Properties dialog box, 50
Background text fi eld, Page Properties 

dialog box, 50
Balance Braces button, Coding 

toolbar, 305
banner, web, 260
BCC (Browser Compatibility Check)

CSS Advisor, 432
overview, 432
site management and FTP, 11
tables and boxes, 131

Behaviors panel, 339–340, 346
Bindings panel, 368
Blank Page category, New Document 

dialog box, 46
Block category, CSS Rule defi nition 

dialog box, 114
<body> tag

creating and modifying styles, 106
hierarchy of tags, 33
HTML document, 27
modifying, 123
tag selector, 256

boilerplate.css, 406
bold (<strong>) tag

compound selectors, 115
tag hierarchy, 33

bookmarks, 434
Border property, 232
border-collapse property, 228–229
borders

adding to elements, 151–152
Box model, CSS, 128–129
overview, 149–150
removing from HTML tables, 224
tables, 232–234

Box model, CSS
<div> element, 129
fl oated images, 159–161
ID selector, 129–130

margins, 128–129
modifying attached style sheets, 123
overview, 128
padding, 128–129

<br> (break) tag, 32, 34
bracketed keywords, 24
break (<br>) tag, 32, 34
brightness, adjusting, 89
Broken Links, 427–428
Browse button, Hyperlink dialog 

box, 76
browser, web

CSS Transition support, 189, 195
mobile, 377
previewing pages, 73–74
web fonts supported by, 203

browser compatibility
adding code for IE 6, 178–179
applying fi nishing touches, 179–180
page layouts, 178–180

Browser Compatibility Check (BCC)
CSS Advisor, 432
overview, 432
site management and FTP, 11
tables and boxes, 131

browser hacks, 158
built-in FTP, 14
bulleted lists, 80–81
Business Catalyst, 22, 40
buttons

Add new Server, 413
Advanced Formatting CSS, 312
All, CSS Styles panel, 179
Anything, Validate Form dialog 

box, 342
Apply Comment, 306
Balance Braces, 305
Browse, Hyperlink dialog box, 76
Code View, 57
Collapse Full Tag, 305, 307
Collapse Selection, 305, 307
CSS, 100
Current, 99
Design View, 56, 101, 319
Detect Size, 265
Disable/Enable CSS Property, 154
Draw AP Div, 129, 138
Email address, 342
Expand, 421
Expand All, 305
Format Source Code, 306
Freeze JavaScript, 16
Get/Put, 14
HTML, 65
Indent Code, 306
Insert, 298
Insert Div Tag, 129
Insert Rows radio, 217
Insert toolbar, 322
Italic, 83

Line breaks radio, 327
Line Numbers, 305
Live View, 74, 352, 356, 358, 372
Move or Convert CSS, 306
New CSS Rule, 229
New Library Item, 281
Open Documents, 305
Ordered List, 80
Outdent Code, 306
Plus, Behaviors panel, 340
Preview/Debug in Browser, 

Document toolbar
adding text fi elds, 324
closing Hyperlink dialog box, 78
Draw AP Div tool, 141

Recent Snippets, 306
Refresh

Files panel, 418
Property Inspector, 72

Remove Comment, 306
Reset, 332–333
Select Parent Tag, 305, 307
Show All Events, 341
Show Code Navigator, 305
Show Set Events, 343
Site Root, 350
Source Code, 104
Split

changing workspace, 69
creating gallery page, 85
placing images in HTML, 28
tag structure and attributes, 24
whitespace rules, 31

Split View, 58
Spry Region, 369
Submit, 332–333
Syntax Error Alerts in Info Bar, 306
Tag info, 298
Test Connection, 415
Text Field, 323
Unordered List, 80, 166
Update from Original, 20
Word Wrap, 305
Wrap Tag, 306

C
Canonical Decomposition, 53
Cascading Style Sheets (CSS)

applying .label style, 337–338
classes, 109
Clear property, 165
creating and modifying styles

advanced text formatting, 
112–114

contextual and pseudo-class 
selectors, 115–118

CSS Styles panel, 111–112
overview, 106–108
Property Inspector, 108–110
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CSS rules
Code Navigator, 102, 104
Code view, 101
CSS Styles panel, 98–99
Property Inspector, 100

customizing Spry Widgets, 352–
356

defi ning cascading, 105
div tags

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

external
attaching, 334–338
overview, 103–105

<font> tags, 95–96
ID selectors

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

inline, 102–103
Inspection feature, 17
internal, 103–105
overview, 69, 93–94, 96–97
page layouts

Absolutely Positioned CSS 
layouts, 153–155

Box model, 128–131
creating centered container for 

page, 132–128
overview, 127–128
positioning content with AP 

Divs, 138–148
setting margins and borders, 

149–153
rule weight, 125
setting background color, 335–336
setting width and fl oating columns, 

163–164
snippets and, 278
styling form elements, 337–338
tables

advanced styling, 229–231
alternate row styling, 234–236
controlling cell alignment, 

padding, and borders, 
232–234

formatting and styling, 226–229
reusing for other tables, 236–237

Transitions. See CSS Transitions

case sensitivity
HTML, 31–32
tags, 31

case-sensitive link checking feature, 
44

cell alignment, tables, 232–234
CellPad property, 222, 232
CellSpace property, 223, 232
centered container

absolute positioning, 136–138
making layouts cross-browser 

compatible, 135
overview, 132–134
relative positioning, 137–138

CFML (ColdFusion Markup 
Language), 11, 308

CGI (Common Gateway Interface) 
script

collecting form data, 346
form processing and validation, 338
setting form properties, 321
verifying fi eld contents, 344

Character menu, Text Insert panel, 82
Characters drop-down menu, 92
Check In/Check Out

built-in FTP, 14
checking fi les in and out, 421–422
overview, 419–420
testing server and, 419

Check Links feature, 425–426
checkboxes

adding to form, 345
adding to web form, 325–326
Insert toolbar, 322

child of the body element, CSS, 116
Class drop-down menu, Property 

Inspector, 98, 333
Clear property, CSS, 165
client-side languages, 11
Cloaking category, Site Setup dialog 

box, 44
closing tag, 24
code

accessing with tag selector, 296–297
editing comments, 299–300
formatting

indenting, 313
overview, 311–313

HTML, 34
inserting comments, 299–300
inserting tags with Tag Chooser, 298
object Insert panels, 14
text editor and, 11
validating

highlighting and correcting 
invalid code, 308–309

running report, 309–310
code blocks

collapsing, 307–308
expanding, 307–308

Code Format preferences, 311–312, 314
code hinting, 21, 300–301
Code Inspector, 303
Code Navigator

CSS rules
creating, 102
locating, 104

overview, 19
Code view

Coding toolbar, 305–306
collapsing and expanding tags and 

code blocks, 307–308
containers and, 130
creating CSS rules, 101
defi ned, 314
editing in Live View, 74
<form> tag attributes, 320
modifying workspace, 303–304
overview, 13
viewing comments, 299–300
work views, 57

Code View button, Document 
toolbar, 57

codecs, 268
code-editing features

code
accessing with tag selector, 

296–297
formatting, 311–313
inserting and editing comments, 

299–300
inserting tags with Tag Chooser, 

298
validating, 308–310

Code view
Coding toolbar, 305–306
collapsing and expanding tags 

and code blocks, 307–308
modifying Code View 

workspace, 303–304
overview, 295–296

Coding toolbar
Apply Comment button, 306
Balance Braces button, 305
Collapse Full Tag button, 305, 307
Collapse Selection button, 305, 307
Expand All button, 305
Format Source Code button, 306
Highlight Invalid Code button, 305
Indent Code button, 306
Line Numbers button, 305
Move or Convert CSS button, 306
Open Documents button, 305
Outdent Code button, 306
Recent Snippets button, 306
Remove Comment button, 306
Select Parent Tag button, 305
Select Parent Tag button, 307
Show Code Navigator button, 305
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Syntax Error Alerts in Info Bar 
button, 306

Wrap Tag button, 306
ColdFusion, 57, 302, 414
ColdFusion Markup Language 

(CFML), 11, 308
Collapse Full Tag button, Coding 

toolbar, 305, 307
Collapse Selection button, Coding 

toolbar, 305, 307
collapsing tags and code blocks, 

307–308
color

background
alternate row styling in CSS, 235
CSS, 335–336

HTML, 30
Color category, CSS Style panel, 152
columns

changing layout and size, 172–175
creating appearance of equal height 

columns, 175–177
creating with CSS

setting width and fl oating 
columns, 163–164

using Clear property, 165
creating with HTML, 161–162
fi xed, 46
liquid, 46

Comcast, 23
comma-delimited fi le, 210
commands

Apply Source Formatting, 312
Attach Style Sheet, 122
Get, 418
Import Tabular Data, 240
Insert Table, 219
Put, 417–418
Template, 293

comma-separated values (.csv) fi le 
format, 210

Comment dialog box, 299
comments

Apply Comment button, 306
editing, 299–300
inserting, 299–300
Remove Comment button, 306

Common Gateway Interface (CGI) 
script

collecting form data, 346
form processing and validation, 338
setting form properties, 321
verifying fi eld contents, 344

Common Insert bar, 435
Common section, Insert panel, 119
compound selectors, 115
compressing audio fi les, 271
CompuServe, 84
Connect Using menu, 414

contact form
inserting <form> tag, 317–320
setting properties, 320–321

Container Tag drop-down menu, 
Insert Spry Repeat List dialog 
box, 368–369

containers
centered

absolute positioning, 136–138
creating, 132–134
making layouts cross-browser 

compatible, 135
relative positioning, 137–138

positioning, 128
content

dynamic, 334
positioning

adding images to layout, 144–145
adding introduction section to 

page, 142–143
adding main and sidebar content 

areas, 146–147
creating header section with 

Draw AP Div tool, 
139–141

Photoshop integration, 145–146
styles and, 148

content management systems, 20
contextual selectors, 115–118
contrast, adjusting, 89
Contribute category, Site Setup dialog 

box, 44
Contribute tool, 285
controls, HTML form, 316–317
Copy Dependent Files dialog box, 

262, 352
copyright

inserting notifi cation, 82–83
video material, 269

correcting invalid code, 308–309
Create New column, Welcome 

Screen, 35
criticism, constructive, 439
.csn extension, 277
CSS Advisor, 11, 131, 432
CSS button, Property Inspector, 100, 

206
CSS (Cascading Style Sheets)

animating properties, 188
applying .label style, 337–338
classes, 109
Clear property, 165
creating and modifying styles

advanced text formatting, 
112–114

contextual and pseudo-class 
selectors, 115–118

CSS Styles panel, 111–112
overview, 106–108

Property Inspector, 108–110
CSS rules

Code Navigator, 102, 104
Code view, 101
CSS Styles panel, 98–99
Property Inspector, 100

customizing Spry Widgets, 352–356
defi ning cascading, 105
div tags

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

external
attaching, 334–338
overview, 103–105

<font> tags, 95–96
ID selectors

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

inline, 102–103
Inspection feature, 17
internal, 103–105
overview, 69, 93–94, 96–97
page layouts

Absolutely Positioned CSS 
layouts, 153–155

Box model, 128–131
creating centered container for 

page, 132–128
overview, 127–128
positioning content with AP 

Divs, 138–148
setting margins and borders, 

149–153
rule weight, 125
setting background color, 335–336
setting width and fl oating columns, 

163–164
snippets and, 278
styling form elements, 337–338
tables

advanced styling, 229–231
alternate row styling, 234–236
controlling cell alignment, 

padding, and borders, 
232–234

formatting and styling, 226–229
reusing for other tables, 236–237
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CSS color property, 101
.css fi le (external style sheet), 124–126
CSS hacks, 135
CSS Rule Defi nition dialog box

adding images to layout, 144
Box category, 123
changing type styles of form fi eld 

labels, 337
overview, 112–114

CSS rules
Code Navigator

creating, 102
locating, 104

Code view, 101
CSS Styles panel, 98–99
internal and external style sheets, 103
Property Inspector, 100

CSS Starter Pages, 21
CSS Styles panel

Add property, 354
All button, 179
Attach Style Sheet command, 122
Box category, 160
creating and modifying styles, 111–112
creating CSS rules, 98–99
Current button, 99
customizing Spry Menu bar, 350
Disable/Enable CSS Property 

button, 154
Move CSS Rules option, 121, 179
New CSS Rule button, 229
New CSS Rule icon, 111
overview, 15
Text-transform section, 114

CSS Transitions
adding, 184–189
browser support for, 189, 195
description of, 446
easing, 192
Internet Explorer support for, 189
modifying, 190–195
navigation menu, adding to, 

196–199
support for, 189

CSS3
description of, 21, 44, 181, 184
@font-face, 199, 447
Media Queries

defi nition of, 381–382
description of, 12, 44, 378
principles of, 388
resource for, 382
site-wide query fi le, 383–386
style sheets, 382, 386–387

transitions. See CSS Transitions
CSS3 Transitions window, 191
.csv (comma-separated values) fi le 

format, 210
Cubic-bezier(x1,y1,x2,y2) option, 192
Current button, CSS Styles panel, 99

customizable workspace layout, 14
Customize Favorite Objects dialog 

box, 245–246
customizing

panel groups, 242–245
panels, 242–245
Spry Menu bar, 350
Spry Widgets, 352–356

D
DD Column drop-down menu, Insert 

Spry Repeat List dialog box, 
369

Default Images folder, 44
Default option, Method drop-down 

menu, 321
Default Panel drop-down menu, 

Property Inspector, 358
default split view, 303
default workspace, Dreamweaver, 58
dependent fi les, 406, 417, 422
Description dialog box, 436
descriptions, adding to page, 435–436
design

layout tools and, 10
mobile

creating, 398–401
description of, 12
navigation, 391–394
optimizing of, for mobile web, 

388–391
single-column, 391–394
tools for, 376–377

site
library items, 280–284
modular page elements, 274
overview, 273
repeating regions, 290–293
snippets, 274–279
templates, 285–290

tables, 210
Design Notes

displaying in Files panel, 424
overview, 422
sharing, 423

Design Notes category, Site Setup 
dialog box, 44

design tools, 10
Design view

content management system fi le 
preview in, 20

CSS Transitions, 185
CSS-styled text, 96
description of, 13, 56
modifying snippets, 279
resizing document window, 246–248
setting form properties, 321
tag selector and, 314
viewing comments, 299

Design View button, Document 
toolbar, 56, 101, 319

Design-Time style sheets, 15
desktop, three-column fl uid layout 

for, 403–406
detaching library item, 284
Detect Size button, Insert Flv dialog 

box, 265
dialog boxes

Attach External Style Sheet, 334
Comment, 299
Copy Dependent Files, 262, 352
CSS Rule Defi nition

adding images to layout, 144
Box category, 123
changing type styles of form fi eld 

labels, 337
overview, 112–114

Customize Favorite Objects, 245–246
Description, 436
Email Link, 79
Grid Settings, 253–254
Guides, 251
Hyperlink, 76–78
Image Optimization, 145
Image Tag Accessibility Attributes

adding text fi elds, 323
Alternate text fi eld, 85
placing images in HTML, 29

Import Tabular Data, 211
Input Tag Accessibility Attributes, 323
Insert Div Tag, 119, 161
Insert Flv, 264
Insert Rows or Columns, 217
Insert Spry Repeat List, 368–369
List Properties, 80
List Values, 329
Manage Sites, 40
Move Guide, 250, 257
New CSS Rule

creating new external style 
sheets, 124–125

naming style in, 25
styling paragraphs, 70
styling text, 67

New Document
adding pages to website, 45–46
DocType drop-down menu, 47
overview, 36
Page from Template option, 288
Page Type column, 46

New Editable Region, 286–287
Page Properties

Active links fi eld, 52
Appearance (CSS) category, 49
Appearance (HTML) category, 51
Background color option, 50
Background image fi eld, 50
Background text fi eld, 50
Headings (CSS) category, 52
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Link Color fi eld, 52
Links (CSS) category, 51–52
Margin settings, 51
overview, 49
Rollover links fi eld, 52
Size fi eld, 49
Text color option, 50
Title/Encoding category, 52
Tracing Image category, 52
Transparency slider, 54
Visited links fi eld, 52

Parameters, 271
Popup Message, 340
Preferences

File Types/Editors section, 89
formatting code, 311

Radio Group, 326
Repeating Region, 291
Reports, 429
Save As, Site Root button, 350
Save As Template, 286
Save Style Sheet, 121
Select Image Source, 86
Select Style Sheet File, 334
Site Setup

Add new Server button, 413
Advanced Settings option, 40, 43
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
Local Info settings, 44
Local Site Folder fi eld, 41
Save button, 415
Servers option, 40
Servers tab, 42
Spry category, 44
Templates category, 44
Test Connection button, 415
Version Control option, 40

Snippet, 276
Update Library Items, 283
Update Pages, 283
Validate Form, 342

directory paths, 75
Disable/Enable CSS Property button, 

CSS Styles panel, 154
<div> element

Box model, CSS, 128–129
HTML and, 161–162

div tags
attaching external style sheet to 

page, 122
.css fi le, 124–126
internal versus external style sheets, 

120–122
modifying attached style sheets, 

122–124
overview, 119–120

DNS (Domain Name Service) server, 23

DocType drop-down menu, New 
Document dialog box, 47

document(s)
creating, 36–37
Hypertext Markup Language 

(HTML), 27
opening, 36–37
saving, 36–37
tiling, 256
titles, 441
titling with <title> tag, 432–434
validating, 308

Document toolbar
Code View button, 57
Design View button, 56, 101, 319
Live View button, 352, 356, 358, 372
Preview/Debug in Browser button, 

324
Split button, 24, 28, 31, 70, 85
Split View button, 58

Document Type (DTD), 53
Domain Name Service (DNS) server, 23
domain names, 23
Draw AP Div button, Insert panel, 

129, 140
Draw AP Div tool, 139–141
Dreamweaver CS5.5

authoring support, 449
CSS3 authoring support, 449
description of, 443
HTML5 authoring support, 449
jQuery Mobile Framework, 448, 450
native mobile applications for 

iOS and Android with 
PhoneGap, 451

PhoneGap, 448
W3C validation, 451

Dreamweaver CS6
coding environment and text 

editor, 11
design and layout tools, 10
features

built-in FTP, 14
CSS Styles panel, 15
CSS Transitions. See CSS 

Transitions
customizable workspace layouts, 14
Fluid Grid Layout. See Fluid 

Grid Layout
Page and code object Insert 

panels, 14
points of view, 13
visual aids, 15
web fonts. See web fonts

fl exibility of, 12
overview, 9–10
site management and FTP, 11
starting, 3

Drupal, 20

DT Column drop-down menu, Insert 
Spry Repeat List dialog box, 369

DTD (Document Type), 53
dynamic content, CSS forms, 334

E
Earthlink, 23
Ease option, 192
Ease-in option, 192
Ease-in-out option, 192
Ease-out option, 192–193
easing, 192
Edit Image Settings button, 90
Edit link, 89
Edit Transition window, 194
editable regions, 286–287
editing

code-editing features
accessing with tag selector, 296–297
Code view, 302–308
formatting, 311–313
inserting and editing comments, 

299–300
inserting tags with Tag Chooser, 

298
overview, 295–296
validating, 308–310

comments, 299–300
fi les, 59–60
images

adjusting brightness and contrast, 89
resizing, 90–91
updating, 91

elements
adding borders, 151–152
adding to web forms

checkboxes, 325–326
File Upload fi eld, 331–332
lists and menus, 328–329
radio buttons, 326
radio groups, 327–328
Submit and Reset buttons, 332–333
text area, 330
text fi eld, 323–325

ancestor, 116
<div>, 128–129, 161–162
HTML page, 65–66, 69
nesting, 137
parent, 116

e-mail address, linking, 79
Email address radio button, Validate 

Form dialog box, 342
Email Link dialog box, 79
Embedded OpenType (EOT), 203
embedded style sheets, 103–105, 120–122
emulator, 380
Enable/Disable feature, 17
Enctype drop-down menu, Properties 

dialog box, 321
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event, setting in web form, 341–342
Expand All button, Coding toolbar, 305
Expand button, Files panel, 421
expanding code blocks, 307–308
expanding tags, 307–308
eXtensible Markup Language (XML)

incorporating real-time data from 
fi les, 348

validating documents, 308
Widgets, Spry, 366
XHTML and, 33

external JavaScript, 18
external links, validating, 426
External Links report, 428
external style sheet (.css fi le), 124–126
external style sheets

attaching to page, 122
CSS, 334
versus internal style sheets, 103–105, 

120–122
eyedropper, sampling color, 362

F
.f4v format, 263
Favorites panel, 14
Favorites tab, Insert bar, 245–246
features. See also code-editing features

case-sensitive link checking feature, 44
Check Links feature, 425–426
Inspect feature, 150–151
Live View feature, 16–17, 74
Point to File feature, 87
Preview in Browser feature, 73–74
Sort Table feature, 239
Top Features (videos) column, 

Welcome Screen, 36
feedback, 439–440
fi le(s)

audio, 271
comma-delimited, 210
dependent, 417, 422
local, 59
selecting and editing, 59–60
transferring on remote server, 417–418
XML, 348

fi le formats
.aif, 269
.csv, 210
.f4v, 263
Flash video, 263
.fl v, 263
.mp3, 269
PNG, 53, 84
text (.txt), 210

File Transfer Protocol (FTP)
creating remote connection, 412
defi ned, 441
description of, 14
over SSL/TLS, 414

site management and, 11
File Types/Editors section, 

Preferences dialog box, 89
File Upload fi eld, 331–332
File View Columns category, Site 

Setup dialog box, 44
Files panel

adding pages, 14, 45
Assets tab, 261
creating and viewing Design Notes, 424
creating Design notes, 423
Expand button, 421
FTP and fi le transfer functionality, 417
Get command, 418
managing fi les, 61
opening contents of, 86
overview, 58–60
Put command

transferring fi les on remote 
server, 417–418

transferring fi les on testing 
server, 417

remote connection, 412–415
remote web server, 417–418
resizing images, 90
selecting and editing fi les, 59–60
Spry Assets folder, 352
uploading and downloading fi les, 14
viewing local fi les, 59

FireFox, 203
Fit Table Width To Data option, 215
fi xed columns, 46
Fixed columns layout category, 46
fi xed-width layout, 394
fi xed-width table, 240
Flash

adding video, 263–266
inserting movies, 260–263
making web content interesting, 260
overview, 259

Flash CS6 Professional application, 260
Flash Media Server, 264
Flash player, 6
fl oat property, 158–161, 182
fl oat-based layout, 155
fl ow chart, website, 22
Fluid Grid Layout

basics of, 394–398, 444–445
description of, 181
goals of, 445
styling elements in, 407–409

Fluid Grid Layout Div Tag object, 400
fl uid layouts, 158
.fl v fi le, 272
.fl v format, 263
focus groups, 439–440
Font drop-down menu, Property 

Inspector, 66
<font> tags, 95–96
@font-face, 199, 447

fonts
Geneva, 66–67
sans-serif, 66–67
Verdana, 66–67
web

adding to website, 200–204
basics of, 199, 447
browser support of, 203
licensing, 204
resources for, 207
styling headings with, 205–207

Fontsquirrel, 207
footer

fl oated elements and, 164
modular page, 274
naming, 119–120
page layout, 120

form elements
adding

adding checkboxes, 325–326
adding File Upload fi eld, 331–332
adding lists and menus, 328–329
adding radio buttons, 326
adding radio groups, 327–328
adding text area, 330
adding text fi eld, 323–325
overview, 322
Submit and Reset buttons, 

332–333
defi ned, 345

form ID, 320–321
<form> tag

background color and, 335
inserting into contact form, 317–320

Format drop-down menu, Property 
Inspector, 65

Format Source Code button, Coding 
toolbar, 306

formats, fi le
.aif, 269
.csv, 210
.f4v, 263
Flash video, 263
.fl v, 263
.mp3, 269
PNG, 53, 84
text (.txt), 210

formatting code, 311–313
forms, web

adding form elements
adding checkboxes, 325–326
adding File Upload fi eld, 331–332
adding lists and menus, 328–329
adding radio buttons, 326
adding radio groups, 327–328
adding text area, 330
adding text fi eld, 323–325
overview, 322
Submit and Reset buttons, 

332–333
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adding validation
Behaviors panel, 339–340
previewing button behavior, 342
setting event or trigger, 341–342

contact form
inserting <form> tag, 317–320
setting properties, 320–321

overview, 315–317
processing, 338
styling with CSS

applying .label style, 337–338
attaching external styles, 334
setting background color, 

335–336
styling form elements, 337–338

validating form fi elds
changing form fi eld’s behavior 

order, 343–344
overview, 342–343

validation, 338
Forms category, Insert panel, 322
Freeze JavaScript button, 16
FTP (File Transfer Protocol)

built-in, 14
creating remote connection, 412
over SSL/TLS, 414
site management and, 11

G
gallery page, inserting images, 84–86
generating site reports

addressing listed item, 430–431
Browser Compatibility Check

CSS Advisor, 432
overview, 432

saving reports, 431
understanding report results, 430

Geneva font, 66–67
Get command, Files panel, 418
GET option, Method drop-down 

menu, 321
Get/Put button, 14
GIF (Graphics Interchange Format), 

53, 84
Global Navigation menu, 280
Google, 432
Google Chrome, 16, 190, 203, 393
Google Gmail, 348
Google Web Fonts, 207
Graphics Interchange Format (GIF)

description of, 84
logos, 92

Grid Settings dialog box, 253–254
grids, 253–256
guides, 250–252
Guides dialog box, 251
gutter width, 395

H
h2 tag, 107–108
hacks

browser, 158
CSS, 135

Hand tool, 249
hand-coding, 34, 72, 101, 317
handheld devices, XHTML 1.0, 33
hard drive

copying lesson fi les to, 4
copying video tutorials to, 5

<head> tag
CSS rules, 71
HTML document, 27

Header checkbox, Property Inspector, 217
headers

adding background image, 229
adding images, 144
aligning, 141
modular page, 274
page layout, 120
POST command, 321
setting width, 141

headings
HTML structure, 65
web fonts used in styling of, 

205–207
Headings (CSS) category, Page 

Properties dialog box, 52
Help menu, 438
Help system, 438–440
hexadecimal code, 30
Hidden Characters option, 302
Highlight Invalid Code option, 302, 

305, 314
highlighting invalid code, 308–309
horizontal navigation bar, 167
hosting websites, 7
hover property, hyperlinks, 170–171
HTML button, Property Inspector, 65
HTML (Hypertext Markup 

Language), 22–34
blank page, 48
case sensitivity, 31–32
colors, 30
div elements and, 161–162
explorations in code, 34
incorporating real-time data from, 348
language, 69
placing images in, 28–30
reports, 429
snippets and, 278
structure of document, 27
tables, 221–225
tag

hierarchy, 33
structure and attributes, 24–26

validating documents, 308
whitespace rules, 31–32

XHTML 1.0 Transitional, 33–34
HTML <meta> tag, 435
<html> tag, 27, 33
HTML5

authoring support, 449
code hinting, 300–301
description of, 21, 46, 181

hyperlink(s)
absolute, 77–78
linking to e-mail address, 79
overview, 74–75
relative, 77–78
styling, 117–118
validating, 426

Hyperlink dialog box, 76–78
Hyperlink icon, Insert panel, 77
Hypertext Markup Language 

(HTML), 22–34
case sensitivity, 31–32
colors, 30
div elements and, 161–162
explorations in code, 34
incorporating real-time data from, 348
language, 69
placing images in, 28–30
reports, 429
snippets and, 278
structure of document, 27
tables, 221–225
tag

hierarchy, 33
structure and attributes, 24–26

validating documents, 308
whitespace rules, 31–32
XHTML 1.0 Transitional, 33–34

I
id attribute, <form> tag, 320
ID selectors, CSS

attaching external style sheet to 
page, 122

Box model, 129–130
.css fi le, 124–126
internal versus external style sheets, 

120–122
modifying attached style sheets, 

122–124
IE4 (Internet Explorer 4), 135
IE6 (Internet Explorer 6)

adding code for browser 
compatibility, 178–179

CSS boxes and, 178
optimizing for, 179

IE9 (Internet Explorer 9), 195, 203
IE10 (Internet Explorer 10), 195
image(s)

adding to layout, 144–145
adjusting brightness and contrast, 89
editing of, 89–91
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inserting
gallery page, 84–86
image formats, 83–84
image resolution, 83

optimizing of, 90–91
placing in Hypertext Markup 

Language (HTML), 28–30
resizing of, 90–91
updating of, 91
on web, 64

image editor, 59
image (<img>) tag

attributes, 85
placing in HTML, 28
tag hierarchy, 33
tag selector, 255

Image Optimization dialog box, 145
Image Optimization window, 90
image placeholder, 88–89
Image Tag Accessibility Attributes 

dialog box
adding text fi elds, 323
Alternate text fi eld, 85
placing images in HTML, 29

<img> (image) tag
attributes, 85
placing in HTML, 28
tag hierarchy, 33
tag selector, 255

Import Tabular Data command, File 
menu, 240

Import Tabular Data dialog box, 211
Indent Code button, Coding toolbar, 306
indenting, 313
inheritance, 125
inline style sheets, 102–103
Input Tag Accessibility Attributes 

dialog box, 323
Insert bar, 245–246
Insert Block option, Snippet dialog 

box, 277
Insert button, Tag Chooser, 298
Insert Div Tag button, Insert panel, 129
Insert Div Tag dialog box, 119–120, 161
Insert Flv dialog box, 264
Insert panel

adding Spry Menu bar, 350
description of, 86
design and layout tools, 10
expanding, 245
Hyperlink icon, 77
Layout section, 139

Insert Rows or Columns dialog box, 217
Insert Rows radio button, Insert 

Rows and Columns dialog 
box, 217

Insert Spry Repeat List dialog box, 
368–369

Insert Table command, Table dialog 
box, 219

Insert toolbar, 327
inserting

comments, 299–300
Flash movies, 260–263
images

gallery page, 84–86
image formats, 83–84
image resolution, 83

sound, 269–271
Inspect feature, 150–151
Inspect Mode, 17
integrity, site

Check Links feature, 425–426
Check Links Sitewide, 426–428

interactivity, navigation links, 170
internal style sheets, 103–105, 120–122
Internet Explorer 4 (IE4), 135
Internet Explorer 6 (IE6)

adding code for browser 
compatibility, 178–179

CSS boxes and, 178
optimizing for, 179

Internet Explorer 9 (IE9), 195, 203
Internet Explorer 10 (IE10), 195
Internet Service Provider (ISP), 23
introduction section, adding to page, 

142–143
invalid code, correcting, 308–309
iOS, 203, 451
ISP (Internet Service Provider), 23
Italic button, Property Inspector, 83

J
Java Server Pages ( JSP), 308, 346
JavaScript

description of, 11, 57, 181, 302, 
338–339

external fi les, 18
respond.min.js, 406

Joint Photographic Experts Group 
( JPEG) format

GIFs versus, 83–84
PSD fi le saved as, 146
tracing image, 53

Joomla!, 20
JPEG ( Joint Photographic Experts 

Group) format
GIFs versus, 83–84
PSD fi le saved as, 146
tracing image, 53

jQuery Mobile Framework, 12, 448, 450
JSP ( Java Server Pages), 308, 346

K
keywords

bracketed, 24
meta, 435–436

L
.label style, 337–338
languages

CFML (ColdFusion Markup 
Language), 11, 308

client-side, 11
HTML (Hypertext Markup 

Language), 22–34
case sensitivity, 31–32
colors, 30
div elements and, 161–162
explorations in code, 34
incorporating real-time data 

from, 348
language, 69
placing images in, 28–30
reports, 429
snippets and, 278
structure of document, 27
tables, 221–225
validating documents, 308
whitespace rules, 31–32
XHTML 1.0 Transitional, 33–34

scripting, 11
text-based, 36
Wireless Markup Language 

(WML), 308
XML (eXtensible Markup 

Language)
incorporating real-time data 

from fi les, 348
validating documents, 308
Widgets, Spry, 366
XHTML and, 33

launching site
Site Launch Checklist, 436
uploading site, 437–438

Layout column, New Document 
dialog box, 46

Layout CSS setting, 47
Layout section, Insert panel, 139
layout tools, 10
layouts

adding images, 144–145
advanced

AP divs, 158
browser compatibility, 178–180
changing column layout and size, 

172–175
creating appearance of equal 

height columns, 175–177
creating columns with CSS, 

163–165
creating columns with HTML, 

161–162
creating more sophisticated 

layouts, 180–181
fl oat property, 158–161
list-based navigation bar, 166–172
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overview, 157
CSS

Absolutely Positioned CSS 
layouts, 153–155

Box model, 128–131
creating centered container for 

page, 132–128
overview, 127–128
positioning content with AP 

Divs, 138–148
setting margins and borders, 

149–153
fi xed-width, 394
fl uid, 158
Fluid Grid

basics of, 394–398, 444–445
description of, 181
goals of, 445
styling elements in, 407–409

making cross-browser compatible, 135
mobile

creating, 398–401
description of, 12
navigation, 391–394
optimizing of, for mobile web, 

388–391
single-column, 391–394
tools for, 376–377

tablet, 402–403
three-column, 403–406
workspace, 14

.lbi fi les, 280
LCK (lock) fi le, 420
length, video, 269
lesson fi les, 3–4
<li> tag, 97
Library folder, 294
library items, 280–284, 294
Library Items category, Assets panel, 280
licensing, web fonts, 204
Line breaks radio button, Radio 

Group dialog box, 327
Line Numbers button, Coding 

toolbar, 305
Line Numbers option, 302
line returns, Design view, 32
Linear option, for easing, 192
Line-height drop-down menu, CSS 

Rule defi nition dialog box, 113
Link Checker panel, 425–426, 428
Link Color fi eld, Page Properties 

dialog box, 52
<link> tag, 94
Link text fi eld, Property Inspector, 75
links

absolute, 77–78
to e-mail address, 79
image, 87
linking to e-mail address, 79
overview, 74–75

relative, 77–78
styling, 117–118
validating, 426

Links (CSS) category, Page Properties 
dialog box, 51–52

liquid columns, 46
List menus, Insert toolbar, 322
List Properties dialog box, 80
List Values dialog box, 329
list-based navigation bar, 166–172
listed item, addressing, 430–431
lists

adding to web form, 328–329
bulleted, 80–81

Live View button, Document toolbar, 
74, 352, 356, 358, 372

Live View feature, 13, 16–17, 74, 206, 
405

LiveSearch, 432
local fi les, 59
Local Info settings, Site Setup dialog 

box, 44
local root folder

checking fi les in/out, 421
defi ned, 41
saving pages, 48
storing resources, 61

Local Site Folder fi eld, Site Setup 
dialog box, 41

Local/Network, 414
Lock Guides option, Guides dialog 

box, 251
lock (LCK) fi le, 420
logos, 84, 92
Lucida Sans font, 201

M
Macintosh OS, 2–4
Macromedia ColdFusion library, 298
Manage Sites dialog box, 40
managing website

Check In/Check Out
built-in FTP, 14
checking fi les in and out, 

421–422
overview, 419–420
testing server and, 419

Design Notes
content, 422–423
displaying in Files panel, 424
sharing, 423
using, 422–423

Files panel
remote connection, 412–415
transferring fi les to and from 

remote server, 417–418
viewing fi les on remote web 

server, 416
focus groups, 439–440

generating site reports
addressing listed item, 430–431
Browser Compatibility Check, 432
overview, 428–429
saving reports, 431
understanding report results, 430

Help system, 438–440
launching site

Site Launch Checklist, 436
uploading your site, 437–438

optimizing pages for launch
adding meta keywords and 

descriptions, 435–436
search engine visibility 

and Search Engine 
Optimization, 432

titling your documents with 
<title> tag, 432–434

overview, 411–412
Reference panel, 439
testing site integrity

checking links sitewide, 426–428
importance of, 425
using Check Links, 425–426

website design resources, 440
Margin settings, Page Properties 

dialog box, 51
margins

Box model, CSS, 128–129
overriding default margins in CSS, 

150–151
overview, 149–153

Marquee tool, Photoshop, 177
McKnight Institute, 433–436
Media Queries, CSS3

defi nition of, 381–382
description of, 12, 44, 378
principles of, 388
resource for, 382
site-wide query fi le, 383–386
style sheets, 382, 386–387

Media Queries button, 383
menus

adding to web form, 328–329
Character, Text Insert panel, 82
Characters, 92
Class, Property Inspector, 98, 333
Container Tag, Insert Spry Repeat 

List dialog box, 368–369
DD Column, Insert Spry Repeat 

List dialog box, 369
Default Panel, Property Inspector, 358
DocType, New Document dialog 

box, 47
DT Column, Insert Spry Repeat 

List dialog box, 369
Enctype, Properties dialog box, 321
Font, Property Inspector, 66
Format, Property Inspector, 65
Help, 438
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Line-height, CSS Rule defi nition 
dialog box, 113

Lists, Insert toolbar, 322
Method, 321
Order, 239
Selector Type, New CSS Rule 

dialog box, 67
Show, Link Checker panel, 428
Size, Property Inspector, 72
Skin, Insert Flv dialog box, 265
Sort By, 239
Spry Data Set, Insert Spry Repeat 

List dialog box, 369
Style, Property Inspector, 98
Targeted Rule, Property Inspector, 

110
View, 303
Window Size, 247, 257

meta keywords, 435–436
method attribute, <form> tag, 320
Method drop-down menu, 321
mobile design and layout

creating, 398–401
description of, 12
navigation, 391–394
optimizing of, for mobile web, 

388–391
single-column, 391–394
tools for, 376–377

“mobile fi rst” design, 397
mobile phones

design and layout for. See mobile 
design and layout

website appearance on, 377
XHTML 1.0 Transitional, 33

mobile web
growth of, 376
native applications, 376–377
websites, 377–378

modifying
<body> tag, 123
Cascading Style Sheets (CSS)

advanced text formatting, 112–114
contextual and pseudo-class 

selectors, 115–118
CSS Styles panel, 111–112
overview, 106–108
Property Inspector, 108–110

Code View workspace, 303–304
CSS Transitions, 190–195
library items, 282–284
templates, 289–290

modular page elements, 274
mono sound, 269
Move CSS Rules option, CSS Styles 

panel, 121, 179
Move Guide dialog box, 250, 257
Move or Convert CSS button, Coding 

toolbar, 306
movement, 260

movies, Flash, 260–263
Mozilla FireFox, 203
.mp3 format, 269
Multiscreen Preview feature, 12, 

378–381, 389, 393

N
name attribute, <form> tag, 320
navigation, mobile, 391–394
navigation menu, CSS Transitions 

added to, 196–199
nesting elements, 137
Netscape 4, 135
New CSS Rule button, CSS Styles 

panel, 229, 390, 392
New CSS Rule dialog box

creating new external style sheets, 
124–125

naming style in, 25
styling paragraphs, 70
styling text, 67

New Document dialog box
adding pages to website, 45–46
DocType drop-down menu, 47
overview, 36
Page from Template option, 288
Page Type column, 46

New Editable Region dialog box, 
286–287

New Library Item button, Assets 
panel, 281

New Transition window, 186, 198
nodes, XML fi le, 366

O
object Insert panels, 14
Open a Recent Item column, 

Welcome Screen, 35
Open Documents button, Coding 

toolbar, 305
OpenType (OTF), 203
Opera, 203
optimizing pages for launch

adding meta keywords and 
descriptions, 435–436

Search Engine Optimization, 432
titling your documents with 

<title> tag, 432–434
options

Advanced Settings, Site Setup 
dialog box, 40, 43

advanced site-creation
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
overview, 43–44

Spry category, 44
Templates category, 44

Auto Indent, 302
Background color, Page Properties 

dialog box, 50
Default, Method drop-down menu, 

321
Fit Table Width To Data, 215
GET, Method drop-down menu, 321
Hidden Characters, 302
Highlight Invalid Code, 302, 305, 314
Insert Block, Snippet dialog box, 277
Line Numbers, 302
Lock Guides, Guides dialog box, 251
Move CSS Rules, CSS Styles panel, 

121, 179
Page from Template, New 

Document dialog box, 288
POST, Method drop-down menu, 

321
Remove Tag, 297
Servers, Site Setup dialog box, 40
Show Grid, Grid Settings dialog 

box, 253
Show Log, Update Pages dialog 

box, 283
site-creation, advanced

Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
overview, 43–44
Spry category, 44
Templates category, 44

Snap to Grid, Grid Settings dialog 
box, 253

Syntax Coloring, 302
Syntax Error Alerts, 302
Text, Insert panel, 83
Text color, Page Properties dialog 

box, 50
Version Control, Site Setup dialog 

box, 40
Word Wrap, 302

Order menu, 239
Ordered List button, Property 

Inspector, 80
Organic Utopia example, 349

adding introduction section to 
page, 142

adding main and sidebar content 
areas, 146

advanced site creations, 43–44
creating home page, 132
creating new templates, 285–286
site setup, 41–43
using Snippets panel, 275

orphaned fi les, 427
Orphaned Files report, 428
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Outdent Code button, Coding 
toolbar, 306

overfl ow property, CSS, 152–153

P
<p> (paragraph) tag

case sensitivity, 32
compound selectors, 115
creating rule defi nitions, 106
structure and attributes, 25–26

padding
Box model, CSS, 128–129
tables, 232–234

page(s)
adding title, 433–434
creating from templates, 287–288
defi ning properties, 49–54
object Insert panels, 14
optimizing for launch, 432–436

adding meta keywords and 
descriptions, 435–436

search engine visibility 
and Search Engine 
Optimization, 432

titling your documents with 
<title> tag, 432–434

previewing in web browser, 73–74
Page font fi eld, Page Properties dialog 

box, 49
Page from Template option, New 

Document dialog box, 288
page layout

advanced
AP divs, 158
browser compatibility, 178–180
changing column layout and size, 

172–175
creating appearance of equal 

height columns, 175–177
creating columns with CSS, 

163–165
creating columns with HTML, 

161–162
creating more sophisticated 

layouts, 180–181
fl oat property, 158–161
list-based navigation bar, 166–172
overview, 157

CSS
Absolutely Positioned CSS 

layouts, 153–155
Box model, 128–131
creating centered container for 

page, 132–128
overview, 127–128
positioning content with AP 

Divs, 138–148
setting margins and borders, 

149–153

Page Properties dialog box
Active links fi eld, 52
Appearance (CSS) category, 49
Appearance (HTML) category, 51
Background color option, 50
Background image fi eld, 50
Background text fi eld, 50
Headings (CSS) category, 52
Link Color fi eld, 52
Links (CSS) category, 51–52
Margin settings, 51
overview, 49
Rollover links fi eld, 52
Size fi eld, 49
Text color option, 50
Title/Encoding category, 52
Tracing Image category, 53–54
Transparency slider, 54
Visited links fi eld, 52

Page Type column, New Document 
dialog box, 46

panel groups, customizing, 242–245
panels

Assets
Library Items category, 280
managing library items and 

templates, 294
Templates list, 285

Behaviors, 339–340, 346
Bindings, 368
CSS Styles

Add property, 354
All button, 179
Attach Style Sheet command, 122
Box category, 160
creating and modifying styles, 

111–112
creating CSS rules, 98–99
Current button, 99
customizing Spry Menu bar, 350
Disable/Enable CSS Property 

button, 154
Move CSS Rules option, 121, 179
New CSS Rule button, 229
New CSS Rule icon, 111
overview, 15
Text-transform section, 114

customizing, 242–245
Favorites, 14

customizing, 14
Files

adding pages, 14, 45
Assets tab, 261
creating and viewing Design 

Notes, 424
creating Design notes, 423
Expand button, 421
FTP and fi le transfer 

functionality, 417
Get command, 418

managing fi les, 61
overview, 58–60
Put command, 417–418
remote connection, 412–415
remote web server, 417–418
resizing images, 90
selecting and editing fi les, 59–60
Spry Assets folder, 352
uploading and downloading 

fi les, 14
viewing local fi les, 59

Insert
adding Spry Menu bar, 350
design and layout tools, 10
expanding, 245
Hyperlink icon, 77
Layout section, 139

Link Checker, 425–426, 428
Reference, 439
Results, 428–429
Site Defi nition, 441
Site Reports, 309
Snippets, 275–276, 294
Spry Collapsible, 364–365
Spry Tabbed, 356–360
tabbed, 356
Text Insert, 82–83

panels, customizing, 242–245
Panels column, Property Inspector, 357
paragraph (<p>) tag

case sensitivity, 32
compound selectors, 115
creating rule defi nitions, 106
structure and attributes, 25–26

Parameters dialog box, 271
parent elements, CSS, 116
percentage-based table, 240
period character (.), 129
periods, avoiding in site name, 61
PhoneGap Build Service, 376–377, 

448, 451
Photoshop

creating Flash video, 263
CS6, 10
integration, 145–146
smart objects, 20

PHP
code hinting, 21
coding environment, 11
creating new site, 43
form processing and validation, 338
hand-coding environment, 57
inserting tags, 298
syntax, 21
validating documents, 308
working in Code view, 302

pixel-based table, 240
pixels, 250
placeholders, image, 88–89
Plus button, Behaviors panel, 340
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PNG format
versus GIF and JPEG, 84
Photoshop, creating fake column 

background, 177
tracing image, 53

Point to File feature, 87
Popup Message dialog box, 340
positioning content

absolute positioning, 136–138
adding additional content and 

styles, 148
adding images to layout, 144–145
adding introduction section to 

page, 142–143
adding main and sidebar content 

areas, 146–147
creating header section with Draw 

AP Div tool, 139–141
Photoshop integration, 145–146

POST option, Method drop-down 
menu, 321

pound sign (#), 129
Preferences dialog box

File Types/Editors section, 89
formatting code, 311

Premiere Pro program, 263
Preview in Browser feature, 73–74
Preview/Debug in Browser button, 

Document toolbar
adding text fi elds, 324
closing Hyperlink dialog box, 78
Draw AP Div tool, 141

previewing
button behavior, 342
pages, 73–74

processing web forms, 338
Progressive Download Video, 264
properties

Add, CSS Styles panel, 354
Border, 232
border-collapse, 228–229
CellPad, 222, 232
CellSpace, 223, 232
Clear, CSS, 165
CSS color property, 101
fl oat, 158–161, 182
hover, 170–171
overfl ow, CSS, 152–153
Target, Properties dialog box, 321

Property Inspector
applying classes to tables, 227
Brightness and Contrast button, 89
correcting invalid code, 308, 314
creating class style, 108–110
creating CSS rules, 100
creating hyperlinks, 75–76
CSS button, 100
customizing Spry Menu bar, 350
Default Panel drop-down menu, 358
displaying properties of AP Div, 140

formatting text, 64–65
Header checkbox, 217
Ordered List button, 80
Panels column, 357
selecting and activating widgets, 351
selecting table elements, 213
setting column width, 216–217
setting form properties, 321
setting table width to percentage of 

browser window, 215–216
Targeted Rule drop-down menu, 110
versus Text Insert panel, 82
Unordered List button, 80

protocols, FTP, 10, 412. See also FTP
PSD fi le

dragging into web page, 20
importing into Dreamweaver, 145
optimizing, 145
saved as JPEG, 146

pseudo-class selectors, 115–118
Put command, Files panel

transferring fi les on remote server, 
417–418

transferring fi les on testing server, 417

Q
Question Mark icon, 430
Quick Tag editor, 296
QuickTime video, 266–269

R
radio buttons

adding to form, 345
adding to web form, 326
Insert toolbar, 322

Radio Group dialog box, 327
Radio Group element, Insert toolbar, 327
radio groups, 327–328
RDS, 414
ready-to-use snippets, 275
real-time data, 348
Recent Snippets button, Coding 

toolbar, 306
Rectangular Marquee tool, 

Photoshop, 177
Red X icon, 430
Reference panel, 439
Refresh button

Files panel, 418
Property Inspector, 72

Related Files bar, 18
relative hyperlinks, 77–78
relative positioning, 132, 137–138
remote connection, 412–415
remote server

copying fi les to, 438
LCK fi les, 420

sharing Design Notes, 423
transferring fi les with Get and Put, 

417–418
using Files panel to transfer fi les 

to, 58
using Server tab to defi ne, 42

Remove Comment button, Coding 
toolbar, 306

Remove Tag option, 297
Repeating Region dialog box, 291
repeating regions

detaching from Template 
command, 293

overview, 290–291
putting into action, 291–293

reports, site
addressing listed item, 430–431
Browser Compatibility Check, 432
overview, 428–429
saving, 431
understanding report results, 430

Reports dialog box, 429
Required checkbox, Validate Form 

dialog box, 342
Reset button, adding to web form, 

332–333
Reset Designer, 48
resizing

document window, 246–248
images, 83, 90–91

respond.min.js, 406
Results panel, site reports, 428–429
RGB spectrum, 30
Rich Internet Applications (RIAs), 348
Rollover links fi eld, Page Properties 

dialog box, 52
root folder, local

checking fi les in/out, 421
defi ned, 41
saving pages, 48
storing resources, 61

rule weight, 125
rulers

making visible, 140
purpose of, 15
units of measurement, 250

rules, CSS
Code Navigator

creating, 102
locating, 104

Code view, 101
CSS Styles panel, 98–99
internal and external style sheets, 103
Property Inspector, 100

runaround, 159

S
Safari web browser, 16, 377, 393
sans-serif font, 66–67
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Save As dialog box, Site Root button, 
350

Save As Template dialog box, 286
Save button, Site Setup dialog box, 415
Save Style Sheet dialog box, 121
saving

pages, 48
reports, 431

schema, XML fi le, 366
scripts

AJAX, 348
CGI

form processing and validation, 338
setting form properties, 321

JavaScript, 11, 338
server-side, 338

search engine
navigation bars, 166
page optimization, 432
ranking and listing web pages, 435
<title> tag, 434

Search Engine Optimization (SEO), 
432, 435

Select Image Source dialog box, 86
Select Parent Tag button, Coding 

toolbar, 305, 307
Select Style Sheet File dialog box, 334
selecting fi les, 59–60
Selection tool, 250
Selector Name fi eld, New CSS Rule 

dialog box, 110
Selector Name section, New CSS 

Rule dialog box, 117
Selector Type drop-down menu, New 

CSS Rule dialog box, 67
selectors

compound, 115
contextual, 115–118
CSS ID

attaching external style sheet to 
page, 122

Box model, 129–130
.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
pseudo-class, 115–118
tag

accessing code, 296–297
overview, 255–256

self-closing tags, 34
SEO (Search Engine Optimization), 

432, 435
servers

defi ned, 23
DNS, 23
remote

copying fi les to, 438
LCK fi les, 420

sharing Design Notes, 423
transferring fi les with Get and 

Put, 417–418
using Files panel to transfer fi les 

to, 58
using Server tab to defi ne, 42

Servers option, Site Setup dialog box, 40
Servers tab, Site Setup dialog box, 42
server-side script

defi ned, 11
form processing and validation, 338

SFTP, 414
Show All Events button, Behaviors 

panel, 341
Show Code Navigator button, Coding 

toolbar, 305
Show Grid option, Grid Settings 

dialog box, 253
Show Log option, Update Pages 

dialog box, 283
Show menu, Link Checker panel, 428
Show Set Events button, Behaviors 

panel, 343
single-column layout, 391–394
Site Defi nition panel, 441
site design

library items
modifying and updating, 282–284
overview, 280–281

modular page elements, 274
overview, 273
repeating regions

detaching from Template 
command, 293

overview, 290–291
putting into action, 291–293

snippets
creating new, 276–279
overview, 274
Snippets panel, 275–276

templates
creating new, 285–286
creating new pages from, 

287–288
modifying, 289–290
working with editable regions, 

286–287
Site Launch Checklist, 436
site management, 11
Site Reports panel, 309
Site Root button, Save As dialog box, 350
Site Setup dialog box

Add new Server button, 413
Advanced Settings option, 40, 43
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
Local Info settings, 44
Local Site Folder fi eld, 41

Save button, 415
Servers option, 40
Servers tab, 42
Spry category, 44
Templates category, 44
Test Connection button, 415
Version Control option, 40

Site Setup window. See Site Setup 
dialog box

site-creation options, advanced
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
overview, 43–44
Spry category, 44
Templates category, 44

site-wide query fi le, 383–386
Size drop-down menu, Property 

Inspector, 72
Size fi eld, Page Properties dialog box, 49
skin, defi ned, 264
Skin drop-down menu, Insert Flv 

dialog box, 265
slashes, avoiding in site name, 61
smart objects, Photoshop, 20
smartphones, 376
Snap to Grid option, Grid Settings 

dialog box, 253
Snippet dialog box, 276
snippets

creating new, 276–279
overview, 274
Snippets panel, 275–276

Snippets panel
description of, 275–276
moving snippets with, 294

Sort By menu, 239
Sort Table feature, 239
sound

inserting, 269–271
making web content interesting, 260
overview, 259

Soundbooth program, 271
Source Code button, 104
spaces, avoiding in site name, 61
Split button, Document toolbar

changing workspace, 69
creating gallery page, 85
placing images in HTML, 28
tag structure and attributes, 24
whitespace rules, 31

Split view
addressing listed item, 430
case sensitivity and whitespace, 31
Code Navigator, 102
CSS and, 97
default, 303
displaying page in multiple modes, 58
editing in Live View, 74
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formatting tables in HTML, 225
hand-coding, 72
internal style, 104
Live view and, 74
overview, 13, 69
placing images in HTML, 28
view options, 303
viewing fi les on remote server, 416

Split View button, Document toolbar, 58
Spry Accordion panel, 360–363
Spry Assets folder, 373
Spry category, Site Setup dialog box, 44
Spry Collapsible panel, 364–365
Spry Data Set drop-down menu, 

Insert Spry Repeat List dialog 
box, 369

Spry Data Widgets, 365–370
overview, 365
Spry Repeat List, 368–370
Spry XML data set, 366–368
styling and fi ne-tuning, 370–372
XML, 366

Spry Framework
additional features, 347–348
Spry Collapsible panel, 364–365
Spry Data Widgets, 365–370

overview, 365
Spry Repeat List, 368–370
Spry XML data set, 366–368
styling and fi ne-tuning, 370–372
XML, 366

Spry Menu bar, 350–352
Spry Tabbed panel, 356–360
Spry Widgets, 348

AJAX, 348
customizing with CSS, 352–356

Spry Menu bar, 350–352
Spry Region button, 369
Spry Repeat List, 368–370
Spry Tabbed panel, 356–360
Spry Widgets, 348

AJAX, 348
customizing with CSS, 352–356

Src attribute
changing, 91
<img> tag, 85

states, defi ned, 117
Streaming Video, 264
<strong> (bold) tag

compound selectors, 115
tag hierarchy, 33

Style category, CSS Style panel, 151
Style menu, Property Inspector, 98
style sheets, CSS

applying .label style, 337–338
creating and modifying styles

advanced text formatting, 112–114
contextual selectors, 115–118
CSS Styles panel, 111–112
overview, 106–108

Property Inspector, 108–110
pseudo-class selectors, 115–118

CSS rules
Code Navigator, 102, 104
Code view, 101
CSS Styles panel, 98–99
Property Inspector, 100

customizing Spry Widgets, 352–356
defi ned, 94
defi ning cascading, 105
div tags

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

external
attaching, 334–338
versus internal, 103–105

<font> tags, 95–96
ID selectors

attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

inline, 102–103
internal, 103–105
organizing, 386–387
overview, 69, 93–94, 96–97
page layouts

Absolutely Positioned CSS 
layouts, 153–155

Box model, 128–131
creating centered container for 

page, 132–128
overview, 127–128
positioning content with AP 

Divs, 138–148
setting margins and borders, 

149–153
setting background color, 335–336
styling form elements, 337–338

<style> tag
CSS rules, 71, 94
internal style sheets, 103, 120

.style1, 109

.style2, 109

.styledtable class
applying to unstyled table, 236–237
formatting and styling tables, 227

styles, defi ned, 69–73
styling

in Fluid Grid Layout, 407–409

form elements, CSS, 337–338
Submit button, adding to web form, 

332–333
Subversion, 22
Swatches panel, 30
.swf extension, 262–263
.swf fi le, 272
Syntax Coloring option, 302
Syntax Error Alerts in Info Bar 

button, Coding toolbar, 306
Syntax Error Alerts option, 302
system requirements, 1–2

T
tabbed panels, 356
tables

converting to snippets, 276
creating, 219–220
CSS

advanced styling, 229–231
alternate row styling, 234–236
cell alignment, 232–234
cell borders, 232–234
cell padding, 232–234
formatting and styling, 226–229
reusing for other tables, 236–237

data sorting, 238–239
fi xed-width, 240
HTML, 221–225
importing data, 210–212
modifying

size, 215–217
structure, 217–218

overview, 209–210
percentage-based, 240
pixel-based, 240
selecting elements, 213–214
web design, 210

tablet layout, 402–403
tabular data, 210, 240
Tag Chooser, 298
Tag info button, Tag Chooser, 298
tag selector

accessing code, 296–297
overview, 255–256

tags
<body>

creating and modifying styles, 
106

hierarchy of tags, 33
HTML document, 27
modifying, 123
tag selector, 256

<br> (break), 32, 34
case sensitivity, 31
closing, 24
collapsing, 307–308
div
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attaching external style sheet to 
page, 122

.css fi le, 124–126
internal versus external style 

sheets, 120–122
modifying attached style sheets, 

122–124
overview, 119–120

expanding, 307–308
<font>, 95–96
<form>

background color and, 335
inserting into contact form, 

317–320
<h2>, 107–108
<head>

CSS rules, 71
HTML document, 27

hierarchy, 33
<html>, 27, 33
<img> (image)

attributes, 85
placing in HTML, 28
tag hierarchy, 33
tag selector, 255

<li>, 97
<link>, 94
<p> paragraph

case sensitivity, 32
compound selectors, 115
creating rule defi nitions, 106
structure and attributes, 25–26

self-closing, 34
<strong> (bold)

compound selectors, 115
tag hierarchy, 33

structure and attributes, 24–26
<style>

CSS rules, 71, 94
internal style sheets, 103, 120

styles, 106
<title>, 432–434
XML and, 366

Target property, Properties dialog 
box, 321

Targeted Rule drop-down menu, 
Property Inspector, 110

Template command, 293
templates

creating new, 244–245
creating new pages from, 287–288
modifying, 289–290
working with editable regions, 

286–287
Templates category, Site Setup dialog 

box, 44
Templates folder, 294
Templates list, Assets panel, 285
Test Connection button, Site Setup 

window, 415

testing server, 419
testing site integrity

Check Links feature, 425–426
Check Links Sitewide, 426–428
overview, 425

text, adding
hyperlinks, 74–79
lists, 80–81
overview, 63
previewing pages in web browser, 

73–74
styles, 69–73
Text Insert panel, 82–83
typography and images on web, 64

text area, adding to web form, 330
Text Color button, 68
Text color option, Page Properties 

dialog box, 50
text editor, 11
text fi eld, adding to web form, 323–325
Text Field button, Insert panel, 323
Text fi elds, Insert toolbar, 322
text formatting, advanced, 112–114
Text Insert panel, 82–83
Text options, Insert panel, 83
text (.txt) fi le format, 210
text wrap, 159
text-based languages, 36
Text-transform section, CSS Styles 

panel, 114
three-column fl uid layout, 403–406
tiling documents, 256
<title> tag, 432–434
Title/Defi nition sets, 369
Title/Encoding category, Page 

Properties dialog box, 52
toolbars

Coding
Apply Comment button, 306
Balance Braces button, 305
Collapse Full Tag button, 305, 307
Collapse Selection button, 305, 307
Expand All button, 305
Format Source Code button, 306
Highlight Invalid Code button, 305
Indent Code button, 306
Line Numbers button, 305
Move or Convert CSS button, 306
Open Documents button, 305
Outdent Code button, 306
Recent Snippets button, 306
Remove Comment button, 306
Select Parent Tag button, 305, 307
Show Code Navigator button, 305
Syntax Error Alerts in Info Bar 

button, 306
Wrap Tag button, 306

Document
Code View button, 57
Design View button, 56, 101, 319

Live View button, 352, 356, 358, 
372

Preview/Debug in Browser 
button, 324

Split button, 24, 28, 31, 70, 85
Split View button, 58

Insert, 327
tools

Contribute tool, 285
design, 10
Hand tool, 249
layout, 10

Top Features (videos) column, 
Welcome Screen, 36

Tracing Image category, Page 
Properties dialog box, 53–54

Transition On menu, 187
Transitions, CSS

adding, 184–189
browser support for, 189, 195
description of, 446
easing, 192
Internet Explorer support for, 189
modifying, 190–195
navigation menu, adding to, 

196–199
support for, 189

Transparency slider, Page Properties 
dialog box, 54

trigger, 341–342
TrueType (TTF), 203
.txt (text) fi le format, 210
typography, web, 64

U
Unicode Normalization Form, 53
Unicode (UTF-8), 53
Unix, 44
Unordered List button, Property 

Inspector, 80, 166
Update from Original button, 

Property Inspector, 20
Update Library Items dialog box, 283
Update Pages dialog box, 283
updating

images, 91
library items, 282–284

URL address, 75

V
Validate Form behavior functions, 344
Validate Form dialog box, 342
validating

code
highlighting and correcting 

invalid code, 308–309
running report, 309–310
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documents, 308
external links, 426
form fi elds

changing behavior order, 343–344
overview, 342–343

web forms, 338
Value column, Radio Group dialog 

box, 327
VCS (version control system), 43
Verdana font, 66–67
Verizon, 23
Version Control option, Site Setup 

dialog box, 40
version control system (VCS), 43
video

adding, 263–266
making web content interesting, 260
overview, 259
QuickTime video, 266–269
Windows Media, 266–269

video tutorials, 5–6
View menu, 303
viewport, 380–381
views

Code
Coding toolbar, 305–306
collapsing and expanding tags 

and code blocks, 307–308
containers and, 130
creating CSS rules, 101
defi ned, 314
editing in Live View, 74
<form> tag attributes, 320
modifying workspace, 303–304
overview, 13
viewing comments, 299–300
work views, 57

Design
CSS-styled text, 96
description of, 13, 56
modifying snippets, 279
resizing document window, 

246–248
setting form properties, 321
tag selector and, 314
viewing comments, 299

previewing
button behavior, 342
pages, 73–74

Split
addressing listed item, 430
case sensitivity and whitespace, 31
Code Navigator, 102
CSS and, 97
default, 303
displaying page in multiple 

modes, 58
editing in Live View, 74
formatting tables in HTML, 225
hand-coding, 72

internal style, 104
Live view and, 74
overview, 13, 69
placing images in HTML, 28
view options, 303
viewing fi les on remote server, 416

visibility, search engine, 432
Visited links fi eld, Page Properties 

dialog box, 52
visual aids, 15
Visual SourceSafe (VSS), 21

W
W3C (World Wide Web 

Consortium), 11, 94, 451
Warning Sign icon, 430
.wav format, 269
WCAG (Web Consortium 

Accessibility Guidelines), 428
web banner, 260
web browser

CSS Transition support, 189, 195
mobile, 377
previewing pages, 73–74
web fonts supported by, 203

Web Consortium Accessibility 
Guidelines (WCAG), 428, 434

web design
layout tools and, 10
library items, 280–284
modular page elements, 274
overview, 273
repeating regions, 290–293
snippets, 274–279
tables, 210
templates, 285–290

web fonts
adding to website, 200–204
basics of, 199, 447
browser support of, 203
licensing, 204
resources for, 207
styling headings with, 205–207

Web Fonts category, Site Setup dialog 
box, 44

web forms
adding form elements

adding checkboxes, 325–326
adding File Upload fi eld, 331–332
adding lists and menus, 328–329
adding radio buttons, 326
adding radio groups, 327–328
adding text area, 330
adding text fi eld, 323–325
overview, 322
Submit and Reset buttons, 332–333

adding validation
Behaviors panel, 339–340
previewing button behavior, 342

setting event or trigger, 341–342
contact form

inserting <form> tag, 317–320
setting properties, 320–321

overview, 315–317
processing, 338
styling with CSS

applying .label style, 337–338
attaching external styles, 334
setting background color, 335–336
styling form elements, 337–338

validating form fi elds
changing form fi eld’s behavior 

order, 343–344
overview, 342–343

validation, 338
Web hosting services, 23
Web Open Font Format (WOFF), 203
web page

adding title, 433–434
creating from templates, 287–288
for mobile devices, 390
Multiscreen feature for viewing, 

378–381
optimizing for launch

adding meta keywords and 
descriptions, 435–436

search engine visibility 
and Search Engine 
Optimization, 432

titling your documents with 
<title> tag, 432–434

previewing in web browser, 73–74
WebDAV, 414
WebKit rendering engine, 16
website

adding pages
fi xed, 46
liquid, 46
New Document dialog box, 45–46
saving pages, 48

advanced site-creation options
Cloaking category, 44
Contribute category, 44
Design Notes category, 44
File View Columns category, 44
overview, 43–44
Spry category, 44
Templates category, 44

defi ning page properties, 49–54
design

library items, 280–284
modular page elements, 274
overview, 273
repeating regions, 290–293
resources, 440
snippets, 274–279
templates, 285–288

domain names, 23
Files panel
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overview, 58
selecting and editing fi les, 59–60
viewing local fi les, 59

fl ow chart, 22
fonts added to, 200–204
hosting, 7
IP addresses, 22
managing

Check In and Check Out, 419–424
Design Notes, 422–424
design resources, 440
Files panel, 412–418
focus groups, 439–440
generating site reports, 428–436
Help system, 438–440
launching site, 437–438
optimizing pages for launch, 

432–436
overview, 411–412
Reference panel, 439
testing site integrity, 425–428

on mobile device, 377–378
operating principles of, 22–23
overview, 39
servers, 23
web browsers, 23
web fonts added to, 200–204
web hosts, 23
work views, 55–58

Welcome Screen
Create New column, 35
Open recent item column, 35
Top Features (videos) column, 36

whitespace, Design view, 32
Widgets, Spry

AJAX, 348
customizing with CSS, 352–356
overview, 365
Spry Repeat List, 368–370
styling and fi ne-tuning, 370–372
XML, 366
XML data set, 366–368

Width category, CSS Style panel, 151
Window Size drop-down menu, 257
Windows Media, 266–269
Windows OS, 2–3
Wireless Markup Language (WML), 308
Word Wrap button, Coding toolbar, 305
Word Wrap option, 302
WordPress, 20
work views, 55–58
workfl ow

customizing panels and panel 
groups, 242–245

Favorites tab on Insert bar, 245–246
grids, 253–256
guides, 250–252
overview, 241
reports, 429
resizing document window, 

246–248
tag selector, 255–256
zooming, 249–250

workspace
features of, 13–15
layouts, 14

resetting, 3
World Wide Web Consortium 

(W3C), 11, 94, 451
Wrap Tag button, Coding toolbar, 306

X
Xcode, 451
XHTML, validating documents, 308
XHTML 1.0 Transitional

Hypertext Markup Language 
(HTML), 33–34

mobile phones, 33
XML data set, Spry Widgets, 366–368
XML (eXtensible Markup Language)

incorporating real-time data from 
fi les, 348

validating documents, 308
Widgets, Spry, 366
XHTML and, 33

Y
Yahoo!, 23, 432

Z
z-index, 155
Zoom tool, 249–250
zooming, 249–250
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 John Wiley & Sons, Inc.
End-User License Agreement

READ THIS. You should carefully read these terms and conditions before opening the software packet(s) 
included with this book “Book”. This is a license agreement “Agreement” between you and John Wiley & 
Sons, Inc. “WILEY”. By opening the accompanying software packet(s), you acknowledge that you have 
read and accept the following terms and conditions. If you do not agree and do not want to be bound by 
such terms and conditions, promptly return the Book and the unopened software packet(s) to the place you 
obtained them for a full refund.

 1. License Grant. WILEY grants to you (either an individual or entity) a nonexclusive license to use 
one copy of the enclosed software program(s) (collectively, the “Software”) solely for your own 
personal or business purposes on a single computer (whether a standard computer or a workstation 
component of a multi-user network). The Software is in use on a computer when it is loaded into 
temporary memory (RAM) or installed into permanent memory (hard disk, CD-ROM, or other 
storage device). WILEY reserves all rights not expressly granted herein.

 2. Ownership. WILEY is the owner of all right, title, and interest, including copyright, in and to the 
compilation of the Software recorded on the physical packet included with this Book “Software 
Media”. Copyright to the individual programs recorded on the Software Media is owned by the 
author or other authorized copyright owner of each program. Ownership of the Software and all 
proprietary rights relating thereto remain with WILEY and its licensers.

 3. Restrictions on Use and Transfer. 

 (a) You may only (i) make one copy of the Software for backup or archival purposes, or (ii) 
transfer the Software to a single hard disk, provided that you keep the original for backup 
or archival purposes. You may not (i) rent or lease the Software, (ii) copy or reproduce the 
Software through a LAN or other network system or through any computer subscriber system 
or bulletin-board system, or (iii) modify, adapt, or create derivative works based on the 
Software.

 (b) You may not reverse engineer, decompile, or disassemble the Software. You may transfer the 
Software and user documentation on a permanent basis, provided that the transferee agrees to 
accept the terms and conditions of this Agreement and you retain no copies. If the Software is 
an update or has been updated, any transfer must include the most recent update and all prior 
versions.

 4. Restrictions on Use of Individual Programs. You must follow the individual requirements and 
restrictions detailed for each individual program in the “About the CD” appendix of this Book or 
on the Software Media. These limitations are also contained in the individual license agreements 
recorded on the Software Media. These limitations may include a requirement that after using 
the program for a specifi ed period of time, the user must pay a registration fee or discontinue use. 
By opening the Software packet(s), you agree to abide by the licenses and restrictions for these 
individual programs that are detailed in the “About the CD” appendix and/or on the Software Media. 
None of the material on this Software Media or listed in this Book may ever be redistributed, in 
original or modifi ed form, for commercial purposes.
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 5. Limited Warranty.

 (a) WILEY warrants that the Software and Software Media are free from defects in materials and 
workmanship under normal use for a period of sixty (60) days from the date of purchase of this 
Book. If WILEY receives notifi cation within the warranty period of defects in materials or 
workmanship, WILEY will replace the defective Software Media. 

 (b) WILEY AND THE AUTHOR(S) OF THE BOOK DISCLAIM ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE, WITH RESPECT TO THE SOFTWARE, THE PROGRAMS, 
THE SOURCE CODE CONTAINED THEREIN, AND/OR THE TECHNIQUES 
DESCRIBED IN THIS BOOK. WILEY DOES NOT WARRANT THAT THE FUNCTIONS 
CONTAINED IN THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT 
THE OPERATION OF THE SOFTWARE WILL BE ERROR FREE. 

 (c) This limited warranty gives you specifi c legal rights, and you may have other rights that vary 
from jurisdiction to jurisdiction.

 6. Remedies. 

 (a) WILEY’s entire liability and your exclusive remedy for defects in materials and workmanship 
shall be limited to replacement of the Software Media, which may be returned to WILEY with 
a copy of your receipt at the following address: Software Media Fulfi llment Department, Attn.: 
Adobe Dreamweaver CS6 Digital Classroom, John Wiley & Sons, Inc., 10475 Crosspoint 
Blvd., Indianapolis, IN 46256, or call 1-800-762-2974. Please allow four to six weeks for 
delivery. This Limited Warranty is void if failure of the Software Media has resulted from 
accident, abuse, or misapplication. Any replacement Software Media will be warranted for the 
remainder of the original warranty period or thirty (30) days, whichever is longer. 

 (b) In no event shall WILEY or the author be liable for any damages whatsoever (including 
without limitation damages for loss of business profi ts, business interruption, loss of business 
information, or any other pecuniary loss) arising from the use of or inability to use the Book or 
the Software, even if WILEY has been advised of the possibility of such damages. 

 (c) Because some jurisdictions do not allow the exclusion or limitation of liability for 
consequential or incidental damages, the above limitation or exclusion may not apply to you.

 7. U.S. Government Restricted Rights. Use, duplication, or disclosure of the Software for or on 
behalf of the United States of America, its agencies and/or instrumentalities “U.S. Government” is 
subject to restrictions as stated in paragraph (c)(1)(ii) of the Rights in Technical Data and Computer 
Software clause of DFARS 252.227-7013, or subparagraphs (c) (1) and (2) of the Commercial 
Computer Software - Restricted Rights clause at FAR 52.227-19, and in similar clauses in the NASA 
FAR supplement, as applicable.

 8. General. This Agreement constitutes the entire understanding of the parties and revokes and 
supersedes all prior agreements, oral or written, between them and may not be modifi ed or amended 
except in a writing signed by both parties hereto that specifi cally refers to this Agreement. This 
Agreement shall take precedence over any other documents that may be in confl ict herewith. If any 
one or more provisions contained in this Agreement are held by any court or tribunal to be invalid, 
illegal, or otherwise unenforceable, each and every other provision shall remain in full force and effect.
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